View Full Version : 2490U2B and Mac OS X (Old World)

04-25-2001, 12:59 PM
Has anyone had any experience getting these cards to boot OS X?

04-25-2001, 05:21 PM
That's what I use. Can't say I find OS X to offer anything and using disk utilites less than stellar, Norton 6.0 to be _dangerous_ and while it seems to help etc once, I've also ended up speed disk freezes, NDD finding Major errors repeatedly, Disk Warrior taking an hour to process the huge number of files.

I had to use non-raid and recognizes it fine. but I'm on new world b&w rev 2.


05-30-2001, 04:53 PM
I've used it in a YOSEG3 too... but just for data. I booted of a Maxtor 7200 (1st partition) and had it set to MASTER.

I know I've heard of people posting about NOT using ADAPTEC cards in AppleCLONE systems... but it SHOULD work in an oldworldAPPLE. I know most of those types (7500/9500) have issues with the stock internal SCSI, but the external SCSI seems to work fine.

Not much help, let us know how it goes.

06-01-2001, 06:42 AM
haven't tried.

i boot off IDE drives in New World machines. Just like Apple wants.


06-18-2001, 04:54 PM
According to an Apple support guy I talked to this past Friday & http://www.adaptec.com/worldwide/support/supporteditorial.html?prodkey=mac_osx_info, the 2940 series of cards will not be supported at all, which blows chunks imho. Of course, my Yosemite G3 450 shipped back in 11/1999 with the 2940U2B card, a 9G drive & no IDE drive, which was fine with me until I tried to install OS X. Looks like I'll have to ditch the card. I may just stick with OS 9.1 indefinitely & run X on the cheap 1st-ed iBook that I will soon get my grubby paws on. . .


06-18-2001, 08:33 PM
While Adaptec has dropped the ball, I think Apple has included some support for the 2940U2b card. My Yosemite works fine with it, but I do not boot off it. Get a cheap, fast IDE/ATA card and your in business. Definately cheaper than a new iBook... but hey those iBooks are http://www.macgurus.com/ubb/rad.gif !

The thing is the OLD WORLD macs are not supported at all... 3Dfx's 'unsupported' V3 cards were better supported than X on say a 9500. http://macgurus.com/infopop/emoticons/icon_redface.gif

Apple had the draw the line somewhere. It looks like they barely have support for the BeigeG3s (Gossamer).

07-07-2001, 12:56 AM
I just installed the 2940U2B from MacGurus to replace my older JackHammer. I did this exclusively for the promised OSX and Linux compatibility. Unfortunately, OSX refuses to boot a drive on the card (while booting the installer does recognize the drives on the card.). Also, booting any version of Linux on CD or a drive on the main SCSI bus results in an immediate Kernel Panic.

07-07-2001, 03:10 PM
What did you use to format your drive? Did it boot into OS X to finish the Startup Assistant routine after install? I didn't like the FoxConn cable and got better performance etc once I put a "real" active terminator on it, but I don't think that would do it. I have it in my b&w and wanted to donate it to a 7500 but maybe now I won't. Or use two to get cheap dual-channel http://macgurus.com/infopop/emoticons/icon_wink.gif

07-08-2001, 04:44 AM
I had previously installed OS X with the drives running on my internal 10MHz narrow bus. I noticed today that it appeared that the partition table was corrupted on the OS X drive, so I reformated it and installed OS X again. The install went fine, but when it came to booting the drive, the computer just hung without initializing the screen. I can't do anything to trace the problem since the open firmware boot code messes up the open firmware text display.

After fixing the drive Linux still gives me a Kernel Panic with the following message:

Machine check in kernel mode (regs at c0b799d0)
Caused by (from srr1): Unknown values in srr1

This is upsetting since both versions of Linux that I've tried claim to work with the 2940U2B card.

07-09-2001, 04:24 PM
There is a note today on someone triple boot into linux - Mac OS X - OS 9 on one of the newer Macs that supports Option key choice at bootup. OS X does weird stuff to the partition may, but it isn't damaged. However, updating the driver via Drive Setup does probably render OS X impossible. And changes the boot partition numbering scheme.

I even put SoftRAID driver on one drive just to prevent OS X from hopefully modifying the drive. Any way to use different drives for each OS?


07-09-2001, 05:48 PM
Mainly for Gregory:

I have a 9600 setup to multi boot Linux PPC, X, 9.1, 8.6, 7.6.1. I have all boot volumes running on a Atto UL3D.

The trick that worked for me was to plan things before beginning. The X drive is Apple formatted, 9.1 (8.x & 7.X) are SoftRAID Volumes, Linux owns its own drive, and everything works smoothly.

The way I've got this rigged, System Picker chooses X (9.1 for X is on yet another Volume), and Option reboot goes back to my 9.1 RAID. Then BootX gives me a LinuxPPC option. If I need 8.x or 7.x, I need to pick them via Startup Disk after booting into 9.1. This may or may not work with partitions, but it works with drives.

It is not the most elegant thing, but since Old World machins lack that nifty pre-boot volume chooser, its the only way I could get it to go...

07-09-2001, 09:51 PM
Well, I took out the SCSI card and everything's back to normal (albeit a bit slow...). The Partition table on my X drive was corrupt as it showed a 6GB and 2GB mounted and an addition 2GB unmounted partition. Since it's a 9GB (8.4GB realworld), that additional partition was a clear sign.

With the card removed, I'm now back to a triple boot machine. MacOS (9.1 or 8.6 choosable via Conflict Catcher, Mac OS X (Via BootVariable scripts making it much easier than System Disk, and Linux (Via MiBoot by holding Cmd-Opt-Shift-Del w/o a CD in the drive). This works quite nicely in my 9500 clone (PowerTower Pro).