PDA

View Full Version : Cannot start Classic mode



toddmr
06-13-2001, 03:14 PM
When I try to start Classic mode as any user other than root, I get a message that "You do not have sufficient permissions to boot from //System. Please correct permissions and restart Classic."

How do I do that?

I have checked a number of sites for any hints, and have not yet found anything.

I have installed software that makes me hesitant to just reformat and load OS9.1 and OSX again.

Thanks.

jorge
06-13-2001, 06:44 PM
it only boots in Classic when logged in as root? Did you change a directory for Classic?

A re-install of OS X and OS 9.1 is in order I think.

j

toddmr
06-14-2001, 01:12 PM
Last night, I was sick of playing around with it, so I re-installed OS 9.1 and OSX.

I did not perform clean install, because I have a lot of time in setting it up to serve a mysql database.

toddmr
06-14-2001, 01:54 PM
Fixed. Temporarily.

I found a fix that probably opens some security holes, but since the box I'm working on in OS X is not a production machine, I can live with it for now.

I first logged in as root.

Second, I went into the System folder and started changing privileges. To do this, you single-click to highlight, then apple-i to bring up the finder info box for the file.

I changed privileges to read and write from read only for all "wheel" users on the Classic, Classic Support and Classic Support UI files within the system folder.

Logged out as root, back in as user with Admin privileges.

Tried to start up Classic, no dice.

Went back in as root, tried the info box trick on the System folder, but it wouldn't allow me to change the pull-down menus for wheel user privileges.

Single-clicked on the HDD on the desktop, apple-i, change privileges to read & write and checked the copy to all enclosed folders box.

Went to the System folder again, and it showed read and write privileges for all wheel users.

Logged in as user w/ Admin again, and Classic started just fine.