PDA

View Full Version : itunes2 issues



kjay
01-13-2002, 03:02 PM
hello all,

i am experimenting with the resedit hack of the apple cd/dvd driver to see if i can get compatibility with OS9.1 and Itunes2.0.3. the hack i used was found on the resexcellence site and works flawlessly except that i cannot burn from itunes (no prob with toast5 w/wout toast extensions).

i always get the same error. shortly into the burn process it fails and gives the following - "cd burning failed because of unknown error (-7932)" i've tried two different machines (upgraded ptp, upgraded 7500 w/no other software other than OS9.1/xlr8/voodoo drivers and itunes2.

both machines work flawless for everything else... ripping/reading/games etc. i did see some posts on apples' forum addressing this error - most of them with fully supported machines. the two drives are yamaha 8/4/24S and 8/8/24S.

the ptp is my main machine and i normally use speedtools and flip between extension sets to burn from itunes but the 7500 is for my niece and wanted to try to make it as seemless as possible. i've just been doing a little r&d on both to eliminate a hardware specific prob.

anybody have any experiences with itunes2 or hacking the apple drivers?
i've been using the OS9.1v1.4 driver as the hack targets this one among others. the authoring support 1.1.5 driver doesn't match the hack as far as corresponding rows, etc.

thanks
kj

lasvegas
01-13-2002, 09:15 PM
The hack from ResExcellence's site (I wrote it!) is only for reading CDs from a bootable reader. Many CDRs and CD/RWs are bootable so they will work with the hack. The Toast Extension is also just for reading through the writer.

Your problem is that your burner is not compatible with Apple's Authoring Support software. The fact that Authoring Support does see your drive as a valid writer is about as much as one could expect. The rest is up to the ROMs in the writer. Apple only tested it with certain drives and cannot guarantee that it will work at all with others. My SONY burner works flawlessly with Authoring Support 1.0.2, Burner 1.0 and iTunes 2.0.3. Upgrading the Burner and Authoring Support makes my drive stop working.

kjay
01-15-2002, 10:58 AM
good morning...

thanks for the tip and the hack lv. oh! by the way, that powerforce is working awesome, thanks again.

as for itunes, i tried every flavor of 2 (2.0, 2.02, 2.03) and every flavor of authoring support to no avail. always the same error at relatively the same spot, near or at end of first track, unknown error (-7932). eventually backed down to itunes 1.1 and authoring support 1.1.2. all is well. ripping, mixing, burning just fine.

as i've noticed on a few forums a percentage of other folks with fully supported machines/burners with the same error, perhaps a small bug to be fixed in a update. one can only hope. i really like itunes2 and some of the new features.

lv, thanks for the clarification on the reader/burner driver issue. makes complete sense now. your hack is working flawlessly.

later
kj

kjay
01-15-2002, 11:53 AM
check this link out to the apple forums....
http://discussions.info.apple.com/webx?128@207.uCFEaajighr^8@.eff80c4

one guy even has a built in cdrw on his imac. very strange.

there is a apple article on -7932 and it says it is caused by using high speed media not supported. there is one difference though, the error box. apple's example say "drive failed", mine says unknown error. i've also used several different makes of media.

kj

[This message has been edited by kjay (edited 15 January 2002).]