PDA

View Full Version : Interesting.... 9.2.1 update



skyhand
08-23-2001, 07:27 PM
I downloaded Mac OS 9.2.1 from Apple's site, mounted the disk image, then selected "Get Info" on that file. An odd thing in the comments field: "693-3460-Ciao" What the heck is this? Looks like someone's phone number. "For a good time, call..." http://macgurus.com/infopop/emoticons/icon_wink.gif

mactheripper
08-23-2001, 09:25 PM
You go, boyee!!!

Macdaddi2u
08-24-2001, 12:57 AM
I read someplace that the 9.2.1 upgrade is for machines running OS 9.1 or 9.2 with OS X and that the upgrade was for compatability with the OS X, not a real upgrade for 9.1. I ask this because I am running 9.1 in my 8500 which will never see OS X. Is this correct?........and was very disappointed when Jenny didnt answer the phone when I called the number

[This message has been edited by Macdaddi2u (edited 24 August 2001).]

ricks
08-24-2001, 03:06 AM
So...the 9.2.1 instal CD came with my new 867. I tried to instal 9.2.1 on my 8600. The 8600 has an XLR8 ZIF Carrier 500 G3, supposedly OSX compatable. Not yet anyway.
The installer wouldn't!

I also loaded a drive with 9.2.1 installed on the G4 and tried switching it out to the 8600, wouldn't boot!

Lastly,(I don't give up easily) I networked and drag copied the whole darn installed drive over to the 8600s drive, no go.

I installed the new OSX compatable control panel from XLR8 on the last try figuring maybe that was the issue. I had the extension manager already configured to start up with the XLR8 controls up first thinking that 9.2.1 would look for a operating G3 or G4 but that didn't help.

I also have an itch to get OS10 running on the Old 8600. Maybe next months OS10 release will make it possible.

Rick

chrismenke
08-24-2001, 03:54 AM
I went through the same frustrations with 9.2.1 on my 9600...

No luck, but you can run OSX on your 8600, I have it setup on my 9600. All you need to do is patch the installation.

Ryan Rempel wrote some code to add Old World support to the installer, and a description can be found over at OWC.

lasvegas
08-24-2001, 05:11 AM
skyhand: That "693-3460-Ciao" is the internal Apple ID for that image. Apple has been using 7 digit IDs for drive images as long as I can remember. It struck me as odd originally too since the original set of numbers started with 694 and that happened to be the prefix of the phone numbers I grew up with in Grand Blanc, MI.

Macdaddy and all: Mac OS 9.2.1 is for only newworld Macs (those that are officially supported in OS X). The installer will refuse to install in any oldworld Macs in native mode. There is a bright side though. Version 10.1 of OS X will allow running the update within Classic, and it will install on our oldworld Macs.

kirk-pa
08-24-2001, 11:18 AM
I just wanted to add that I got 9.2.1 to run on a PM9600 w/ XLR8 Upgrade. I accomplished this 2 times 2 different ways:

1) Used tome viewer to extract the files from the updated and simply replaced the same files in my 9.1 startup folder.

2) Installed a base 9.1 system onto an external drive. Took that external over to a G4 tower and updated the external drive to 9.2.1. Brought the external back to the 9600, booted from the 9.1 CD (so that nothing in either the external or my default System folder was loading), replaced the system folder on my desktop with the one from the external drive, and restarted.

So far so good. I'm running XLR8 1.4.3 which seems to be working fine. System response time is a little quicker. May have a problem with Desktop Printers....can set them up in both Chooser or Desktop Printer Utility but can't seem to print, nor have them show on the desktop. I'm going to try this install at home on my 8600 w/ XLR8 2.5 and other more important programs like Diablo 2...LOL

*** I must stress that you backup a copy of your 9.1 system folder incase something goes wrong. Supposedly people have gotten 9.2.1 to work but had to use the 9.1 system suitcase. For me this is not the case, I'm running the updated System Suitcase.***

Hope this helps any who want to find out more of 9.2.1. I'm happy with the performance so far, but am not set in stone if its going to work 100% or not.

-Kirk

--Edit to this post:---
I have just noticed that I too am running System Suitcase 9.1 still to get my 9600 to load with the 9.2.1 extensions. Will update again if I find out a workaround.

[This message has been edited by kirk-pa (edited 24 August 2001).]

tm311
09-21-2001, 09:39 PM
i am also able to run 9.2.1 on my PTP. i was not able to hack the installer, as it kept giving me an error to the effect that it could not install over the current OS9.1 and i needed to do a clean install. So i opened the installer in TomeReader and created a partition with disk copy. To this i copied on my current OS9.1 system folder and expanded all the 9.2.1 files using TomeReader....and threw everytthing into the system folder on the partion i created...replacing everything and letting the chips fall wherethey may. I then hid my current system folder on my boot drive and copied over this new 9.2.1 System folder. Hit restart....would not restart as it said i had a file open...so i hit shut down.....and then did a cold boot...walked away and listened to Tom Petty sing :won't back down".....(nice to see he is still as cool as ever)....anyway...walked back upstairs expecint a meltdown of my computer....but it booted fine into 9.2.1 and after i tweaked a couple settings i am running fine. However i noticed something odd that maybe the guru's can explain....all the key files in my system folder report as being 9.2.1 with the exception of 2. "System" is saying 9.1 and even when i PUT a 9.2.1"System Resource" file in and verify it using Get Info....when i restart i check and the "system resource" file reverts back to 9.1, And when booting the happy mac says 9.1....but in system profiler i t says Finder 9.2 but under System it reads 9,1 International English....is this right?

[This message has been edited by tm311 (edited 21 September 2001).]

lasvegas
09-21-2001, 11:40 PM
I got 9.2.1 to work on my PTP as well. I originally installed it using MacOnLinux. I could only use it in OS X until I found the patch to the 9.2 System suitcase the other day. The patch is available at XLR8 Your Mac (http://www.xlr8yourmac.com). It works with the patch, but Apple's Disk Burner no longer works with my SCSI SONY CDRW, even if I reinstall version 1.0.1. I'll stick with 9.1 for normal work until I can figure this little problem.