PDA

View Full Version : New to G4 9.1



drallen
05-18-2001, 08:28 PM
What is taking so long on my G4 as it boots?

All the desktop icons appear, then a long gap (at least a minute), and then the control strip loads, and then the computer is usable.

What is going on with this long gap?

Can I turn it off?

Thanks,

Mark

kaye
05-19-2001, 12:10 AM
That is strange. Is there something in the Startup Items folder? Try disabling the Control Strip control panel and Control Strip Extension. Then reboot and see what happens. Or perhaps a corrupted Control Strip Module? Count how many you have in that folder and count how many are showing up on the Control Strip. k

drallen
05-19-2001, 01:26 AM
Kaye,

Thanks for you response...

My start up folder loads and then nothing happens for over two minutes...

Then the control strip pops out and the computer works...

Any thoughts?

Thanks,

Mark

kaye
05-19-2001, 10:53 AM
Mark,

As I mentioned before, disable the Control Strip inits and see what happens to your startup delay. If that does not help, re-enable the Control Strip inits, and disable the Startup items folder stuff and see what happens to the startup delay.

According to my Conflict Catcher, set to load order, it appears that after the last inits, then the Fonts load, then the Startup Items folder loads. Could also be a problem with something in the Fonts folder, but I would start troubleshooting with the Control Strip stuff and then the Startup Items stuff.

If at any point you see a normal startup, start adding things back to see where the problem reappears. My guess is that something in the Startup Items folder is causing the long wait but you need to remove all of those items and see if the problem disappears. If it does not fix, then the problem is elsewhere. k

Louie
05-19-2001, 12:22 PM
d:

What is going on during that period is Open Transport stuff; building stacks, etc. If per chance you have TCP/IP always on set for DHCP and it can't get a lease for some reason (not connected to DHCP server, etc.), it will hunt for a very long time and finally come ip with a phony IP address of 169.xxx.xxx.xxx. After it does that, see what IP address shows in TCP/IP.

Carbon Lib 1.3.1 is also causing some pain. Try v 1.4.3 SDK from the Apple Deveroper Site.

magician
05-20-2001, 01:34 AM
nuke the Launcher prefs from the System Folder Preferences folder. Toggle "Show Launcher at System Startup" off in the General Controls control panel.

make sure nothing is in the Startup Items folder in the System Folder.

cull fonts. If if the system didn't install them, disable them for now.

as a last resort, update your disk drivers.

MacMikester
05-20-2001, 05:07 PM
Also nuke your desktop database files, finder and display prefs and check finder info with one of the utes. Make sure all your aliases, especially ones in the system folder, are resolvable. Kaye's idea about the control strip modules is a good one to check out.

Louie
05-21-2001, 09:35 PM
Hey drallen? Have you done all that yet? http://macgurus.com/infopop/emoticons/icon_biggrin.gif

chrismenke
05-28-2001, 05:13 AM
Same sort of pause occurs if Web Sharing has been enabled, as the machine assesses what is being shared, where it lives, and how it is being shared.

You might want to dbl check this, and turn off web sharing if you aren't using it.

Cheers,
Chris

magician
05-28-2001, 04:39 PM
one more thing....nuke everything in the Recent Docs, Recent Servers, and Recent Apps folders, and double check that everything loading under the Apple Menu is readily resolvable, particularly aliases. If you have an alias of your entire drive there, delete it. That can cause hell on earth.

tachyon
05-28-2001, 09:15 PM
Magician is nearly there. You may have had the machine set up to automatically look for a server which is no longer there.
Go into the System Folder, then look inside your "Servers" folder, not the "Recent Servers" in the Apple menu. Anything in the Servers folder must be deleted at the same time as AppleShare Prep, AppleTalk Preferences and TCP/IP prefrences (all inside the Preferences folder).

Louie
05-29-2001, 09:54 PM
Yes, drallen must have passed on from "Help Overload". He's MIA.

magician
05-30-2001, 03:47 AM
talking about MIA forums members....where the heck is Dave "CrazyEights"?

I miss him. Hope he's ok--anyone heard from him?

Ketone
06-06-2001, 07:27 AM
You need to use ResEdit to make a file entitled "AppleShare PDS" visible and delete it. Its at the root level of your boot partition.
You also need to delete the "AppleShare Prep" preferences file in the preferences folder.

These are the only two files you need to delete, they have become corrupted and are responsible for the long delay you are exeriencing at the desktop.

Ketone