PDA

View Full Version : G4 vs. Firmtek: KnockOut!



Olijf
11-12-2003, 05:16 AM
Hi,

after several emails with Rick who has been very patient and helpfull in all kind of ways, I try to get my answers from forum members who might had the same problem.

The problem is:
My new FirmTek SeriTek/1S2 card and new Western Digital 250 GB S-ATA disk won't work on my G4 QS. What happens is that the Mac starts up, the powerlight is on, I can hear the fan and that's all! The keyboard, mouse and monitors won't work. Seems that USB and video signals are dead...
Rick came up with the solution to do boot and an Open Firmware reset (before and after installing new hardware). No luck.
I've tested the power supply to the HD's, which is okay. I've switched HD's around, no luck.

Who has an idea what is going on here (Apple Firmware issue?), who had similar problems, who can help or can come up with another thing to try out?

My set:
G4 QS 933mHz
OS X 10.2.8
1 FirmTek SeriTek/1S2
1 Western Digital 250 GB, S-ATA 7200 rpm, 8 MB cache, WD2500JD
1 default ATA HD 60GB (model: IBM-IC35L060AVER07-0)
1 extra ATA HD (model: WDC WD200BB-00CFC0)

Thanks for any reply!
Olijf

[This message was edited by Olijf on Sat November 15, 2003 PT at 5:05.]

TZ
11-12-2003, 08:33 AM
If you don't have another mac to try the SATA card and drive in, I'd RMA it. It could be the quirkiness of QS models (rick can attest to their finiky nature), or bad firmware or other problem with the card. Or... the firmware on the WD drive. I assume the WD hasn't been initialized yet either.

If you have a Panther CD, I'd try booting from that, and see if you can, before you try to return it.

ricks
11-12-2003, 09:40 AM
?I am currently working on four cases of the Seritek not booting in Digital Audio and Quicksilver models. At first I thought this was Panther related but Marc here has his computer in 10.2.8, there goes that theory.

?Just MacGurus alone have sold dozens of the Seritek card and this issue just now popped up. We've been selling the Seritek for almost two months now. We had been testing them for another couple of months previous to that. The hard thing is we have sold a bunch of them in the last two weeks that work.

?I have sent a couple of replacement cards out but haven't got reports yet whether that resolves the problem for those customers. In both cases I tested the cards first in my QUicksilver and didn't ship cards out of the warehouse. So at least by the end of the week we'll know if this is a bug that only a select small percentage of DA or Quicksilver's have or if the bug is only in some of the Firmtek cards. Until we hear back from the customers with replacement cards we are only guessing.

?Unfortunately for Marc that isn't much help in the very short term.

Rick

Quis Custodiet Custodes Ipsos?

TheKoyoteKid
11-12-2003, 01:01 PM
When my replacement arrives, I'll pop it into my B&W first, then I'll give it a shot in my DA. Im sure FirmTek will have a solution out pretty fast in any case.

ricks
11-12-2003, 01:11 PM
Thanks KoyoteKid,

?Do publish what happens here for all to see, that way it gets out fastest what is happening.

?I still don't know what to put on the sales page as a bug report. Too few cases and not enough commonality for a accurate idea of what is going on. I REALLY look forward to seeing what happens when you get a new card.

Rick

Quis Custodiet Custodes Ipsos?

kaye
11-12-2003, 02:21 PM
Marc,

I don't have the same QS but do have a QS 2001 G4-800DP running 10.2.8 and 10.2.6. I also have access to older SeriTek/1S2 firmware. All of my SeriTek/1S2 tests to date have been on a G4 MDD (FW400).

I have something SCSI to run first before I can get to this issue but hope to start testing SeriTek in my QS G4 tomorrow morning. Also the SATA drives, in my case the WD Raptor, are striped in a 4-drive RAID so I need to reinitialize the drives on the MDD as single drives today before proceeding with the QS tomorrow.

Some questions:
1. You have only tried 10.2.8? How about OS9.2.2?
2. When you get the black screen on bootup, is that only with your drive attached or is that also occurring with just the SeriTek/1S2 in a PCI slot and no drives attached?
3. How are you getting out of this situation? Shutdown and have to remove the card? Or just shutdown and remove the data cable?
4. Have you tried another PCI slot? For instance, if you have the card installed in the PCI slot next to the AGP slot, have you tried the PCI slot furthest from the AGP slot? Are there any other PCI cards installed? If so, what? And if there are other PCI cards, have you tried moving them to different slots?
5. Have you tried booting from CD? If so, what OS CD?

I'm not asking you to try any of the items above, just what you may have already done. Also no guarantee that I will see the same problems. Apparently not all QuickSilvers and DA machines are afflicted. If you can think of anything else I should know that might be helpful... k

Costa
11-12-2003, 04:38 PM
Dear Marc,

I am with Kaye on this one.

I'd like to be of help and I first need to check weather all possible hardware issues have been taken care of.

Please, let us have more informations about your hardware, as this could help us narrow down our suspects.

For istance, it is a good practice when installing new hardware peaces to a machine, to do so one-at-a-time and, in between, test your Mac for eventual issues.
The Firmteck card and the new Raptor drive are two peaces of hardware which go in.

Also, after each new peace of hardware that is fitted, while booting back up the "beast", it is a good practice to reset the PRAM (http://kbase.info.apple.com/viewdoc.jsp?dialogID=3197956&searchMode=gs&docID=2238&sliceID=&sessionID=|3199434), so as to force the booting sequence to re-scan all the main buses and to re-build the hardware hirarchy tree. Then, it is a good thing to check under Apple System Profiler (provided the machine has successfully booted), weather the new hardware is correctly reported.

Another basic test which many times is missed, is to consider the current PRAM battery status; your machine should not be older than a year or so, but if it's main power supply is regularly switched off, then the small PRAM battery may have been put to it's wits that more often, or, maybe, your machine was sold with a difective PRAM battery (http://discussions.info.apple.com/WebX?128@241.sKXgaUk9jeX.8@.3bbb7270). All sorts of strange issues occur when that small "bugger" goes on the down side, including having the start-up sequence loose the booting volume.

Check out the above and Kaye's post first, then let us know your findings/results.

HTH

Costa

P.S.: Kaye -
Those where 5 super-good questions to make!

unclemac
11-12-2003, 05:05 PM
howdy Marc,

According to this Apple chart (http://docs.info.apple.com/article.html?artnum=86117), no system firmware is required, so scratch that off your list.

Just to clarify: Do you get the boot tone with thte SATA gear in, and when you "switch HDs around"? And when you pull SATA gear back out does it then boot fully, or differently?

__________________

Charlie Don't Surf!

[This message was edited by unclemac on Wed November 12, 2003 PT at 16:28.]

kaye
11-14-2003, 07:50 PM
I ran a whole series of tests with SeriTek/1S2 and four WD 36GB Raptors, two Raptors at a time in my QS G4-800DP. I did not do a PRAM/NVRAM reset nor anything in OpenFirmware. Just trying to test all of the possibilities.

My QS has OS9.2.2 and 10.2.8 (Build 6R73) which was the updater from 10.2.6, not a combo updater. The SeriTek/1S2 installed has the shipping firmware 5.0.3.L335. ASP says it is a Revision 2. I have the two other earlier firmwares from testing SeriTek in beta stage and was prepared to try them but it was not necessary. Short story, I could not duplicate the QS problem on my QS. Long story follows.

In Disk Utility for 10.2.8 (DU 10.3 (v88.11)), I initalized one of the Raptors for both OSX and checked the OS9 driver box as well. The other Raptor I wiped, no driver at all. Then began a whole series of reboots to 10.2.8 and a whole series of shutdowns and cold startups. Then a series of reboots between 10.2.8 and 9.2.2. Then a series of shutdowns and cold startups in 9.2.2. Then back to 10.2.8 and tested the initialized drive thru three cycles with Intech Integrity X. Finally a series of cold boots and reboots with just the card installed and no drives connected. No errors. No problems with any of this, my luck I guess....

I had the other two Raptors which I initialized in 10.3.1 Disk Utility (DU 10.4 (v145)) on my MDD G4 since I don't have Panther yet on the QS. One of those Raptors I set for non-Journaled, the other Journaled, both with the OS9 driver box checked. Ran all of the same above sequences with these drives on the QS in 10.2.8 and 9.2.2. Again, no errors, no hiccups of any sort. Just works.

ASP in both 9.2.2 and 10.2.8 tells me:
Slot-1 (AGP) GF3
Slot-2 Seri-Tek
Slot-3 is empty
Slot-4 Acard 6880M (my two IBM drives in "Hard" RAID mode, boot volumes for 9.2.2 and 10.2.8)
Slot-5 Initio Bluenote SCSI

Sorry, I can't help. It works for me, so nothing to troubleshoot. k

[This message was edited by kaye on Fri November 14, 2003 PT at 18:59.]

ataMan
11-15-2003, 12:12 AM
Olijf,

So far, I could not verify the "non-booting" issue with SeriTek, but after some scepticism I strongly believe, this issue does exist. Even more: there is an other issue which is in my opinion very closely related. on G4 Digital Audio and "Quicksilver" mechines the SeriTek/1S2 cards seem to block the PCI bus after the machine is waking up from the "deep sleep". This isssue I can reproduce 100% of the time. I also did verify and so did Apple engineers, this issue is not related to the firmware. Both Apple and SiliconImage (the manufacturer of the SATA ASIC) are working on it. I know, the default setting of the end-user with FirmTek is "all your bugs are belong to us" rather than to Apple or to SiliconImage.

So far the findings:

1) On the machines owned by FirmTek and Apple Compatibility Lab in Cupertino every SeriTek/1S2 card tested does allow the machine start.

2) On the above machines if they feature either QuickSilver or earlier DigitalAudio motherboard the SeriTek/1S2 cards do not let the machine wake up from the deep sleep.

3) As you know, there are numerous SATA cards on the market made for PC. These cards do feature a same SATA ASIC, but they won't work on the mac due lack of Mac firmware and some other important features omitted for PC to save costs. However, nothing prevents us to put these cards in the Mac and see, will it wake up from the "deep sleep" or not. So far, most SATA cards made for PC were tested in last few days (including the cheapest no-name Chines and the most expensive Adaptec) and NONE did let the Digital Audio or QuickSilver machines we tested "wake up" from PCI "deep sleep". Since no Macintosh firmware is involved, obviously, the bug is due either Apple motherboard design/firmware or SiliconImage ASIC.

4) A single card made by Bustek DID prevent my DigitalAudio G4/533 to start, and it has exactly the same issues you have. All what the card did have was a PC BIOS, no Mac-related firmware. Therefore this specimen was the "smoking gun". My machine was taken with the Bustek card by SiliconImage engineers to analyse the issue, while Apple engineers as I did mention earlier also work on the (likely related) sleep issue.

It looks, like all this got a good awarness in these companies. I cannot say at this moment, who will provide the solution: Apple, FirmTek or SiliconImage and in what form. We simply need more time to investigate.

Olijf
11-15-2003, 06:04 AM
Thanks all for your support and testing. I'm currently working on a multimedia project (reason why I bought the extra 250GB ;-) which will finish sunday morning. I'll then start testing my set, answering your questions and drink loads of coffee :-)

Thanks and till tomorrow
Olijf

ataMan
11-15-2003, 09:30 PM
Olijf,

I have a very weird question for you. I can mail to you a card which looks so scary, no one on the earth aside me would touch it. I promise, it won't destroy your Mac ;-) and I also promise with about 95% probability, your Mac and your SATA drives will start like a charm. I pay for the post.

All I need from you is a feedback: did it work well or not. I do not want to provide my eMail to public, but the Macgurus know well, who I am, so you are free to ask and MacGurus are free to give it to you.

Is it OK?

Olijf
11-16-2003, 11:40 AM
Hi all,
I've tested the WD SATA HD & Firmtek card in different settings.

My set:
Power Mac G4 (version = 2.1)/933 MHz, 768MB, Mac OS X 10.2.8 (6R73)


Here are the results:

- HD and Card connected, in 3 different empty slots, OSX 10.2.8: Mac not booting
- HD and Card connected, in 3 different empty slots, OSX 10.3: Mac not booting
- HD and Card connected, in 3 different empty slots, OSX 9.2.2: Mac not booting
- card in empty slot, HD not connected with card, HD connected with powersupply, OSX 10.2.8: Mac NOT booting
- card in empty slot, HD not connected with card, HD not connected with powersupply, OSX 10.2.8: Mac NOT booting
- HD connected with card, HD connected with powersupply, no card installed, OSX 10.2.8: Mac IS booting
- HD connected with card, HD connected with powersupply, HD connected with data cable, no card installed, OSX 10.2.8: Mac IS booting
- after PRAM and OF reset, with card and HD installed: Mac NOT booting

than this...

- card and HD installed in PowerMac G4/400MHz (AGP Graphics)(version= 2.7), 896MB, Mac OSX 10.2.6 (6L60): MAC IS BOOTING... it bloody works!! but it's not my Mac!!

hope that will shine some more light on this story. if you need more info or want other testing results please mail.

Who has got the answer?

Olijf

P.S. ataMan, I'm all ears!

ataMan
11-17-2003, 11:34 AM
Olijf,

Please do not experiment with the card you have. It won't boot in your machine, no matter what. Please put it aside and provide FirmTek or MacGurus with your address. The issue is not within FirmTek driver, but either it is an Apple or SiliconImage bug. There is a batch of prototype cards which seems to avoid an other issue of your machines (deep sleep). All DigitalAudio and QuickSilver machines do not wake up from deep sleep if the card is installed. However, a very small number of these machines does not start at all. My theory is, these issues are having the same root. This is outside of FirmTek control bu it will try to help as far as possible.

Please read my previous posting again.

TheKoyoteKid
11-18-2003, 06:23 PM
Well, after a few days of trying to fix my B&W to try the card out there, I put the SeriTek into my DA, and behold..it boots. Its recognized by ASP and it works like a charm.
So, I must have had a bad card the first time?

So thats atleast one DA that boots with the card installed.

Tyler

Olijf
12-08-2003, 05:58 PM
Hi,

still no "white smoke" from Firmtek and its engineers ;-(
it seems that it has something to do with the software on the card. well, i just hope it will work this week. the stuff is lying around for weeks now. just a waist of money sofar...

just now i found out that there is another SATA card that "might" work on a G4 QS, a Sonnet SATA PCI card. does anyone have any experiences with this card? the website tells me that it will work with al G4's (except Cube's).
all news is welcome!

Cheers
Olijf

ricks
12-08-2003, 09:49 PM
?I haven't heard word one back from Firmtek. One thing I can tell you, it isn't software. At least it isn't anything to do with Firmware or drivers on the card. Even with no firmware at all it is possible to get some few computers to not boot or support sleep with cards that use the particular SATA chip that the Firmtek and Sonnet both use. It appears that just the connection with the Sil SATA chip is enough to cause this, even with no firmware at all.

?Another thing I can tell you, the Sonnet card is exactly the same as the Firmtek card. Take a peek at the PDF data sheet from Sonnets spec page and you'll see the exact same card only on a different colored board. And since firmware isn't the issue the Sonnet will share the same liabilities.

I thought you had that card working fine with sleep disabled? What happened?

Rick

Quis Custodiet Custodes Ipsos?

[This message was edited by ricks on Mon December 08, 2003 PT at 21:00.]