PDA

View Full Version : G4 boots to firmware, then to grey screen



Appleman
10-06-2003, 06:05 PM
I bought a G4(Gigabit Ethernet) what was just the case, logic board, CPU and power supply. Power supply was bad, had it replaced. Added stock video card, hard drive, RAM, optical drive and have successfully installed OS X (10.2).
This is the problem: After pressing the power button, there is a long tone(beep) that is played, followed by the usual start-up chime. Then it just loads the open firmware. After typing in mac-boot, I get the grey screen with the Apple logo and the spinning gear, but that's as far as it gets.

From the Open Firmware I have done the reset-nvram, set-defaults and reset-all commands, nothing. I have reset the PMU, nothing. I think I have 2 issues here. One in that is only loads the firmware, and two in that it won't load the OS. I read somewhere about booting into single-user mode and blessing a folder somewhere, but it won't start in single-user mode. Although I can get it to when booting from the install CD, but then it won't mount the drive (insufficient permissions)

Anybody have any suggestions?

ricks
10-06-2003, 09:52 PM
?The long tone at the beginning makes me think you have a ram problem. A single beep is supposed to mean no ram installed I think. You might pull all but one ram module and see if that persists. Switch the ram around and see if things change.

?You will not be able to boot into single user until you have an OSX install in place able to be accessed. Open Firmware is stored on the motherboard, single User is loading the UNIX core and no user files. Most of the boot rom is stored on your hard drive or CD so if neither is available you will not get past Open Firmware. That is why it will boot a CD but not the hard drive, your hard drive is inaccessible.

?I would pull that drive and be certain of its jumper settings. I would also run Disk Warrior on it. DW is bootable from CD.

Rick

Quis Custodiet Custodes Ipsos?

unclemac
10-06-2003, 10:40 PM
If it is a short beep, then Ricks is correct, according to Apple (http://docs.info.apple.com/article.html?artnum=58442). Reseat your RAM, and verify it is correct; OS 10 is unforgiving about RAM speed and quality. If you have the Apple Hardware Test CD, that might help verify your hardware, including RAM.

If it is long tone (maybe 2-3) seconds, then it might be the firmware update tone, not a hardware test beep. Most G4s need a firmware update before installing 10.2.... check here (http://docs.info.apple.com/article.html?artnum=86117) if you are not sure about your model. And don't forget, you can only run the firmware updater from OS 9. If you don't know the history, you might install 9 and check/update firmware. I have not seen a new world mac do exactly what you describe, but have seen them be wonky and unstable because of a lack of a firmware update.

Hope that's all it is...

__________________

Charlie Don't Surf!

[This message was edited by unclemac on Tue October 07, 2003 PT at 8:09.]

Appleman
10-08-2003, 03:25 PM
The hardware diagnostic CD listed no RAM problems, but it did state that no mass storage device/hard drive was attached.

Booting from a CD has been troublesome in that it is working very inconsistently. Once I get it to boot an OS 9 CD, I will attempt the firmware upgrade, although the current firmware seems to be the latest (4.2.8), but without knowing the history of the computer, I don't know if an upgrade was in progress or not. I'll keep trying.

I was able to boot DiskWarrior, it found some problems and apparently fixed them, but nothing changed. I will continue looking down there as well.

The hard drive jumper settings is a good point, I will check them. I believe it is set to CS, so should I change it to Master then?

Bear with me on responses, I left the computer in another city for the next 2 weeks, so I am getting my father to do things I am suggesting. So it takes a while to get any responses to the steps.

Also, what really boggles me, is that everything seems to point to hard drive, yet I was able to finish an OS X install, why would the OS install, if there was a hard drive problem? Also, at one point when I was having CD-ROM issues, I started the G4 in firewire target disk mode, and mounted the hard drive on my Dad's powerbook. I installed OS X onto the now mounted firewire drive. I was able to boot the powerbook off the firewire drive, it loaded OS X and I went through initial setup, including the initial user accounts. So, it's like the OS has been loaded, and it works, just not when the G4 tower boots off it!

ricks
10-08-2003, 03:34 PM
?Make sure you set the drive to Master. Only the new Mirrored Drive Door G4s support Cable Select.

?Since the problem appears to be hard drive related I would check the cable for bends, bent pins on drive and motherboard connectors, power connector should be OK since DW tries to fix it. Check every last jumper on the drive just in case something was installed that shouldn't have been.

?Your best tool is usually Apple System Profiler for mounted devices and firmware versions. Hard to use if your drives aren't allowing you to boot up. If you have a jumper problem it can effect the EIDE Optical bus as well making booting from CDs difficult.

?Keep at it, you will get it running.

Rick

Quis Custodiet Custodes Ipsos?

unclemac
10-09-2003, 09:15 AM
To second Ricks, make sure you have the drive jumpered to Master!

Firmware is most likely correct if it is showing as 4.2.8

FYI, If you want try to reinstall the current firmware, when you attemp you will recieve a message that states that the firmware is up to date (assuming it is current and was installed correctly), or words to that effect.

If you do want to check/install firmware, the updater must be run from 9 from the HD; the mac has to be booted to the HD, and the firmware has to be on the HD. Booting/running the updater from a CD isn't possible.

Having said all that, I would not bother until you set the drive to Master. I have seen several Macs myself with the CS jumper problem. . . You will probably want to reinstall OS 10 after you resovle this.

What do you think Ricks? Foolhardy to run the current install if the jumper change fixes the problem?

__________________

Charlie Don't Surf!

Appleman
10-09-2003, 09:44 AM
Ok, drive jumper has been set to Master, disk has been reformatted using Disk utility with the OS 9 drivers (just in case) and the OS reinstalled. Now, the grey screen sits there for 2 mins, then goes to the login screen, except there is no username/password box, just a blue screen with the cursor available. I think this might be covered in this document:Apple Article (http://docs.info.apple.com/article.html?artnum=106214)

Am I correct in thinking this? Also to note, that there still hasn't been any user accounts created, as this is done after the first reboot after the install, which still hasn't occurred successfully.

unclemac
10-09-2003, 10:02 AM
So, blue screen and curser... Do you see the extensions load with the progress bar? Sounds like no.

Normally, at the first startup, you get the "Welcome" assistant to build your first user; since you are not getting this far, there must be some other problem...

You could try safe mode or fsck per your last link, but I would not expect to need to do either after a clean install.

Like Ricks said (again!) did you verify *all* the jumpers on the drive, check and recheck cables, etc? I wonder what else - hardware wise - could be at fault?

Just thinking out loud here: bad HD, bad cable, or bad ATA contrller? with other macs available at work, in this situation I would start swapping components to verifiy each one; hard to do with one machine...

__________________

Charlie Don't Surf!

TZ
10-09-2003, 11:02 AM
Try getting to single user mode. From there you can

> sudo diskutil repairPermissions

What you need to do is launch the startupassistant which is in your home library.

You could also boot from the Install CD and see what it wants to do, repair the disk, repair permissions.

Appleman
10-19-2003, 09:28 PM
Ok, I now got OS X installed successfully. It was a bad IDE cable. But I still have the long beep and boot to firmware. What I would like to try is a firmware upgrade and see if that does anything. But the firmware upgrade has to run in Classic, which my install doesn't seem to have. I can't boot from an OS 9 CD either(holding down c key), it just shows a grey screen. I tried selecting the OS 9 CD as the start-up disk, but I still get a grey screen. I tried copying the System Folder onto the OS X hard drive and running classic that way, but it just hangs.

How do I get into OS 9 to do a firmware upgrade?