PDA

View Full Version : external scsi problem for upgraded 9600, Mach 5



thilderi
08-13-2003, 02:26 PM
Hi,

Perhaps some of you are aware of this problem with a 9600 Mach 5 board.

I have used the Miles2 scsi controller internally, working fine with 2 Seagate drives, using OS 9.22 and applied the firmware patch for Seagate. Besides I am using the ATI 7000 graphics board and the XLR8 G4 450 MHz SSE upgrade. Everything fine sofar.

But my external scsi (original Apple 9600) is behaving strange!!!When I connect a HP scanner 4C, everything works.

But adding an external drive (HD or ZIP) is a disaster. The system refuses to boot when the external scsi device is on line / activated (Except for the HP scanner). Even the laughing mac doesn't appears and the video remains black. I tried it with several external HD's.

I have swapped the 9600 board (!!), the power supply, zapped the PRAM etc. swapped RAM and the phenomena are remaining the same!!

Any idea what it could be?

Thanks in advance!

-------------------
Editorial note:
This scsi problem has been solved now! See below.

However, to be able to use external scsi equipment, I bought a scsi controller card, the Bluenote from INITIO and tried to install this card for my external equipment.
No succes up to now.


Theo Hildering

[This message was edited by thilderi on Wed September 03, 2003 PT at 0:46.]

[This message was edited by thilderi on Thu September 11, 2003 PT at 7:56.]

M.Brane
08-13-2003, 05:02 PM
Only the last device on a SCSI chain should, and must be terminated.

All devices must have a unique ID#. Remember the host is always #7

Cables should be of good quality, and only as long as necessary.

I've read in more than a few threads that Zip drives can have flakey termination. Mine seems to be fine, but YMMV.

If you're sure the term & ID's are configured properly, it could be a cable issue.

Edited for clarity.http://macgurus.com/infopop/emoticons/icon_wink.gif

[This message was edited by M.Brane on Sat August 16, 2003 PT at 8:44.]

thilderi
08-15-2003, 01:48 AM
Thanks for your reply.

I have tried everything, even in combination with another computer. The same external scsi equipment works fine with my 8600 Mach 5 board!!
So I can't imgagine a scsi cable issue.
It is really connected to the 9600 board (XLR8 SSE G4 450 MHz upgrade)

Since upgrading to the new Mach Speed control version 2.63 (Now from Daystar!) original 2.61 (XLR8) I see a difference. The 9600 refuses now even to boot when the connected external scsi drive is OFF_LINE! Video remains black!
But the HP scanner still works!

Kind regards,

Theo

thilderi
08-16-2003, 06:35 AM
Hi,
I have tried everything (!!), changed processor with the original 604ev-350 MHz, removed PCI cards from the lower 3 slots etc. In every configuration I have the same booting failure when attaching an external scsi device (especially the external ZIP drive)

Now I have attached an external CD-R writer with a perfect reputation from the past, always reliable!

Result:
This 9600 starts up normally(!!) in 80% of the cold starts, in the other 20% the video remains black and booting stops. It seems to be a lottery!!

READING CD's is good, but WRITING is impossible (lots of error messages)
So the scsi communication is still troubled with errors (noise?)

Could it be noise from the 5 V power supply
(390 Watt version)? So, after swapping boards, now swapping the power supply?

Any idea is highly appreciated!

M.Brane
08-16-2003, 08:41 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by thilderi:

Since upgrading to the new Mach Speed control version 2.63 (Now from Daystar!) original 2.61 (XLR8) I see a difference. The 9600 refuses now even to boot when the connected external scsi drive is OFF_LINE! Video remains black!
But the HP scanner still works!

Kind regards,

Theo<HR></BLOCKQUOTE>

Hmmmmmm. By off-line do you mean disconnected? What drivers are you using for your other devices? Could be a conflict there. I use Intech for all my drives. Have you tried going back to 2.6.1? That's the version I'm using on my 8600. The only thing on the external SCSI is my Zip though.

Have you contacted Daystar about this issue? They might be able to help. t

thilderi
08-17-2003, 06:01 AM
Hi,

I have got some informantion from Daystar (Gary)
Very kind and helpful! However no solution sofar.

I had the idea to investigate the power supply, regarding high frequency disturbances (EMC problem?) but Gary advised at first to investigate RAM. I swapped it with the RAM from my 8600 Mach 5, same type and size (512 Mbytes, 4 x 128 Mbyte EDO Ram, OWC brand), which is running fine (!) with external scsi devices and still does with its G3 upgrade, XLR8 Mach Speed 400/200/1Mbyte. In both systems I am using the highest no's of the Ram Banks (Interleaved)

An explanation to Bran regarding OFF_LINE:
I just disconnect the MAINS power of the scsi device that remains connected to the scsi interface. That could influence the noise on the scsi bus. This exercise has impact with my Canon filmscanner!
In the On_line situation the 9600 refuses to boot, Off-line it works.
For my ZIP drive it makes no difference, the 9600 refuses to boot anyhow!

Both computers (8600 and 9600) are connected to an UPS, from APC (1400 VA) There is a mains filter inside for normal operation.

Should I really swap the power supply ??

Any idea is really appreciated!

TZ
08-17-2003, 07:24 AM
I don't trust the scsi termination of zip drives at all, preferring to use active terminators to tame scsi chains.

Some people go for years turning on scsi scanners as need, then turning off, without the use of a "safe" pass-thru terminator that can temporarily terminate the chain.

Passive termination may or should 'work' but we've learned and seen in OS X that SCSI termination and tolerance is much tighter.

If a device is off and was using passive termination or using a jumper to terminate, that might be a problem. I know you said you've checked all the jumpers. it sounds like there is damage.

Do you have an old box full of active or passive terminators and cables to try swapping things?

M.Brane
08-17-2003, 09:56 AM
Sure looks like a termination issue to me.

I would try TZ's suggestion of disabling term. on all external devices and attaching an active terminator on the end of the chain. Probably cheaper & less hassle than swapping the power supply. I would think if the power supply was having problems it would affect more than just the ext. SCSI chain."

thilderi
08-18-2003, 01:37 AM
Hi,
Of course the ideal situation is with active termination. But it is very strange that only this 9600 Mach 5 is so sensitive to the external scsi. There must be another reason, because 2 other computers (8600 Mach 5, 400 MHz G3 and another 9600-200 MHz 604) behave good!

(But I must admit, the 8600 Mach 5 is more sensitive with regard to termination than the older 7100, but it works with ALL my external scsi equipment, including the ZIP drive)


I think that I should stick to 4 HW differences:
- the 9600 case (EMC shielding near the scsi connector, perhaps corrosion of the strips?)
- the power supply
- main board (already swapped)
- The Farallon ethernet 100/10 card.

All the other HW have worked without problems in the 8600 (eg PCI cards)

I still have the idea that there is a high frequency disturbance (a crystal oscillator, which is not designed properly with regard to EM radiation), that is demodulated at the external scsi interface. The scsi cable could pick-up the signal. That could explain why the ZIP drive (with the standard 25 pin scsi cable, not shielded?) is having troubles in both on/off-line situations.

TZ
08-18-2003, 06:43 AM
Granite Digital cables and terminators deal with all of those issues you list. We know Iomega never used good equipment. And stuff fails over time.

I've had my 7100 with 3-4 drives, scanner and zip and used TWO smart-active terminators. I think we've all heard that sometimes you have to terminator in a non-standard method. There is a limit in length of cables also. SCSI was never built to perfection as far as standards go, and OS 8/9 were very forgiving.

Even if there was interference, a proper cable will shield the equipment. I think replacing those items would be "barking up the wrong tree" maybe.

thilderi
08-18-2003, 07:56 AM
Hi
I think that TZ is indicating the right direction. But good cables and active termination have only benefits if the 9600 case connection (at the scsi connector) is good, especially at high frequencies, because of skin effects!
There are thin EMC "fingers" in the case behind the scsi connector and they are 6 years old ..corrosion?
If there is a high frequency resistance in the system ground, it could easily act like an antenna ( experience with high power AM transmitters and gold-plated coaxial connectors)
and create a common-mode signal on the scsi bus.

SOURCE?
Could it be that my ethernet switch (4-1, with 100 MHz) and cabling is the EM radiator? It is situated close to the 9600 computer and that could explain the difference with my other computers.

thilderi
09-03-2003, 12:07 AM
I gave up to use the external scsi from my 9600 after trying everything as proposed. So I ordered last week a brandnew Bluenote (INITIO), to create another external scsi for my external equipment.

I had downloaded the latest software from the Initio site (Beige systems only folder!!!): using Smartscsi version 3.06 and changed the firmware to Macfirmware Version 2.11 (created 1959!!)
(Using the internal Apple disk for booting)

This firmware version 2.11 is declared also by the new Smartscsi utility 3.06 (On top of the application window)

However, when running the older Smartscsi application version 1.05 on the (obsolete ?) supplied CD, the utility states that this Bluenote card is for PC use only !! (after changing to firmware Macversion 2.11 That gives confusion!

NOW I see that this Bluenote and the Miles2 are NOT compatible in my 9600!

I have done a lot of experiments, changed PCI slot for the Bluenote (between 3 and 4). The system refuses to finalise the booting process and halts when the icon appears from the laughing Mac. And it takes a lot of time (ca 3 minutes) before it starts with the booting process (without success) after a cold boot.

However, when I disconnect the Seagate drives from the Miles2 (Softraid 2.2.2), the system wants to boot completely from the internal (Apple) disk. (while the Bluenote is in PCI slot 3 or 4, no equipment connected)

As soon as I connect the Miles 2 internal cable, the booting process from the same internal drive halts again when the laughing Mac appears.

I have ZAPPED the system several times etc. the phenomena are repeatable and consistent.

Now I have removed the Bluenote card and my system is happy again! (except for my external scsi devices)
http://macgurus.com/infopop/emoticons/icon_mad.gif

[This message was edited by thilderi on Wed September 03, 2003 PT at 8:05.]

[This message was edited by thilderi on Wed September 03, 2003 PT at 8:10.]

kaye
09-03-2003, 07:18 AM
I don't know if this is helpful

http://www.macgurus.com/6/ubb.x?a=tpc&s=40160367&f=18460098&m=85660798&r=36660798#36660798 but the CD stuff will not recognize the Bluenote properly until after you have flashed with SmartSCSI and the sim file in the "Bluenote Beige Systems 9 only" folder. Even then I wouldn't use what is on the CD. Just use the latest download files and don't change sim files from the one inside that "Bluenote Beige Systems 9 only" folder.

Since I wrote that link, I do have Jaguar on my PTP now and I will say that I can flash back and forth between 9 and X sim files for both my Miles2 and Bluenote cards. It is somewhat of a hassle but it works. I do have two IDE drives to boot from via a Sonnet Tempo RAID133 PCI card but not running in Hard RAID mode, both 9.1 and Jag, which makes the flashing much easier. Last, my PTP has been modified with a Sonnet G4-800 and the Kansas Mach5 ROM. k

thilderi
09-05-2003, 04:59 AM
Status report.....

I have changed the Bluenote firmware to Macfirmware Version 2.11 and this is acknowledged by the older Smartscsi 1.05.

(You should NOT use the smartscsi 3.06 in the beige folders only on INITIO's website but the other 3.06 in the main folder!) After flashing it to the blue and white Macversion 3.06, I used the older Smartscsi 1.05 and the older Bluenote sim to get Macversionfirmware 2.11, without any reference to a PC-bios


However, the Bluenote still blocks the 9600!
As soon as I connect the internal LVD cable from the Miles2, the 9600 refuses to boot from the original Apple HD. The booting process halts when the laughing Mac icon appears (you could hear that the internal disk is starting to boot in a fast way and suddenly it remains silent)

This seems comparable with the phenomena when connecting a ZIP drive to my original 9600 external scsi interface!!!!

Softraid 2.22 conflict?
Could it be that the Miles2, with Softraid 2.22 and the 1.06 Sim (beta version, to be used in combination with Cheetah drives) & OS 9.22 is the cause? That was the only constant factor in all my exercises!!
Perhaps I should change disk-cache parameters in Softraid? (now optimised for Adobe Photoshop)

PCI conflict?
When I put 6 PCI cards in the 6 slots (incl. Sonnet Tango and Bluenote) it is impossible to reset the PRAM during a cold boot!!Total blocking!! After removing one card (eg the Tango), the pram reset works. But the booting process still halts.

So I have removed (again) the Bluenote and the 9600 is happy again (except for my external scsi equipment!)


Any idea is highly appreciated!

thilderi
09-07-2003, 03:53 AM
I have followed the advice from Mark James (SoftRaid) to disable the SoftRaid Accelaration. After disabling acceleration, the behaviour of my original external scsi was "normal" again. I can connect several devices!!!
This disadvantage of this strategy are slower Cheetah drives..

So this confirms Mark James statement: Softraid acceleration makes a less optimal scsi situation worse! (something to express loud and clear in the MACGURUS scsi forums!!!!).

So I checked once again all terminations, cleaned them (!!) and used an active terminator at the end of the chain. Then I reinstalled the SoftRaid drivers, everything in the default setting!
I guess that this was what the 9600 system needed.

Note: I reflashed the Miles2 firmware too!

Now everything seems perfect with the 9600 external scsi! I have connected 2 scanners and the ZIP drive!

However, during 10 different starts, I observed 1 refusal to boot and 9 successful bootings. Still something spooky?


MILES2 PROBLEM?
The compatibility between the Bluenote and the Miles2 are now open for new investigation. Perhaps this will work now too! I will keep you informed.

[This message was edited by thilderi on Sun September 07, 2003 PT at 7:23.]

[This message was edited by thilderi on Sun September 07, 2003 PT at 7:24.]

[This message was edited by thilderi on Thu September 11, 2003 PT at 7:58.]

kaye
09-07-2003, 09:52 AM
Yes please do keep us informed. However that tip by Mark James is nothing new to us nor to the SoftRAID website Compatibility FAQs (http://www.softraid.com/compfaqs.lasso) and Troubleshooting (http://www.softraid.com/troubleshooting.lasso) and do a search for acceleration on both pages.

So many possibilities. Age or firmware of the drives, G3/G4 upgrade to a vintage or even New World machine, best quality cabling and termination, SCSI card/s, MacOS, and on and on. k

TZ
09-07-2003, 11:19 AM
It is also possible that newer SEagate Cheetahs would work well, faster, and with improvements in the drive's firmware.

There use to be problems (still are if you have older drives) using Adaptec 29160/N cards and 9GB Ultrastar and some Seagate drives. So it isn't unique to just Miles or Initio.

It is next to impossible to remember everything, but firmware on drives, cards, etc has always been a factor. I've heard of people having to switch off synchronous transfer and use asynch to get reliable results which also really really slows down a drive.

SATA may offer hope, I think but it is also very slow on Vintage systems probably, too.

thilderi
09-11-2003, 04:40 AM
After trying several approaches I gave up. The Bluenote doesn't work with the Miles2 in my upgraded 9600.

I had simplyfied the 9600 system as follows; removed at first all PCI cards, including the Miles2

Put in at first the Bluenote (Slot 4) and my ethernet card in Slot 6. Started up from the Apple HD and works (without video control). Shut-down with the Power-up button and return.

Put in the Miles2 (Slot 1, without cabling!) and it started-up after PRAM reset. Shut-down again.

Put in the ATI Radeon 7000 videocard (Slot 5) and after PRAM reset (and first start-up without video!) it started to work with video and shut down the system.

Connected the LVD cable to the Miles2 and again the same phenomena;
Booting halts when the laughing Mac icon appears.

After a cold Pram reset (This worked now, however more than 100s between the chimes!) the system refused to give video and didn't want to start at all!!!

So I took out the Bluenote and could start initialising the 9600 all over again (with several PRAM resets, when putting in the PCI cards)

Luckily the system is back now in the condition where the external scsi is working fine.