View Full Version : Can't print from Classic on OSX-only Mac

04-16-2003, 01:06 AM
I have recently bought a new G4 that boots only OSX and I have a huge problem I have not yet solved. I can't print from Classic apps including Quark. Apple does not officially support printing out of Classic and the last HP tech (I have a Laserjet 1200) pretty much said it can't be done. Reason: drivers seemingly only work if installed in a bootable OS9 system. HP doesn't seem to know that Macs no longer boot into OS9. It LOOKS like you can print and the printer even blinks, until the inevitable -8993 postscript time-out error comes up. Anyone have a suggestion?

04-16-2003, 03:49 PM
Actually, you can run "Classic" and you may be able to actually install stuff into Classic as well. That or switch to Adobe or wait for Quark 6 I guess.

04-16-2003, 10:32 PM
You may be able to set up IP/LPR printing. If you have printer sharing running on the OS X side, I believe that you can print to it with LPR printing. There are guides out there that describe the procedure. Next, on OS 9, you follow this guide:

Use the TCP/IP address of your Mac, and the printer name as the queue name.

It should then allow you to print to your printer from OS 9, but use IP to loop back to the printer that's actually shared by CUPS on the OS X side. I haven't tried it, but it will theoretically work.


04-27-2003, 05:56 PM
I have recently succeeded in printing from Classic. Apple support suggested I download HP's latest OS9 drivers. They are bundled with OSX drivers. I think I had already installed this package but I'm not sure. However, I did delete all existing desktop printers that I had created and reinstalled the OS9 drivers. The thing I believe that made it work was something I saw in this or another forum: I did a get info on the installer and checked the "Open in Classic environment" box. Then I ran the installer and now I can print directly fromm Classic programs. I also plugged the printer's USB cable directly into the computer instead of the keyboard where I had it connected previously. Apple suggested this because of the lower power of the keyboard port. I'm not sure it was a factor because I have always printed out of OSX with no trouble. I still have Postscript issues, however, due to my printer being an HP LaserJet 1200. Printing graphics out of Quark sometimes requires selecting ASCII as the data format. Binary doesn't seem to work.

[This message has been edited by rkenney12 (edited 27 April 2003).]

04-27-2003, 08:43 PM
Thanks for the update. I have never heard of the Get Info check box for classic environment install. Good to know.

A printer connected to the keyboard in OS9 will frequently not work. It may also depend on whether you use an Apple mouse or something else like my Kensington Turbo Mouse Trackball which draws more power than the Apple mouse.

Question about your comment on having to use ASCII vs binary format on your PostScript printer. Been a long time since I used a PS printer. Is there an advantage to using binary? Faster or better output? k

04-29-2003, 06:30 PM
Kaye- I really don't know the difference regarding PostScript data in binary versus ASCII mode. Quark print dialog "picture output" defaults to binary. I guess I assumed binary was more compatible for graphics. So far ASCII seems to be getting the job done although I've read that some binary eps files might give trouble. It's just one more setting i have to remember to change. I don't believe it's printing slower. It's hard to say if ASCII prints faster because I've only used it with my new faster Mac and new LaserJet 1200 so everything seems zippy (except the OSX Finder!). Why the LaserJet 1200 can't handle binary data is another question. It also seems to print crooked on the page sometimes which is another issue I've seen others complain about with this printer. I may just have to move up to something a little more capable.

After successful testing the printer is again plugged into the keyboard (Apple mouse on the other side). This just works better for me as I have a USB floppy drive to connect and no hub.

04-29-2003, 09:00 PM
Thanks for the info. k