PDA

View Full Version : Beige G3(G4) EXTENDED startup times



hubba bubba
09-05-2001, 08:46 AM
Specs:
Beige G3 rev.2 (maybe 3)
Had G3/333 OC'd to 400; now G4/400 OC'd to 66/433 and 70/420
384MB RAM, PC 133
Apple/ATTO stock UW PCI
Belkin USB/Firewire PCI combo
ATI XClaim VR 128
2 9.1GB Seagate Cheetas in RAID 0 on ATTO (boot drive, OS 9.2.1)
1 Maxtor 7200RPM 30GB on primary IDE (OS X and backups)
1 Hitatchi DVD on secondary IDE
1 Plextor 40x U-SCSI CD ROM on internal SCSI
1 external ZIP 100 on external (internal/same bus)
1 Yamaha 8/8/24 Firewire on Belkin card
Extra processor, case, and drive fans to keep everything cool

Phew, think that's it. What happens is, I press the power button, power comes on, drives spin up, my monitor's light blinks orange for approx. 1 min., then I get video and it will by default boot into X unless I hold cmnd, opt, shft, del. The startup time is what's worring me, not the booting into OS's. Startup memory tests are off, but this seems to be happening before startup memory testing takes place. This happened also with the G3 chip, in 9.1, before the firewire card and drive. It also seems to go away for a little while whenever I open the case to perform my endless tweaking only to come back again at a later date. It seems to have started when I added memory a while back (some PC133). The memory is generic (I know), but all up to spec. with Apple's current systems. I've ran thorough RAM tests with Apple's MacTest Pro and with XLR8's utilities even leaving it overnight...the system always pulls through unscathed. Other than this everything runs fine, no lock ups, the usual minor app crashes...I just can't stand it not being 100% perfect ;-)

Any ides would be appreciated.

[This message has been edited by hubba bubba (edited 05 September 2001).]

ChrisYip
09-05-2001, 09:18 AM
Couple of things come to mind

(1) is AppleTalk off?
(2) are you trying to mount a network drive - my machines take a while to boot up too as they try to mount up drives.
(3) File Sharing on / off
(4) Device scanning - the more devices on your various chains - SCSI / IDE / Firewire - the slower it will be to boot, I suspect, as each device is scanned. I know my 7300 that has 4 hard drives, MO, three VXA, CD-R, CD-RW, MO, DAT, pen tablet, USB mouse, US camera takes a while to boot up too...

Chris

hubba bubba
09-05-2001, 11:19 AM
Appletalk is off, file sharing is off, no servers to connect to. The thing is, this is happening before I even get a video signal. Software wise I keep this machine lean and mean, but this is before we get to any OS.

ChrisYip
09-05-2001, 03:07 PM
Odd...

Can't hurt to try a PRAM zap...I've had issues where it would stall (w/ a video signal) until I did the PRAM / NVRAM zap....
Chris

lasvegas
09-05-2001, 03:11 PM
hubba: Boot into OpenFirmware (Command-Option-O-F) and then enter the following:

>setenv auto-boot? false
>boot

On subsequent boots just enter "boot" to start OS X. This will give you a display of what's going on during that delay. I expect you'll find that the computer is having difficulty finding the OS X partition. What you should see is a repeated message to that effect before the screen goes grey to the smiling mac.

When you're done diagnosing through OpenFirmware enter the following to restore normalcy:

>setenv auto-boot? true
>boot

[This message has been edited by lasvegas (edited 05 September 2001).]

hubba bubba
09-12-2001, 11:06 AM
I'll try that tonight...been busy lately. It seems to be related to memory though, because after I installed a 256MB chip for 512 total, the black screen lasts noticibly longer before I get a video signal than with 384MB. (With startup memory tests off).

hubba bubba
09-12-2001, 11:13 AM
BTW, I also tried a rev. 3 ROM chip (this had a rev. 2), same issues.

hubba bubba
09-14-2001, 11:31 AM
Installed xlr8's latest software, v2.5. Seems to run a bit better (still have the purple line problem, if you look at my post in the processor upgrades forum), still had the startup problem. Installed xlr8's startup disk control panel modifying software, now I can better select the OSs to boot from. Had the problem one last time, but last night I powered on, got video immediately and booted up normally. It's done this before, but it only lasts for a few days/weeks for some reason. Can't say it's solved, but It seems now like it must have something to do with OS X on a computer that Apple says is supported but is more than a bit quirky. We'll see how long this lasts. If anyone checks out the other post, I'd love to have some ideas about what's going on with the lines. Thanks a bunch.

seekr2
01-02-2002, 12:33 PM
Hubba bubba -
I have the same extended boot times on my rev3 beige G3 MT. After zapping PRAM, it will boot right up, but after a while, reverts to a 60 second delay. All RAM etc checks OK, new battery etc., etc.

Have you found the problem yet?

seekr2
01-02-2002, 12:37 PM
Sorry - should have noted that this is with 8.6 or 9.2.1 on the internal partitioned HD. Also happens with internal SCSI running 8.6. After PRAM zap, machine always reverts to SCSI as boot disk, starting right up. But the problem eventually returns, regardless of boot drive.