PDA

View Full Version : Uh Oh, Spaghetti-O



batmantis00
09-01-2001, 06:20 PM
I just swapped the mobo in the beige g3 with a newer one (rev 3). since i installed it, ive got no sound. Im a little worried. The comp doesnt even recognize a sound input (it wont let me move the volume control up from the lowest setting-its locked on mute.) Ideally, this would be a busted speaker or damaged audio cable from the dvd-rom, but i dont think thats the case. if i disconnect the audio cable it gives me some warning about not having an input and the cd/dvd driver not loading properly, so i assume the cable is ok (I tugged it pretty hard when trying to remove it was the reason for my concern there). I think if the speaker was blown it would play sound, thinking it had an output, but i just wouldnt hear it. i tried plugging head phones in the back and still got nothing. that and the inability to change the volume indicates to e that it isnt the speaker. The ASP recognises the whisper card in the perch slot, so im prety sure its seated properly. btw, will a rev 3 board accept a whisper? or do they only support the a/v input cards? im not stoked at buying a new perch card, as they are spendy, but its better than finding out that something is wrong with the motherboard. If someone has some reccommendations of tests I can do to isolate the problem I would love to hear it.

bat

dragon_x
09-01-2001, 07:10 PM
What version of MacOS are you running?
With version 8.6 you can use INTECH DVD/CD drivers and run sound over the IDE/ATA bus. With 9.x this is automatic with the Apple drivers. What DVD-ROM do you have? Is it an Apple OEM or compatible?

If the speaker was blown, you would probably still hear sound - but it would be mostly noise and garble. I have about 4 bG3s at work, but I've never really examined the perch card - I've only installed RAM, HDs and PCI cards. I guess if you need to replace it you could probably go ALL OUT and get a full blown AV card for cheap, right? http://macgurus.com/infopop/emoticons/icon_smile.gif

I did have an issue that vaguely resembled this - when I moved my S900 out of its stock case. I did not have any mounts for the switches and occasionally one would ground out (I later added electrical tape) and I would lose sound. I could not even adjust the sound on the sound control panel. Usually rebooting fixed the issue... of course the tape helps to... maybe you have an 'low level short' in your case?

Brace for some misspelled words! http://macgurus.com/infopop/emoticons/icon_biggrin.gif


------------------
Life in the fast lane leads to:
The Resteraunt At The End Of The Universe

batmantis00
09-04-2001, 02:55 AM
since i dont even get a startup chime, i dont think its a software problem (unfortunately). My next hope is that its the perch and NOT the motherboard (please GOD). Im running various 9.x's righ now. BTW, has 9.2.1 killed anyone else. Anyone know what commpn problems/solutions are. I just installed a barracuda IV (st380021a) and installed on an empty partitioon, and it crashes during startup. I installed on a scsi drive and it does basically the same thing, though it gets slightly further along in the startup.

another fun problem im having since the mobo swap. about 1 restart in 2 hangs my original system folder, which i havent changed since the swap. once that happens i have to reset the PRAM to get through a startup.

Man I love this. even better, my nice new teflon ide cable is too short. so i have to swap drives in and out till i figure out whats going on and find some longer 2 device cables.


also, you know where i can get one of those av perch cards cheap? they are like $250 at preowned.com and usually go for $150+ on ebay. that doesnt fit my idea of cheap, since i can get a whole beige g3 for $600-700 or less depending on where you look.

[This message has been edited by batmantis00 (edited 04 September 2001).]

dragon_x
09-04-2001, 10:08 AM
Well, I've never done business with these guys - but they seem to have a good deal. Looks like a complete mobo swap is only about $300 - I assume this includes a perch card, ROM(s), etc... of course no CPU or memory.
http://www.dttservice.com/powermacs.html

tachyon
09-05-2001, 03:07 AM
Reset the logic board and reseat the Personality card, then zap PRAM 4 times... Reset Open Firmware... maybe you bought a dud logic board?

hubba bubba
09-05-2001, 08:19 AM
I've worked on a few beige G3's where the problem was an unseated personality card. They have a way of working themselves out of the slot...

lasvegas
09-05-2001, 03:04 PM
Pressing the CUDA switch for 30 seconds does the equivalent of Zapping the NvRAM. Additional zapping would be unnecessary.

batmantis00
09-23-2001, 06:53 PM
The board had no battery in it when i bought it, so i think the nvram should have been blank. since im taking 18 units and working full time i dont have ANY time to play with it these days.

lasvegas
09-23-2001, 10:11 PM
If the battery was missing and you installed a new one, you still want to press the CUDA switch for 30 seconds. Inserting a battery simply initializes the NvRAM to a random state. The CUDA switch will zero the NvRAM using the battery power.

batmantis00
09-24-2001, 06:52 AM
you can boot up with the perch card removed. i didnt realize that was possible. when i boot up with the card removed, it still lists "whisper" under attributes. no amount of jiggling the card seems to get me a startup chime though, so i assume its fried. resetting nvram will get me through a startup, but only one or two of them. something seems to be corrupting the pram. no idea what though. i also installed a pc133 256mb dimm from the gurus on the day i swapped mobos. removing it doesn't seem to alleviate any of the problems though, so i assume its ok where it is. havent really decided on my next course of action.


[This message has been edited by batmantis00 (edited 24 September 2001).]