PDA

View Full Version : I think I killed my iMac 333's CD-ROM drive



Boo Berry
08-15-2001, 11:42 PM
Dear Gurus,

I believe I have just screwed up the CD-ROM drive in my iMac 333 by attempting to install the iMac CD-ROM Firmware Update 2.0. (Geek that I am, I couldn't leave well enough alone.) The flasher aborted and said the drive didn't need updating. Now it won't open without the paper-clip-through-the-hole thing, and CDs won't mount.

I do know this much: Apparently, the update attempt did something to the CD/DVD Driver (OS 9.1)--to test, I tried to open Apple CD Audio Player, and I got a dialogue box saying the driver didn't load at startup. It's there in the Extensions folder, though.

Tried rebuilding the desktop/zapping PRAM/running Disk First Aid.

Is this a lost cause? http://macgurus.com/infopop/emoticons/icon_frown.gif

Boo Berry
08-16-2001, 12:38 AM
Update: I just reinstalled the CD/DVD driver by downloading iTunes, and it still refuses to load.

lasvegas
08-16-2001, 12:54 AM
Boo: Try putting your System Intall CD into the drive and restart. If the CD mounts, the drive is fine. If this is the case, look for another CD extension conflicting with your Apple CD/DVD Driver extension. If no conflict can be found, try doing a custom install of OS 9 and turn everything off except the CD support in the Multimedia area of OS 9.

If the CD didn't mount, the drive is then suspect. Doing it yourself isn't terribly difficult, but the replacement drive may hard to locate. They usually run around $100.

Boo Berry
08-16-2001, 01:28 AM
No joy--I held down C on restart, and the system just booted from my hard drive.

lasvegas
08-16-2001, 09:36 PM
I assume then that the CD didn't mount either. With the CD present, it should load the driver from the CD even without booting it.

If you're comfortable replacing the drive yourself (not too difficult. Just screws and no soldering), I can look around for a replacement source for you.

Boo Berry
08-17-2001, 08:24 AM
>I assume then that the CD didn't mount either.

Yup. Has this particular firmware update hosed other people's CD-ROM drives?

>If you're comfortable replacing the drive yourself (not too difficult. Just screws and no soldering), I can look around for a replacement source for you.

Know anything about MicroDoc (www.microdocusa.com)? (http://www.microdocusa.com)?) They have iMac tray-loading CD-ROMs for $89.

tachyon
08-17-2001, 08:50 AM
do me a favor, try running the updater again?

tachyon

Boo Berry
08-17-2001, 12:20 PM
Hi, Tachyon. I'm at work, but I'll try it when I get home.

Also--would deleting my CD/DVD prefs help?

lasvegas
08-17-2001, 07:17 PM
Also--would deleting my CD/DVD prefs help?

Nope. Wouldn't have an effect. Wouldn't hurt anything though.

Boo Berry
08-20-2001, 07:31 PM
Tachyon,

Just got back from vacation--I tried reflashing twice a few minutes ago. Flasher aborted both times, drive still dead.

Looks like a new drive is the only route. At least it won't be too expensive ...

tachyon
09-03-2001, 07:46 AM
If I were you and knew what I know, I would take the issue to Apple Customer Relations, and present a case to them that explained the situation. "My perfectly working drive was made defective by your own software!" The Tech Support Center will have records of if this has happened before (it hasn't in my experience and I happen to believe it was coincidental, like the guy that posted about loading Photoshop turning his iMac screen pink...)
I'm not sure how you would prove that it wasn;t faulty before, the Techs at Apple might wish to inspect it first...

No, I haven't checked if there are any TIL articles regarding this issue. Did you try resetting the logic board? Also, a backup and reformat of the hard drive followed by yet another attempt of firmware updating would be what I'd do. I'm not sure about the CD-ROM updater, the the "normal" iMac firmware updater works by putting the new firmware data on the hard drive. If it works the same way, it's possible that this has become corrupt somewhere in the process and it uploaded garbage into the CD-ROM's firmware, thus giving you your symptom.

jmlv2
09-03-2001, 10:46 PM
Boo,

Try this :

Open up the CD tray and look if the lens is parked on the inner side near the spindle. If it is parked on the outer portion, use a pencil to force the lens module to park near the spindle. Re-boot.