PDA

View Full Version : 8.6 / Dead Modem???



icebucket_9
06-17-2001, 09:10 PM
Don't laugh. A friend asked me to look at his flaky 1st gen iMac. It was crashing like no ones business out of System 8.5. I did a clean system install and just to be a nice guy I upgraded to 8.6 - a much more stable system - Right? I get a call that night 科my AOL doesn't work!!!秋 So I did every modem check I could think of, re-set the NVRAM, and tried Apple modem updater 2.0. Still no modem. Any ideas? (please!!!)

kaye
06-18-2001, 12:45 AM
I had a 3rd gen iMac for a few days until a friend wanted it. I was running some hard drive maintenance on it yesterday, OS8.5.1, and checked her modem settings. I forget a lot of it, but I checked the Modem control panel, it showed iMac 56k and I forget the "Connect via:" or maybe it wasn't even there. Checked her TCP/IP and everything seemed OK there, checked Internet (in control panels folder), and checked her Remote Access for name, password, and dial out telephone number. It worked on AOL. Anyway, some possibilities. k

icebucket_9
06-18-2001, 07:28 AM
Checked the settings and they are fine. Just a thought. If Apple Modem Updater (firmware update for internal mac 56k modems) can't find your modem is she kaput?

kaye
06-18-2001, 11:06 AM
Take a look here http://asu.info.apple.com/swupdates.nsf/artnum/n11859 k

icebucket_9
06-18-2001, 11:13 AM
Thanks, but I tried and it was no go. Hypothetical Question - Is it possible that a clean install wiped out the modem? I know this sounds ridiculous....

kaye
06-18-2001, 11:43 AM
No, not ridiculous. I don't think a clean install would do that, but stranger things have happened. I have a friend with a B&W G3-300 with an Apple 56k. It failed in normal use. Apple replaced it and the replacement failed. So he just gave up and purchased an external GV unit. The iMac I was referring to, I have been afraid to upgrade OS to later because of possible glitches like yours. And I can't conveniently get my hands on it. For what she needs it for, it works great with OS8.5.1.

I think I would try a clean install of 8.5 and update to 8.6 again, unless you can get your hands on the OS8.6 CD, either iMac or universal CD. BTW, there is a font issue with 8.6. Go here http://asu.info.apple.com/swupdates.nsf/artnum/n11489 and follow the directions exactly. k

icebucket_9
06-18-2001, 04:03 PM
Damn! - tried your suggestions and still no go. Okay, call me crazy but I am going to move all of the users files (prefs, control panels,extensions, programs...) onto my G4 and re-initialize. I'm taking a long break so if anyone thinks this is a bad idea I'll take it into consideration. Kaye, thanks for your help, I'll keep you posted. b.

dragon_x
06-18-2001, 04:08 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>I get a call that night 科my AOL doesn't work!!!秋<HR></BLOCKQUOTE>
I really do not see the problem http://macgurus.com/infopop/emoticons/icon_wink.gif

OK - a couple things:
1) Get a 3rd party dialer, like FreePPP 2.6.2. It is old, but it should still work. You should be able to set the dialer to the internal (modem) port and you can then try the TERM window. This can allow you to reset the modem. When the TERM Window is up you can type ATZ. You (or the user) may not see this, but you can type ATZ again. Also note you MUST hit [RETURN] as the text does not auto return. This is a very simple term windows so things like DELETE do not work either.

2) Setup the Apple dialer (Remote Acccess). Try the regular modem script (Apple 56K V.90/ Apple 56K V.34) and see if that works.. see if the modem is responding. If that does not work get into the term Window. This is a bit more complex than FreePPP - so if you need specifics let me know.

If you can get the modem to respond you have more or less verified that the modem is working. Then your next step would be to check the AOL software to make sure that is working. AOL uses its own 'COMM' software... its been awhile, but AOL often sets up their software to work even if the built-in software (Mac/PC) does not.

He did have 8.5, so maybe there is an issue with his version on 8.6? I've never been a big fan of AOL , since they have no standards -but I guess its easy?

If the modem is KAPUT it is possible that a power surge fried the modem. Often thunderstorms will do this. With my old job we would get spikes in the call volumes in areas where thunderstorms just hit. Some people lose their whole system http://www.macgurus.com/ubb/eek.gif Also the voltage spike does not need to be all that much and it can come from miles (10s, 100s?) away. This is why it is a good idea to have a surge suppressor on your modem line!

If the modem is dead, I would highly recommend going to a 2-WayCablemodem or DSL setup. This will use the built -in ethernet and it will ROCK! http://www.macgurus.com/ubb/cool.gif

I know that the MacOS updates have broken older modems - like the 64/6500, but I've never heard of this before. Maybe a PRAM/NVRAM clear would fix it?



------------------
The Hitchhikers Guide To The Galaxy: Earth
The third planet from a insignificant star in the outter rim of the galaxy. It is mostly harmless. http://macgurus.com/infopop/emoticons/icon_wink.gif

icebucket_9
06-18-2001, 04:32 PM
Tried your first 2 suggestions already - thankfully my roomate is a networking nerd - I think god is punishing me because I hate AOL and modems....( I've got DSL myself - Rock On!)

kaye
06-18-2001, 06:34 PM
Don't bypass the suggestion by d_x to try zapping the PRAM/NVRAM. k

icebucket_9
06-18-2001, 09:28 PM
I tried, but again, no luck. I think it would be a good idea to seriously drink lots of beers at this point and resume the madness tomorrow. b.

Louie
06-18-2001, 10:17 PM
If you are using the AOL dial-up, you need TCP/IP configuration of AOL Link Enhanced and BootP Server.

Louie
06-18-2001, 10:19 PM
Never help newbies with iMacs and AOL; bad combo. It sucks you down to their level as soon a Murphy's Law takes over, as it always will.

icebucket_9
06-19-2001, 12:38 PM
I admit defeat. Yes, I re-initialized and brought the computer right back to square one - system 8.5. I tried all of the modem tests and n-o-t-h-i-n-g. I also tried the following before I re-initialized:

This solution worked for me... - Robert Douglass (Posted 10:53pm Dec 30, 2000 CST)
To recover an apparently 科dead秋 modem, after installing OS 9.0.4 on an older (233 MHz tray-loading) iMac盆 Here's what started the
problem: I did an install of OS 9.0.4 directly on top of original 8.5.1 that came with the iMac (not a clean install). I know, I know盆 but it
usually works for me. http://macgurus.com/infopop/emoticons/icon_smile.gif The CD that I used for installation of OS 9.0.4 was from a very recent 350 MHz slot-loading iMac.

The installation went perfectly盆 All seemed normal., except when I went to test AOL v5.0, it gave the dialog that modem could not be
found, and I got the 科No serial ports available..秋 dialog.

The System Profiler 科saw秋 the modem, but could get no info about it.

Further attempts to connect by adjusting the modem control panel, or using the Internet Setup Ass秒t didn秒t work. The panel that notes
科which port is the modem connected to盆秋 was blank, with no choices possible in the pull-down.

Also, in the expert setup section of AOL Setup, under Modem Options, the pull-down titled 科Connected to盆秋 was blank.

I tried all the normal stuff: Zapped PRAM; trash various prefs; rebuilt desktop; used NUM, etc盆 nothing helped.

I, too, solved the problem after reading a post on one of the discussion boards that the installer simply doesn秒t load the 科right秋 extension
set for the old iMac. Using TomeViewer, I went into the OS 9.0.4 CD and extracted the extension called (exactly) 科iMac Modem Extension秋
v1.0.

I then went into the extension folder on the iMac and dragged out the extension titled (exactly) 科Internal V.90 Modem秋 that the OS 9.0.4
installer had placed there as part of the upgrade, and dragged into that extension folder the 科iMac Modem Extension秋 v1.0 that I got using
TomeViewer.

I trashed the modem prefs, and the two AOL prefs, I shut down, waited a minute, and started up. I Zapped the PRAM on startup.

Then I went into modem control panel盆 and all was well盆 it showed: 科Connect via internal modem秋盆盆. whew!

I then did the brave (?) step of trying to use the Apple Modem Updater v2.0. (I first disconnected all USB and phone lines for good measure).
It recognized the modem, updated it, and I was finally ready to try to connect via AOL.

I turned on AOL, went into the prefs section and hit the 科reset to AOL link秋 for good measure; quit AOL, restarted AOL and signed on. YEAH
!

I must have spent 6 or 7 hours figuring this mess out. I hope this helps others of you who are upgrading.
Robert Douglass

I'm afraid that it's time to break the news... (did I say 科break秋 ?) -b.

kaye
06-19-2001, 01:08 PM
i_9,

WOW. Did I get this correctly, you got the modem and AOL working, but you are admitting defeat of the OS upgrade? If the modem is working after all of that, congrats, gold star. I am never, ever going to upgrade my friend's iMac from 8.5.1. Never, ever. She called me this morning to say that my hard drive maintenance of a few days ago on her iMac solved her AOL uncommanded quitting. And she nagged me again about upgrading her AOL 4.0 version to 4.5 or 5.0.

Another Mac friend of hers tried to install AOL 4.5 on my friend's iMac several month ago and couldn't get it to work. I had to go rescue that poor machine, found a dozen partial/full installs of 4.5 on the hard drive. One tenacious lady. k

Louie
06-19-2001, 01:36 PM
Well done! Do you agree with my previous post?