View Full Version : os 9 and geoport internal modems on ppc 6400/200

05-10-2001, 04:40 PM
since installing os9, my internal modem won't work and tech tools when run keeps mentioning lost apple telecom files (and suggests re-installing system software).
Apple say they know of some people who have managed to change the modem strings so as os9 works with the old internal modems, but also add that very definitely that os9 does not support the geoport internal modems.
I know that it did for a fact work initially - maybe ten days or so, but subsequent crashes seemed to change all that.
Now I use an external global village teleport fax modem with k56 flex.... seems fine but occasionally get problems on aol ....I have to use it thru the printer port as the mac still thinks that an internal modem is ousting the modem port (and believe me I did try to persuade it otherwise !)
I want my printer port back !!! (using a T switch....very annoying).
Any one got a clue what to do ?
(os 9 and geoport internal modem on ppc 6400/200, 88meg ram, 1.5 gb hd)

05-10-2001, 06:36 PM
I did some testing of Geoport under OS 9.x. They're correct; it doesn't work. I can't remember my exact findings (these days I keep a notebook when troubleshooting) but it went something like this. It would connect once or maybe the connection attempt would go once, but the modem would drop the connection pretty quickly. After that, if you tried to reconnect you got an error message, probably the one you're getting. It was necessary to either reboot, or change something and reboot, before connecting would work again, once.

Basically, OS9 made the Geoport modems unusable. There might be a workaround out there somewhere, but I've never heard anything about it.

05-11-2001, 03:10 AM
Thanks for your reply Trag, I'll keep you informed if I do find a work around...

In the meantime, do you think I can get the modem port back by physically taking out the internal modem and stripping out any geoport modem software/drivers I can find, .. would this finally convince the mac that I'm not using the geoport?

..or is there an easier, non 'back off the machine with a screwdriver yanking at the logic board' method (my house is so full of static I'm paranoid about zapping it).... it's not as if I need the space in the machine.

If I have to take the back off then I'll probably want to put a bigger hd in at the same time- any recommendations?

05-11-2001, 10:40 PM
To me a Geoport Modem was one of little boxes that Apple sold that pretended to be a modem but made the CPU do all the work.

The 6400 came with a Global Village Comm Slot II 28.8 modem that could be flashed to 33.6 Here's the flasher and updater http://www.globalvillage.com/support/teleport-platinum-commslot.html .

I haven't tried that version with OS 9.x, but I did test the external version of the Platinum modem last week with OS 9.1 and it works. Mine uses v 2.68 and yours 2.56. If you are trying to use the old MegaPhone telephony stuff you also need Apple Telephony Extension, MegaPhone stuff and maybe more.

06-14-2001, 01:26 PM
I actually dealt with this last night, and here's the fix.

Get an OS 8 or 8.1 cd-rom and put it in. In the CD Extras folder, there should be a folder called "Apple Telecom." Run the installer in the Apple Telecom folder.

Apple Telecom was done away with at some point after 8.1, but one of my machines at home is a 6400/300 with Geoport modem, and after upgrade to 9.0.4, internal modem died.

Give it a shot.