PDA

View Full Version : Adaptec U2B won't boot with drive attached



whynot
05-22-2001, 03:22 PM
Hello.

I'm trying to get my $114 Adaptec U2B card working. No Dice.

I bought it as a replacement for my Miles UW card, which went down last week. Just working one day, the Mac crashed, and wouldn't restart until I removed the Miles from the PCI bus.

Now I have the Adaptec in there, and the process has been as follows:

Plug in the card.
Plug in my various drives (both internal and external, just as they were on the Miles).

No Boot. Gets to "Happy Mac", and to desktop, but won't mount any drives once there.

Removed the external cable, and the machine booted, but saw the internal LVD drive as "Asynchronous" and crashed during a test copy.

Again wouldn't boot at all after that. This time no Happy Mac.

Removed the internal cable from the drive (the one that came with the card) and the Machine booted fine.

I can flash the card no problem. But if there is a powered-up drive attached the machine will light up the monitor and pause forever. No Happy Mac.

Any ideas?

JW

the_anarch
05-22-2001, 07:27 PM
I was having problems similar to that. What are the other cards in your system? There might be a conflict now that wasn't there with your Miles UW.

You can also try this, suggested to me by Chris Menke: Boot up while holding down Cmd-Opt-P-R to reset the PRAM. Do this four times (through four startup chimes), so that it will also flush the VRAM. Then, boot into Open Firmware by holding down Cmd-Opt-O-F. When you get to Open Firmware, don't do anything, just push your computer's power button to turn it off. Then boot up one more time while resetting your PRAM as above, and then see if you can boot up with a drive attached. Chris said he used this whenever he was having hangs at the Happy Mac.

magician
05-23-2001, 12:41 AM
interesting...

whynot
05-23-2001, 12:50 PM
Interesting, but still no go.

I got hold of Dan at Initio, and he's sending down another Miles card today. If that one fires up, then I can assume that the U2B has a fault, or that my devices (Cheetas, Ultrastars, all LVD) don't like the Adaptec.

I'll post when I have the result of that.

BTW it was pretty cool starting with the "Open Firmware" boot - the mac played some weird music, and triggered the various midi devices.

Thanks for the help
JW

whynot
05-23-2001, 06:15 PM
OK Update.

Received the replacement Miles today from Initio. Stuck it in, plugged one of my Cheetahs into it and booted. Everything's AOK.

So it's the damn card.

Thanks for the input
JW

the_anarch
05-23-2001, 11:02 PM
Sorry man. Glad you got it worked out.

When you said it triggered the various MIDI devices, I assume you have MIDI equipment of your own connected to your serial port? Or something?

whynot
05-24-2001, 12:14 AM
Yes, through a MOTU Midi Express...

But I think some of the music was coming from the Mac itself.

I'll have to try it somehow.

JW

chrismenke
05-24-2001, 05:05 AM
An FYI...anarch got most of my somtimes cures the Happy Mac Hang routine correct, but after power buttoning out of open firmware, you should try booting without another PRAM clear before attempting the PRAM again.

whynot
05-24-2001, 02:36 PM
Yes, I actually did that (by not quite reading the steps all the way through).

Pretty sure I had a bad card there...

Thx
JW