PDA

View Full Version : Too many PCI cards = not enough memory for drivers



the_anarch
04-03-2001, 01:58 AM
Hey hey hey, guys guys guys, what was that problem that Darin discovered with his maxed-out 9600? The one where he had so many cards in his PCI slots that there wasn't enough memory at startup to load all his drivers? Did he fix that problem or what?

I think I might be having the same problem. Here's how it goes:

Started with my PTPro with just a TwinTurbo8M and a Bluenote. Swapped out the TwinTurbo for my XClaimVR 128. Checked it out and it was OK (although I am getting an X through my Desktop Video extension icon in the March of the INITS). Then I added in my VR Rage Pro with 8MB, one of the ones the Gurus used to have on clearance sale. Still OK.

Now we get to the doozies- my two brand new Adaptec 2940U2Bs. For those who weren't following my thread about these things in the SCSI forum, my idea was to put in two of these cards, one in each busmaster slot, and stripe across both buses for faster thruput (natch).

Put in one 2940U2B and it was fine. Firmware was up-to-date. Put in the second one, and the machine would not boot. I would get the chime, everything spins up, but the monitor would never even reach the gray screen. It'd just stay with it's yellow "no signal" LED on. If the green "signal-received" LED came on at any point, it would go back to yellow after a couple of seconds. I waited along time to make sure it wasn't just being slow, and it never did boot.

OK, now comes for troubleshooting. I removed the first 2940, leaving the second one in. Now it boots just fine. Put the first back in, and it's back to no-boot. Remove the second 2940, leaving the first in, and it boots again. Put the second back in, try a PRAM zap, no boot.

Now I get creative. I removed the VR Rage Pro card. A-ha, it boots!

So I'm running right now with only one video card (which is fine for now because I only have one monitor, but eventually I will want two), but both 2940s. Incidentally, I have no drives attached to the cards, I was waiting to make sure dual-head 2940s would work before I ordered the drives to go with them.

This sounds to me like the problem Darin was having- too many PCI cards with large drivers, running out of, what, PRAM? NVRAM? So the machine won't boot. Is there a way around this problem? Or do I have to decide between two monitors and two 2940s?

jorge
04-03-2001, 09:35 AM
the flexibility of the Miles2 card far surpases the Adaptec board.

Darin is running dual miles 2 as are many people here just fine (except the write through issues). I guess we take them for granted. Darin's problem is when he added a 3rd video card to the dual miles2 setup.

j

trag
04-03-2001, 12:32 PM
Hmmm. I don't know how relevant it is, but I have used a machine with two 2940UWs, two Twin Turbos and a 3940U without any problems booting.

I would try moving the SCSI cards to the same Bandit (slots 1 & 2, or slots 4 & 5, e.g.) and similarly for the video cards. Try a few variations like that. I realize this appears to defeat your original purpose, but we're not looking for a workable configuration with this test. We're just testing to see if the cards will coexist in a different arrangement.

I'm assuming that regardless of what slot they're in, the cards' drivers use the same amount of memory. So, if the cards will work in a different slot configuration, then your problem is not the driver memory problem that Darin reported--probably.

Also, see if the problem might be a coexistence with the VR Rage Pro card. If you have two Twin Turbos try that. Also try the Rage Pro on one PCI bus with the Adaptecs on the other. Then try the Rage Pro on the same PCI bus with both Adaptecs.

EGPoulin
04-03-2001, 02:29 PM
This is a shot from WAY left field but it might work...

I had a problem where my PTP would not start up with the first press off the power, I had to turn it on, wait for the chime etc and the monitor light to go yellow, then using the front pannel button quickly turn off and back on the machine.

I found that disabling the Memory test at start up fixed the problem. (For thoes of you reading who don't know, hold command-option while double clicking the memory control panel, will show the option to turn off the test at the bottom)

Who knows, maybe the test needs NVRAM/PRAM/Cosmic Dust to work and there is just not enough with the cards...

kaye
04-03-2001, 03:25 PM
Darin's problem (my interpretation of what he said) is that there is a 4MB boot wrapper. The more stuff you have, the more you fill this wrapper. He was running HFS+ on his boot partition. HFS+ uses more of the 4MB boot wrapper. By going back to HFS (which uses less of this space) on his boot partition, he was able to get back within the allotted 4MB, and therefore able to boot. k

the_anarch
04-03-2001, 06:35 PM
Then I guess the problem I'm having is not related to the 4MB boot wrapper, for two reasons: #1, the boot-up process stops before there's even a gray-screen, so there's no way the boot partition is being accessed, and #2 the boot partition is HFS anyway, not HFS+.

So we've got an old-fashioned PCI card conflict going on here. I'll be testing out Jeff and Eric's ideas tonight. I don't have two TwinTurbos to test them on, but I do have one so I can just put that in instead of the Rage Pro. And I did actually make the change to the Memory control panel last night, but hadn't reinstalled any other PCI cards after that.

I guess I still have a little hope that I can get this to work, but it's starting to sound like to me like I just happened to get a system that doesn't like to be pushed much, unlike Kaye's. I have a MachCarrier G3/466 in it right now that doesn't really like to go above 486, maybe 490. If I can't make these two cards work together, I'll just have to send them back and settle for the speed of a single Miles2. I can't afford to spend $400 on dual Miles2 so I can join the write-through party.

the_anarch
04-04-2001, 01:02 AM
*sigh*

Guys, I could really use any other ideas you might have, any at all. I tried every combination and configuration I could imagine. I removed the Bluenote so that I only had four cards in there, two video cards and the two 2940s. No luck. I switched out the ATI Rage Pro with my original TwinTurbo8MB. Still no luck. I put the ATI Rage Pro back in but took the XClaimVR 128 out, leaving the TwinTurbo8MB as the second video card. No luck. I moved the cards around to different slots. I had them separated on the two PCI busses, I had them ganged up together on one bus (as in, all video on one, all 2940s on the other). I switched the two busses these cards were installed in too. Nothing worked. Nothing except removing either one of the 2940s, or one of the video cards. I really really really would like to not have to choose, because if I do it'll mean pulling both 2940s and getting them traded out for a single Miles2, and I won't be able to have fun with the dual-Ultra2 bus RAID game.

I did CUDA resets between any changes that involved adding a card- if I was just removing a card, or moving cards to different slots, I didn't do a CUDA reset.

I do not believe anymore that I have the 4MB wrapper problem, unless it's possible to overload the wrapper with just two video cards and two 2940s before the boot partition is even accessed. Which I imagine, if that's the case, I won't be able to do anything to solve it anyway.

Eric's suggestion about the memory control panel did not have an affect. Although it is nice not waiting forever for it to check the RAM before it boots. Hey guys, do you think it's possible that I could check the write-thru box in my Speed Control panel, then shut down and install the last card, and somehow have it change this? Is it possible the 2940s are even more adversely affected by this problem than the Miles2?

http://macgurus.com/infopop/emoticons/icon_frown.gif

trag
04-04-2001, 11:22 AM
Well, the last thing I can think of is the old, add one card at a time and CUDA between every boot trick. Configuring the S900 years ago, I ran into what seemed like a similar problem and the machine froze as yours does. The solution seemed to be to go back to a working configuration and then add cards one at a time with a CUDA reset and boot up between each addition.

So, you might try just a video card, with your boot drive on internal SCSI. Boot up, shut down. Then add 1 SCSI card, hit the CUDA and reboot. Shut down, add another PCI card, reset CUDA, boot up. Shut down, etc.

I used very conditional verbs above because my more recent experiments with the S900 show that there are some very non-intuitive things up with its PCI slots (problems with two or three separate required conditions) so I'm uncertain whether any of the diagnostic/troubleshooting tricks I developed in the past are really what they seemed.

Louie
04-04-2001, 11:49 AM
I doubt that it's the "write-through" problem, although it might be worth a try. In my situation and Ton's, with write-through disabled, the machine goes through the startup sequence until the instant the XLR8 extension is loaded. At that point it hangs.

I've tried to ignore Adaptec cards, but in the back of my foggy memory, I seem to remember that two of them can't get along. Has anyone ever succeeded with what you are trying to do?

the_anarch
04-04-2001, 12:23 PM
Well, before me, the only people I've known who ever got two Adaptec 2940 cards to coexist were both running 2940UWs, as in UltraWide, not Ultra2. But, I got my machine to boot (and recognize) two 2940U2Bs- just not when I had two video cards installed at the same time.

I'm totally confused as to where exactly the conflict is. What is it about two video cards and two 2940s that makes my machine puke? I'm stumped. It's not like it has a problem when there are two 2940s and two of any other (different) cards plugged in- I had it running with the two 2940s, a Bluenote and the XClaim VR 128. It's only when there are two video cards AND two 2940s when things aren't copacetic.

As I said below, I tried both 2940s when I was running the XClaim and the Rage Pro, the XClaim and a TwinTurbo, and the Rage Pro with the TwinTurbo. None of these three combos worked. I have no reason to believe this idea would work either, but I do have one more Rage Pro (with only 4MB, not 8) that I could try- maybe dual 2940s and dual Rage Pros will somehow bring the genie out of the bottle.

Magician, can you give me an opinion on my situation, any ideas on how to proceed? I've still got a couple of weeks to try stuff out, before I have to decide to give up and send them back, or keep them forever.

MacMikester
04-04-2001, 10:15 PM
Hey ta,

I think you probably are having the exact same problem that Darin had. You are running an XLR8 upgrade right? It loads boot code from NVRAM, all your firmware loads boot code into ROM and some of your drivers load boot code into ROM, probably using up the max 4MB allotment (or else using some noncontiguous memory space and wasting some of the ROM allotment due to fragmentation. One possible experiment: pull the XLR8 and replace your original CPU but *do not* hit CUDA or reset NVRAM, see if you can boot with everything; then reset NVRAM and disable the XLR8 extensions (to clear the XLR8 code) and see if you can boot with everything. I'll bet that you will hang on the first part and go on the second part. If so, maybe just try re-enabling the XLR8 software with the old CPU and restart to see if you can boot, then put the XLR8 card back in. Similar to reordering extensions, this may shake ip the order that code is written into the ROM allotment. Don't know, I just have a vivid imagintion.

the_anarch
04-05-2001, 12:13 PM
No dice.

I did exactly what you suggested: put the second video card back in, replaced my XLR8 G3 with the original 604e, and rebooted without touching the CUDA reset or anything. No boot. OK, we expected that.

Now I attempted to clear the NVRAM and PRAM. I held down the CUDA reset switch for 40 seconds six times in a row. I figured four whole minutes of discharging should work. Started up again. No boot.

Just to make sure, I pulled my Bluenote with the 604e installed, so that I now only had the two video cards and two 2940s. No boot.

I am beginning to believe that this is a conflict directly related to ATI. The reason I think this is that whenever I try to boot with all four problem cards installed, I get a brief second or two of the green LED on my monitor. I even hear the little "FFFFTTT" many monitors make when they're bringing up the CRT. But at that point the LED goes back to yellow. Whenever I'm booting with a working arrangement, I get the green LED, the "FFFFFTTT" sound, and then a second smaller "FFFTT" sound as the grey screen actually becomes visible. That second smaller "FFFTTT" never comes when I've got the four problem cards installed.

So I guess something is preventing the machine from actually sending a video signal to the monitor after it has successfully recognized that there is a monitor attached to the card.

Every test I've done so far that used two video cards with the two 2940s involved at least one ATI card. But it just occurred to me this morning that I do have one other non-ATI video card, in addition to the TwinTurbo. My brother's old StarMax has a 4MB Mactell card in it I can yank and try in my machine. I guess that's worth a shot. But if I find out that the problem is I can't use two ATIs along with two 2940U2Bs, I'm gonna be fightin' mad.

the_anarch
04-05-2001, 12:24 PM
Well crap, I just remembered something. There was one time when I tested the two 2940s with the ATI Rage Pro and the TwinTurbo card installed. The card I actually had running my monitor was the TwinTurbo, and it did the exact same thing during other failed boots with the XClaimVR: chime, green LED, first big "FFFTTT", yellow LED. So the same thing that's preventing the monitor from getting a video signal with the ATI (and, I presume, preventing the continuation of the boot process) is doing it with the TwinTurbo as well.

This just baffles me. I'll throw a couple more things out there- all these times I've been running my tests, I've been doing them with only one monitor connected, so the second video card is monitor-less. Anyone think that might be causing a problem? The other thing is, all these tests have been run without any hard drives connected to the 2940s. I don't have any LVD drives yet. Could THAT be somehow causing a problem? Again, the machine boots fine with dual 2940s when there's only one video card...

...Or maybe it's just my particular PTPro. Unfortunately I don't have another six-slot machine to test this arrangement on.

Jeez this just sticks in my craw. (Maybe I should, as Det. Munch on "Homicide" once said, "have my craw surgically removed.")

Magician, I know I must sound like I'm whining, and I apologize, but if I could get some kind of feedback from you on this, even if it's just "sorry but I have no idea what's going on with this stuff", I'd greatly appreciate it.

the_anarch
04-05-2001, 12:49 PM
All right, here's something else I thought of.

Of course, these 2940U2Bs that I got from the clearance sale here came without software. I knew that going into it. I just went and searched for any drivers and/or control panels that might be what I would need. All I found was the firmware updating utility and a 2940U2W Power Domain control panel (I got it off my Silverlining Pro CD-ROM).

Whenever I boot up with one or both 2940U2Bs installed, assuming I actually boot, I can run the firmware flashing utility and it will recognize both cards. It also happens to tell me that I have the latest firmware on the cards. However, the Power Domain control panel doesn't see anything there. Maybe that's because I don't have any drives attached to the cards.

Can anyone tell me if there's a different piece of software or control panel I should be seeking out and utilizing? Anyone who's also bought one of these 2940U2Bs?

Louie
04-05-2001, 01:12 PM
I would check Apple's site for firmware for those cards.

the_anarch
04-05-2001, 10:52 PM
Do you guys all have calluses on your thumb and fingertips from all the removal and reinsertion of PCI cards? http://macgurus.com/infopop/emoticons/icon_smile.gif

Well, I really thought I couldn't get anymore frustrated over this, and I was wrong. I just went through another few rounds of PCI musical slots. There was some progress made, but not much. I am now back to thinking the problem is somehow specifically related to the ATI cards. Although I suppose I would buy it if it turned out this was just another variation on Darin's overstuffed 4MB boot wrapper problem. At any rate, I do not specifically suspect the Adaptec boards anymore.

When I got home tonight I decided to try the XClaimVR and a 4MB Vision3D that I pulled out of my brother's old StarMax. Still no boot. So I pulled the XClaim VR and replaced it with the 8MB TwinTurbo.

And lo and behold, it booted. So I now have two video cards with both Adaptec boards. Everything was correctly indicated in the PCI Slots utility (although strangely PowerControl only shows 3 slots), as well as in the ASP. And both video cards were functioning correctly, albeit without drivers. I had to dig out an old 14" Apple monitor to be sure.

I wish I could be happy with an 8MB card and a 4MB card, but the XClaimVR was rather expensive for me to just not use, not to mention that I wouldn't have the XClaim TV function anymore. And the Rage Pro cards weren't exactly cheap either. So I pressed on to see what else I could get to work together.

I pulled the 8MB TwinTurbo and replaced with a 4MB Rage Pro. I now have two 4MB video cards installed, but one is ATI. Because my monitor has a VGA plug and the Rage Pro only has an Apple connector, I moved the monitor to the Vision3D card. This time, when it booted, the green LED would come on, and I would get the "FFFFTTTT" sound before the yellow LED came back on, but in addition to that I got a little flicker of white on the monitor.

It dawned on me that the machine was trying to get a video signal through to this monitor but couldn't for some reason. So I turned it back off and put the 14" monitor back on the ATI Rage Pro card.

This time it booted. Great. So now I have two video cards- one a 4MB ATI and the other a 4MB MacTell dinosaur. Still not optimal, but getting there.

I pulled the 4MB Rage Pro and replaced it with my other one, which has the extra 4MB chip installed to make it 8MB total. Again, it booted. Now I feel like I'm really getting someplace. I've had two different combinations of cards give me a total of 12MB of video memory. So I get cocky.

I replace the 4MB Vision3D with the 4MB Rage Pro. This doesn't change the overall total of video memory, if that somehow has to do with how much of the boot wrapper is being used at boot. Ah ah ah, not so fast. Clearly this is not the night I'm going to whip this once and for all- it doesn't boot. So- 12MB total with only one card being ATI, OK; 12MB total with both cards ATI, no dice.

So. Where does that leave me? I dunno. I'm mulling over in my head the possibility of trying to get another non-ATI video card, this time a more recent high-powered one, to see if that will work with either the Vision3D or possibly the 8MB TwinTurbo. Maybe, if I got lucky, it could even work with one of the Rage Pros the way the Vision3D did (but not the way the TwinTurbo wouldn't). If somehow a non-ATI high-powered card worked, then I'd be looking at two choices- try to sell my ATI card(s) so that I could keep dual 2940s, or return the 2940s and exchange them for a single Miles2- no dual channel RAID, but still better than a single 2940. And way better than trying to do all my work with one monitor, or two underperforming ones.

The flip side is, if a non-ATI high-powered card doesn't work with any of my other cards, just like the XClaim VR, then I'm thinking that all these higher-powered cards are too much. And the question would be, do the Adaptecs in combination with the XClaim VR just gobble up every available bit of the boot wrapper, or are they (and the boot wrapper) just fine and the real culprit is the PowerTower Pro itself- I somehow got a lemon?

At any rate, I'm totally tired of this. I'm going to take a few days away from this and not think about it. I'll check back in next week if anyone has any further thoughts, opinions, suggestions, etc. Seriously, please, if anyone's got anything, I feel like I'm really close to getting this whipped. But the only idea I have for proceeding is to try another video card, and that means spending more money that I hadn't planned on. Thanks very much.

Louie
04-06-2001, 01:48 AM
Power Control only shows three PCI slots, probably because it hasn't been updated in so long. There was a recent (like 8.6?) ASP that only showed three PCI slots. I suppose this was more of Apple's arrogance; we only build three slots, therefore we only show three slots. You can use the newer ASP's from 9.xx with 8.6 if you want to see six slots.

You can put the "wrapper" thing away by reformatting with HFS. I did it twice yesterday. It's fun.

the_anarch
04-06-2001, 08:19 AM
Yeah, actually my ASP does show all six slots, it's just the Power Control that doesn't.

Unfortunately, my boot volume is already formatted in HFS, so I can't clear the boot wrapper thing by reformatting. And since my freeze comes before I even get video on startup, I'm afraid that if this is a boot wrapper problem, I'm overloading it with stuff before it even gets to my boot volume.

One thing I can't believe I forgot to detail in my last report: At one point I tried the 4MB ATI Rage Pro with the 8MB TwinTurbo. I really didn't expect this to work, but I thought what the hell. Well, it surprises me and actually boots. I go to ASP to check the PCI slots, and the slot for the TwinTurbo ($B1) is indicated as "PCI Slot". When I get info on it, it just says "Card 8,0" or something like that, totally generic. I was not running a monitor with the TwinTurbo. I thought that maybe I hadn't seated it properly, so I shut down and pressed on the card again. I don't think it even moved a whole millimeter. But this time, when I rebooted, it didn't come up. OK, back to square one, or maybe two.

I'll throw this one thing out there and then that's it, I swear I'm going to drop this for a couple of days. I don't really believe the 2940s are at fault here, but I was thinking about their firmware, maybe something in that would actually alleviate the situation. The Firmware Flasher utility that I got tells me the cards are both already at firmware v1.2, the latest. Anyone think that maybe I should try reflashing them? Or possibly downloading the 1.1 firmware and using that to flash them? I'm not exactly jumping at this idea because I'm just scared I'll ruin the cards, but maybe...?

Louie
04-06-2001, 02:16 PM
You could have another video card choice if you can find a Voodoo 3. They were cheap when new. They were all for PCs but will flash to Mac ROM. The Beta 12 and 13 drivers do a good job with Glide and OpenGL. The 2D accelleration is OK but they don't do QT. I've got all the flashers and drivers. They were about $100 new.

MacMikester
04-06-2001, 11:19 PM
Hey ta,

Have a good weekend, sounds like you need it. Mag can't get two Radeons to work together in Beast, so maybe it is some peculiarity with the ATI software and/or firmware. Strange.

the_anarch
04-17-2001, 01:17 AM
Well, gentleman, tonight I met with certain measure of success. Exactly how much success remains to be seen, ultimately it may not be enough. But just for tonight, I can go to sleep feeling good about the way things went tonight.

I received my latest order, a Miles2 kit with two 9.1GB Cheetahs and an Ultimate HDD Cooler (I already had one). I know this must sound like a straight-up, dual-drive, single-bus RAID I got going on here, and that would be fine with me. But before I go for that set-up, I wanted to try one last kooky thing.

I put the Miles2 in my $A1 slot while one of my two 2940U2Bs was in the $D2 slot. I booted and so far so good. Then I gave it the real test for the night- I put back in one of my ATI Rage Pro VRs, along with the XClaim VR I already had in there. This was to see, once and for all, if I could get two Ultra2 SCSI cards and two ATI video cards to coexist.

Lo and behold, it booted. And it has several times since then.

However I knew I was not yet out of the woods (still ain't even now, in fact). I need to make sure I could get both cards to recognize a drive simultaneously. I set about installing the Cheetahs into the Ultimate HDD Coolers, then plugging one of those each into the Miles2 and the 2940U2B. At this point, I was using both of the FoxConn cables that came with my original order for the two 2940U2B kits. I left the Initio cable out of it for now.

First try, no boot. It would come to gray screen, unlike my booting problem with the ATIs before, but would not come to the happy Mac, or any Mac for that matter. So I shut down to try them singly.

I tried the 2940U2B with a drive, but unplugged the drive from the Miles2. Booted just fine. Then I switched, unplugging the 2940U2B's drive and replugging the Miles2's drive.

No boot. A-ha, now we're getting somewhere.

I proceeded on a switch-and-alternate process to rule out if it was a card, drive, or cable. Eventually I narrowed it down to one of the FoxConn cables. I switched it out with the Initio cable and voyla, it booted, both drives functioning and recognized.

The last thing I tried, just to see if there was going to be any further problems with the PCI cards, was to install the last one on my list, an XLR8 DualPort. This would fill all six of my slots, Holy moly. I plugged the card into the $E2 slot and rebootedȡ yes, it does work with my intended six cards all installed. So here's what I've got:

$A1- Initio Miles2, running one 9.1GB Cheetah
$B1- ATI Rage Pro VR, not connected to a monitor yet
$C1- Initio Bluenote, running 9.1GB Barracuda (boot volume), plus Plextor CD-RW and CD-ROM

$D2- Adaptec 2940U2B, running one 9.1GB Cheetah
$E2- XLR8 DualPort USB card
$F2- ATI XClaimVR 128, running a little ol' 15" monitor

XLR8 MachCarrier G3/466 (at 486) / 384MB RAM / OS 8.6

As I said above, I do not believe I'm out of the woods yet. The next test that I will wait until tomorrow for is to see if I can actually format the two Cheetahs into a cross-dual-bus RAID 0, using SoftRAID. Obviously if it doesn't work, then I will settle for the single-bus RAID with just the Miles2 and return the 2940.

Also, if I can't get the dual-bus RAID to work without checking my Write-Thru box, as Louie and the others have had to with their twin-Miles2 set-ups, then I'll revert to a single-bus RAID as Louie has. I will be genuinely surprised if replacing one Miles2 with a 2940U2B somehow changes the whole write-thru situation. But it's not worth the money to me for a dual-bus RAID until SoftRAID works out that situation. Although I may give something like SilverLining Pro a shot, just for kicks.

Stay tuned.

[This message has been edited by the_anarch (edited 17 April 2001).]

magician
04-18-2001, 02:09 PM
men, I'm sorry I seem to have totally missed this thread and am coming late to the party. Not to make excuses, but I've been overwhelmed with cancer doggy and legal stuff regarding my son's custody and residency and sleep clinic stuff at the VA and a million other things.

for future reference, if it appears I am ignoring something important, it is probably because I am clueless. Just shoot me an email and I'll swoop in as soon as I can.

now....one thing leaps out at me. Fletch simply couldn't get two monitors to sync using two ATI and two Apple 2940U2B's.

Fletch, did you ever try using like the ATI Universal 4.2 install or anything? I have seen ATI-controlled displays sync off the built-in driver on the card....and then lose sync, and then regain it as the ATI driver kicked in. I long ago gave up paying attention to displays until the ATI driver had seized control. Since you appear to have been running a generic MacOS system folder, it is possible that you lacked the right ATI drivers.

Just an idea, and probably not a good one.

now...one other point: the Apple cards have Apple firmware on them. To flash them, I would flash one at a time, with one installed at a time. I would think that flashing them, or, reflashing them, with the 1.2 update, would be a viable way of talking to the cards and ensuring that they are paying attention. I would not expect to be able to talk to these cards using Adaptec control panels....though it comes to mind that others may have successfully done just that. You may want to surf thru the various Adaptec control panel revisions we have on the FTP site.

if you can talk to the cards using one of those Adaptec control panels......I would play with the PCI interrupts, and the sync rates, and see if you can find a magic spot.

let's see.....what else....I would not, personally, bus duplex across a Miles2 and a 2940U2B. I would use a matched pair of cards, just as I would use a matched pair of drives. Fletch, if you still have both 2940U2B's.....I believe I have a couple of fast little 8MB MacTell/Formac boards in the basement that were on their way to Louie and Dookie. I would be pleased to shoot them out to you if you would like to try them, instead. These boards were actually pretty damned fast, in the day....not sure what drivers they will use....but I'm pretty sure the drivers for them are on the FTP site. If not, I should be able to find floppies for them downstairs somewhere.

ok.

yes. I feel like shit for having missed this.

sorry, Fletch!

and the rest of you guys: send up a flare or something! Fire three rounds, use a signaling mirror, or break an infrared chemlight! At minimum, beam hard thoughts in my general direction!

thanks.

http://macgurus.com/infopop/emoticons/icon_smile.gif

Louie
04-18-2001, 02:43 PM
Let me be clear; you have only one Miles U2W card? So the choice is either two adaptec cards (dual channel) or one Miles U2W, right?

the_anarch
04-19-2001, 01:00 AM
Louie- as you are now aware, the choice now is actually between a single Adaptec paired with a single Miles2, or just the single Miles2 solo. Everything I tried to get dual Adaptecs to boot with my ATI video cards did not work.

Magician- you have nothing to apologize for. I just figured my posts were too long for the problem to be readily focused on. Sometimes I wind up confusing myself too. Besides, a dog with cancer, a son who needs a father and a place to live, and sleep therapy are all not simply excuses, they are DGRs- Damn Good Reasons. Thanks for putting in your thoughts on my issues.

<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>
Fletch simply couldn't get two monitors to sync using two ATI and two Apple 2940U2B's.
<HR></BLOCKQUOTE>

Well, actually I couldn't even get ONE monitor to sync using two ATIs and two 2940U2Bs. In fact, in most cases I could not get one monitor to sync if even just ONE of the video cards was ATI (I had a Twin Turbo and a Vision3D to test on too).

<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>
Fletch, did you ever try using like the ATI Universal 4.2 install or anything?
<HR></BLOCKQUOTE>

Yeah, that was what I was using from the very beginning, actually.

<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>
I long ago gave up paying attention to displays until the ATI driver had seized control. <HR></BLOCKQUOTE>

That's the other half of the problem- I wasn't just unable to sync a monitor, I wasn't able to proceed to the gray-screen to continue booting. The ATI drivers never seized control because they never loaded, nothing did. I would press the power key, hear the chime, watch the green LED on my monitor come on for a second, and then go back to amber. Nothing further would happen.

Just an idea, and probably not a good one.

<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>
I would think that flashing them, or, reflashing them, with the 1.2 update, would be a viable way of talking to the cards and ensuring that they are paying attention.
<HR></BLOCKQUOTE>

Well, here's where it gets interesting. You may not have read my other thread in the SCSI forum tonight- basically I have met with a certain amount of success in getting one 2940U2B and one Miles2 to run a dual-bus, dual-Cheetah RAID using SoftRAID. Further tests will be conducted, but so far Integrity and HD Corruption Test are OK, and ATTO Pro-Tools says I'm getting SustReads of 75MB/sec and SustWrites of 65.

So, given all that, I don't think I'm having any problems talking to the 2940U2B. Unless something changes, I'll pass on reflashing.

<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>
You may want to surf thru the various Adaptec control panel revisions we have on the FTP site.
<HR></BLOCKQUOTE>

I think I did try that, as well as trying a PowerDomain panel that came with a SilverLining Pro disc I have, and couldn't get any of them to work.

<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>
Fletch, if you still have both 2940U2B's.....
<HR></BLOCKQUOTE>

I do, but only for another couple of days. After that I have to return at least one, or both if this cross-breed Initio/Adaptec dual-bus RAID turns out to not work properly. 30 days is 30 days.

<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>
I believe I have a couple of fast little 8MB MacTell/Formac boards in the basement that were on their way to Louie and Dookie.
<HR></BLOCKQUOTE>

Well, here's what would have to happen in order for me to try this:

1. I would need to go ahead and request an RMA for one of the 2940s with Deb, so that I don't miss my 30-day window.
2. Then I would actually have to sit on that 2940 for a few days, until the Formac card showed up, so I could try it before I sent the 2940 back.
3. If it worked, I'd have to cancel the RMA with Deb, which I imagine would not put me on her Christmas card list.
4. If it didn't work, I'd be suddenly very scared that I would not, for some SCSI-PCI-Voodoo reason, be able to reinstall the Miles2 and regain the dual-bus RAID I have running right now, at least for now.
5. It wouldn't be good to keep Dookie and Louie on hold while you wait for me to get over being wishy-washy about this whole thing.

I guess I just think that as long as this "bastardization" as Louie calls it works, I shouldn't look a gift-horse in the mouth. But if you think there's something significant to be gained by trying it, e-mail me and we'll figure something out. Perhaps someone else (Louie?) with two ATIs and a PowerTower Pro would like to try it- it might just be something about my particular machine.

Louie
04-19-2001, 01:31 AM
You don't need to worry about me waiting for anything. I've been waiting for Initio and/or XLR8 for so long that I'm rotting in my socks already.

Here's a key question that I haven't seen asked or answered: Is there a history of anyone successfully using a dual channel RAID with Adaptec cards like these; ATI cards or no??

the_anarch
04-19-2001, 07:19 AM
I investigated that question before I bought them, and the only example I found on these forums was Santilli's, who told me he ran a dual-Adaptec RAID in his G3 tower and in a beige G3 desktop (so it wasn't bus-duplexed), and it was absolutely rock solid. However, the Adaptecs in question were 2940UWs, not 2940U2Bs.

For the record he did state that he was having problems running his ATTO simultaneously with one of his 2940UWs, and also that he could not get his 2930CU to run at all simultaneously with a 2940UW.

magician
04-20-2001, 01:06 AM
ok....don't worry about your 30-days on the Adaptecs. We own those, and don't have to cut a check to an OEM for those. We can extend your time-frame another couple of weeks and deb probably won't even notice. In any case, I can take the heat on this one so we can do a little more work here.

In the interests of symmetry, I would prefer that you use two matching cards. I think there is nothing wrong with using dual Adaptecs, and if I'mnot mistaken, you already proved that you could indeed run with two installed, as long as you were creative about your video cards, right?

well...I do have a pair, I'm pretty sure, of a couple little 8MB MacTell boards. If you want me to shoot them out to you at no charge, it's not a problem. I was going to send one to Louie and one to Dookie. If these work, and you want to keep them, you can send your old cards to Louie and Dookie, and they'll get those. Or, you can just keep them. It's not like I don't have other stuff in the basement to send those guys.

I guess I would like to see this work for you. I would feel better about it if you were running a pair of Adaptecs. If you need to return the Miles2, once we get this working, just shoot deb and email and handle that thru standard channels.

did she discount you on your order? Let me know.

http://macgurus.com/infopop/emoticons/icon_smile.gif

the_anarch
04-20-2001, 08:41 AM
Mag,

Thanks a whole bunch, I really appreciate your concern on this. I guess I didn't think that running mismatched cards would be that big a deal, and when I actually got it to work I thought, Hey, that takes care of that. But I'll follow your advice. I'll send Deb an e-mail today to let her know about the extension, and what we're trying to accomplish. BTW, she did hook me up, thanks a bunch.

You are indeed correct about booting with the dual Adaptecs- I can make it work as long as I get creative with the video cards. Here's a recap of what combinations worked and didn't work:
<UL TYPE=SQUARE>
XClaim VR and Rage Pro 8MB: No
XClaim VR and Rage Pro 4MB: No
Rage Pro 8MB and Rage Pro 4MB: No

XClaim VR and TwinTurbo 8MB: No
Rage Pro 8MB and TwinTurbo 8MB: No
Rage Pro 4MB and Twin Turbo 8MB: No

XClaim VR and MacTell 4MB: No
Rage Pro 8MB and MacTell 4MB: Yes*
Rage Pro 4MB and MacTell 4MB: Yes*
TwinTurbo 8MB and MacTell 4MB: Yes
[/list]
*With these combinations, I couldn't get a video signal out of the MacTell card, I had to hook an old Apple monitor up to the Rage Pros to see the boot process take place.

Anyone notice the odd man out in the listings above? It's the XClaim VR and the MacTell 4MB. For some reason, that combination wouldn't work. And unfortunately, the XClaim VR is the most important video card to me. I love it, it was fairly expensive and I've gotten really used to having that purple pod. So far, no combination of video cards has allowed me to use the XClaim VR, another video card AND both Adaptecs. Which is really the situation I was going for.

Mag, when you send me the 8MB MacTell cards, I'm going to be trying to get them to run with the XClaim VR. If I can't get that configuration to work, I will try the 8MB MacTell with my other Rage Pros. If that doesn't work either, then I guess that's it. But if that does work, I'm going to have to make a very, very, very hard decision about whether or not I'm willing to give up the XClaim VR and use a Rage Pro as my main video card, so that I can have matching SCSI hosts, or if I'm willing to risk the mismatched dual-bus RAID in order to keep my XClaim VR.

I'll send you an e-mail about my shipping address and all that. Thanks again Mag for your consideration and assistance. I'll send whatever video cards I wind up not using to Louie and Dookie.

From here on out, this thread will be the one we use for continued discussion of my overall situation. I will use the other thread (http://www.macgurus.com/ubb/Forum3/HTML/000369.html) that I started in the SCSI forum to discuss what few further tests I run with the mismatched dual-card RAID only.

magician
04-21-2001, 03:29 AM
ok, Fletch.

those boards are on the way.

we'll know soon enough.

http://macgurus.com/infopop/emoticons/icon_smile.gif

the_anarch
05-01-2001, 08:28 AM
OK- I've already posted in the other thread (http://www.macgurus.com/ubb/Forum3/HTML/000369.html) in the SCSI forum about what I did with the Miles2/2940U2B hybrid RAID. Hopefully without too much overlapping, here's what happened in terms of my trying to get the dual 2940U2B RAID to work:

The result of Magician sending me the MacTell 8MB card was... I never got to install it. I pulled the Miles2 ($A1) as well as the 2nd ATI card ($B1) that had been conflicting with the 2nd 2940, and then put the 2nd 2940 back in ($A1). To remind everyone, this set-up worked before when I did not have any drives attached.

This time, with the drives attached (and formatted into a RAID with SoftRAID), the cursor would freeze after a few seconds- not even the happy Mac came up. I disconnected the drives, rebooted, got to the Finder, invoked the Write-Thru option, and then shut down to reconnect the drives. No help.

One thing that did seem to make a difference was the cables. I started by using a third FoxConn cable (after figuring out that the second one I'd gotten made my machine unhappy) with the second 2940U2B. When this arrangement didn't work, I switched back to using the Initio cable with the 2940U2B. This time, the machine would reach the happy Mac, but still would freeze. Not even a blip of activity from the boot drive.

At this point I started having other problems with booting even when I pulled the drives off and then pulled the cards out, so I changed my focus from experimenting to trying to get the machine back and running again the way it was before I started- with the hybrid RAID.

Since I couldn't get the machine to boot with both 2940U2Bs AND their drives connected, I never bothered to try out the MacTell card. I'm sorry Magician, and I would like to thank you profusely for going out of your way to send those to me.

At this point I have a couple of suspects: One is the 2940U2B card itself. I'm thinking it might be defective in some way so that it works by itself, and for some reason with the Miles2, but screws up with the 2nd 2940. Trouble is, either 2940 could actually be causing the problem. As soon as I stop being chicken, I might try swapping out the 2940s and seeing if that makes a difference in the hybrid RAID. Depending on what I find out there, I'm thinking that my next course of action might actually be to return one or both of these 2940s for replacement. Can't hurt to try another card or two, right?

The other possibility I thought of is the cables. This is the second time switching one of the FoxConns made a difference in the usability (the first time, it made all the difference in the world).

I find myself wondering if I'd even have this kind of trouble with two Miles2s. It seems that my machine does not have a real need of its own for speed, since I can't get a dual-bus RAID completely worked out, not to mention I can't overclock the G3 very well.

Anyway, I now have two continuing experiments here- trying to get the dual 2940s to work, and trying to get the 2940/Miles2 hybrid to be the boot volume (see the other thread). Anyone with any suggestions are extremely welcome.


[This message has been edited by the_anarch (edited 01 May 2001).]

chrismenke
05-01-2001, 08:32 PM
Anarch,

All of your symptoms are mimicking mine, save for that your U2B works with a dissimilar SCSI card, and mine doesn't (Streamlogic JackHammer [I'm not trying to bus duplex]). Issues with drive connection are markedly similar, hanging at the happy Mac evokes the night I pulled a rare all nighter trying every possible card/slot/cable/drive combo.

I say you flip a coin, pick a U2B, we send each other our cards, and pray.

I've been waiting on your results with the MacTell to decide on trying another U2B, and moving Vegas (my new name for the Pair of Jacks and associated money sucking array) into my #2 machine, but I think it might make more sense to use the one U2B in the second machine, and be happy with Vegas where it is.

To buy or not to buy...if anyone having a U2B issue would be willing to ship their card previous to returning it, I could try the dual U2B thag in 9600 ub?┤r mutt, 9500/150 (bone stock), and a lightly massaged PTP 225, and we could all be closer to making a theorem from a hypothesis.

Still open to thoughts....


[This message has been edited by chrismenke (edited 01 May 2001).]

the_anarch
05-01-2001, 10:21 PM
Chris, you might be onto something here.

To respond to all your points individually:

I apologize for the delay in getting the results with the dual 2940 with MacTell card testing posted. In fact I'm sorry to Magician as well, because I could've tested the dual 2940s with only one video card, and discovered the problems associated with that before he took the trouble to send me the MacTell cards.

I'm going to try swapping out the 2940 I have installed now, to see if the other one works with the Miles2. If I'm lucky, it will indicate to me which 2940 I need to return. If not, I may choose to return both of them and ask for a new pair.

Chris, if you're serious about trying to figure out if a dual 2940 configuration would work in any of your machines, I would say just go ahead and try it. Once you receive it you've got 30 days to determine if it does work; if not, you just return it and you're no worse off. I believe the Gurus feel that this is a legitimate use of their guarantee policy.

However, I would be lying if I said I was optimistic. Right now I am torn between knocking this on the head and just going with a single Miles2 RAID, or settling for this dual-bus RAID in the only configuration I've gotten it to work in so far (specifically, the Miles2 with one 2940U2B, the included Initio cable, and one specific FoxConn cable out of three I've tried).

chrismenke
05-03-2001, 01:32 AM
Anarch,

Having just caught your post in SCSI, here's how I cure hang's at happy mac.

NVRAM, Open Firmware (just boot to it don't do anything), PRAM, boot.

I have found that this seems to clear up my issues, which I believe also have something to do with installed drivers fighting (I have Apple drivers on my Apple Bus OSX drives, and SoftRAID 2.2.2 on everything else).

I can tell you that based on your descriptions, I think we are having the same problem.

Try this. Create your RAID, use sytem picker, and control panel to identify it.
Remove all other SCSI devices. It should boot.

Also, you should be able to boot from a CD with all drives present and usable. Now try the CD's Startup Disk cp. Are more than one device greyed?

I strongly believe that your problem now is not just the cards, but the cards, and the drivers.

I beleive your earlier problem was the cards, as I had the same boot with no devices/no boot with devices situation.

This whole thing is baffling me.

Chris

[This message has been edited by chrismenke (edited 03 May 2001).]

the_anarch
05-03-2001, 11:29 AM
Chris, thanks for the suggestions. I'm going to try them and I'll post the results in the thread in the SCSI forum, so come join me over there. As you'll soon see why, I'm gonna end this one.

Last night I made a few last feeble attempts at getting the dual 2940 to work. In the end I was so thoroughly exasperated, and I only got a minimal amount of progress as a result.

I started with 2940 #2 in $D2 and the Miles2 in $A1, which came as a result of swapping 2940 #1 out of $D2 to see if 2940 #2 by itself was the problem. (As near as I could tell, it wasn't).

I swapped out the Miles2 and put 2940 #1 back in its place, then pulled the 2nd ATI video card so that I only had one video card installed. I booted with no cables attached to the 2940s. So far so good. I attached cables but no drives and booted. Again it went fine.

I attached the drives to the cables and had the happy Mac hang again. That's OK, I was expecting it. I removed the cables again and put in the MacTell video card to see if it would boot with that and the ATI XClaimVR 128 installed. No go; it gave me the same result that I described at the beginning of this thread- green LED up, then back to amber, no gray screen, no boot activity.

I pulled the XClaim VR and replaced it with my TwinTurbo 8MB. This time it booted up. This was the first dual-8MB video card combo that I had gotten to work with the dual 2940s. Just to be sure, I tried booting with the drives attached, but again it hung at the happy Mac.

I pulled the Twin Turbo and replaced it with my 8MB ATI Rage Pro. This required me to switch my VGA monitor to the MacTell card (I had been booting without a monitor attached to the 2nd card). It booted, but I got no video signal on my monitor. It gave me the green LED as if it was receiving a video signal, but the screen was black.

I pulled out my old 14" Apple monitor and plugged it into the ATI Rage Pro and booted, and it went up just fine, although it thought it was the 2nd monitor so I couldn't see the splash screen or March of the INITs. I shut down, switched the Apple Monitor to the MacTell card (since it has both kinds of monitor ports) and tried again. Still no video signal, but still got the green LED. Very weird. Since I couldn't see the splash screen, I couldn't tell if I hung at the happy Mac when I booted it with the drives attached, but I'm guessing it did since I heard no boot activity from the fixed Barracuda.

So, end result was: an 8MB MacTell card does work with an 8MB TwinTurbo or an 8MB ATI, when dual 2940s are installed, but it doesn't work for me because I couldn't see video from the MacTell card, and I'd really like to keep using my XClaim VR 128 anyway. Chris, I don't know if this tells you what you want to know, but if you're asking me if I would recommend trying dual 2940s, I would say "Only if you're fully prepared for a lot of card swapping, and probably returning the 2nd 2940 in the end anyway."

The last thing I want to mention is that while I was doing all this card swapping and testing, I kept having a problem pop up where my Barracuda would not boot the machine after a card swap. It's possible I didn't hold down the CUDA reset button long enough between swaps, so maybe that had something to do with it. But the way it happened was, I would press the power key, I'd get a long silence with the gray screen, and then when the happy Mac came up, a lot of chatter noise would come from the Barracuda. Not any sounds that sounded like a hard drive shouldn't make, but definitely not the kind that you ever hear in normal use. And it wouldn't shut up. It just kept making the noise while the happy Mac stayed on the screen, not splash screen. I figured out that it was not actually booting, so I hit the interrupt switch and that stopped the noise, but still not booting. I would shut down and restart, but the same sequence would occur.

I decided to pull the Barracuda and put it in my old 6100 (along with its boot drive) to see if I could access it that way, and I could. Then when I pulled the Barracuda back out and put it back in the PTPro, it would boot itself. This was a major nuisance but I think it's OK. Disk First Aid found no problems. But I did have to do this weird jumping-through-hoops after almost every card swap. Very weird.

The machine is now back to its usual set-up with the Miles2/2940 hybrid RAID and ATI Rage Pro and XClaim VR cards. It seemed to be sleeping peacefully when I left for the office this morning.

If anyone wants to ask me more questions about my testing of the dual 2940s I'll be glad to answer them, but I'm not going to try anymore tests. I'm asking Debarooni for an RMA on 2940 #2. I've got to get back to getting work done. So except for that, consider this topic ended.

Oh, and Magician: Again, thanks so very much for sending the MacTell card. I really appreciate your interest and support in getting me running right. Too bad it didn't work out, I'll be glad to send the card to Louie, Dookie or wherever. You rock.