View Full Version : softraid

04-16-2001, 03:40 AM
Hello, this is my first time posting a topic to this forum, and thanks to the Gurus for providing it. I have only been using computers for a couple of years, but I did my homework and now own a beloved 9600. I have two problems, the most severe one being this: I created a striped level 0 raid volume using Softraid 2.2.2 and two 9.1 GB drives. This worked well, so I recently added two 18GB drives and went to create another raid volume for them. Before I mounted it, I decided to make a change, so I went to deleted it and create another one. Somehow, and I'm cringing as I write this, I deleted the softraid volume for the two 9GB drives. Now I can not get to the VERY critical data on them. Every one of my mac user friends gasped in horror when I told them no, the data wasn't backed up, which brings me to the second problem: when I added the new drives I installed a Miles2 card in slot A1, and since then my computer won't boot unless I disconnect the CD-R drive, which is external. It runs fine with the Miles card or the CD-r, but not both. I was in the process of trying to resolve this problem when the first one occurred, and the CD-R is the only thing I have to back stuff up on, since I deal mostly with audio files which are to large for zip disks; hence no back-up. All of this happened within a couple of days, and I know there's no excuse for not having backed up right away, but I don't get much sleep nowadays, and wasn't being careful. Anyway, trying to recover the data from the two drives has cost me all sleep since then, and I'm feeling a sense of panic. So far, I've managed to create a new partition map, and a new volume, but it won't mount because the master directory block is damaged, according to the dialog box I get. As Far as the problem with the CD-R, I tried zapping the pram, but no luck. I haven't moved the Miles card because the Initio guys said it won't make a difference. Any advice? I'm desperate. Thanks

04-16-2001, 07:07 PM
Have you tried DiskWarrior on that directory? k

04-16-2001, 10:23 PM
DW 2.1 will hopefully bebuild the MDB. I suspect the external bus with the CD is not terminated properly. Give us detail: what devices, cabling, jumper settings, etc.

04-16-2001, 11:48 PM
get your array straightened out, then mess with your external device.

you know it has to be a cable, ID, or terminator problem.

04-17-2001, 05:45 AM
I have an older version of Disk Warrior (1.0.3), but it wouldn't recognize the volume, and said the directory can't be rebuilt. I'm going to get the latest version as soon as funds allow it. As far as the external cd, it is a yamaha 4260 which has run reliably for almost three years, and is in a generic enclosure I bought used at a local shop. It's the only device on scsi bus 1, plugged into the port on the back of the tower. I've tried different cables, terminators (all passive), and ID's, with the same results. Strange thing is, on one occasion it decided to straighten up and fly right, for now discernable reason. I connected it, fired up the computer, expecting to have it freeze on the grey screen, but it booted, and there it was, in the system profiler. Another odd thing I can't figure out: when I first connected it way back when, the scsi ID on the back of the enclosure matched the one listed in system profiler. Now, on the one occasion it showed up, it didn't. And when I tried to restart, I got the grey screen and nothing else, as before. I tried restarting with it set on every ID the enclosure allows, and nothing. I'm pulling out hair in gobs.

04-18-2001, 02:46 AM
the ID switch connectors inside the enclosure may have fallen off the mechanism.

04-25-2001, 06:14 AM
Dear Magician, you were right. I opened the enclosure, disconnected the ID switch connectors, cleaned the contacts and reseated everything firmly. Put it all back together and it works like a charm. I suspect corrosion. As for the SoftRAID problem, still no luck. In fact, the problem has gotten more complicated. The folks at SoftRAID tech support got me through recreating the partition map, and creating a new temporary volume, but since it can't read the damaged MDB, the new temp volume shows up as hfs, not hfs+, which is what it should be. However, the alternate MDB is hfs+, and is intact. I emailed Alsoft to see if Disk Warrior will rebuild the directory from the alternate block when it sees the that the master is damaged, or if there is some way to get it to accept the alternate block instead of trying to rebuild the master block as hfs. What a mess! Please, wish me luck, I'm gonna need it. I will say this: now that the cd-rw problem is solved, I have backed up EVERYTHING!

04-26-2001, 06:54 PM
good luck!

helping you mentally.