View Full Version : Anyone help with some 9600 mobo troubleshooting?

04-18-2001, 05:43 PM
I bought a 9600 mobo on eBay and it was listed as having a problem. So I thought "Heck, for a cheap price, what do I have to lose?" Well, it came a while back and I just put it into a spare 9600 case and plugged it in. I put a HD from my 7500 onto the factory bus. The seller initially said no RAM no nothing, but I talked them into tossing in 2 16MB sticks. They checked in at 70ns old-old-style RAM. I put them in my 7500 and it fired up and the RAM checked out via XLR8 SW for 1 hour. So I installed the 32MB onto the mobo. Then dropped in a 200Mhz 604e processor card from a 9600. I crossed my fingers and hit the power key. I got the chime, the video signal light flickered "on" the monitor for a couple seconds, but then went back to its sleep-blink. So I powered off and restarted. Same thing. I tried a new battery. Same thing. I reset the PRAM (Cuda and key-combo at restart) and same thing. No video. The HD would never act up more than the initial whirrs and clicks. But here is where it gets weird.

After about 10 of these trials, I could get no startup chime. Nothing. So I unplugged everything (battery, power cord and PS connection). Let it sit for about an hour. Same deal happened when I plugged it all in. The chime for a bunch of startup attempts. Never any video.

Before I get pounced on, I paid $50 for it, so I really don't feel too burnt. And the things happening to me are the things the seller said he had. He stated it made the crashing glass sound upon startup one day and then began this behavior I have now. I never got that sound from this board (yet). So I was just wondering if anyone has any ideas where to go from here, other than Paperweight # 73. http://macgurus.com/infopop/emoticons/icon_smile.gif

04-18-2001, 05:55 PM
Is it a Kansas motherboard? That would probably explain why the 200 Mhz card wouldn't work. I can't tell you right off the top of my head how to tell the difference. My 9600 is a Tsunami. My only Kansas machine is an 8600, and there's a lot more differences there. I'd check the Motherboard diagrams here.... I checked it myself, but I can't see the differences. Apple removed the motherboard cache from the Kansas models, and went with a backside cache on the daughtercard. So if you can identify the cache on the motherboard, it's a Tsunami. I wish you luck with that, but I'm sure that somebody will be along shortly that can give you something else specific to look for.

04-18-2001, 06:03 PM
OK, lemme preface.

I have used 9600's since they came out back in late 96. This is a rev A board. Non Mach V. Cache on the mobo. That would have been an easy fix. I also tried sticking in a spare G3 card and I got the same results as with a 604 card.

Thanks for the zippy response, canine cohort! Hopefully some of the mystical Gurus can help me out. I hate to admit it, but the slew of things I have tried (most mentioned here) have just about exhausted conventional troubleshooting. Though I am open to suggestions and will literally try anything to get this board working. It would be a hell of a steal for $50 minus the $30 (or so) for the RAM. A $20 9600 mobo? Yeah, I must be dreaming.

04-18-2001, 06:31 PM

Couple of long shots - what are you using for a video card? Did one come with the mobo? Have you another to try? Also, have you tried an OS floppy? I have had a couple of situations where nothing would work except a floppy. Up thru OS8.5, the CD will make a floppy for you. In fact the 8.5 CD is probably the best to use. The only time it will not work is with Radeon PCI, which requires OS9 or later. Just to be sure, I tried.

BTW, the floppy route takes a long time to boot, even just to get a screen. k

04-18-2001, 07:01 PM

I will try the floppy route. I think I have an OS floppy lying around. If not, I will make one, as soon as I find and reinstall a floppy drive into one of my machines. http://macgurus.com/infopop/emoticons/icon_biggrin.gif Damn hard drives....they find their way into the weirdest of places. This'll be a good exercise for me. I can't remember the last time I floppy-booted! The thing that concerns me is that the startup chime disappears for an hour or so at a time.

As far as the vid card goes, I have thrown these at it:
ATI Nexus GA 16MB (the older one, not the 128)
ATI Orion
IXMicro (or whatever they are/were) factory card
3dfx Voodoo 3 3000

These card all work on my 3 other vintage Macs here in the house.

04-18-2001, 07:18 PM
Kinda figured you'd be able to sort that one out, but you never know. I always seem to miss the obvious solution, on my way to a more complex one. Well, if all else fails, maybe Trag will buy it for the PCI chips http://macgurus.com/infopop/emoticons/icon_smile.gif

04-18-2001, 07:35 PM
I have a couple mobo's ear-marked for him! Damn, I really want this one to work. Just to fight the odds.

The obvious conclusion sometimes eludes me, too. I bought this 9600 partially due to my familiarity with them and a surplus of parts I can swap out to test. Might actually be a dead board. Now, if someone wants to point me to some test I can run...Well, that'd be ducky. I never actually diagnosed a hosed board. Maybe I will just get exhausted and toss it into the East River. Someday we might have a nice Mac in there!

[This message has been edited by Dogstarman (edited 18 April 2001).]

04-18-2001, 08:40 PM
Does the river really need a six slot though? http://macgurus.com/infopop/emoticons/icon_biggrin.gif

04-18-2001, 11:10 PM
you might just want to mount it on velvet, and then put it in a presentation wall case. You could send it to Steve Jobs.


04-19-2001, 11:08 AM
Got a floppy installed and tested the bootup on my 7500. It worked, so I tried on the 9600 in question. I got the startup chime, held down "F", and heard the floppy getting accessed...for about 5 minutes. No grey screen, no happiness. I tried it with another vid card in another slot on another bus. Same. And then after about 8 tries, no more startup chime. OK, so maybe this is beyond a simple fix, but it would be nice if I at least had some clue as to what it is that is going wrong. I hate letting things go unless I have at least a good idea about why they are going wrong. That's all. Thank you kind folks. Good day!

04-19-2001, 01:14 PM
Well, I kind of put off reading this thread, because troubleshooting bad boards has got to be one of the most frustrating things.

If you are getting a startup chime, my guess would be that if you have a hardware problem, it is in the cache or one of the SCSI controllers. Of course, it could be in a Bandit chip too, but that seems unlikely to me. But just in case, have you tried your video card in both the lower slots and the upper slots? That would help mitigate for one or the other Bandits being bad. Of course, if Bandit 1 is bad, your connection to Grand Central is hosed, so all your board I/O would be hosed too.

If its the cache, disabling it would probably take care of the problem. There is supposed to be a hack to disable the onboard cache on the 9500 board--which is essentially what you have there. You might want to try that. I'm not sure where you can find that hack. On the S900 it's just a matter of installing an jumper (and the pins to put it on), but there's probably a resistor or something that can be installed or removed on the 9500. Isobe over at XLR8yourmac has probably published the hack for the 9500.

If the problem is in one of the SCSI controllers, you're basically hosed, unless you can replace the MESH chip or the CURIO chip. Because the MESH is only found on x500 machines, you can't really get a replacement for it, though I suspect that a 53CF96 might work. That's the chip in the 8100 and it's made by LSI Logic these days.

The Curio chip you can get off of anything from a 6100 to a 7200 so those are easy to get, but it's still something like 160 pins to move.

I'd say your best bet is to try the cache disabling hack, to eliminate the possibility of bad cache.

Another thing to try would be to boot the machine into Open Firmware and print out a listing of the device tree. If there are devices not appearing that should be, then you know that somewhere along the way leading to those devices, there's probably a bad chip. If you can get floppy activity, then your machine is probably making it through Open Firmware at startup.

Instructions for using Open Firmware can be found at Apple Developer web site, which you can reach through www.apple.com. (http://www.apple.com.) Go to Developer:hardware http://www.macgurus.com/ubb/tongue.gif ci card development. I'm not sure about that last one. There are three tech notes. The first two are 116x or something like that. They are basic guides to Open Firmware parts 1 and 2 and walk you through using Open Firmware. You need a second Mac with a terminal program installed and null modem cable.

I think if you download the PCI SDK it will include all three of the OF tech notes. The whole SDK is a few megabytes though.

04-19-2001, 11:51 PM
Well, I was kinda putting off posting the thread, so call us even. http://macgurus.com/infopop/emoticons/icon_smile.gif Thanks to all for trying to help. I was aiming for a far-off star with this creation. And I guess I hit the mark I expected to hit. I will check out my OF findings, but I am not terribly hopeful.

Now, what color velvet to frame it in? And where do I find Steve's home address.....I got some work left on this board if all else fails.

04-23-2001, 04:36 PM
Hmmm, what color to put under that lovely green board.... I'm thinking Black.... This could be an installation piece. Gotta get the lighting just right..... http://macgurus.com/infopop/emoticons/icon_biggrin.gif