View Full Version : Hard drive problems

04-19-2001, 12:36 AM
I am trying to install a 2 gig Hard drive into an external case but am having trouble formatting it. The drive utility that I am using sees it and gives it's scsi Id#, bu twhen I try to initialize it I get a message that the drive is not ready. any wisdom on this folks?

04-19-2001, 01:34 AM
What's the make and model of the drive and what software are you using to format?

Is it properly terminated? What else is on the bus?

04-19-2001, 07:42 PM
The hard drive in question is a compaq model#C2490A It is in a case with a 50 pin terminator on the back, Scsi ID#2, My system drive is #0,and my cd rom drive is #3. Both of these are internal devices. I suspect that this is a matter of setting jumpers in the proper positions....
ok then, thanks again for your response and any help :-)

04-20-2001, 07:14 PM
I didn't know Compaq made drives; I thought the major manufacturers made drives for Compaq. Can you read the actual drive label?

This smells of a drive that was formatted for a PeeCee.

Depending on the computer you are using, the external drive may or may not be on the same bus as the other devices. What machine is it? Some have two built-in busses. What does Apple System Profiler show.

What drive utility are you using?

[This message has been edited by Louie (edited 20 April 2001).]

04-20-2001, 09:00 PM
It's an old HP SureStore 2000S SCSI Hard Drive http://www.hp.com/cgi-bin/cposupport/get_doc.pl?SNI=hpsurestor9696&LC=information_storage&Tfile=lpg61018 and here http://www.hp.com/cgi-bin/cposupport/get_doc.pl?SNI=hpsurestor9696&LC=information_storage&Tfile=lpg61019

HP made them for Compaq, but if your utilities say Compaq C2490A, then it probably has Compaq, not HP, firmware. I have an old Seagate with Compaq firmware and it was a bitch to find a Mac utility that would format it. And I remember trying again and again until it did so. But once it did, I had no trouble using any other formatting/initializing Mac software to reinitialize it. k

04-20-2001, 11:29 PM
Well Kaye:

Since I've never heard of a SureStore drive, I'm bowing out. You should be able to get this guy going based on your vast knowledge of stuff like that.

[This message has been edited by Louie (edited 20 April 2001).]

04-21-2001, 01:32 AM
You can use the link to set the jumpers properly, but what software are you using to try to format and what MacOS version are you running? k

04-21-2001, 03:31 AM
he may need to tickle it with Configure to get it to behave with a Mac.


04-21-2001, 03:24 PM
firstof all i want to thank everyone for replying to my post :-)
I am trying to format this drive using Hard drive toolkit.my system is o.s 9.1 What is configure?? If that would work then I sure could use a copy..
It figures that somthing made to go in a PC would be a B***h to configure..lol!...

04-21-2001, 03:45 PM
Oh,and also I wanted to say that you guys called it exactly correct. there are several HP chips on the bottom of this drive and the tech sheets you linked me to match exactly as well..
thanks again :-)

04-21-2001, 05:54 PM
Kaye's the man here.

If you are using 9.1 you need a compatible version of FWB (except for the Configure part). Sometimes the PC SCSI drive are configured with odd sector sizes, etc. Kaye can guide you through what to change (using FWB Configure) and probably lead you to some off-the-wall driver software to use to initialize the beast.

04-22-2001, 03:35 AM
You tried the version of Drive Setup that comes with OS9.1? And I'm unclear where this drive is installed, on the external chain? If external, draw me a diagram such as:
external SCSI connector====>Compaq

Is it by itself on the external SCSI?

I'm not sure it is worth trying several different drive utilities that are compatible with OS9.1. HDT, CharisMac Anubis, Intech HD SpeedTools, these are going to get costly and there is no assurance that any will work. Besides Apple's Drive Setup, the only freebie is ATTO's ExpressPro Tools version 2.50.

One thing, get rid of that external terminator. I'm guessing it is a passive terminator. The drive has jumper pins at location 15 for Terminator Enable (TE). I would terminate that way and remove the external terminator, if the Compaq is the last or only device on the external chain. Then see if Drive Setup will work. If not, try the ATTO utility. If it does not work, you need to decide whether you want to spend the money for another utility that may not work. Getting past the Compaq firmware is the problem. If this drive is like my Compaq, all of basics, like the sector sizes and so forth, match what you need for a Mac.

What worked for me was Anubis and about four hours of trying to initialize, or trying to format and initialize, everytime failing, but being persistent, I just kept trying and trying. Anubis had two methods of initializing. It always tried its regular way, but if that failed it would go to a backup method of initializing. Eventually the backup method worked. I then initialized again, and the regular method worked. So I then did a format and initialize and the regular method worked. Then I went to FWB HDT and initialized. Purring like a cat ever since.

However caution, this was a Seagate drive and Seagate told me the drive had Compaq firmware on it and I would probably never be able to get it to initialize on a Mac, and even if I did, it would not be reliable. That's why I was persistent. Works just fine. YMMV. k