View Full Version : Start-up conundrum

04-11-2001, 09:15 AM
Hi all

Well - now here's a conundrum that perhaps the forum can resolve... I hope


System - 7300 w/ a G3/400 card (stock settings - XLR8), OS 9.1, Miles2 latest firmware. SoftRAID 2.2.2
Drives - Raid 0 array for boot, Raid 0 - 2 drives on external mobo w/ MO drive / CD-RW + 1 external drive
Miles2 is driving a RAID 0 array + 3 VXA drives
Adaptec 2930CU is driving a DAT + MO drive external

This booted fine until this morning - now it seems to stall at the happy Mac.. I can get it to boot off the CD-ROM, NDD says all is well. I tried to boot off the 9.1 CD-ROM and choose to the right start-up drive but then it boots to another system folder (7.6.1) on an external drive.

If I use System Picker, it shows the 9.1 boot drive as having a 1.1. system (while the other ones (7.6.1) and the 9.1 CD-ROM show up correctly.

I had reinstalled the OS two days earlier when this same problem appeared.. now about to try it again.

BTW - the reason I had to reboot was because I had just installed the drivers for an HP ink jet and turned on USB Printer Sharing ...

Any ideas?. \


04-11-2001, 10:10 AM
I'm back up and running - did a complete reinstall of the OS... Odd problem... would like to resolve it though so any hints????


04-11-2001, 03:27 PM
Arghh - back to where I started. Tried a restart and it stalls again at the happy Mac.

04-11-2001, 06:25 PM
Geez Chris... failing VXA tapes, systems that won't boot from a freshly-installed OS? Something's going on with your mojo... maybe even your mobo, but definitely your mojo.

04-11-2001, 07:11 PM
I know - tell me about it.. gawd... I need a vacation...

I think it's just one of those - all at once things start to go problems - check this one out - one of my students has a ThinkPad - she goes to install a Logitech mouse - BOOM - Blue Screen of Death - BUT cancel out of that and all is well.. So... surf over to the Logitech site - tada - If you have a ThinkPad and get the BSOD after installing our mouse, you need to disable the trackpoint and then you will be fine.. Good grief.

(We're have a $250K machine installed in our lab today and I'm just PRAYING that it won't do funky things .... like blow its alignment or fry a detector)...


04-11-2001, 10:36 PM

It's the Startup Disk CP for 9.1. I have 5 boot volumes ranging from 8.6, 9.04 and now, 9.1 Before 9.1, I was already having to use System Picker because of a SoftRAID/Miles bug. The Startup Disk version that came on the CD would spin and quit. I got the 9.2.1 upgrade and it's cool. The new version is like System Picker on steroids; it actually de-blesses some systems.

I haven't completely figured it out yet, but most of the time 9.2.1 will do it, sometimes I have to use System Picker. Try 9.2.1. One thing for sure, Apple intends for us to have only 9.1/OS X on our machines.

04-11-2001, 11:22 PM
Louie's onto it like stinkbugs on a pile, I think. http://macgurus.com/infopop/emoticons/icon_smile.gif Once you boot even once from a different system other than OS 9.1. That version of the startup disk control panel does something different to NVRAM that doesn't allow OS 9.1 to simply boot up afterward. In my experience, you have to reset NVRAM before you can successfully switch OSes on boot.

04-11-2001, 11:27 PM
Thanks Louie, I'll give a shot in the am - I'll run the Software Update to slurp it down from Apple.. what a pain. I thought that might be it - but what's odd is that OS 9.1. has been on that machine (and I think updated) ever since OS X was released a few weeks ago. (I used the full CD from the OS X package).

(we won't go into the dilemmas I had earlier w/ OS X - still not running Classic on it but am playing inside it)...



04-11-2001, 11:31 PM
I have played around with it some. 9.2.1 is an app and not a really a CP. It seems to work for all systems on the machine like a Super System Picker. If you choose a volume where the system has been de-blessed, you may need to use System Picker instead though. All you have to do is trash all systems except 9.1 and OS X and you are cool. But, I'm not going to do that.

04-11-2001, 11:32 PM
9.2.1 just came out last week. You may need System Picker too (FTP site).

[This message has been edited by Louie (edited 11 April 2001).]

04-12-2001, 11:06 AM
I'm so confused - had to do this again - it got stuck, I reinstalling 9.1 AGAIN.. then I'll update the Startup Disk Control panel.

The issue here is that I wasn't in fact running OS X at all on this machine. I may just downgrade to 9 and then go to 9.0.4 if this doesn't work.

Very confused...could it be the hard drives are funky?. NDD seems to say they are fine but I've now reinstalled OS 9.1 three times in the last four days (although I will say that it doesn't crash that much - the problem only occurs when I go to restart...)


04-12-2001, 01:33 PM

Maybe your drives don't jive with OS 9.1 or it could be that your G3 card is rejecting the OS--just a thought. One of my friends had the same type of reboot problem with his PowerCenter Pro with a G3 card. He had to downgrade to OS 9 and upgrade to OS 9.0.4. The Apple site claims that OS 9.1 does not support third party powerpc upgrade cards. The problem could just be a simple extension conflict. Have you tried booting with the extensions off?

04-12-2001, 01:38 PM
Doing a clean install of OS 9 -> 9.0.4 now.. Annoying since it was working fine before under OS 9.1.. ugh...

Could never get to the extensions loading part - it would always stall at the happy Mac icon (i.e. the little one - not the big faces)


Good thing it's a long weekend


04-12-2001, 01:55 PM
This is so weird. I truly understand your frustration. Can you try booting from the OS 9.1 disk instead of from the start up disk? Have you used Nortons or a similar disk utility to troubleshoot? Zapped the pram lately?

Thank goodness this is a long weekend. Need time to come up with some more testing strategy since OS 9.1 was working before.

04-12-2001, 02:58 PM
Did that - can boot fine from 9.1 CD.. I'm beginning to suspect some sort of SCSI voodoo connected with my VXA drives.. but what's odd is that if the drives aren't connected to the Miles2, then the problem still occurs.. Most odd.. need to check something there I think

Anyways- I'm about 80% there with the clean install and upgrading.. Argh - this is not what I want to spend my day doing..


04-12-2001, 03:14 PM
This is great news since we know that the culprits must be the other drives. Its a good indication when the system responds to the CDrom. Perhaps one of the extensions or settings jumped out somehow which is typical in Mac land. I think that maybe once you reinstall the OS from the 9.1 disk while holding the "c" key things should improve all around. I know this is a pain, but what choice do you have since you have multiple drives attached to the drive? The last test I would suggest to test each drive by changing them one by one to the start up disk. This way you will know if it is actually one isolated drive that is really causing the problem or a combination of drives. This effort will save time in reinstalling the 9.1 if there is no actual problem on a particular drive. You can also run Disk First Aid on these drives to see if thre are some problems with sectors.

04-12-2001, 04:35 PM
Hi there...

Well - it's come down to now I'm using 9.0.4 under a clean install and all is well - it reboots etc.. Funkiness still prevails though - I had an older OS sitting on an external drive that never caused problems but now the StartUp panel still gets confused as to which drive to start with (at least this is what ASP says). I basically turned it off and now I can boot fine to the 9.0.4 volume w/o the other one starting up (I think it's 7.6.1). Anyways - this really wasn't the crux of the problem since it had the stall at the grey-screen-of death when.. check this out.. I had tapes in my VXA drive array (I have three VXA drives connected to the external port on my Miles 2 card which is driving my boot RAID 0 array). I know - probably on the serious hairy edge of stability and perhaps that was what it was.. now to ensure I boot cleanly, I make sure the tapes are ejected from the drives. For some reason, on boot, the tape drives seem to start winding and one seems to get stuck (which I hope doesn't portend its failure).

Whatever, success (moderate though it is) is in the offing for a gorgeous afternoon in Toronto....


04-12-2001, 05:13 PM
Great idea to take a break and enjoy Toronto. I see that you are back to OS 9.0.4. I assume after a mental break you will be back at getting your system operative with OS 9.1. Maybe instead of using the 9.1 full install disk, you could try using the update from the Apple site. Just a thought.

It was a good idea to eject the tapes from the drives, but somehow your mixed OS environment is driving your computer crazy. Maybe your computer needs a mental break too ha, ha.

04-12-2001, 05:31 PM
The side benefit of this little tangential run is that my machine seems a bit zippier now.. must be because I trimmed off a TON of extensions with the new install.. ;-).. excellent


04-12-2001, 05:46 PM
I agree too many extensions can make the computer go bezerk as too many applications can. You gave me the same advice about deleting extensions and preferences to increase performance and it works. Glad to hear that trimming helped. Are you thinking about putting the OS 9.1 back on now?

04-12-2001, 08:09 PM
Chris, the choice highligted in Startup Disk 9.2.1 HAS to match the choice you make in System Picker or an earlier Startup Disk CP. 9.2.1 is KING for every bootable volume on your machine. I've even considered making an alias of it for the desktop.

04-13-2001, 12:02 AM
Yup - did that - I had SystemPicker aimed at the right one, StartUp Disk CP pointed at the right one and it still balked... Right now it's fine although I didn't upgrade from 9.0.4 yet..I think this all started when the machine locked up during a network copy and I had to reboot - somehow it got all confounded.. anyways - it was good to do a clean install to set things up...


04-13-2001, 01:12 PM
You know what I think the problem is - for some reason, my Mac is trying to boot from one of my Ecrix tape drives.. when you execute a restart, it stalls now at the grey screen AND if I look at the tape drives (w/ tapes in them) - two of the three tape drives are sitting at the "stand-by" while one is in the forward wind phase.. and I think the problem is that it's stalling there.. If I eject the tapes and then restart - all is well... very odd - this particular configuration was working so well for about a month...

Any suggestions short of writing a script to somehow eject the tapes from the drives before shutting down and restarting?.

04-13-2001, 06:54 PM
I went through a whole lot of hair pulling with a similar issue, and I found that the fix (for me) involved tracking down SoftRAID volumes which had artifacts of Apple's Drive Setup Drivers on them, and re-initializing.

Try paring down the number boot volumes, and then addressing HD drivers again (lucky you've got all those VXAs).

I've found that I get the happy Mac hang if I boot with mixed drivers on my #3 bus or #4 busses, hanging exactly where you are hanging. All SotftRAID, or all Apple booted just fine. Once you fix the driver issue (if it even applies to your system), then you may bump into a problem with all the new developments in Startup Folder assignation (I sure did).

I can now reboot, switch OS's, etc. I'm just worried what will happen when I try X again...

[This message has been edited by chrismenke (edited 13 April 2001).]

04-14-2001, 11:34 PM
Chris; this OS X stuff does weird things to NVRAM. Just booting from the OS X CD eliminated ATA Bus 1 on the wife's beige G3. I bought a new CD player and almost a logic board before I did a NVRAM flush and the bus came back. I think that Startup Disk 9.2.1 and its predecessor mess with your NVRAM. Do a COLD start with CMD-OPT-P-R down and let her bong three times.

04-15-2001, 09:17 AM
Hi Louie

Zapped the PRAM / NVRAM a couple of times and it never did seem to really help. Now I've totally removed the 2 drive Ecrix array and just have the external Ecrix back on the Miles2 (along with the boot drives). Now, while I can boot w/o a problem,suggesting that there's something funky with the array, Retrospect spazzes out with it goes to backup a network client - i.e. the Mac freezes solid when it starts to execute the backup - it's not the connection per se since it does scan the remote machine, I think it has to do with when it starts to wind the tape... I wonder if I need to replace the tape.. I have three tapes coming in from the 'Gurus and two RMAs from Ecrix to resolve my blown media problems so I'm hoping that will solve it..

I even turned down the Miles2 card to 40 rather than 80 in the vain hope that that would resolve the tape drive problems.


04-15-2001, 06:25 PM
Ongoing saga - now TWO more of my VXA tapes have died w/ "content unrecognized" errors in Retrospect. This is a tad disconcerting and I'm not sure that it's NOT unrelated to my current SCSI problems. Wonder if my drives are somehow messed up and this is translating to the tapes somehow.

Chris (who really isn't enjoying his long weekend very much)

04-15-2001, 11:30 PM

i've reviewed this thread in disbelief....and i have no really brilliant ideas....but I guess one thing I would definitely recommend is to ensure that you have updated drivers on all devices.

there is no harm in updating drivers on striped or mirrored arrays....just don't reinitialize them, and you won't lose your data.

since you have done clean installs....and you will update drivers....I'm wondering if Ecrix can talk you thru firmware updates on their tape drives, so you can at least ensure that you are running the same firmware rev on each VXA-1? I'm trying to think of weird, arcane things that might cause problems in the event several drives are used.

it is a little unusal to run three or four VXA's on the same machine....right?

the other thing that is freaking me out, is you were apparently running for a couple of weeks with reliability for awhile?

what changed?

something had to change....if nothing changed, something had to fail.


have you swapped terminators?

I was going to say, swap tapes....but you did that....and now two tapes got eaten?