PDA

View Full Version : Install problems



batmantis00
04-06-2001, 05:51 AM
Ive come across a problem I haven't encountered before. I recently installed 9.1 on my dads 7600. However, he uses Claris CAD on a daily basis. (In case you dont remember when that software was last updated, ill give you a hint-the box has a sticker that reads "System 7 compatible.") It works alright with 9.1, except that you cannot open a document from outside the program if the application is already running. It suggests opening the document from inside the app, and upon closing that dialog it gives a type 2 error and unexpectedly quits. There are a couple other similar quirks, but i wont go into them. I am trying to reinstall 8.6, since there really isnt anything that 9.1 has my dad needs that 8.6 doesnt offer, and it doesnt have the strange behavior in the old apps. However, when I try to install, once I get through the dialogs and configurations and start the install, it checks the media, updates the drivers if i have it selected, begins reading and then gives the following error:

Problems were encountered reading the source file "Installation Tome". Installation cannot continue.

And returns to the install configuration. That was from the 8.5 disc. I figured one of the scratches on the disc was causing the problem. I bought one of those disc burffer things at the music store and tried again, same error. Tried with a different cd-rom drive. at this point i had been having some problems with 9.1 that i hadnt figured out-i have since determined to be a corrupt pref file that got messed during a manual shutdown. i tried to run the 9.1 updater, to replace any extensions that might have gotten hosed, from a disc image. it gave me the same error, so obviously it isnt caused by a scratch on the disc. ive also run norton discdoctor 5.0.3-which fixed some minor stuff but didnt find anything significant, reset pram, rebuilt dektop, disk first aid.

so anyone have any clue?

heres some sys info:

Newertech g3 366
4x64mb ram @ 60ns
4mb vram
256k (?) L3 cache (ill try pulling this)
xlr8 USB card
1.2 gb oem hard drive

I think the only non-apple software installed is ms office 98, claris cad, some xlr8 utilities for the usb and g3 card, and handspring software.

jorge
04-06-2001, 08:27 AM
are you booting off the 8.5 cd when installing? Have you selected a clean install?

j

batmantis00
04-06-2001, 03:40 PM
yes and yes.

Louie
04-06-2001, 07:00 PM
You lost me.

What happened when you ran the 8.5 CD with another CD player? attached to what machine? And the 9.1 CD was run in the what machine/CD combo?

batmantis00
04-07-2001, 06:59 AM
ive been booted off the 8.5 cd in all instances. i used the 4x cd rom that shipped with the machine and an apple oem 24x internal scsi (i thought the more recent drive might be better for reading damaged cds-though i no longer think the cd is the problem.)

everything in question has been on a 7600.

9.1 is aready installed, but before isolating the stability problem as a preference file, i thought it could have been an extension that was corrupted (i accidently hit the power buttton during the boot up-which has messed up extensions in the past.) an easy way to replace alot of potential problem extensions is just to run the 9.1 updater-atleast it seems like ive dont that in the past, albeit an updater for an earlier OS. so, i was trying to run the 9.1 update on a hard drive that already had 9.1 installed, while the machine was booted from the 8.5 disc. this gave the exact same error and message as when trying to install 8.5 from the disc. the 9.1 updater was on a zip disc, by the way. i have also tried renaming and/or moving the system folder to the trash while running the installers, with no change in behavior.

is that any clearer? if not, ill try again.


[This message has been edited by batmantis00 (edited 07 April 2001).]

Louie
04-07-2001, 01:53 PM
Oh! You can't run an installer of a system that is older than the installed system.

If you want something off the 8.5 CD, use Tome Viewer and extract it.

batmantis00
04-07-2001, 03:45 PM
that makes sense, but why would it know that 9.1 was installed if i had moved it to the trash? i'll try moving it to the trash and restarting. if that doesnt work, ill wipe the hard drive and try again. that seems like a rather obscure error message for what seems like it would be a fairly common problem.
will post back later.

batmantis00
04-07-2001, 05:05 PM
ok, heres an update. i put everything in the trash (without emptying) and restarted with the cd as the boot drive. tried install (installer said no system installed for the drive) and got the same error. i dont have the guts to wipe the drive. i backed it up, but im not terribly fond of copying system folders to and from disks-ive had bad times as a result of that in the past, and without being sure that i will be able to install an operating system if i wipe it, id like to keep it functional. i realized that one of the hard drives on the g3 has 8.6 on it, so i might try copying that to the 7600 (without wiping it) and see how that works. i also ran the 8.6 updater on the drive that already had 8.6 on it, and it went off without a hitch. like i said, i tried that with the 9.1 installer on the 9.1 drive and it gave the tome reading error. uhg. frustrating.

MacMikester
04-07-2001, 05:24 PM
Sometimes reading from large compressed files gets florfed if there is a SCSI problem lurking. Check cables, termination and IDs. Also try a power-off complete shutdown, followed by a cold boot with PRAM reset keys held down for three chimes, then allow boot off the install CD. OS 9.1 does things to NVRAM.

Luck

batmantis00
04-07-2001, 10:29 PM
no luck. tried all this and a whole slew of other things and havent found a solution. after wiping the disc im recopying a back up onto the drive and giving it all back to my dad. technically the computer belongs to british petroleum, so they can deal with it. but since they converted to pcs long ago, and have been trying to get my dad to give his up since they swallowed arco, they probably wont make much effort to help him out.

kaye
04-08-2001, 10:36 AM
I had this same Tome problem with my OS9.0.4 CD (brand new, no scratches), never before with any OS CD, and the 9.1 CD worked fine in the same CD-ROM drive. What I did was this, do a custom install. A window opens with all of the various installs. Start at the top and only do the first install, the OS. When it completes, a window asks if you want to quit or continue. Select Continue. The custom install window reopens with the install you just did still checked. Uncheck it and select the next install (just do one at a time). Just continue to select Continue after each install (don't Quit) and continue to deselect the single install you just did, and select the next install until you are done, then Quit. Worked for me without the Installation Tome error message. k