PDA

View Full Version : Fast & Wide SCSI drives won't work



ryboy
02-21-2001, 08:50 PM
i have two 4 gig fast & wide scsi drives on my power pc 9600. i have a fast & wide scsi pci card in and i have the latest drivers installed for it. i have done a low level format on all of my drives including the internal scsi drive. i have also done a clean installation of my os, which is 9.0.4, and i have updated the drivers on all of the drives. i have my two external drives on when i boot up and have them set to automatically mount on startup. when i boot up the computer the happy mac logo appears and then i get a blank white box that appears and the computer locks up. however, when i boot up off of the mac os cd the two external drives mount fine. the same is the case when i boot up without extensions. my computer works perfectly when i shut these two external drives off and just run off of my scsi internal drive. also, i have tried setting the external drives not to mount on startup and if i have them on while booting i run into the same problem. PLEASE HELP! =)

kaye
02-21-2001, 09:11 PM
What is the name and model number of the PCI card and the 4GB external HDs and the internal HD? Do any of these drives have adapters on them? Lets start there before we ask more questions. k

[This message has been edited by kaye (edited 21 February 2001).]

ryboy
02-21-2001, 09:34 PM
the card is an advansys ABP-940UW. as far as the external drives go, i'm not sure to tell the truth. i pdate the drivers on them from the MAC OS 9 cd. the internal drive is an ibm, it's the one that came with the machine. the only adapters on the external drives are the fast and wide connectins on the back . there are two one each drive and i have them daisy chained. the last one on the link is terminated. i have tried booting up with one at a time as well and it still doesn't work.

[This message has been edited by ryboy (edited 21 February 2001).]

MacMikester
02-22-2001, 12:52 AM
Hey ry,

Use Apple System Profiler to get the make and model numbers of the ext. drives.

ryboy
02-22-2001, 02:22 AM
the vendor is quantum and the product i.d. is viking 4.5 SCA. the driver version is 8.1.4.

kaye
02-22-2001, 12:55 PM
r,

Got to be the adapters on those SCA drives, or could be the external cable. You have no idea how often we see problems with inexpensive SCA to 68-pin adapters. SCA drives are cheaper but by the time you put good quality adapters on them, they are more expensive. If you can return those Vikings, do so. If you can't, then you need good quality adapters, like the Gurus Granite adapters. But try another cable first.

There is also a possibility that the advansys ABP-940UW is not configured correctly. So you need to check that. But I'm betting on those adapters. Course I lose a lot. Luck. k

ryboy
02-22-2001, 04:26 PM
i'll give the cable a try and then try out new adapters. however, i'm wondering why the drives seem to work fine when i boot up without extensions or when i boot up off of the mac os cd. any ideas?

kaye
02-22-2001, 06:51 PM
One other thing to check, the Viking on the end of the chain should have Termination Enable (TE) pins on the drive and/or adapter with a jumper on the adapter to enable termination. On the other Viking there should not be a jumper for TE on the drive or adapter. k

ryboy
02-22-2001, 07:02 PM
the last drive on the chain is terminated with a scsi terminator.

magician
02-23-2001, 02:53 AM
if things work well with extensions off, guess what? You probably have an extensions problem.

booting off a MacOS CD is a very thorough way of ensuring that you really are booting with extensions off.

http://macgurus.com/infopop/emoticons/icon_biggrin.gif

ryboy
02-23-2001, 02:45 PM
why would i have an issue with my extensions if i have done a clean install and i'm running off nothing but the mac os base extensions? i have absolutley nothing else except for OS 9.0.4 installed on this thing. i don't get it. if you have any ideas, please give 'em to me.

thanks :-)

trag
02-23-2001, 05:15 PM
If things were as they should be, no one would ever have extension conflicts. Unfortunately, extension conflicts are a fact of life. The Advansys card may have problems with some of the OS 9.04 extensions. I'm not that familiar with the ABP-940UW but my vague memory says that it is an older card.

What you may not be aware of is that many PCI cards (and all SCSI cards except the 2906) have some software on the card itself. This software is called firmware. At boot up, the firmware is read off of the PCI cards and loaded into the Mac's memory.

Older PCI cards sometimes contain firmware which conflicts with newer OS components. So, while you updated your hard drive drivers (little smidgens of software, much like firmware for hard drives), and you updated the control panel and/or extension for your SCSI card, you probably did not update the firmware in your Advansys card. So you could still have a conflict with OS9.04.

Even if you did update the firmware in the Advansys card, and even if Advansys said that this version of the firmware works with OS 9.04, it is still possible that it doesn't. You could fill a good size dumpster with one copy of each software update that was supposed to work with a new OS and didn't.

So, what we have to go on, is that your computer is behaving like it has an extension conflict. Nothing else comes to mind. Absent someone who has had this specific problem with this specific setup before, the only way to proceed is to test for conflicting extensions.

So you should either use Conflict Catcher, or manually disable half of your extensions and CPs and see if the problem persists. If it does not, switch the disabled extensions and CPs with the enabled ones and now the machine should crash. Disable half of the remaining extensions and see if it crashes. Continue until you're left with the extensions causing the problem. There are a few situations in which this might not get all of the problem, and you could do it the opposite way (start with the half that doesn't crash and add extensions in until it does) but you should see the basic methodology.

Once you've completed this test, you'll know what extension is causing the problem and one can determine a course of action from there.

magician
02-25-2001, 01:30 AM
hmmm....it almost sounds as if your Mac wants to mount those drives, but fails right about when it tries to put them on the desktop with extensions on.

I have no brilliant ideas for you, really. If I were in your shoes, I would get rid of the Advansys card, replace the cabling, replace the SCA adapters, and replace the terminator. If it is possible to return the SCA drives, I would do so, and get standard LVD drives with a Miles2.

I realize this may not palatable for you, so I'll shut up now. You are using a lot of stuff that is known to be problematic (which is why we neither sell it or endorse it), so I wish you luck.

ryboy
02-25-2001, 10:21 PM
i want to thank everyone who tried to help me out with this problem. THANK YOU =) i ended up writing an email to advansys about my problem and they sent me an updated version of their driver, or some utility to flash my bios with, that's wht they said it was. by the way this utility was not available on their web site and they took about 3 days to get back to me. anyway this little utility did the trick! however, i now have one of my two external drives that will not mount whatsoever now. when i go into my drive set up utility it tells me that the drive is not available and i can't even initialize it. it won't even let me initialize it when i boot up from th OS 9 cd. this was not happening before i used this utility from advansys. i don't understand this problem at all now. do you think it could have something to do with the card anymore? or is this a disk drive problem? the other external drive is working fine. please give me suggestions if you've got 'em.

thanks-
ryboy

MacMikester
02-26-2001, 12:33 AM
I think you have no choice but to try quality Granite SCA adapters on those external drives. The fact that the current ones worked in a slightly different hardware/software environment is no guarantee that they will ever work in your current environment. $0.02

crazyeights
02-26-2001, 03:09 AM
Magician's reply was, as usual, modest and succinct.

I, on the otherhand, am rather verbose, and am unafilliated with MacGuru's, so I'll toot their horn a wee bit more.

Before the MacGurus sell ANYTHING, they get it down in Hardware Heaven, and pound the crap out of it. Some of the stuff might work fairly well, but if flakes out, and they can recreate the problem, they flat out won't sell it, unless/until the manufacturer fixes the bugs.

If they find the manufacturer unresponsive to their concerns as a vendor, they have NO desire to put their customers through the manufacturers customer no-support grist mill.

They only sell what they would put in their own macs, and they support what they sell. As a vendor, MacGurus support is PEERLESS, and is of a quality others can only hope to be someday. (Although most other mac vendors don't even seem to get close. Go figure.)

My experience biased 2

c8

trag
02-26-2001, 11:37 AM
Termination in the wrong place can keep your SCSI controller from seeing a device or devices depending on exactly where the wrong termination is. It is likely that when the firmware in the Advansys card was flashed, any settings you had for termination on the card were changed back to defaults. So I would do the following. Some of it has nothing to do with the card, but these are all the things to double check. If I had a nickel for every time that a problem turned out to be in a component that I was sure was already set correctly...

I would double check that you have termination enabled only on one of your external drives and then only on the one at the end of the chain. Check the jumper settings on your SCA adapters. Then make sure you don't have an external terminator installed.

Or alternatively, make sure that you do not have termination enabled on either external drive's SCA adapter and make sure you do have an external terminator installed on the end of your external chain.

I am assuming that you are using 68 wire cabling to your external drives, so there should not be any termination issues regarding the upper 18 wires versus the lower 50 wires.

Next, if your internal SCSI drive is on the Advansys card with the external drives, then makes sure that termination on the Advansys card is turned off. That should be a Control Panel setting. If the internal drive is a narrow drive instead of a wide drive and connected to the Advansys with a 50 pin ribbon cable, then make sure that the Advansys card is set to terminate only the high byte (upper 18 wires).

Double check that the internal drive is terminated.

If the internal drive is not on the Advansys card, then make sure that termination is fully enabled (high and low byte) on the Advansys card.

It might make your testing easier if you try connecting one hard drive at a time.

Finally, if none of that works, there is a tiny little minute chance that if you left the drives connected while you flashed the Advansys, the flashing process hosed the drive. Which SCSI ID is the problem drive at? I've never heard of that happening, and the Advansys shouldn't be sending signals out on the SCSI bus while it's getting flashed, but my paranoid/creative mind just came up with that idea and had to share.