PDA

View Full Version : PowerLogix dipswitch problem?



Peter
01-25-2001, 02:27 PM
PowerLogix dipswitch problem?
I have been having some intermittint problems with my PowerCurve, which has a PowerLogix Z-force 266 cpu card. The problem is it won't start up--no bong, no video. Seemed to be getting more frequent. After leaving it on for a while to get warm it would, sometimes, start up if I restarted. If not, I'd open it, reseat the card, that would ususally to it. However, I recently noted that a couple of the dipswitches felt "mushy" instead of crisp (they don't seem to have real positive "click" to them), and I began to suspect they might be the culprit. So, I laid a piece of rubber band along between the switches, so the "on" switches are on one side, the "off" switches are on the other. It fits snug enough to exert just a tiny pressure on the switches, holding them more firmly on or off. So far, this seems to be working. My question is, has anyone had a similar problem? One note: I have not played with the switches much, probably only tried five to ten different settings, so I don't think I should have worn them out! As always, thanks for any assistance.

Note: I have posted this question on the PowerWatch message board also. Please forgive me if this violates any cross-posing protocals, I just want to get as wide a range of feedback on this as I can.

Louie
01-25-2001, 02:46 PM
No violation of anything; good question. I personally have not heard of the problem but I've often wondered about the durability of upgrade card dip switches. I tinker with mine a lot. I use exclusively XLR8. There are probably different qualities of switches. Maybe a deft soldering hand is needed to change switches.

kaye
01-25-2001, 02:48 PM
Peter,

I saw your post at PowerWatch, and no you are not violating cross posting protocol. It would be if you posted to more than one forum here or more than one forum on PowerWatch.

OK, that said, my first inclination would be to replace the PRAM battery. Some Macs/compatibles will not startup with a battery that is either flat or close to minimum voltage. Sometimes you can startup after leaving it on for awhile, as you did. The battery typically lasts for three years. A fresh battery will not hurt and is only about $10. A voltmeter test may tell you if it is flat, but bear in mind that a voltage check only tests for voltage under no-load conditions, so, while it may test OK, it may not work well under load if near minimum voltage to do a startup.

The mushiness of the dip switches, I think you have come up with a satisfactory temporary fix, but let's see if a battery solves it first. k

Peter
01-25-2001, 04:11 PM
Louie, Kaye,
Thanks for the prompt replies. I, too suspected the battery, but I put in a new one and no change. Also checked voltage, old and new batteries both good, albeit at no load. However, sticking in the rubberband DOES appear to have fixed it--it's just been a few days, so I'm still keeping my fingers crossed. It had gotten to the point where it failed to start almost every time, but now it has started every time since I put in the rubberband.

The dipswitch thing was a lucky shot in the dark (if in fact that is the problem), because the symptoms would not have lead me there logically. But, I recalled having tried another speed once and noticing the mushy switches--two or three of them feel very different from the others. I had boot problems when I was trying that, and that is why I quit fooling with different dipswitch settings and decided to leave well enough alone at 270 mHz. However, this no-boot problem began a couple months back as a rare occurance and then got progressively worse. I'm wondering if some other accounts I've read of mysterious PowerLogix problems might be dipswitch related. At any rate, rubberbands are cheap!

If it continues to work properly, I may pull the rubberband and see if the problem reappears. If so, I'll send it in for replacement, since I think it is still under warranty. I'm a decent hand with a soldering iron but hey, this is what warranties are for!

magician
01-25-2001, 07:17 PM
I would look at the pads for the switch on the daughtercard, too. You may just need to touch up the solder there a little bit, and it might save you from sending the board in to PowerLogix.

Peter
01-26-2001, 10:29 AM
True, cold solder joints can be a problem. However, if that isn't it I imagine I would likely have voided my warranty by messing with it. While I shudder at the thought of going back to a slower CPU for a couple weeks, it might be the more prudent course under the circumstances. Besides, it is the operation of the switches, that they are not clicking soundly into postion, rather than the attachment of the dipswitch module to the board that both is suspect and is remedied by the way I have threaded the rubber band through the switches. It isn't holding the module to the board, it is just laid along between the switches themselves. If I get a chance this weekend I'll post a picture of my fix so you can see it.

[This message has been edited by Peter (edited 26 January 2001).]

[This message has been edited by Peter (edited 26 January 2001).]

[This message has been edited by Peter (edited 26 January 2001).]

Peter
01-28-2001, 04:04 PM
--Sunday:
OK, here is a picture of my high-tech dipswitch repair:
http://albums.photopoint.com/j/View?u=1271524&a=11238379&p=39388032&Sequence=0&res=high

I talked to PowerLogix Friday, they said that dipswitch problems are not common, but not unknown either. They said they'd be glad to fix it, no problem, gave me an RMA number. By the way, I continue to have no startup problems since the rubber band fix, so I'm more convinced than ever that the dipswitches were in fact the problem.

magician
01-29-2001, 07:54 PM
damn.

good one!

http://macgurus.com/infopop/emoticons/icon_biggrin.gif