PDA

View Full Version : FileMaker Pro Server 5.0v2 crashes when backups



goliveira
01-25-2001, 11:50 AM
Here is my problem:

I upgraded the FileMaker Pro Server last week and runs fine but crashes when FileMaker Pro does a backup. It backs up to the raid FileMaker is running on (worked fine with 3.0). I have ordered another 9GB Cheetah to have as the backup drive but this issue is bothering me. The SEL light on the Granite Term stays solid with the TRM light. (Solid SEL means target is waiting for the next command from the Initiator, or the target is reconnecting and hanging the SCSI bus) Here are the specs:

Beige G3 Rev 1
466 MHz Xlr8 zif
256 MB PC-100
Initio Miles U2W (Firmware1.06)
Softraid 2.2.2
dual 9GB Cheetahs in Raid 1
Granite cable and terminator with remote led
in a Marathon rackmount case

The problem exibits itself under 9.1 and 9.0.4.
Tried cache write through in the Xlr8 control panel
disabled driver acceleration in Softraid
Disabled all 3rd party extensions and control panels

I have run the FileMaker Pro server on my B&W G3 (OS 9.1) with the Atto board and it backs up fine. The difference is, I am running two x15s but they are separate drives with Softraid drivers.

This leaves two posibilities, the firmware on the miles2 board, or the raid 1. Before I pull another 12 hour day, and have to take the Atto board out of my B&W, wondered what do you guys think. I will try the Atto board to rule out the firmware on the Miles2 and I will unstrip the drives to rule out the raid. FileMaker always had issues writing to a raid. 2.2 killed most of them. Really think that is the issue.

Thanks,
George

kaye
01-25-2001, 12:28 PM
George,

Yours is the first report I have seen of one Miles2 causing that wait or hang. And I would have recommended trying enable Write-through which you have already tried. Judging by what you have checked, I would point towards FileMaker also, but I am curious about the results of what you intend to try, the ATTO board to rule out the Miles2 firmware, and also unstripe the drives. k

magician
01-25-2001, 07:20 PM
I have had two similar reports, J, one from Jay the Unnicknamed, and one from an anonymous customer who called a few days ago. In the past, when Jay the U discussed this with Mark James, he had nothing for him. No idea. The fact that it runs ok on the other machine....that is interesting. That suggests it could be a subtle cable or terminator problem, OR a Miles2 problem. Supposedly, this is the sort of thing that SoftRAID was engineered to do, so .....it should work, or at least be understandable.

goliveira
01-25-2001, 08:42 PM
guys,

I setup both drives as individual drives and tried to backup to each. Experienced the crash both times. Darin suggested I reduce the speed of the zif which did nothing. Worth a shot.

The 9 GB Cheetah should be here next week. I'll bring in the Atto board to test the night I stay for the install. Funny how it worked fine with the Atto board and Softraid 2.2.2.

They are Granite cable and terminator. I'll test it with my personal set as well as the office set with the Atto board.

Thanks,
George

goliveira
01-25-2001, 09:21 PM
m,

can you ask Dan @ Initio and Mark James to take a look at this?

George

Louie
01-25-2001, 10:55 PM
g;

There is an obscure possibility to consider here; there are some that argue that the Rev A biege should not run that fast unless a Rev B ROM is installed. Those are getting real scarce. I happen to be hoarding a v4.5F1 module which I would loan you. I'd have to sort it out by installing several in my wife's machine. All subversions have the same Apple part number on the module.

goliveira
01-26-2001, 08:49 AM
Louie,

the machine ran @ 400 Mhz with FileMaker Pro Server 3.0. I installed an Xlr8 466 MHz zif when I did the upgrade to FileMaker 5. Turned down the zif to 400 MHz to test (Darin's idea), still had the crash.

This machine is running Rom Revision .40F2

Thanks for the offer,
George

Louie
01-26-2001, 03:49 PM
OK; just had a WAG. I just realized lately that the extra Rev B ROM is a very rare commodity.

goliveira
01-26-2001, 04:17 PM
Just installed the Atto dual channel U3LD and the backup works! Same cables, Mac OS 9.1 with Softraid 2.2.2 in a raid 1.

The Miles2 firmware is causing the problem.

George

Louie
01-26-2001, 05:17 PM
Magician:

Seems like Bob at Initio needs to know this while he still has Kaye's machine and bevy of X15's on the bench.

magician
01-26-2001, 06:18 PM
definitely. Can K mention it to him, since Bob has his machine on the bench? Jorge can send him the software, if necessary.

Louie, I would be willing to barter something to you for that ROM. Let me know.

http://macgurus.com/infopop/emoticons/icon_biggrin.gif

Louie
01-26-2001, 07:09 PM
I didn't know how scarce they were till someone quoted a $175 price wanted by some company for one. Let me think about what you have that I might want http://macgurus.com/infopop/emoticons/icon_biggrin.gif.

I don't have any FireWire device, but I had to remove the FireWire card to get the second Miles 2 in. I suppose the Voodoo card could go, since I never have time for games anymore because of the forum.

kaye
01-26-2001, 08:47 PM
I emailed George with all the data on Bob at Initio and with the go-ahead to reconfigure the PTP RAID to fit his situation, load software to his heart's content, but after Bob solves the problem that Louie/Ton/I have. k

magician
01-27-2001, 07:20 AM
thanks, K.

I'm sure that Jorge will want to buy you beer.

http://macgurus.com/infopop/emoticons/icon_biggrin.gif

Louie
01-27-2001, 04:09 PM
Let's see; George buys Kaye a beer, Kaye buys Bob a prostitute (or Darin - bad choice), Louie buys Bob and Kaye a________________? If he fixes it.

goliveira
01-27-2001, 04:39 PM
only a beer? Thought it was gonna cost me more.

Send Darin huh? Boy, what have I started.

I will install Macsbug on the FileMaker server to try to get the exact error if Macsbug can catch it.

g

magician
01-28-2001, 02:15 AM
ok.....who pulled my post?

Darin?

bad Cheetah!