PDA

View Full Version : USB PCI card problems



aricher
12-18-2000, 05:08 PM
Hi there - this sounds like a question for Kaye the PTP expert.

I recently installed a SIIG 2 port USB PCI-M card into my PowerTowerPro that was upgraded (thanks Gurus!) to an XLR8 G4 450 processor that has treated me like a star. I know I should have bought an XLR8 USB card from MacGurus but this card came with my scanner. My problem is the card is installed, shows up in the system profiler, but Apple's USB Card Support 1.4.1 software causes the system (9.0.4) to freeze on startup. I isolated the issue with Conflict Catcher and narrowed it down to one part of Apple's software - the "USB Device Extension." Anyone know what is going on or if there's a workaround?

Thanks,

Adam

kaye
12-20-2000, 10:41 AM
Adam,

Sorry, I missed your post and I don't have a USB card. This will put you at the top of the heap and hopefully more help will arrive.

I do recall someone with a very similar or the same problem with that init, USB Device Extension. Louie may know more about this as he is the real expert on Power machines. I think he is cutting his hands on rebuilding several Power boxes for relatives for Christmas. I asked him if I could be a relative and he listed all of the requirements. I met all but one. Anyway I will search for what I saw recently and get back. k

kaye
12-20-2000, 10:52 AM
Adam,

Will have to do a more thorough search later but the USB Device Extension itself is up to version 1.4.4. Do a Get Info of it and if you are running version 1.4.1 then get the update. If you already have 1.4.4, get back to us. It should be on our ftp site. k

aricher
12-20-2000, 02:28 PM
Kaye,
I tried to find USB Card Support 1.4.4 but it's only on the latest Mac OS CDs that ship with Dual Processors & Cubes - see below.

I found this info on the Apple site.
-For Power Macintosh systems with USB Built-in
G4 MP (and non-MP system) -USB 1.4.4
G4 Cube -USB 1.4.5

-For Power Macintosh systems without USB Built-in support, but with USB PCI Card installed, USB is installed as a standalone installer.
USB 1.4.1 installed via USB Adapter Card Support

I also found some info saying that by downgrading to USB Card Support 1.2 the card may work - I'm trying that right now and will let you know what happens. Another option may be to develop a driver with Mac OS USB DDK 1.4.1

I'll let you know what the solution is.

Adam

Well, I tried the USB Card Support 1.2 - no go - I get an "address error" bomb at startup and a freeze when I startup w/o extensions. Going quite mad now. Going to try a hack.

[This message has been edited by Adam (edited 20 December 2000).]

kaye
12-20-2000, 05:19 PM
What I saw was someone using Support 1.4.1 but USB Device Extension 1.4.4.

I have since found an Apple Developer page with a lot of info here http://devworld.apple.com/hardware/usb/versionusb.htm

Hope this helps. k