PDA

View Full Version : Installing from 7500 3.5" via router to QS 733?



rwm
04-06-2002, 01:57 PM
I have one old address/database program I woul d like to have on my new QS. It is on 1-2 3.5" disks but when I try to install over thwe network I get an error meggage... about my privilages"

Ideas - Thanks, Randy

ChrisYip
04-06-2002, 02:52 PM
Hi Randy - you're running OS X on the 733 right?. Then it's likely that your file sharing permissions aren't kosher on your 733...

Unless you log in as an administrator, you won't be able to install programs globally.

Can you not simply mount up the 7500 in your 733, copy the files over to your local user directory, and then install from there?. That should work. We've done there in our lab although it's set up so that users can only install apps into their own user directories and not for global use. That's not to say that they can't "chmod" the app to make it globally accessible

Chris

rwm
04-06-2002, 03:05 PM
No I have not yet got fully into OS X - doing this with OS 9.2.2 on the 733 and OS 9.1 on the 7500. OS X thats another thing I was working on - seems like everything is set right for networking and on a OS X startup it finds something at startup pauses and I get a message about a bad address... it's lookinng for the 7500. I did everything the Apple menu help had -

Thanks
Randy

ChrisYip
04-06-2002, 03:28 PM
Hmmm - Sounds like you're on the right track - i.e. there's some system preference for that app that is on the 7500 but not on your QS - that can happen with the "over the network" installation. Can you not simply copy all the files to your QS, and then run the install directly on that machine? Were you trying to install onto a MOUNTED network drive?

Chris

rwm
04-06-2002, 04:09 PM
Chris - What I was trying to do is go install from my 7500's 3.5" disk to a mounted drive/partition from the QS 733 thats on my 7500's desktop.

Am I thinking this right? I had error/problems related to ... installer access over AppleShare?? I have not tried in a while so my detail to the real specfics escape me now. If you think of something post it - please.

I will post better specfics by weekend. - Thanks, Randy

rwm
04-06-2002, 04:15 PM
Define - MOUNTED - if the HD icon is on my desktop from the other computer it is MOUNTED - right?

Randy

ChrisYip
04-06-2002, 04:40 PM
Hi

Yup - that's the problem - when the network drive is mounted onto your 7500's desktop, your installer thinks that it's physically on your 7500. This usually creates problems when the program is expecting a specific resource that has been installed in the machine's system folder. In your case, that resource would end up in the 7500's system folder and NOT on the 733's.. What you need to do is copy the ENTIRE installation stuff into a folder on your 733. Run the installation program on your 733, then the system resources end up in the right place - i.e on the 733's system folder.

Sometime's this isn't a problem but it depends on the program so it's always best to install the program on the actual machine you want to run it on.

Hope this helps

Chris

rwm
04-06-2002, 06:35 PM
YUP that was it. Thanks Chris - That was easy - I thought it was easier.

Any thinng special in OS X I need to do to use X and connect to the 7500 with OS 9.1.

Thanks again Randy

ChrisYip
04-06-2002, 09:03 PM
Hi Randy

Nope... As long as File Sharing is on on your 7500, your OS X machine should see it - either under the Local Neighbourhood or via AppleTalk under the Go / Connect To Server option in the Finder menu

Our OS X machines, two of which are behind a firewall and have DHCP private IP addresses, have no problem at all connecting to my ASIP server...

Glad things worked out

Chris.

rwm
04-06-2002, 09:17 PM
Chris - Just opened OS X again and heres the meggage I get...

"The AppleShare server you are trying to connect to appears not to support the IP protocol reqwuired by Maxc OS X.

Check with the server's administrator to see if a "Server IP Address" is available"

Mean anything to someone...............

Thanks
Randy

rwm
04-06-2002, 09:42 PM
OH YEA. Another one for Chris . Just do things right - This worked first time... "via AppleTalk under the Go / Connect To Server option in the Finder menu"

Thanks - fixed two things today.

Randy

ChrisYip
04-06-2002, 10:15 PM
<grin> - No problemo - glad it all worked out...

Chris

rwm
04-06-2002, 10:33 PM
Chris - But now this message still..........

"The AppleShare server you are trying to connect to appears not to support the IP protocol reqwuired by Maxc OS X.

Check with the server's administrator to see if a "Server IP Address" is available"

message still pops up - prompts me to click OK - How to disable it??

Randy

[This message has been edited by rwm2 (edited 07 April 2002).]

ChrisYip
04-07-2002, 12:09 AM
Is this via AppleTalk as well?. And you're routing via your Router using DHCP addressing administered by the router?.

It might be that your TCP/IP leases are running out and your machines get new IP addresses so you need to reinitialize the connection.

If this is the case, i.e. you can set up the network connection but then after about an hour or so, it disappears, then what you need to do is get into your router's set up and tell it to set your DHCP leases for some enormous amount of time.

Also - double check that on your 7500, that the TCP/IP control panel is set up so that the TCP/IP stack is ALWAYS loaded. You can find this in the control panel when you click on the Options button - You may need to set the User mode to Advanced (Command-U) into order to get in there. Be sure that TCP/IP is set to Active and that Load only when needed is not activated (that forces it to always be on)..

That might be what the problem is

(Oh - double check your AppleTalk setting just in case it's off)

Chris

ChrisYip
04-07-2002, 12:12 AM
Oh wait - I just reread your message - it might be that you somehow told your QS to always mount up the 7500's drive on boot. We always ran into this problem when the little check box that said "Mount on startup" was checked when people mounted up servers using the Chooser/AppleShare approach. Perhaps the same thing happened here?

Chris.

rwm
04-07-2002, 05:22 PM
Yes that makes sense - now where is that little box? I looked some - will keep looking. Working in OS 9.2.2

Randy

ChrisYip
04-07-2002, 05:28 PM
Hi

If you are using the Chooser to mount, then it's when you select which volume you want to connect to - there's a check-box there - Don't check it if you do NOT want it to be mounted in start-up.

As for OS X...not sure there is one for mounting on start-up unless it's in your .login file (at least that would be under Unix)

BTW- you could also try Go / Computer and then Network Neighbourhood to find all your AppleTalk and IP servers...

Chris

rwm
04-07-2002, 06:11 PM
At startup both computers have a screen pop-up with the "little AppleShare hand icon" and I can cancel or connect - is this how it should work?

Thanks, Randy

[This message has been edited by rwm2 (edited 07 April 2002).]

ChrisYip
04-07-2002, 07:10 PM
Yup - that's right - you must have checked off that 'Mount on Start-Up box" when you selected those network drives.

O.K. Here's how to clear that out

(1) unmount the shared network drives (drag to trash)
(2) open Chooser / AppleShare and select the network drive again
(3) UNCHECK that 'Mount on start-up" box
(4) mount the drive, logging in as usual
..

Now you should be fine

It's a less than intuitive thing

This way, you won't automatically mount the drive.. You can always cancel as well but it's a pain since it's a modal box and expects input at some point.

Chris

lasvegas
04-11-2002, 03:18 AM
A bit simpler process is to trash all of the aliases in the Servers folder in your System Folder. This is where automount drives are stored.

ChrisYip
04-11-2002, 06:57 AM
Opps - forgot about that one...our lab machines are set to usually automount our server drives, except that we now boot into OS X so I wasn't sure where those aliases were...

Chris