View Full Version : Acard strange shut down

06-14-2002, 07:30 PM
I have a Beige G3 300 Mhz, with an Acard Raid controller with two 60 GIG Barracudas attached. Whenever I shut down, sometimes the computer freezes, but most of the time, it just shuts down flat out with out the "it's now safe to turn off your computer message"

Am I doing damage to my data?


06-14-2002, 08:28 PM
HI Holly,

I think you should run Disk First Aid to see if you have a problem with your data. Better yet Disk Warrior if you have it. I am only concerned with the times your computer freezes. I would have to guess that you have a software conflict if you are frequently freezing on shutdown. Are you quitting out of all your programs before shutdown? Not that you should have to but if your computer will shutdown properly with all programs quit then at least you'd know where to start looking.

When you say "it's now safe to turn off your computer message" you are showing your PC experience. Macs have auto shutdown after all the housekeeping chores are done when you tell it to shutdown. Those housekeeping chores include closing out temporary files and storing to disk all the information currently in RAM. When you have a crash or do a hardware reboot those housekeeping chores do not get done, which is why you should run Disk Warrior when you're having that problem.

Normal shutdown sequence is:

Tell your computer via the menu bar command to shutdown.

The computer will quit all active programs and run all its housekeeping.

Power goes off. No warning panels should be expected.

Disk Warrior at: www.alsoft.com (http://www.alsoft.com)


[This message has been edited by ricks (edited 14 June 2002).]

Adam D
02-08-2003, 02:58 AM
To revive an old topic.......

I'm actually having a similar problem with a G3 266/DT system. I moved a Sonnet Tempo ATA133 PCI card (non-raid) from my G4/400 to the G3 system, and connected a single 30GB IBM 75GXP drive. It formatted fine and ran fine under OS 9.2.2, but has an issue when the computer is shut down. When "shut down" is selected, the system powers down fast (REALLY fast!).....you can hear the hard drive cut out in a little over a second. While this may seem like a good thing, the next time the computer is powered up the eternal "your computer was not shut down properly" message appears. Disk first aid runs the normal check, and then it's back to work. It almost seems like the G3 cuts power to the PCI bus (and hence the Sonnet card and drive) before it's finished shutting things down. It doesn't even sound like the drive has time to park itself (if this is supposed to happen.....I'm making a guess here). I've tried putting the card in each of the three PCI slots, tried connecting the drive to each of the card channels, with the same results. Even attempted to use a different drive (Western Digital 80GB Caviar JB).....same thing. Sound normal to you guys? The G3 is a ROM revision 3 that was overclocked to 292 MHZ/83MHZ bus. I set everything back to normal (266 MHZ/66MHZ bus) thinking that might be the problem, but no luck. For now the card is back in my G4/400 Sawtooth exhibiting it's normal problem of not allowing the system to sleep under OS 9.2.2 (works like a charm under 10.2.3, though). The cards firmware has been fully updated to current Sonnet releases. Any opinions would be more than welcomed! http://macgurus.com/infopop/emoticons/icon_smile.gif

02-22-2003, 02:12 AM

There is an issue with G4 "Sawtooth" and multi-channel cards (in Apple's sense). The power management of G4 under MacOs 9.x has an issue and it is unlikely, Apple will ever fix it. As you noticed everything works on "X". Sonnet does have a solution for this issue and it provides the workaround you need for MacOs 9.x and Sawtooth, but it is not on-line. You have to ask explicitly for firmware 4.x (4.0.2 or 4.5.2 if you running drives over 137 GB). Be aware that the boot path associated with a drive connected to Tempo with 3.x firmware vs. 4.x firmware is different. Therefore you should boot from internal drive before updating the firmware and re-booot immediately after the update (wihout using the "Startup Disk" in between!). After the re-boot you can change the boot path as much as you like and the PCI Power Manager should also work fine.

The 4.x firmware may also "cure" your problem with the G3 power-down, but I am not sure, since I cannot replicate it on my G3. I am curious, how it works out.