PDA

View Full Version : PC hard drive into a Mac clone...?



fakeguru
05-20-2002, 10:24 PM
Got a known-good 3.5GB Maxtor I pulled from an old PC. It's from the same era ('96-'97)as a PowerBase I'm working on.

Trying to replace the PowerBase's original busted hard drive with it, but the Maxtor isn't seen by any formatting utility on the bus.

Refresher: The PowerBase has only one IDE bus with only this one item one it, so I've tried the jumper either off (Single mode) or just in the storage position.

Some of the documentation for the drive suggested setting it to Master might work in a Single scenario, but that just prevents the computer from booting. Setting it to Cable Select doesn't help either.

I'm resigned to the fact this drive won't work on at least the Valkyrie motherboard, but don't know enough about IDE to know why. I've read several instances where new IDE drives can work in the old clones.

What would keep this one from working here? Again, I'm not expecting it on the desktop yet; I know I have to format it first and put a Mac HFS(+) driver on it.

It's a Maxtor model 83500A8. The PowerBase otherwise runs fine from a 9.1 CD. I can just go SCSI and chain it to the CDROM, but wanted to take advantage of the IDE bus. with some older (but bigger) PC drives I have. Any thoughts?

lasvegas
05-21-2002, 02:33 AM
The drive should work in Master mode. Have you tried booting the CD holding Command-Option-Shift-Delete?

Another thing you can try, takes a steady hand. Set the drive as Master. Remove the power plug from the drive. Leave the IDE cable connected. Startup the computer with the Mac OS CD in the CD drive. After the computer is in Finder, carefully plug the power connector into the drive. Once the drive has come up to speed, run the Drive Setup program in the CD's Utilities folder and format the drive. This should solve your problem if the drive is supported by Drive Setup.

fakeguru
05-21-2002, 01:17 PM
Thanks for the reply, and suggestion.

Booting from CD was never a problem -- I'd previously selected it in the Startup Control panel back when the original IDE drive was on its last legs and it has remembered it nicely.

Tried booting with no power to the drive, but IDE cable left in as you suggested with jumper set to Master. This did let the Mac ignore the IDE bus in order to boot from another device!

It then continued to ignore the IDE bus after power was applied to the drive. Rescanning with Drive Setup or FWB HD Toolkit 4 never found the drive on the bus, so they never had the opportunity to format it. Just for drill I also tried this method with other jumper configurations such as Slave (no jumper) and Cable Select with similar luck.

So it appears to be more than just an issue of my formatting utilities not being able to format it; the drive's interpretation of the IDE protocol seems different than the computer's.

I understand the SCSI protocol to be backwards and frontwards compatible. I presume there wasn't really any such claim for IDE?

trag
05-21-2002, 08:16 PM
It sounds like it should work, and it isn't working. Some of those older Maxtor drives absolutely need to be in "single" mode, not "master", in order to work when they're the only drive on the bus, but you tried that. I can think of two things, one that might help and the other that won't help, but might explain things.

First, you might see if you can get the specs on your drive model from Maxtor's web site (or did someone buy Maxtor?) and check to see if there are any other jumpers on the drive that might be set oddly. Is there a write-protect jumper for example, or something like that that could be causing your problem? This is a very long shot, but it should be fairly easy to download a sheet of jumper settings for the drive.

The second one is you might check some of the message boards at PowerWatch and see if anyone else has used this particular drive. There have always been a few IDE drive models that just didn't work right with Apple machines and clones. The 1.2 GB Western Digital IDE drive didn't work properly in the Q630 series, IIRC, e.g. So it may be that this Maxtor drive just doesn't with Apple machines for some archane reason. I'm not sure if PowerWatch is the best place to check for that info though. Hmm. You might also try a search on Mike's compatibility database at xlr8yourmac.com for that model of drive.

fakeguru
05-21-2002, 08:53 PM
Good suggestions, all. Over the next few days I'll poke around some more.

I have been to Maxtor's site and found jumper stuff for my drive. This is one such thing they show:
http://www.maxtor.com/products/DiamondMax/CrystalMax/QuickSpecs/42053.pdf

The only thing necessary for a Single install seems to be one jumper on the first set (Master), although somewhere else on their site I thought I read that you can use it in Single mode with no pins at all. I thought that was odd, considering no pins means this drive is in Slave mode (from somewhere else on their site.) I could be wrong about seeing that.

When it was in the PC (as the D:\ drive but on it's own bus) it had the jumper on the storage position.

I'm under the impression that Master and Single are done the same for this drive, and that Storage is different than Slave. I think I've tried them all, including Cable Select, but will give it one more go and check out the other resources you've mentioned. In my world of ancient Macs, a 3.5 GB drive, however slow, is nothing to sneeze at.