PDA

View Full Version : IDE recognized as SCSI!



paramongaia
05-16-2002, 05:12 PM
ok, here is the problem.
Have a beige G3 rev B G4/450Mhz upgrade running OSX
Installed a SIIG ATA/133 card and hooked up a 40 GB ultraATA/133 drive.
The drive shows up on the desktop.
System profiler indicates that the drive is on a SCSI bus !!
What gives?
Any suggestions would be appreciated.

Charles

ricks
05-16-2002, 07:34 PM
Charles,

That's how most IDE host cards for Macs work. Very few are true IDE cards. Even the drivers are SCSI on the drive. That means that a hard drive won't mount on the Siig if it was formatted on the internal bus without being re-initialized.

If you use OSX Drive Utility it actually installs both IDE and SCSI drivers and the drives will cross over from a host card to an internal bus. OSX Drive Utility is the only one that does that for you though.

Rick

paramongaia
05-16-2002, 09:00 PM
Thanks Rick.
I was going batty trying to figure out what the problem was.
Unfortunately I have been having a heck of a time trying to load OSX to the ATA drive attached to the SIIG card. The OSX CD does not recognize the drive attached to the SIIG ATA card. The drive is however seen on the desktop, I can partition it to a 5 GB and 35 GB but no dice regarding the OSX CD.
I am thinking about returning the SIIG card.

Thanks again
Charles

ricks
05-16-2002, 10:21 PM
Charles,

I doubt it's the card. You might try booting up on the OSX CD and then run Drive Utility off the CD to initialize your drive. I never had any trouble with my Siig and OSX, try the OSX utility and see if that solves it. OSX Drive Utility gave me the best results, speed wise, of any of the drivers I tried. Also Drive Utility is fairly robust, it will overwrite just about any other driver.

Installing OSX on a Beige G3 is always a challenge when there are PCI cards and added buses. Patience and a willingness to try again will usually do the trick.

Do you have a graphics card in a PCI slot? THat can be a sticky point also.

Rick

[This message has been edited by ricks (edited 16 May 2002).]

paramongaia
05-17-2002, 04:25 PM
Thanks ricks:
To reiterate, my goal is to boot OSX from the drive attached to the siig card.
Well, I tried your suggestion.
Booted of the OSX CD and disk utility does not see the ata drive attached to the siig card. It only sees the drive attached to the motherboard controler.
I disconnected the motherboard controller thinking that now the OSX cd would recognize the siig card. Unfortunately, it still does not see the drive attached to the siig card.
I also removed audio/video card but no dice.
The only way the siig card is active is when I boot OSX from the internal controller and use disk utility.
I am wondering now if the problem is with the G4/450 Mhz OWC zif upgrade. I may try removing it and replacing it with the original G3/300. Appart from that I am just about ready to give up on the beige G3.

wingman
05-18-2002, 05:51 AM
paramongaia,

Some thoughts.

1. What X CD do you have? If it's old enough, e.g. 10.0.0, then there's a real possibility that the X CD won't recognize the Siig -- probalby doesn't have the drivers. I've seen someone with a B/W have this problem with the Siig. The 10.1 update however could see HDs attached to card. In that case, Ricks' suggestion to move it back to the mb is what you may have to do to install if you have an old CD.

2. If you move it to the motherboard, remember that Beige G3s are subject to the 8GB rule. X must be fully contained within the first 8GB. That means making the first partition just a hair under 8GB (to be safe) or smaller, and then installing X on that partition. See http://docs.info.apple.com/article.html?artnum=106235

3. I'm not sure if the 8GB rule goes for HDs on attached to the card. It may since the problem is in the firmware of Beiges. I'm not positive on this however. But if the same goes for HDs on a card, then you're going to have to partition it.

4. If you do partition that HD, remember that partitioning wipes the entire HD, so backup everything.

--edited to fix the link

[This message has been edited by wingman (edited 18 May 2002).]

paramongaia
05-18-2002, 04:37 PM
Thanks wingman:
I think you may be right about the OSX CD, it is vintage 10.0.
I just got a hold of a newer version and will try it later this afternoon. I will post with the details as soon as I am done with the installation.

kind regards,
Charles

paramongaia
05-18-2002, 07:45 PM
Hi wingman.
Well, that did the trick. The new OSX10.1 CD recognized the SIIG card and I was able to load OSX on to it.
I also have a 29160N adaptec SCSI card and will try to see if it is also recognized.
I am most grateful for your helpfull sugestions.

Kind regards,
Charles

wingman
05-18-2002, 08:35 PM
paramongaia

Glad it worked out b/c I know you want to run X off the Siig.

Question: did you have to partition the HD on the Siig (with the first partition less than 8GB), or was it o.k. w/o partitioning?

paramongaia
05-18-2002, 09:57 PM
Hi wingman:
I had to partion the drive with one partition <8GB otherwise it could not be seen. Now I can boot of the SIIG card.
By the way I was able to load OSX into a 15K scsi drive running of the 29160N card but it would not boot. Adaptec has a note with the driver indicating that this is not possible in the beige G3, at least for the time being.
In any case your and ricks suggestions were very helpful in helping me out. This is a great forum because of people like you.
Thanks.
Charles