View Full Version : Sony CRX175A2 CDRW not burning

05-01-2002, 03:58 PM
Oh man,
I finally got the problem with the overlapping files straightened out. This is another step in my upgrade and I thought it best for a new thread. I am having a bear of a time getting this cd burner to work. And of course each manufacturer says that it's someone elses fault. And perhaps I was really stupid not getting a Plextor. (expletive deleted)!!!

OK, I installed a Sonnet ATA 100 Tempo card on my 7600. I also got an IDE drive from Maxtor and a Sony CRX175A2 CDRW. I don't expect any help from Sony as they are quite clearly not selling this drive to the Mac community. As I have gone IDE and Sonnet guarantees full atapi compliance, I thought I was in the clear. Now I am not so sure.

The Sony will read music CD's. I have even done some ripping and Mp3 creating through Toast (got the full version of Toast). At first it would not read data CD's. Then I updated the firmware in the Sonnet card and now the Sony will read a Mac disk.

I have inserted recordable and re writable media into the Sony but it sees the disk as not initialized and, it will not let me initialize the disk (disk is locked) So, What I really am saying is that I bought this CDRW drive that wont record. I also thought that in a pinch, although the Toast drivers should have done the trick, I could try and then buy Intech's CD SpeedTools drivers. But the Intech guy promised to shoot me an updated driver 2 days ago. Now Intech must be really busy because they haven't returned a call or an email in 2 days.

And software architects has a driver demo but it also won't work. With their driver installed I keep getting a freeze on startup when their driver is loaded. The Software architect tech person said that this Sony drive probably had to have it's firmware flashed but the link to it is pretty hard to find. And it would likely have to be done on a PC anyway.

Basically the softarc tech said that, as the Sonnet card essentially runs devices as SCCI the Sony burner would run fine in system X. Because in system X the bus would be recognized as IDE not SCCI. But I have 9.1 now (and no it didn't come with iTunes as someone suggested earlier).

So, I have really become frustrated in all this. Does anyone know of any solution to this problem? I would be sooooooo grateful.


05-02-2002, 12:25 AM
A couple of solutions. Go to Apple's iTunes site (http://www.apple.com/itunes/) and download/install iTunes. Also, you may want to install Apple's Disc Burner package (http://download.info.apple.com/Apple_Support_Area/Apple_Software_Updates/English-North_American/Macintosh/System/Other_System/Disc_Burner_1.0.1.smi.bin). If you've got a pre-G3 machine, this is a bit tricky to install, but it should work great with your Sony CD/RW.

05-02-2002, 06:58 AM
Thanks. I was wondering why someone suggested getting 9.1 and having iTunes. I thought it came with 9.1. I am not sure what happened. But I am both excited and embarrassed. Excited because the drive now works 100%. Embarrassed because maybe I just didn't understand how it was supposed to work? All the errors I was getting came from putting a recordable disk into the drive and seeing if it would mount to the desktop. I did not have Toast running when I was doing that, I just wanted to see if it would mount on the system's desktop.

As a final, last resort, just minutes before I was about to yank the drive and take it back to Comp USA and get a refund, I tried running Toast, throwing a couple of data folders into it and saving it to a disk. When it asked for a disk, I tried inserting the CD to record. And, it worked. Every time. No fancy drivers required. Just Toast and Apple.

I feel a bit foolish. I had no idea that putting in a blank recordable CD will not work. I guess it's similar to using a scanner. Well, not quite, you can still scan something with a scanner as a stand alone procedure. But if you want to have the image in Photoshop, you first have to open Photoshop and "acquire" the scan through a Photoshop menu.

Is this a quirk of this set up, that Toast must be running to use recordable media on my desktop? Or is this just normal behavior, and I am really so foolish as to try it otherwise?

http://macgurus.com/infopop/emoticons/icon_redface.gif http://macgurus.com/infopop/emoticons/icon_wink.gif Embarrassed but wanting to know. (Thanks for iTunes)


[This message has been edited by levelbest (edited 02 May 2002).]

05-03-2002, 02:39 AM
Is this a quirk of this set up, that Toast must be running to use recordable media on my desktop? Or is this just normal behavior, and I am really so foolish as to try it otherwise?

Actually, Apple's Disc Burner software enables just this feature! With Disc Burner installed, you can just slip in a blank disc and a Format window appears. Once mounted, you just drag what you want into the CD and then eject it (Drag to the trash). At that point you're asked to confirm that you want to burn the CD.

All of us made your mistake the first time we installed a CD-R or CD/RW. It's just human nature and the way it should intuitively work! I expect that's exactly why Apple made it work!

05-03-2002, 07:21 AM
SHeesh, live and learn. One last question before I jump this thread and start another, regarding video. Now the monitor doesn't come on at startup. I haven't given it a really long time so maybe it would come on eventually. So far it's a minor but annoying glitch that I work around by either zapping pram (don't like that option because it resets to my old SCCI drive) or just forcing a restart during the first restart. The second time it switches the monitor on right away.

I will have to do a a little archival research on my own posts here as I had some troubles with the drivers when I first installed my video card (old stock 9600 card). I may not have dragged enough video extensions over from 8.6 to 9.1.


05-03-2002, 08:55 PM
Your problem isn't the video card. I expect that you recently added a great deal of memory. There's a minor bug in the ROMs that cause the startup memory test to take an ungodly long time to test with a lot of memory. This test only occurs on a cold start. That's why a Reset solves your problem.

To correct the flaw, open your Memory control panel while holding Command and Option. Then turn off the Startup Memory test. It will never bother you again... Well, until you zap the PRAM again. http://macgurus.com/infopop/emoticons/icon_smile.gif

05-03-2002, 10:45 PM
WOW. http://www.macgurus.com/ubb/dance.gif Great tip. That did it all right. Thanks.

The only other question I can think of with the new burner is, how can I make it startup? It's SCCI ID is zero on bus 2. So holding down the shift option delete and number keys, without the specific drive location, isn't going to work. Neither will the C key work. And I have tried choosing the inserted disk as the boot disk and then restarting. No luck at all in that arena. Perhaps this is not a drive that can be used that way. But what the heck, others might know, or at least know other tricks?


05-04-2002, 12:10 AM
By the way, I was just fooling with disk burner, trying to see if I could install it. There is no disclaimer about it only working on new world Macs in the read me files. But, the installer says it can't install on my Mac. Is this a fluke or is it real? Is there a work around like installing 9.2 on this machine? As in, I have to change it's install code in hex and then it will install OK? Or have I just missed something obvious?


05-05-2002, 02:11 AM
The only way that you can boot from drive 0, SCSI bus 2 is to put a bootable CD in that drive and select it in the Startup Disk control panel. Command-Option-Shift-Delete would also work as long as there are no other bootable drives on SCSI busses 0 and 1.

I was able to install Apple's Disk Burner software in my PowerTower Pro (9500 clone) using GestLab (ftp://ftp.macgurus.com//ftp/old_mac_stuff/GestLab_1.2.2.sit) to temporarily set my Machine Type ('mach') to 510 - PowerMac G3 (The first compatible system). Once set the install went just fine. Note: I've tried this technique on other Oldworld Macs without success. While my Sony CDRW was compatible, few other SCSI drives are.

05-05-2002, 11:25 AM
Thanks. Never heard of that one, although I did read in XLR8yourmac archives that something similar can be done to get 9.2 to install in pre G3 macs (my 7600). I downloaded it and looked through it as best I could. But I would appreciate some guidance on this one. There is way too much info for me to guess at, and I shudder to think that I could mess up my Macs bios permanently? As I say, I am totally guessing here.

Specific only to seeing if I can do what you did to get disk burner to load and to recognize my Sony CDRW, can you give me some guidance on this one? Thanks.


05-05-2002, 02:50 PM
GestLab does not effect the computer's FlashROM (BIOS in PeeCee Talk), especially in your case since your computer uses ROMs that can't be modified. All it changes is the Gestalt Flags in RAM. To temporarily (Until the next restart) change your Machine Type to a Beige G3 using GestLab, follow these steps:

1) Launch GestLab.

2) Locate and select the 'mach' flag. This will have the description "Machine type"

3) Select Set Value of 'mach' from the Data menu.

4) Change the Dec.Value to 510. All other values will change to match the equivalent.

5) Click the Change button. Note that the Machine Type now shows as 510??PowerMac G3

6) Scroll all the way to the top and select the blue (denotes "Changed") Config Overview and note that your computer now identifies itself (Machine) as a PowerMac G3! This will remain until a restart sets it back into what is stored in the ROMs.

7) Quit GestLab and run the installer before restarting.

This is perfectly safe for installing the Disk Burner software. Worst case scenario is that it won't work with your particular drive. It won't render your System non-bootable.

Don't use this technique to install a Mac OS 9.2.x update unless you're prepared to boot from a CD and modify the System Suitcase with ResEdit or the like. While this technique will allow you to install the update, it will not be bootable on your Mac.

05-05-2002, 09:49 PM
It still didn't change anything. Same messages as before. But I thank you for introducing me to the gestalt stuff. Eventually I want to install X on this 7600 so it's all part of the learning curve.

Being a stubborn sort I did manage to open it's Tome with Tome Viewer. That got all the extensions, a new finder, and an application out of the Tome. Unless you can think of some place any of that stuff goes that I didn't think of. Most of it went to the extension folder. Except the Disk Burner App which is temporarily running from my desktop and the newer finder which has now replaced the 9.1 finder.

But that just invited me to insert a blank media, and then did nothing else. Didn't freeze, just did , nothing.

Unless I missed a piece of it, I guess that is it for disk burner on this mac.



PS - The Sony burner sits at SCCI 1 bus 2. I don't believe there is any way to actually configure the burner physically to another SCCI ID. Even though the Sonnet allows it to be seen by the system as a SCCI device, physically, the burner is still IDE. So jumpering it for another SCCI id seems unlikely. If it were possible, I would set it's id to 3 so I could use the "C" key on start up. Baring that, ANY SCCI ID other than 0 or 1 would allow me to call it specifically on start up. (Shift-command-delete-#key of the scci start up device)

Do you know if there is any chance in hell of changing the Sony's SCCI ID?

05-06-2002, 02:17 AM
It would do no good to change the SCSI address of the drive, even if it were possible. The 'C' key feature only works with SCSI Bus 0 (Your built-in internal SCSI connector).

So, after installing the Disk Burner software, you should get an Initialize dialog when you insert a blank CD. If all goes well, an empty image of the CD will appear on your desktop. Drop anything you want burned to the CD into the empty image. Arrange the contents as you want the final CD to appear. When your done, drag the image to the trash to burn the CD.

05-06-2002, 07:33 AM
No, same as before. Loading a blank disk will not even mount to the desk top.

I don't know if it is connected in some way, but I am experiencing an anomaly with my Mac. I have the F-Keys set to run macros from OneClick. But all of a sudden, they stopped working. I even rerecorded a simple launch procedure and assigned a key that should have given a warning as already assigned. But, nothing. My internal sound seems to have quit also. A speaker jack in the back will still run external audio fine. But the Mac is now silent with out external audio. Again, very recent.

I have tried rebuilding the directory from another startup disk with Disk Warrior, Rebuilding the desktop, zapping the pram. But I don't know what else to check or to try? I suppose getting the strange behavior might also be coloring the results of getting the disk burner software to mount.

One thing I don't understand though. The Disk Burner software is an application. So I put it on the desktop for testing. I don't understand how it is supposed to work? As you described it, I just drag my files onto the mounted disk icon and then drag the icon to the trash. When I have thereby unmounted it to the trash, it burns the disk. But how or when does disk burner work as an application?


Added - - I got the OneCLick back. A pallet was somehow tied up or corrupted. After deleteting the pallet with the shortcuts I was able to redo them. But I still am not suer if I have Disk Burner set up right, as I installed it myself. And I still don't know how to get my sound back?

[This message has been edited by levelbest (edited 06 May 2002).]

05-07-2002, 12:21 AM
Disk Burner will not necessarily work with non-apple products. It's a big plus when it does, but no surprise when it doesn't.

That said; There are two parts to the Disk Burner package. The extension portion works along with Authoring Support (including FireWire and USB Authoring Support) to work as I described before. The Application allows you use images previously and saved (rather than burned) to burn new CDs.