View Full Version : Stock CD-ROM no longer bootable?

02-15-2002, 03:15 PM
This is a cross-post from the repair/troubleshooting forum, but I wasn't getting any loving there so I thought I would bring my troubles here.

This problems starts about a month ago when I deleter Internet Explorer 5.1 from my new OS X partition. It didn't want to work with me, so I said "heck with it" and ditched it. Now it is a month later, and I'm finding myself having some troubles with Nestcape (aka I FRICKING HATE IT) and iCab just doen't cut it for some pages. So I decide to reinstall IE 5.1. This is where the fun starts. You can't download IE because it comes standard on the 10.1 CD, but I can't figure out how to install just IE without reinstalling OS X. So I decide to startup my computer off of the OS X CD to see if I can't figure it out from there.

I select the 10.1 CD as my start-up disk, hit restart and sit back. I get a happy mac "bong" or whatever its called, the mac stays dark for about 20 seconds (which is the norm) and then it clicks into a grey screen with a blinking cursor that I have never seen before. It then starts to print over and over "no bootable HFS partition found" until it decides to stop, and then it drops me into 9.2. I don't hear the CD-ROM spin-up, so I don't think it is actually reading the disk at all. When I get into 9.2, neither my CD-ROM drive nor my original 4gig HD are mounted, both of which reside on the same IDE chain. Nor do they show up in ASP.

I've tried doing a CUDA reset because I thought it might be because the CD-ROM changed places when I installed my new HD, but I think the real problem is that it doesn't even spin-up to read for OS 10.1. Also, when I restart my computer in X after getting dropped into 9.2 I could not eject my 10.1 CD with the "e" key (is that still a command with X?) nor could I force the computer to boot using the "c" key. Whats up?!?!?! I would really appreciate ya'lls help.

[added material]
I forgot to mention that I have been able to boot off of the stock HD that is attached to the same IDE chain as the CD-ROM, but only if I make it the start-up disk in 9.2, but it will not boot if I choose it in X]
[end added material]

Thanks in Advance

Apple Beige G3 233 All-in-One
IDE 1 --> 30 gig HD (2 gig partition for OS X / 2 gig for OS 9.2 / remainder is storage) set to master
IDE 2 --> 4 gig (master, also has OS 8.6 installed) --> stock CD-ROM (slave)
416 megs o' RAM
Rage2+ bumped to 6 megs VRAM (wheeeeeeeeee!)
Thats about it....

[This message has been edited by Diq (edited 15 February 2002).]

[This message has been edited by Diq (edited 15 February 2002).]

02-15-2002, 04:05 PM
Hi Diq,

I saw your earlier post and tried to figure out how to install IE without installing the entire OS. Never figured that out and I apologize for not getting back to you .

First thing, what does Apple system profiler say? Does it show your IDE devices? If it doesn't you have a hardware problem, cable,power,bus, whatever.

Check the ASP and let us know what 's up.


02-15-2002, 05:04 PM
in OS X and 9.2 the system profiler shows all three devices, 2 HDs and CD-ROM, as they should appear with both HDs as masters (unit 0) and the CD-ROM as a slave to the stock HD (unit 1). If I try to start the computer off of the CD and it fails and I end up in 9.2, Apple System Profiler does not see either the Stock HD or the CD-ROM. Would I be better off having the two HDs on the same ATA chain, and the CD_ROM on a seperate chain?


02-15-2002, 05:41 PM
Unlike SCSI, I have no idea what progressions the boot goes through to locate its system folder on an IDE bus computer. I bet it goes to bus1 device 0 first and then on up. CD would designate the master bus0 device.

The CD is on an ATA3 ATAPI bus and slower than grass grows. THe hard drive bus is at least ATA33, twice as fast (if one can properly use 'fast' when describing ATA33 buses)

If you have a choice, cabling wise, set up your 2 hard drives on the ATA33 hard drive bus.

This shouldn't effect the CD-Rom working as longas the other device on its bus in not also master configured. The end device should be master, the 'middle' device on the cable should be configured slave.

Hope that helps.


02-15-2002, 11:25 PM
I was just checking on xlr8yourmac.com and noticed a mention to the fact that OS X has to be on the master drive of any IDE chain to boot properly. Is this something you all have heard of, or complete hogwash? Thanks,