View Full Version : new IDE HD won't mount in beige G3

11-05-2001, 04:22 PM
I just installed a new HD in a beige G3 desktop.

I started with the new HD (Western Digital) on the CD-Rom bus, initialized it, moved everything from my old drive (Seagate Barracuda ATA), then moved WD to IDE1, jumpers set to master, but WD won't mount.

Apple System Profiler recognizes the WD as the correct make, model and capacity, but won't mount it.

I've tried Norton and DiskWarrior, but WD does not show up in the list of drives attached. WD does not show up in Apple Disk First Aid, but Apple Drive Setup shows it as available to be initialized.

Any ideas on how to get the drive mounted? Or on how I screwed this up?

When the machine is turned on, the WD spins up and nothing sounds amiss. Just unable to mount the volume.

Thanks, Todd

11-05-2001, 05:35 PM

In similar situation, just got a Beige G3 box w/o hard drive. Put in a new IBM 60GB GXP Deskstar and it won't boot up.

Hard drive works fine when in an external FireWire case hooked up to my 8500.

Seems very strange....

Wish I could be of help... I assume there's some compatibility issue going on here...


11-05-2001, 06:02 PM
I don't know if this is relevant.

I've been looking around for any anomalies that might help explain my problems.

Under Apple System Profiler, for "Active Enabler," it lists "None." That seems wrong.

The machine in question is running MacOS 9.1

All the other machines I've looked at in the office show an Enabler in use, thought they are running 8.1, 8.6 and 9.0.4 No other machines running 9.1, so if anybody can help on this questions, I'd appreciate it.

Thanks, Todd

11-05-2001, 07:55 PM
This is a shot in the dark, but try a PRAM reset: Cold boot, Command-Option-P-R on powerup, hold for three chimes. If that doesn't work, try a CUDA reset: power off, press the little button somewhere on the mobo near the battery for 10 sec, then restart. When you switched busses with the drive, it may not have changed the hardware config info that is held in PRAM. This will force PRAM to load your new config. This is an educated guess, 'cause I have much more experience with SCSI than IDE. This also assumes that all your jumper settings are correct and your cable and connections are solid.


P.S.: OS 9.1 doesn't need any enabler files.

[This message has been edited by MacMikester (edited 05 November 2001).]

11-05-2001, 10:06 PM
Thanks for the tips. I'll try them when I get to the office in the morning.

I'm fairly certain that I tried zapping the PRAM, as that and rebuilding the desktop are a morning preventative maintenance ritual, as well as the first thing I try whenever something starts acting flaky.

I'll do that first, just to be sure, as well as trying the other reset you suggested.

When I checked the other machines in the office, I found that some that run OS 9 have an enabler (9.0.4 on one machine, specifically), and another one didn't. Anyway, I was trying to cover all the bases I could think of.

Is there any information I left out that might be useful?



11-05-2001, 10:10 PM
BTW, are there any software utilities you can recommend for trying to mount the volume?

11-05-2001, 10:26 PM
Disk Doctor has a 'Show missing disks' command that will recognize some florfed SCSI disks but I don't know if it will work with IDE disks or whether it will help with your problem.

12-05-2001, 09:55 PM
I just installed a WD hard drive. After reading everything i could. The book that came with my beige G3 "Setting up your Power Mac" says the internal CD-ROM drive is set to function as the "master" device". I set the hard drive as slave and all seems to work well. (although I am still using my original hd to start up.

12-05-2001, 10:27 PM
I am pretty sure that the CD-Rom bus is going to initialize that disk different since it is a different specification bus. The CD-Rom is an ATA PI bus and the hard drive is a Ultra DMA/33 bus. These are different. Not the right way to do this.

Also, an earlier thread was about a ATA drive that was being used in a firewire enclosure, again, the drivers/initialization is totally different in the firewire device, you can't just switch them over.

One of the reasons that differing spec buses are not readable is that they write different block sizes. Totally incomprehensable to another bus.


12-06-2001, 04:21 AM
The drive wouldn't format any different from one IDE bus to another. It would run slower on the CD's bus simply because that is a slower bus. It would work though, as long as the drive is set as Slave and the CD drive as Master.

12-06-2001, 09:01 AM
I'm fairly certain it wouldn't be the formatting. This drive was formatted on the cd-rom bus and only ever used there.

I have found what appears to be a solution to this problem. Other users on the G3 mailing list from lowendmac.com have reported this problem.

The solution that has been reported is the zap the PRAM multiple times. One poster who successfully overcame this said at least five times, and another said no fewer than ten.

Unfortunately, I learned this too late to save myself, and it just didn't occur to me. Hopefully this will help someone else.

If anyone wants me to forward the list digest containing those messages, post as a reply here.