View Full Version : HELP! massive data loss

11-30-2001, 03:00 PM
here's the situation-

i am using a g4 dual 450 with an initio miles2 card and 2 18 gig cheetahs in a raid 0 (softraid) internal. i was using OS 9.1, and it was only installed on the IDE drive.

the 30 gig ide drive on my mac was giving me problems - norton told me there were bad blocks, and despite several attempts it couldn't seem to fix the problem. i installed a second 1 gig IDE drive, put OS 9.0.4 on it, and started up off of that so that i could work freely on the other drives with more than just the norton cd.

i decided to back up the data from my ide drive to my raid before doing any more work on it, so i dumped some of my video from the raid to mini-dv to make room, and began to copy data from the IDE drive to the raid. when it was almost finished copying, the computer froze. so i restarted with the button on the front of the case.

when the computer restarted, it told me that both my IDE drive and my raid were unreadable, and asked me if i wanted to initialize them. of course i chose not to do that.

the volumes do not show up in drive setup, nor do they show up in the system profiler (although i can see all of the disks).

i installed softraid on the 1 gig drive, and i can see the raid volume in there. when i try to mount it, however, it asks if i want to initialize it.

i would love any suggestions on solutions for getting all (or any) of my data back from either of the disks. basically my entire life's work is lost here.

other system specs in case they matter:

video: one 32mb agp card and one 16mb pci rage orion (i run two monitors).
scsi: aside from the miles2, there is a standard adaptec card installed that i use for my external devices (flatbed and slide scanners).
memory: 1 gig of RAM

thanks for any help or suggestions-


11-30-2001, 03:34 PM
This sounds like a job for....do do do do too do...Disk Warrior.

At times where the OS thinks the Volumes are unreadable, Disk Warrior is my most trusted solution. You can also try 'Show Hidden Drives' inside of Norton, although considering the importance of what you've mentioned, I would march on down to the nearest venue which has Disk Warrior, and buy it.

11-30-2001, 03:53 PM
Yeah, what he said. http://macgurus.com/infopop/emoticons/icon_biggrin.gif

Let me make sure of one thing first here- the data you're seeking to recover should be located on BOTH the original IDE drive AND the SCSI RAID, correct?

As far as the IDE drive is concerned, certainly yes, use Disk Warrior. Disk Warrior may even be able to see your RAID volumes and rebuild the directories for those, but I don't know. But I think it has a better chance of seeing your IDE drive and rebuilding that.

I have a situation here at my office, sounds similar to yours, that I haven't had time to fix for good. I've worked out a solution that usually lasts a few days until the machine (an iMac with OS9) crashes. The result is that the boot blocks are corrupted, I can't boot from the internal hard drive, and when I boot with the Norton CD I can't see the volume and it asks if I want to initialize the drive.

The solution I've kludged together I've termed "defibrillation". I only use the Norton CD to boot. Then I put a Zip disk in that contains the latest version of DiskWarrior. Disk Warrior can usually see the volume even though it's listed as not appearing on the Desktop. If not, I can start Norton Utilities and use it to search for missing disks, I think that's what it's called, then go back to Disk Warrior.

Disk Warrior is very good about repairing the boot blocks. This gets everything back up and running, at least until my iMac's next crash causes the problem again. (It doesn't happen every crash, but maybe every third or fourth).

Good luck. If DiskWarrior indeed does rescue your IDE drive, you're in a better position to work on your RAID volumes. And for more advice on that, I defer to the next moderator who knows more...

11-30-2001, 06:04 PM
Disk Warrior does an equally good job on a SCSI striped RAID. Great software. k

11-30-2001, 06:29 PM
thanks for the tips - disk warrior fixed them both.

i have a new favorite piece of software.