View Full Version : CD and HD on IDE in Beige G3

10-26-2001, 09:46 AM
Hi guys,

Just got a beige G3 300Mhz however I've been unable to get the CD and HD to work in harmony!! the CD will boot off an OS cd but when it boots off the HD It won't mount it. the audio CD player says the CD/DVD driver didn't load. I've tried all kinds of configurations on the IDE settings and still no joy! I'm running 9.1 and the G3 is has the 3D rage 2 + DVD chip on it. the other thing is I'm running the monitor off a radeon and it doesn't half take an age to get to the grey startup screen! I currently have master master on both drives. should it be master slave? and if so which drive is which? I have also tried cable enabled. but still no avail I know this has to be an easy one so please help!! they are both on seperate cables but I think they're on the same IDE bus? cheers in advance

10-26-2001, 04:41 PM
Have you tried booting the computer off of the Hard Drive, with a bootable CD in the CD Drive? Doing this should load the CD driver from the CD and mount it. If this works, your entire problem is with the CD driver in your hard drive's Extensions folder. Reinstalling the 9.1 update should correct this problem. If you've got a Zip drive in this computer, make sure that the Zip is set in Slave mode. The CD Drive should be in Master mode as should the Hard drive (Different ATA bus). I would normally set any Master drive to Master w/Slave mode if available.

You say the hard drive isn't mounting if the CD is booted? Are you booting using the Command-Option-Shift-Delete technique? If so, the driver of the hard drive may not be loading. Hold the 'C' key to boot the CD drive to allow the HD to mount as well.

10-26-2001, 04:47 PM
Is that the factory OEM CD drive? I don't know if ATAPI CD-rom drives had Apple roms in them or not. Some one else will have to answer that. In older macs you would need a third party driver to mount a non Apple CD unless you booted up the machine with a CD in the drive with a valid system folder on it. The boot process looks for drives with systems on them separate from the driver loading.

I carefully read the Apple developer notes for the G3 and for the first time couldn't find out whether the CD and the hard drive are Master/Slave on the same bus or 2 masters on separate buses. That info was easily found for all the other models http://macgurus.com/infopop/emoticons/icon_frown.gif So I am not sure how to answer that one. Again, someone else who knows Beige G3s can easily answer that.

How much ram do you have in the box? That can affect the startup times.

I will look some more. If in fact the ATA bus is singular then you would run the hard drive as master and the CD as slave.


10-26-2001, 04:52 PM
Whoops, posted right after LV, shoulda waited for the pro to get to this one.

10-27-2001, 06:40 AM
Hi guys,
I've finally got the machine working (well sort of!) The CD is set to slave and the HD to master. For some reason my computer doesn't always find the drive on startup. I presume due to the length of getting to the grey screen the HD has already spun back down. my monitor get 1 or 2 no signal screens before eventually going to grey. if I force restart ctrl + command + the poer button on the keyboard it reboots (long wait again) and finds the drives. it even does this on restart?? I'm maxed out with 256Mb pc 133's (perhaps why it takes so long)?

10-27-2001, 02:03 PM
256mb of ram shouldn't cause a long startup. I can't believe that the hard drive would spin down during that amount of time either. Something else is happening. When you do a forced reboot that should turn off the hardware check and get rid of the long startup before the screen comes on. You state it doesn't, again, something else is happening here.

Now, after having all the problems with not finding the system folders, would be a great time to reinstall 9.1. Next, check with the manufacturers of added peripherals to find out if they require a firmware update. Also check Apple in case your G3 needs a firmware update (this would include the ATI rage graphics). OS 9.1 is newr than the OS that came with your computer, sometimes firmware/rom updates can fix incompatabilities with the newer system and the older hardware.

The Hard Drive is on the IDE 0 bus and the CDROM is on the IDE 1 bus. This means they should each be master. They are on separate buses.

We'll keep after it, the time difference from you to California is pretty severe!


10-27-2001, 09:45 PM
Hi! Im new here...in fact I signed up because I was taken aback by your use of PC 133 DIMM in a beige G3. I have a beige G3 MT and was instructed to use PC 100 DIMM in my machine. Also, are you really "max'd out" at only 256MB?! I'm really surprised by that ... bummer! ;-) If you haven't upgraded your processor yet, do so. I put in a 333MHz Apple/Motorola chip (?) which at least brought my 266MHz machine into the 300s. BIG DIFFERENCE! At OWC, they sell these 333MHz for less than $65, and it is very easy to install yourself, esp with visual guides from OWC's tech page.

I've found that a slow start-up can be caused simply because of too many enabled extensions, but you probably have already thought about that! Thin out that Ext Folder by disabling any/all extensions you don't use all the time or won't ever use or need. With Ext Manager, create individualized sets for the different things you use your Mac to do: start with Mac OS x.x base set and build on that. Also, maybe try re-blessing your system folder and throwing out your Finder's Prefs. You might want to look for a little app that I think is called Startup Doubler (free, at ZDnet?). I used it for a little while and it did speed up the start-up process. The larger your hard drive, the longer its going to take your computer to do its checks before it will start-up. Lastly, try running a utility like CleanUp that can help you weed-out all non-native apps (FAT) you may still have on your drive. Check the age of some of your software - I personally don't like having stuff that's 4-5 years old on my computer: technology has advanced so far so fast that the older stuff has probably been incorporated or isn't needed anymore. But proceed with logic and caution on this one...
Hope something here works for you.

Good luck!

10-27-2001, 10:38 PM
PC133 memory will work in any machine that supports PC66, PC100 or PC133 memory. It's just faster memory. Since the G3's bus isn't any faster, the memory will still be limited to 100MHz, but the faster memory will still work fine at the lower speeds. Another benefit is that the memory will transfer to a newer machine if you upgrade.

The fact that the delay occurs before the screen initializes indicates something other than extensions. The hard drives aren't loaded until after the PCI cards are initialized. The fact that forced reset still causes the delay rules out the likelihood of memory being the issue since as ricks points out, a forced reset bypasses the memory test. About the only thing that hasn't been ruled out is the possibility of a bad PCI card or a flaky patch in OpenFirmware. PCI should be easy to rule out. Take them all out and try again. If the problem vanishes, try inserting one card at a time until it resurfaces. To clear OpenFirmware of all extranious code, press the CUDA switch for at least 30 seconds. This will completely clear the NvRAM (including PRAM) and force the computer to reinitialize all of its settings.

10-28-2001, 12:52 PM
umm just to clarify somethings....when I say maxed out with 256Mb PC133's I obviously mean plural! 768mb! I also failed to tell you the HD is a 60Gb IBM deskstar which I pulled out of my FW drive (needed a larger IDE than 4gb!) umm also a FW/USB card and a radeon(it's been suspect b4 I still don't think it's working properly) and I'm experimenting with an adaptec 39160 contoller. so yes I'd say maxed out.

10-28-2001, 04:26 PM
Right guys, here's an interesting one! I've removed all the pci cards and am now on the internal video of the G3 it's weird! I thought I'd seen pretty much them all but on startup the screen is black for a while and then goes white with the words "can't OPEN : "streaming across the screen. getting to the end of the third line it starts up.! Anyone got a clue? cause I don't!

10-28-2001, 05:13 PM
Why do I always forget the power of a NVram flush?!! thanks guys my system is so much happier now!

10-28-2001, 05:33 PM
Greentree: FYI, the white screen you were seeing on the internal video was the Open Firmware screen. It was executing a boot script, trying to find a specific boot sector. I'll bet that at some point you had run the Installer application on a Mac OS X CD only to have the computer restart and you never did the install. Without the CD present, the computer will search for it every time you start the computer until it completes the install, or the script is wiped out via a CUDA reset.

10-28-2001, 08:09 PM
yeah Las. I had a quick think about using OS X but then I decided I didn't have time so quit the install (it was a BETA CD anyway). amazing what can cause probs!

11-13-2001, 07:15 PM
To drag this one out from the dust. I'm Still having problems with my beige G3 I can't seem to get rid of the open firmware screen @ startup. I've tried cuda reset and 4 gongs and still no joy. can anyone help me?? I installed/ part installed OS X Beta version. I decided it prob wasn't worth it. due to it being a beta version. Anyone help me?? I can't even have a second HD with an OS on it (on scsi card) or it boots off it everytime no matter if I select the IDE as a startup. please help guys!!

11-14-2001, 12:32 AM
Hold Command-Option-O-F on startup to bring your computer to the Open Firmware screen. Type in the following:

??> set-defaults
??> reset-all

This should remove any and all patches, even those in protected memory. If this fails, remove the battery overnight followed by pressing the CUDA switch for 30 seconds. Resetting PRAM is not necessary after using the CUDA switch.