View Full Version : IDE drives and Blue and White G3

11-01-2001, 03:09 AM
My Blue and White G3 is pretty close to dead.
The system it had installed on it (8.6) was crapping out pretty consistently (lots of programs crashing and some hard freezes).

So I figure why not install System 9.1.

Not so easy. I start up from a 9.1 install disk. The computer starts up, I wipe the hard drive, and begin to install the system. Crash.

Now I have a computer with an empty hard drive. I can't get it to boot off a CD (and I've tried several). I actually did get it to boot a couple of times of CDs, and every time the system went into hard freeze before I could do much (I've been getting a lot of "bus errors" as well. Go figure.)

So the only possible solution I can think of is to pop another hard drive in one of the expansion bays (one that already has a system installed), boot off that drive, somehow install a system on the old drive, and (hopefully) have a working computer.

Now the IDE question: Assuming this is one the Blue and Whites that supports internal IDE drives, can I pop in an extra IDE drive that I salvaged out of a iMac (Rev. B)?

Is replacing the hard drive even a viable solution to this problem?
Is this computer as dead as it gets?

Please help!
(you can e-mail me at BarkinJ@ripon.edu), and I'll be checking this board.

11-01-2001, 03:25 AM
I'd say the first thing to solve is why you can't get it to boot consistently. Have you checked your battery? Did you use Drive Setup on the CD to Initialize your drive? Have you tried removing and reseating your PCI cards and memory? Have you tried pressing the CUDA switch for 30 seconds?

11-01-2001, 12:15 PM
I don't think this has to do with the hard drive. Or at least not just the hard drive. One can disconnect the hard drive and still boot from cd.

Things to try: (after lasvegas' points, battery,drive setup,cuda,card reseat.)

* Do a PRAM reset next reboot. (command+option+P+R until 3rd chime)
* Pull the first ram module and try booting without it. Pull the second and replace the first and so on...
* Has any hardware been changed from factory installed? Any PCI cards? Pull those and try booting without them.
* I suppose it's possible that something on the hard drive is corrupted enough to crash your startup, try disconnecting it.

Hope this helps.

11-02-2001, 12:54 PM
Thanks for all the suggestions.

Some questions:
1. What is (and where do I find) the CUDA switch?
2. The computer has only one RAM module, a 128mb simm. I have tried reseating it. The problems persisted.
3. I did run drive set-up on the hard drive. It's totally blank now.
4. How do I check the battery? I know how to replace the battery, but how do I check it?
5. The only PCI card on the computer is the video card. It' screwed firmly in place. I'll try reseating it, but I can't see that being the problem...

Rick, to answer your question, the computer (as I understand it) is as it was out of the box. There are no internal upgrades.

Thanks guys.

11-02-2001, 05:54 PM
OK, to start out with, the cuda reset is a small button on the motherboard just inward from the battery. There are 2 buttons on the B&W, the closest one to the battery is the reset, On my B&W this button is grey. (The other button, for purposes only known to hardware designers that Apple only lets out of their cages on february 29ths, is a power button that will start up your computer). Pushing the wrong button won't break anything. Hold that button down for 30 seconds with a pencil or similar.
I wouldn't bother much with the graphics card as the problem, video always worked and you haven't unplugged it at all.
All B&W G3s had IDE hard drives in them. This is built into the motherboard. Early (revisionA) B&W models had a problem in the IDE controller leading to data corruption on the hard drive, this was resolved with a new controller on the revisionB models. You can check which model you have by reading this page at XLR8YourMac: http://www.xlr8yourmac.com/G3-ZONE/yosemite/newfeatures.html
One of the easiest ways to tell which version is to look at the hard drive mount where your factory drive is and see if there mounting brackets above it to mount another drive. The revA model did not have the brackets. If you have a revisionA we will look into how to replace the IDE controller after you get the computer running.

The only way I check batteries is to run down to Radio Shack and buy one. 10 bucks or so.

So, first thing to do now is:
1: Do the cuda reset.
2: Try a restart off the CD. With a blank hard drive you shouldn't have to do anything special to get it to start off the CD.
3: Can't hurt to run PRAM resets however I think doing a cuda reset auto resets the prams anyway.
4: Rerun drive setup and initialize your drive again, then load your OS on it if you get to that point.

Let us know how that worked.

11-04-2001, 03:29 AM

I think you are having the same problem I am with my B+W rev1. It seems the IDE controller is likely to corrupt data on anything other than the stock ATA/66 drive. The newer ATA/100 drives are supposed to be backwards compatable, but it doesn't seems to be the case. Most people have told me to look in to SonnetTech's Tempo IDE controller.