PDA

View Full Version : Stalling IDE Drive



frisch
10-30-2001, 11:47 AM
I have a 19 GIG ATA drive in a Mac G3 that does some intensive drive reads in order to process jobs. Over the past few months the drive has taken to stalling--it evidentually reads the data just fine, but it stalls for up to a minute on a read and then picks up again sometimes only copying 20 megs of data and then stalling again. I thought at first it was a network problem but I don't have the issue with any other drive (the G3 also has a SCSI drive inside). Seems to write just fine--I only have the problem on reads.

Anyone else ever have this issue?

jorge
10-30-2001, 11:54 AM
you may want to backup the data, do a low level format and re-copy all your files back to the drive. That might solve it. If not, your drive might be on it's way to a slow death.

My DP 533 is doing the same thing with the stock 40GB IDE srive. Don't have money in my budget to get a SCSI drive now so I need to live with this thing.

George

frisch
10-31-2001, 11:42 AM
I tried that. I can't do a low level format using Drive Setup and I hesitate to use any other formatter. So I just did another initialize and tested the drive for bad blocks but go nothing. Is that an indication that something else is wrong?

kaye
10-31-2001, 04:18 PM
Can't/shouldn't low level format an IDE drive, just initialize. No bad blocks is good. I'm guessing that your directory was corrupted and your files fragmented so the drive had to do a long search to find all of the data to be read. DiskWarrior is a great utility for rebuilding and optimizing the directory. I use it as part of my monthly preventive maintenance. k