PDA

View Full Version : Dead ATA bus?



Sid
08-02-2001, 06:15 PM
Hi! I have a beige G3 266 DT ( I want to upgrade; I was hoping to see G4s faster than 500 MHz. If they are not coming anytime soon I may send a chack to macgurus for an XLR8 500).

Anyway....I bought it on ebay 6 months ago with 288 MB ram, 20 GB hard drive (IDE), internal ZIP drive (SCSI), CD-ROM (IDE). A week after I got it the hard drive crashed. I put it in another mac, formatted it and it worked for 3-4 weeks and crashed again. I finally trashed it and put in a 9.1GB SCSI hard drive. No problems since then. I upgraded the OS to 9.1. Last week I decided to see how the OSX looks. So I borrowed the CD, inserted it and booted the mac. The computer crashed. I could not restart it from either the CD drive or the hard drive. Luckily I have backed up the important stuff. I booted it from an external hard drive. But the CD drive is gone. It does not show up in the system profiler. When I insert a CD it blinks yellow light for a couple of seconds and goes off.

So did the OSX kill the hard drive and the CD drive? (I reinstalled everything on the hard drive and it works fine now). Is OSX incompatible with SCSI hard drive? Why was the IDE hard drive crashing repeatedly? Thanks for any input.

Sid
08-02-2001, 06:18 PM
Another thing.. Everytime I start the mac it says "No bootable HFS partition" or something like that.

dragon_x
08-02-2001, 09:17 PM
You could
See if the IDE/ATA drives work in another system
See if the IDE/ATA HD will work with a PCI cards - some of these cards work fine in X, I hear.
Get, beg or borrow an IDE/ATA CD drive and see if it works. Make sure it is Mac bootable.

It could be coincidence, but that is unlikely. You have two IDE/ATA buses on that system. It may only support one device per bus - and its ATA/3 (16MB/s) anyway - so getting a PCI card not only could solve your issue, but it should give you better performance - with a modern HD. A DVD or CD is not fast enough to use more than about 10MB/s - so that wont benifit and most PCI IDE/ATA cards do not support removables of any kind (although some can work to a degree).

These errors you are getting are strange. You probably need to flush the NVRAM too... X does strange things to beigeG3 systems - from what I hear. Hopefully 10.1 will address this.

GL

------------------
Life in the fast lane leads to:
The Resteraunt At The End Of The Universe

lasvegas
08-04-2001, 02:24 AM
Your message "No bootable HFS Partition" is the key here. That message is from OpenFirmware trying to boot OS X. If it failed booting the OS X CD, your CD could be out of calabration making it difficult for the OpenFirmware driver to locate the OS X partition.

The easiest way out of this situation is to hold the Option key as you start the computer. Failing that, Zap the NvRAM by holding Command-Option-P-R as you start the computer. It's unlikely booting the OS-X CD did anything to your SCSI drive unless you actually ran the installer requesting a reformat.