View Full Version : Problems booting from 75GXP

07-05-2001, 04:10 PM

I have a relatively new (bought in Feb. 2001) 45 GB 75GXP drive which is the
slave drive in a AGP G4 tower (the one with only 3 PCI slots). I have been
using the drive mainly for storage until recently. I purchased Mac OS X with
the intent of reformatting the stock Quantum 10 GB drive, create 2 partitions,
and put OS 9.1 on one partition and OS X on the other. Since I like to have
more than one bootable drive in my Mac (great for troubleshooting!), I decided
to install OS 9 on the 75GXP. Lo and behold, the G4 will not boot properly
into OS 9.0.4 or 9.1; I have to boot with extensions off then force-quit the
finder to get to the desktop. Of course, this won't do, but before I gave up
I installed OS X 9the original version). Of course, the G4 will boot into X;
moreover, the machine will launch OS 9.1 in Classic mode with no issues!

I have pulled the drive out to check the jumper settings (from both the label
and correspondence from IBM, I seem to have the right settings) and checked
the cable for damage and to see if it fits snugly. I would like to get the
Gurus opinion on my course of action:
1) Pull the Quantum drive and leave the 75GXP as master?
2) Swap drive positions (make the Quantum the slave drive)?
3) Return the 75 GXP to IBM for exchange?
4) Take the computer to a shop and pay someone to figure it out?

Item #1 would be O.K. for short term, but I'd really like to have 2 IDE drives
in my computer. I was planning on buying a second 75GXP or 60GXP later on,
but I'm on a budget right now. Item 2 also sounds appealing, but I can't find
the master/slave settings for my drive on the Maxtor web site, and I don't
want to screw up. I don't think #3 will work, since the drive seems to be
working. I have checked the G4 with both TechTool Pro 3 and DiskWarrior; no
major issues have ever been reported by either. Any help would be appreciated and Thanks In Advance!


07-10-2001, 03:21 PM
marc: since I have the same identical HD in my G3 266 desktop and it has been working great with 9.0.4, I am curious about your problem. Let me understand it:
1. The 75GXP is configured as slave on same bus, and has only
2. Your 10GB is partitioned, one with 9.1 and one with OSX.
3. You can boot from the either partition of the 10GB without any problems.
4. But when you tried to boot from the 45GB (slave), things go bad.

Is this correct? If so, I have two questions:
1. Does the 45GB have the 9.0.4 driver? It wasn't accidentally changed to 9.1 driver?
2. Do you purposely select the bootup drive in the start-up disk control panel?

When I carefully read the IBM/Apple instructions before installing my 75GXP, I understood that master/slave are mere designations requiring different jumper settings, but otherwise they behave in the same way. But I don't know if the two drives on same bus must have the same drivers. Perhaps an expert macguru can help you (and educate me as well).

07-10-2001, 04:04 PM

Actually I guess I wasn't clear - the 10 GB drive is a single partition
with OS 9.0.4 currently. At the time of the first post, the 75GXP was
partitioned into 4 units; one partition had a dual 9.1/OS X system, another
had a 9.1 alone, and a third had a duplicate of the 9.0.4 system from the
10 GB drive. Both 9.1 installs are vanilla 9.1 (direct from the 9.1 CD)
with no updates; the 9.0.4 has alot of 3rd party extensions. BTW, I found
the settings for the Quantum Fireball 10 GB drive for the jumpers.

As of this moment, the 10 GB drive is unchanged except it is now the slave
drive while the IBM 75 GXP is master. The IBM drive was re-initialized this
weekend (via the 9.0.4 CD that came with the G4), 9.0.4 was installed on
2 partitions and NO OS X. Now the 75 GXP will boot to the desktop but locks
up before the partitions are mounted. Both drives have the 9.0.4 drivers
and the IBM has plain 9.0.4. The only PCI card in the machine is a Radeon
in slot "A" I think (the one closest to the AGP slot); moving the card did
not seem to make a difference. I have not tried to remove the Radeon completely. The AGP video card is the ATi Rage 128 OEM card (I have a pre
Gigabit AGP system). I had a stock Zip 100 drive added to my system by the
reseller. I have also tried to remove the Quantum 10 GB and sole boot off the
IBM; same symptoms.

I have been told that some Apple models have "flaky" IDE controllers; I do know
about some of the earlier systems but I didn't think there were issues with any
Sawtooth G4s. I don't see an obvious way to disconnect the Zip drive (it looks
like the upper drive bays are enclosed) but that is an option. All of the RAM
is from the same vendor (the Chip Merchant). I have NOT installed the recent firmware "upgrade" from Apple (4.1.8?). Both drives pass the usual tests and
I try to keep my system clean of software I don't trust to be reliable.

Some things that pop into my head to try:
1) Restore the Apple RAM (I only have 64 MB though so life would be rough)
2) Talk to IBM and get a "new" 75 GXP; the one I have was made in October of 2000 and might be from a bad batch. I have heard complaints about the early 75GXPs at various sites (storagereview.com, deal-mac, etc . . .)
3) Buy a new drive from another vendor (Seagate maybe) or even get an Apple
30 GB drive from someone.
4) Pay someone to check the motherboard of the G4 - who knows?
5) Maybe I have a bad drive cable? I doubt it, since everything else seems to work fine.
6) Disable the Zip drive or at least check to see if the cable is seated.

Thanks for the reply, BTW - at least I have some new ideas.


07-10-2001, 05:03 PM
How about one more option, the simplest of them all?
Reinitialize and reformat the 75GXP and do NOT partition. In effect, the disk will have only one OS.
If that works, reboot from the your old HD (the slave now). If thing work, repeat the process several times.
Your old HD should also have only one OS (no partitions).
I have never tried to have two partitions on one disk, each having its own OS, and the disk being attached to the same bus which has yet another OS.
I don't think the ZIP is a problem, since it is on another bus. The RAM should be ok since it has worked before. I doubt if the PCI card has any effect here. Let me know how you are making out. I am dealing with an older Mac, and will be installing another IBM IDE, so would like to know how others are facing their problems.

07-10-2001, 05:54 PM

Doh! Why didn't I think of that? I'm just used to the pre HFS+ days
of partitioning drives so you'd save space . . . The only 2 reasons for not wanting to keep it that way would be for a dedicated Photoshop partition and I like the idea of having OS X all by its lonesome on a dedicated partition . . .
Its definitely a Good Idea - Thanks! I need to see the doctor today (bad back),
so I'll be doing this tomorrow - will post an update Wed. or Thursday . . .


07-10-2001, 11:05 PM

wow! me a Mac novice and already cooked up some reasonable advice? your answer made me
feel good. thanks.

when I get my OSX, it will be all by itself on its own separate disk, not merely on another partition.
I am eager to learn the results of your new configuration.

08-03-2001, 11:47 AM
Sorry for the long time between replies:

I have been talking with IBM about my issue; following the given advice so far has yielded no improvement. Yesterday I received a new (well, made in May 2001) 60 GXP and did the following. 1) Install in the G4 tower alone, not messing with the jumpers (it arrived as Master, which is how I intend to leave it); 2) Booted from the original 9.0.4 CD that shipped with the G4; 3) did a initialize with "write zeroes" option selected (BTW, this takes forever to finish - best to do overnight!); 4) did a standard install. On first boot, everything works - success! Or at least I thought so - being an idiot, I changed the desktop theme and rebooted. Now the computer hangs - ah, an issue with the Appearance control panel! So after some file deletion, extension conflict management and alot of cussing, I think I have the issue resolved. I think (I'd like to play around with the system more just to be sure) that there is a subtle conflict between the ATi stock extensions, the Appearance CP and the Radeon PCI card my monitor is connected to. I haven't rebooted many times yet, but I do get to the desktop and have control over windows, etc . . .
Now its time to throw in the older 75GXP and see if I can replicate the problem and solution . . . I may also check with the stock Rage 128 card to see if it is definitely a vido card issue. Hope this helps someone! Oh, BTW - thanks again to Marrand for all of the good advice - I just wished it had worked . . .


08-03-2001, 12:19 PM
I don't think you mentioned having tried the IBM drive by itself...

I've had problems with getting IBM's 70gxp to play well with other ide drives on the same channel. This was using a peecee mb's ide controller but even Apple's controllers have to be close enough to the peecee ide spec to support the 'generic' ide drives.

The 70gxp wanted nothing to do with a Western Digital Caviar. The WD failed to show in the BIOS device list at POST. Each worked fine as the ONLY drive on that channel. The IBM worked fine as the Slave with a Seagate Medalist Pro.

WD and Seagates get along together just fine. I haven't had a Quantum ide drive ever so I've not run across your specific combo. I've heard that the IBM drive can be a bit 'uppity' if you get my drift.

I don't know if IBM would admit to having issues with other brands of ide drives on the same channel..."its not our drive...its THEIR drive that is causing the problem"

08-03-2001, 01:02 PM

Thanks for pointing out trying the 75GXP all by itself; I did do that before I talked with IBM, but I wanted to re-try the drive following the IBM guy's advice. Also, if it is an extension conflict, I'd like to settle what the cause is before complicating the picture.

I have heard all kinds of stories on IBM drives from places such as www.storagereview.com; (http://www.storagereview.com;) the general consensus I get is that the 60GXP series seems to be a little less finicky than the 75GXP and the latter series had production issues. Unfortunately, I don't know if my drive is from one of those bad batches. Ideally, I want to have both the 75GXP and 60GXP as internal drives, I'd hope that IBM drives can get along with one another . . .

And yes, the IBM tech wasn't too keen on suggesting that the IBM drive was at fault, but was willing to give me an RMA if his advice didn't work. He suggested using the "zero all data" feature of Drive Setup when initializing as a single partition. He thought a bad bit wasn't being blocked out somewhere on the drive map partition (I think that's what it's called).

The only issues I have with the Quantum (which I plan on using in a Firewire external case) drive is size (way too small) and noise (lots of that). Its been very reliable, but I was sold on quiet and speed of the 75GXP series. Knowing what I know now, I might have bought Seagate drives instead!

Thanks for the points!