View Full Version : Mystery Driver!

05-14-2001, 01:58 PM
I have a 15gb Maxtor in my upgraded 6400/180. It has worked fine for the eight months I have had it. Problem is, it is not working at its potential speed. (Norton Bench: 298).
The driver listed in the System Profiler is 2.0a8.
I initialized the machine with my 8.5 CD and I am now running 8.6. But none of the Drive Setups I have tried will recognize this driver. I have the latest Hard Disk SpeedTools and it, too, cannot recognize the driver.
Is this driver from the OS8.5 alpha 8 version? If so, why is it on my CD? What can I do to update driver without the major nuisance of reformatting?
Any ideas will be very much appreciated.

05-14-2001, 03:04 PM
Are you saying that you initialized the drive with the version of Drive Setup that was on the OS 8.5 CD? If so, that was Drive Setup v1.6. If I remember, that one was a dog because Apple soon released a flurry of updates.

You can find versions 1.7.3, 1.9.2 ans 2.0.3 on our FTP site at ftp://ftp.macgurus.com//ftp/apple_stuff/ . Have you tried any of those?

When you use Drive Setup, it installs a certain driver version like 3.22 for ATA drives and 8.xx for SCSI drives. These later numbers are what you see from "get info".

I can't imagine that 1.7.3, 1.9.2, or 2.0.3 won't update your driver. Can't you just tell it to "Update Driver"?

You need at least 1.7.3 for OS 8.6. It installs v 3.22 ATA driver.

If you have Intech's HD SpeedTools 3.2 that is probably what you should use. I'm not sure if it can update the Apple driver or not because I've never tried it. I think it can "take over" the driver. There are ways around things like this, such as using FWB to erase the old driver leaving room for the new driver. Someone else could possibly talk you through it. I never use ATA drives.

You should be aware that the ATA controller on your machine is very old and slow. The single page, multipage and DMA modes must be set properly by the driver software if you use a modern UltraDMA HD. Otherwise, HD corruption will occur. SpeedTools can do this for you. I don't think Drive Setup can.

[This message has been edited by Louie (edited 14 May 2001).]

05-14-2001, 04:00 PM
Thanks for the reply Louie,

I've tried every Mac Drive Setup Utility I could get my hands on and none will recognize my driver. The GET INFO for the HD only says "Internal HD" in the WHERE section. I have tried TattleTech and a number of others and, somehow, the only driver for the HD that turns up is 2.0a8. One weirdness on the TattleTech report is that in the long list of volume attributes is says " System 7 desktop functions - Yes" Why system 7?
The driver reference on the TT report is:

Driver# = -54, Name - .ATADisk, Version # 2.0.0 Alpha 8, PPC Native -no, Category NA,
Service NA, Description NA, Type - Disk (disk drive), Interface - Unknown, Slot # NA,
Unit #53, Status - open, Location - ROM, Address $FFE7857E, Original flags Enabled - read, write, control, status, needtime, needlock, Current flags enabled - read, write, control, status, needlock.

HDST refuses to take over the driver. It says" Sorry, the partition map on this device does not conform to the Inside Mac v. 5 specifications. Your disk has not been touched."

It should be noted that a number of people I have compared notes with on the 6400 ZONE and TECHSURVIVORS sites have had almost the identical setup as mine and gotten THREE times the speed out of the Maxtor 15/7200 Drive.

It's all beyond me!

Thanks again, Rod

05-15-2001, 12:28 AM
I'm not sure what you mean, "Won't recognize my driver". When you run Drive Setup it should scan for all devices and list them (not the driver). Then you must click on one to highlight it. Then tell it to update the driver.

Are you telling me that Drive Setup says the drive (not the driver) is not recognized?? If so, I don't know what you should do. The drive must be bad.

05-15-2001, 07:56 AM
I would use HDT 4.5 or whatever to delete the driver partition, then I would reinitialize using HDST3.2.

that's just me.

05-15-2001, 06:15 PM
Or even FWB 3 and delete the driver and use Intech. But, I think he's saying that nothing recognizes the drive.