PDA

View Full Version : SCSI performance in the toilet



lcouri
06-26-2001, 12:01 AM
I have a ST3452ON Seagate MedalistPRo 9140 SCSI drive ... 7200 rpm, 4.55GB, 9ms seek, blah blah blah ........... it doesn't amount to beans ... it is the only device connected to an Adaptec 2930UW (from Apple store, pre-configured) and I get a whopping 3.1 MB/Sec !!!! this is while my 5400rpm, 80gig firewire IDE gets 23MB/sec!!! I have tried all combos of termination (I have the last plug on the cable into the drive, and I have enabled termination on the drive)what in tarnation is going on here? This drive is about 1.5 years old and is useless for digital recording unless it speeds up! I'm new (and loving it) to Mac so I'm wondering if you could suggest some options!?!?

Thanks much!
Lance

ChrisYip
06-26-2001, 12:11 AM
Question - isn't that a Narrow SCSI drive? i.e. it would not be able to take advantage of the UltraWide transfer rates possible on the card.?
http://www.seagate.com/support/disc/scsi/st34520n.html

If it is, then you are limited in terms of possible transfer rates...

This might help:
http://www.macgurus.com/graphics/mgwhyscsiadapters2.html

What machine are these drives in?.

Chris

lcouri
06-26-2001, 06:59 AM
Thanks Chris, I'm running this one SCSI drive on a G4 533 with 640MB RAM ... two IDE drives (the IBM I added)and nothing else remarkable. the spec sheet at seagate claims that this drive is 'SCSI 3-Ultra' and is capable of internal transfer rates of 14Mb/s, external 20MB/s sync. This sheet can be found:
http://www.seagate.com/support/disc/specs/scsi/st34520n.html

I must be missing something that is key here, I appreciate your input!
Thanks,
Lance

ChrisYip
06-26-2001, 08:16 AM
Hmmm - Check the settings in your card. I know that on my Initio Miles2 card, I can set the maximum speed for the transfer and perhaps that's been toggled down for some reason.

Chris

dragon_x
06-26-2001, 11:13 AM
OK - I think you mean 14MB/s for the internal transfer rate.

The Ultra3 spec could mean it is either Ultra Wide OR Ultra Narrow. Since it is set for a 20MB/s bus (I assume) this would mean its ultra narrow.
How are you measuring the speed?
What drivers are you using for the drives?
What kind of cables & termination do you have?
Is anything else on the SCSI bus?

If you have a SCSI-1, SCSI-2 or slower device you could be limting your max throughput to 5MB/s or less.

It is possible that so many errors are being generated as to really slow the drive down. Is the drive partitioned? If so you might want to try coping from one partition to another. I would think this should show the internal transfer rate.

I've heard that some older SCSI cards do not work so good on the new Macs. People have posted about the MilesU2W on the new G4/PC133 systems.... so maybe you need a firmware upgrade or something?

The only real advantage of old 50 pin SCSI is that they work great on the vintage PCI PMac SCSI buses. Normally SCSI drives will last (guarneteed) for 5 years or more.

I have two double height 9GB Cudas and two 1/3 height 18GB cudas running off my MilesBNote on a PTPro/9.1MacOS. It works great.

Your stock IDE/ATA drives would be much faster. RPM is not the only thing that determins data throughput. The newer IDE/ATA drives (and newser SCSI drives) will have a greater data density on the platter - so they do not need to turn as fast to push as much data. Newer Macs are built for IDE/ATA. They run it well. Normally you would want to run an Ultra160 setup with a new Mac, but of course this is expensive.


------------------
Life in the fast lane leads to:
The Resteraunt At The End Of The Universe.

MacMikester
06-26-2001, 05:37 PM
Hey Lance,

For some reason, either software settings in the control application or termination/cable problems, your card is restricting communication to to SCSI-1, asynchronous transfers (max 5 MB/s). You need to check settings in the control application and disable wide negotiation, if applicable. You also should have only one jumper HORIZONTALLY across the bottom two sets of TP (Termination Power) pins on the entire J2 block of the hard drive and ONE jumper on the TE (Termination Enable) pinset. No jumpers on the J6 block gives you SCSI ID#0, which is appropriate and simple.

Since you have a narrow 50-pin drive on a wide SCSI bus, you must be using a 50-pin to 68-pin adapter on the drive. If this is not quality merchandise, you are doomed to failure. If it is your intention to make this work, you may need to get a Granite Digital adapter with active termination to properly terminate the unused signal lines in the cable. Lastly, the cable must be checked for continuity across the pins at either end, if all else fails to bring success. You should be getting 16-18 MB/s transfer rates.

Regards

[This message has been edited by MacMikester (edited 29 June 2001).]

lcouri
06-27-2001, 08:52 AM
I took your suggestions, and still no improvement ... I downloaded a program called power domain user, from Seagate ... all it tells me is that the connection is 'Asynchronous' rather than the faster synchronous etc. So then I called Seagate ... they seem to think that with this controller card (max 20mb/s) and this drive (20mb/s) a performance of ~3MB/s is not remarkable.

Thanks for all of your help!

MacMikester
06-28-2001, 11:24 PM
If your drive termination settings are correct and your PowerDomain software settings are correct, then you have a problem with your adapter, you card or your cable. If the card has flashable firmware, I would reflash it or update it as appropriate. I would check your cable by checking continuity across the pins at each end. I vote for your adapter as the problem. If you want to believe that 3MB/s is not remarkable (i.e. OK) for your setup, I certainly don't have the credentials to convince you otherwise.