PDA

View Full Version : Screwy Netscape problems even after installing fresh 4.76



vickishome
06-03-2001, 03:45 PM
I have a feeling there is something wrong on my system. While I can't seem to find it and it doesn't seem to affect most of my applications, it is most definitely letting it be known while using Netscape. Here's what I have observed:

(1) When I get a drop down box, it will not allow me to scroll within the box. So if the box has more options than can be displayed on the screen, I cannot scroll up or down to see the remaining options.

(2) The drop down box also has a very strange look to the font. I am using the default font (Times 12). As I move my mouse up and down the options in the drop down box, the words within the box look as if there is a ghosting of other words behind it. Hard to describe.

(3) I post in another UBB forum, and for some reason, my posts are adding a random stray character at the end of the post. There is no rhyme or reason to what the character will be or when it will appear. We might get lucky and see it at the end of this post.

What I've done. I've tested everything I can think of. Here's my list:

Disk Warrier
Disk First Aid
Checked for viruses using new, freshly downloaded virus files (can't think of their name at the moment)
Ran Norton Disk Doctor
Optimized my drives
Ensured that I had plenty of extra unused disk space on my drives
Updated my HD drivers with Drive Setup 1.9.2
Rebuilt my desktop
COMPLETELY removed ALL files for Netscape (was using v4.6) and have installed a fresh new copy of v4.76 - entered all the setup data again except for copying over my bookmarks and mail folder.

What am I missing?

Here's what I'm running:
Beige MacG3
OS 8.1

The problems continue even if I use another font so I don't feel the font itself is the problem. I use Adobe Type Manager and it's not reporting any bad fonts.

I'm at a loss. Yet, these problems did not occur for years, and then, suddenly, one day, there they were. I cannot figure out what's gone wrong.

Help! http://www.macgurus.com/ubb/confused.gif

Let's see if my random character will appear. If so, it will be directly after the period in this sentence.

[This message has been edited by vickishome (edited 03 June 2001).]

vickishome
06-03-2001, 03:46 PM
No random character in that message. Kind of hard to demonstrate it when it's not consistent. http://macgurus.com/infopop/emoticons/icon_frown.gif

M.Brane
06-03-2001, 04:24 PM
Maybe a conflict between Netscape 4.7.6 & OS8.1? Any particular reason you haven't upgraded your OS? http://www.macgurus.com/ubb/confused.gif

vickishome
06-03-2001, 04:29 PM
It was happening with Netscape 4.6 (which I used for years before this started). I upgraded mainly because 4.76 is more stable (recommendation from the gurus).

I have not upgraded from 8.1 because doing so would create a major domino effect of having to upgrade both software and hardware. Since I have ran this system trouble free for so long, I should be able to continue running it without problems. I suspect I have a corrupted file somewhere - perhaps a system file? - but I can't seem to figure out what it might be and none of the diagnostic utilities seem to be able to find it either.

geotime
06-03-2001, 06:00 PM
Hi Vicki
There are a few problem-causers that seem reasonably well-known (based on some google searches that I've done on Netscape problems). I don't know if any of these will fix your problem(s), but could be useful in getting a better-behaved browser:

1. Netscape Talkback. This is one of those "automatic" applications that can cause freezes and conflicts. I usually trash this first. It's a folder inside the Netscape Folder.

2. Instant Messenger. Since I don't use it, I will usually dump this second (sometimes first because of the damned dropdown menu it intrudes into the system). Make sure to trash the extension, as well.

3. Adobe Type Reunion (NOT Type Manager). Type Reunion is reported as a conflict creator, but I've never had it (maybe you do?).

4. ObjectSupportLib. As I understand it, this is an obsolete resource that can cause problems. Do a FindFile search-you may have multiple occurrences of this (I had six or seven). I noticed no problems from deleting it (them). Anyone know anything more specific about this resource?

Also, make sure to increase Netscape's memory allocation to 25MB minimum. If you want to be careful, simply disable any extensions related to these rather than trashing them. I myself have deleted all these and have a very stable browser. Since you're using OS 8.1 and are having problems with the menubar, I'm suspecting that the version of IM included in 4.76 may not like something in OS 8.1.

These tips may or may not fix your problems, but they will give you a more stable browser, in general. I always liked 8.1, and I forget what caused me to upgrade (I think my current machine came with 8.5.1, and so I went from there--I'm currently using 9.0.4). But I think M.Brane is right in suspecting a basic conflict in using up-to-date apps with older OS--eventually you'll want to move up. OS 8.6 has a pretty good reputation, I think (though I didn't use it very long, myself).

HTH
geo

vickishome
06-03-2001, 06:16 PM
Hi Geo!

Thank you for your suggestions. Here's what I found:

1. Netscape Talkback - I had JUST removed it right before your message came through. Perhaps reading your mind? http://macgurus.com/infopop/emoticons/icon_wink.gif

2. Instant Messenger - anything with the initials AOL doesn't live long on my computer. Instant Messenger was already Instant Trash.

3. Adobe Type Reunion - I must have been told this before because it was already in my disabled extensions.

4. ObjectSupportLib - also in my disabled extensions.

I had forgotten to increase the memory for Netscape. I just did that. Thanks.

I know I will eventually need to upgrade my OS, but I have done my best to avoid upgrading to any software that has required that I run anything beyond OS 8.1. This is because I also do digital video editing and my old software and firewire card will not run on anything after 8.1. I'm looking at some heavy expenses to replace all of that. It will take a lot to get me to upgrade.

Besides, I did not make any major changes to my system to cause these problems. They just appeared one day. I suspect I had a crash that's damaged a file, but none of the diagnostic software can find it. I hate the thought of having to rebuild my system as it would take me months to get it all installed again. I have *73* extensions loading as it is. They all used to get along with each other, but now there's a bad apple somewhere, and I'm having one hell of a time finding it.

vickishome
06-03-2001, 06:22 PM
Whoa! Wait a minute!! The drop down box on THIS page is working fine!

The problem is with the UBB board I frequent!! Not my system!!

Geeeez, this makes me mad! I had never noticed this before (obviously). Apparently, if I go to the other UBB board, it does something to Netscape - and from that point forward, no matter what other website I go to, the problem continues.

This time I did not go to the other board first. Because I wanted to increase the memory for Netscape, I copied the url for this thread, and when I brought Netscape back up, I came to this page first. Now, all of a sudden, the drop down menu box at the bottom of this page WORKS CORRECTLY!

It is NOT my system. It is the UBB board I use! What a big waste of my time! http://www.macgurus.com/ubb/mad.gif

At least now the mystery is solved. Thanks for everyone's help! http://macgurus.com/infopop/emoticons/icon_smile.gif

vickishome
06-03-2001, 06:29 PM
I would like to ask for two favors, please.

(1) Could someone tell me what file allows you to click on a link in a text file (while holding down the control key) and have be automatically brought to that page in Netscape? When I switched to Netscape 4.76, I lost this ability. I must have removed a necessary file that Netscape did not reinstall.

(2) Could someone please go to this UBB board and tell me if the drop down box at the bottom of the page works correctly or not?
http://community.otwa.com/3/OpenTopic?q=Y&a=frm&s=386293084&f=200299906

Thank you! http://macgurus.com/infopop/emoticons/icon_smile.gif

tm311
06-03-2001, 06:46 PM
yes the drop down window works....

vickishome
06-03-2001, 06:50 PM
You were able to scroll through the options beyond what was displayed on the screen?

If so, then I DO have a problem. http://macgurus.com/infopop/emoticons/icon_frown.gif But what?!! http://www.macgurus.com/ubb/confused.gif

Just to be sure... you were talking about the option box at the bottom of the screen for the UBB board I posted a link to in my earlier message - right?

[This message has been edited by vickishome (edited 03 June 2001).]

geotime
06-03-2001, 07:11 PM
Yep. Works for me too. (NS 4.76, OS 9.0.4). I selected a link (Community) just to be sure.

vickishome
06-03-2001, 07:16 PM
Okay, thanks for checking for me. http://macgurus.com/infopop/emoticons/icon_smile.gif

I'm at a total loss now. I guess I'll try running with disabled extensions to see if I can get the problem to go away. If so, then I might be able to track down the offending file. This has been the must frustrating and time consuming problem I have had since having a Mac, and my first one was a Mac 512Ke! This has become worse than finding a needle in a haystack. I think I'd rather look for a needle at this point. http://macgurus.com/infopop/emoticons/icon_frown.gif

geotime
06-03-2001, 08:16 PM
well, you could make a duplicate extension set and disable everything except the ones you need for basic browsing and email. If you're stable with that, then you can add extensions to it until you find the culprit.

vickishome
06-03-2001, 08:22 PM
That's what I've been working on. I don't know which extensions are required for Netscape. I have Conflict Catcher, and using it, turned off everything except OS 8.1 All and two extensions that I believe Netscape needs (MSL RuntimePPC.DLL and MSL Runti mePPC++.DLL). The problem still occured.

So now I'm looking for a list of extensions that Netscape requires. If I can find that info, then I will try it with everything but the bare necessities. If nothing else, it will rule out a large number of extensions..

Edited to add: Guess what I just noticed. The drop down menu on THIS page is no longer working. WHY?!! http://www.macgurus.com/ubb/confused.gif

[This message has been edited by vickishome (edited 03 June 2001).]

vickishome
06-03-2001, 09:05 PM
Now the menu at the bottom is working again?!! http://www.macgurus.com/ubb/confused.gif http://www.macgurus.com/ubb/confused.gif http://www.macgurus.com/ubb/confused.gif

tm311
06-03-2001, 09:25 PM
as far as i know.....netscape does not require any extensions to work properly...do yourself a favor and try downloading a copy of Opera or Icab...whichever is smaller....and see if you can narrow the problem down to a netscape issue. The other thing to think about is "what are the requirements of Netscape 4.7. Could it be OS 8.6? Another thing to do is Load your 8.1 Disk...and copy the Finder to your HD and then replace your Finder with the fresh one...and before you hit restart open the System folder and drag it to the desktop and put it back.....you might just have a corrupted finder.

vickishome
06-03-2001, 11:56 PM
I checked the requirements for Netscape 4.77 (the version after the one I'm running). I meet the requirements with no problems. Please remember that the problem developed while I was running Netscape 4.6. I had been using it for years successfully, and the problem began. I upgraded only because I thought a Netscape file had become corrupted. That wasn't the case.

I replaced my Finder. Moved my System Folder back and forth.

The problem remains. http://macgurus.com/infopop/emoticons/icon_frown.gif

I'll try downloading one of the other browsers and see what I get.

And in all of this mess, I have screwed up something that prevents me from clicking on links in my email editor (MacSoup) and BBEdit's Preview option no longer works. I've lost the "hot links" ability somehow. I'm going backwards.

Let's not even think about the fact that my monitor died this week (using a spare right now), I have a spammer harvesting email addresses from my guestbook (will set bait for him when I finally get this mess cleaned up), and the tracking service I was using on my website has just up and died (I wanted to develop my own tracking anyway, but that's now on hold with this other problem).

This is not my week for computers. And it's not even Monday yet. http://macgurus.com/infopop/emoticons/icon_frown.gif http://macgurus.com/infopop/emoticons/icon_frown.gif http://macgurus.com/infopop/emoticons/icon_frown.gif

vickishome
06-04-2001, 12:18 AM
I actually made some progress. I got my "hot links" working again! I had to set my "helper app" in Internet Config. I haven't had to touch that since I got my G3, many years ago! Now MacSoup and BBEdit links are working.

I also fixed a problem I had not previously mentioned with the way webpages were loading. Plus, I replaced my system fonts with fresh copies and the "ghosting' appearance of the fonts in the drop down menus is gone.

Progress. Finally! It's about time! http://macgurus.com/infopop/emoticons/icon_smile.gif

Now if I could just figure out why the drop down menus don't work right. http://macgurus.com/infopop/emoticons/icon_frown.gif


[This message has been edited by vickishome (edited 04 June 2001).]

magician
06-04-2001, 04:00 PM
briefly reviewing this thread, one thing I did not notice is whether or not you nuked your preferences?

also....and i hate to mention it, but if you are missing some arcane system resource, the easiest and fastest way to get back up and running in a base config is to reinstall your MacOS.

vickishome
06-04-2001, 09:18 PM
Thinking... What if I tried this. I can initialize an external hard drive I have and load my OS and Netscape on it. I can then boot from it as my start up drive and see what happens. This would tell me without a doubt if the problem is something within my system folder. Think that would work?

Michael
06-06-2001, 04:02 PM
what did you finally do?

M

magician
06-09-2001, 02:44 AM
that would work.

vickishome
06-09-2001, 09:36 AM
I'm not ignoring you guys. My kids go to camp next week so I'm waiting to work on it then when I won't be disturbed every 2 seconds. Even if I do confirm that it's in my system, that won't tell me which of the files is the cause so I'll have a fair amount of work to do at that point. I'd prefer to mess with my system files when I can concentrate and not be disburbed. I'll let you know what I find.

I

vickishome
06-09-2001, 09:37 AM
BTW, the random character just appeared on my last message. Notice that stray "I" at the bottom of my message. I did not type that. So it's happening on this board too. Very strange!o

vickishome
06-09-2001, 09:38 AM
And it just happened again. The "o" after the ! at the end of that last message was added. I didn't type that either! What in the world could be causing that?!!

dookie
06-10-2001, 03:15 PM
yeah, I'm hoping it's not some vagary in my intensely hacked posting code.

dookie
06-10-2001, 03:16 PM
I'm mactheripper's alter ego, BTW. Not some lurker.

Louie
06-11-2001, 01:39 PM
Netscape uses no extensions. Some plug-in related stuff like MacroMedia Flash and Director add to you extensions. Try 4.77, the high security version; it's cool.

magician
06-11-2001, 05:48 PM
no problems w IE so far.

http://www.macgurus.com/ubb/jollyroger.gif

vickishome
06-12-2001, 02:59 PM
I feel very certain it's not your board. Remember, I'm having the same problems on another UBB board I use. I'm also having other problems that aren't related to either boards. Not only am I getting those strange characters on my posts, but there are two other things I've noticed.

When I view auctions on eBay, my own auctions included in which I have written the html code so I KNOW what's in the code (syntax checked with BBEdit), certain characters are not showing up correctly. For example, the codes for a hard space (&-nbsp;- without the dashes) change to a question mark whenever I revise an auction, even though I have not touched that part of the code. I've also noticed a large number of question marks and box characters in other auctions and websites. I've been on the internet long enough to know those characters are not normally there. While this may be explained by my choice of font (the font does not contain the characters), it does not explain why the characters change when I do things like revise my auctions. The code worked when I developed it. And then it changes when I revise it on eBay even when I have not changed that line of the code.

I have also noticed that both my old netscape (v4.6) and now this one (v4.76) both "redraw" certain webpages. What I see happening is the webpage will download using a different font than what I have specified in my Netscape and Internet Config preferences. Immediately after the page has downloaded, it reloads again, this time using the correct font. I thought I had fixed this when I loaded the fresh copy of Netscape 4.76 because it had stopped for awhile. But then it started back up again with no explanation.

Doesn't that sound like a font or system problem? The funny thing is it does not affect any of my other applications. They all work perfectly as they always have. So in that respect, it doesn't sound like a system or font problem. I'm using the same font in Netscape, Word and BBEdit, and it only messes up in Netscape. It sounds like a Netscape problem which is the very reason why I deleted everything on my hard drive related to Netscape and loaded a fresh copy, but that did not fix the problems.

I've ran into problems before, but this one tops the cake for being the most difficult one I've had to pin down. I hope to carve out some time to try a few things to see if I can narrow down the cause. I will let you guys know what I find.

Hmmm... I wonder if I'm going to get a random character on this message? If so, it will be directly after this arrow: --HERE-->

[This message has been edited by vickishome (edited 12 June 2001).]

MacMikester
06-12-2001, 10:37 PM
I admit that I don't have a clue really about your strange happenings. I think that I would at least check your fonts for corruption (maybe a bad offset in a font table or two could cause this weirdness). I use ATM Deluxe, which almost always finds some font problems anyway, so I'm not sure that it's capable of distinguishing real problems from little itty bitty ones. Others may have better advice on a good font utility.

mactheripper
06-12-2001, 10:42 PM
Did you check the Character Set your browser is using?

That can cause a lot of the problems you seem to be having, and it would appear across web sites of all kinds.

The setting would be in the preferences for Netscrape. Under View -->Character set -->

I use ISO-8859-1, not Mac, for this setting.

Louie
06-13-2001, 02:01 PM
My Netscape 4.77 Font pref is set for "Use Page-Specified Fonts including Dynamic Fonts".

vickishome
06-13-2001, 07:23 PM
mactheripper - I'm using the same character set as you're using: Western (ISO-8859-1).

Louie - I also have the same font preferences as you: use page-specified fonts, including Dynamic Fonts"

MacMikester - I'm thinking it's the fonts too, but wouldn't it then be logical for the font to exhibit the same abnormalities in other applications as well?

BTW, here's another symptom I forgot about. When I edit something online (an email form, a message in a forum, my AboutME page on eBay), I get spaces where they don't belong. They appear to be at the same interval each time (but I have not counted how many characters). They will break up a word. So, for example, if I were to go back to edit this message, when I click on the edit button and am presented with the box showing my previous message entry, the words will have a random space in them every so many characters (let's say around every 300 characters). I have seen this occur on multiple websites so it must be something on my end.

Weird, weird, weird. I hope to run some tests later tonight (very late). I'm open to any suggestions on what to look for.B

vickishome
06-13-2001, 07:26 PM
Well, there was a random "B" at the end of that message. Grrr!

I just had a thought. These problems are happening ONLY online, right? But they don't appear to be caused by Netscape. And it seems illogical for them to be caused by fonts.

What applications/utilities/system files are used when you're online? For example, I use PPP to connect to my ISP. I wonder if one of those files could be causing the problem. At least that would be a logical possibility!

So there's PPP, Internet Config, Netscape... what else??

Louie
06-13-2001, 10:11 PM
Open Transport; I doubt it. OS 8.1 is really long in the tooth, Vicky. You'd better be glad that it doesn't add a complete dirty word.

If you can see the "B" before you submit, it's got to be some funky thing with the UBB text editor and your machine. UBB is a little flakey in that area. I lose the cursor sometimes and have to click outside the writing box to get it back.

[This message has been edited by Louie (edited 13 June 2001).]

vickishome
06-13-2001, 11:50 PM
Louie, I cannot see the "B" before I hit submit. It is added, at random, somewhere between the moment I hit submit and when the message is displayed in the thread.

But it's not UBB. It can't be. I've had random characters on other websites. For example, on email forms. When sending email to someone using an online form, when I receive the carbon copy, sometimes there is a random character at the end of my message.

It has to be something on my computer.

I have some more work to finish up, and then I'll try to test out a few things. If I could just pinpoint which file is flaky. Or even narrow down the possibilities.

EGPoulin
06-14-2001, 07:34 AM
I quickly reviewed your post and didn't see any mention of you running an Anti-Virus. I've seen this kind of thing with a PC virus (but not on a mac, to be honest I've never had any kind of a virus on my Mac!) :-) Worth a shot. Do you have the newest norton or anything like that?

One of my friends actually wrote a PC virus that would add in a random character after EVERY 40 keystrokes.. talk about a pain of a virus!

~~~Eric~~~

vickishome
06-14-2001, 10:25 PM
I have and use Norton's AntiVirus (NAV). I have a subscription to get the new files. Last I tested, it said everything was clean. I could run it again just in case something new has cropped up in the last week and I got it before NAV could find it.

Oh, and NAV does not run in the background. I have that turned off. I run it manually.

a

vickishome
06-15-2001, 03:27 AM
I FOUND IT! http://macgurus.com/infopop/emoticons/icon_biggrin.gif

It is not my computer. It is the board I posted earlier. But more specifically, it is caused by Infopop's Open Topic boards. I have found a way to test this and confirm it. If anyone wants to read how it was found, it was discovered in this thread (http://community.otwa.com/3/OpenTopic?a=tpc&s=386293084&f=200299906&m=2152957901) (on the other board - non Mac friends helped me! http://macgurus.com/infopop/emoticons/icon_smile.gif ).

I was also able to find a thread on Infopop's boards in which another Mac user complained about the weird characters being left at the end of his posts. Look at the very last post in this thread (http://community.infopop.net/2/OpenTopic?q=Y&a=tpc&s=729094322&f=630091422&m=508098035). Also notice the same weird characters are showing up in posts by this user on the Infopop board.

I don't know much about any of this. I don't know if there is anything I can do to work around this problem or if the other board I frequent can do anything to their code to fix it for me. I keep reading that there may be an issue with Macs and XML. I have never heard of XML before so I'm clueless. Any gurus out there with any suggestions?

At least now I have narrowed down the cause of the problem. Now I have to see how I can work around it. If anyone has any ideas, I'd sure appreciate it.

magician
06-15-2001, 03:49 AM
this is definitely one for pimpdaddy paul.

http://macgurus.com/infopop/emoticons/icon_smile.gif



http://www.macgurus.com/ubb/batlogo.gif Batsignal invoked to pimpdaddy!

vickishome
06-15-2001, 12:43 PM
I now know very specifially what is causing the problem. mactheripper had the answer. It is the character set.

The default character set for Infopop's OpenTopic is UTF-8. This is what has been giving me hell all of this time. Once I go to the other board, my character set is changed (without my knowledge!), and every website I visit after that is messed up. This is why the problems kept coming and going. If I didn't visit the other board, my character set remained correct, and everything worked. But once the other board changed my character set, my problems would suddenly appear. I had no idea the board could change my character set like that.

There is an easy fix. All they have to do is change the board to use US-ASCII character set. This has been discussed and confirmed on Infopop's support boards.

I have made a very well documented request to the powers that be on the other board to change the board's character set. Unfortunately, I have not been impressed in the past with their technical expertise nor their willingness to correct errors (they are extremely slow and seem unable to comprehend certain problems) so I am not sure how well my request will be honored.

At least now I know what is happening. All that remains is to determine whether the other board will make the changes I need.

I will come back to post the final results of my request to have the character set changed and how that affects the problems I have been experiencing. But I would like to take this time to tell everyone at MacGurus how much I have appreciated their help and suggestions. You guys do a fabulous job here! I cannot thank you enough for the support you offer to the Macintosh community.

http://macgurus.com/infopop/emoticons/icon_smile.gif

Louie
06-15-2001, 12:49 PM
Can you change your character set? How?

vickishome
06-15-2001, 01:00 PM
Oh, sure, I can change it manually. Notice how my messages aren't showing the random characters anymore. That's because I'm using the menu choice and changing it every time I go to another website such as this one. But good golly, could you imagine having to do that on a constant, ongoing basis?! http://www.macgurus.com/ubb/eek.gif

Now I have great news!

The powers that be on the other board have already replied to my request and said they will change it. I am SOOOO HAPPY to hear this. It will be wonderful to have my online display working correctly again and to stop chasing my tail on the problems!

Oh, and more good news. Now that I'm not chasing down these problems, I can concentrate on getting a new monitor. Once I finally pick out the one I want, I will be coming here to get one of those German Video Cards you guys recommend. I will finally be a true, paying customer! You guys have earned it, and I will be very pleased to be a real customer finally.

http://macgurus.com/infopop/emoticons/icon_smile.gif

vickishome
06-15-2001, 01:38 PM
To my complete surprise and delight, the people on the other board responded in lightning fast time and have already made the change. Instantly, my problems have disappeared! That was all it took. Change the character set.

So now I can finally put this to rest. That one simple change has made all the difference in the world while I'm connected to the internet. Feels good to get this one fixed. http://macgurus.com/infopop/emoticons/icon_biggrin.gif

Thanks, again, gurus (and helpful members)! http://macgurus.com/infopop/emoticons/icon_biggrin.gif

Louie
06-15-2001, 09:29 PM
Vickie;

I guess I don't understand "character set". That something other than changing fonts I assume. Tell me how to do it. What menu choice?

vickishome
06-15-2001, 09:45 PM
Louie, with Netscape 4.76, I use the menu choice View : Character Set. Character Set is at the very bottom. Play around with it and see what happens. In fact, change it to Unicode (UTF-8) and you'll get to see what I've been looking at for months now.

My (very basic) understanding of the function of a character set is it is used to display different languages. For example, if we were in China, we would need the characters we type to be much different from English. So we would choose a character set that is prepared to display Chinese characters. But you also need a font that has Chinese characters in it to match. So when you are using a character set expecting to display Chinese characters, but you aren't using a font that matches, the display becomes very erratic. Does that make sense? Not very organized explanation, but that's the gist of it.

The best way I can explain what Unicode (UTF-8) is (I'm just learning this myself) is to suggest you look at these websites.
http://www.unicode.org/unicode/standard/WhatIsUnicode.html (UTF-8 is a Unicode character set)

Then check this out which explains why I was having so many problems with my fonts while online:
http://www.unicode.org/help/display_problems.html

Does this help?