PDA

View Full Version : B/W G3 won't boot



unclemac
04-20-2001, 01:35 PM
My B/W G3 350 hangs on startup, with just the destop (no drives, clock, etc.) visible.

It has a new install of 2 seagate cheetahs, with an ATTO UL3S card, and granite cable and terminator. After initializing and installing 9.0.4, the machine now hangs unless I start with the extensions off, then it boots and both drives are visible, and everything looks fine. . .

How can I have an extesion conflict with nothing but the OS loaded? I have tried to shut off every extension that I know I can live without; sometimes it booted and sometimes it did not. I checked the ATTO website, and reset the PRAM; now it will not boot unless the extensions are off. I have tried removing each drive from the SCSI chain, but it has no effect.

Previous to this it was running 8.6 on ATA drive fine. I had to update the firmware to install 9.0.4. The app I need to run will not run in 9.1. Is this a hardware issue????

Thanks Gurus!!

TZ
04-20-2001, 06:23 PM
Corrupt system file? restore from backup (disk copy image of system folder after clean insall). Move the entire Preferences folder out of System Folder. Give more memory to Control Strip and other small system app extensions & control panels.

Make sure it isn't trying to enable a network type connection. See what TCP's Option is set to.

You're using Softraid 2.2.2?

YOu should be able to create a mirror boot volume (800MB is fine). Which helps preserve the integrity of your files. Keep all the non-system on stripped volume(s).

I know that RAM even on B&W G3 and 3rd party Sonnet G4 and Sonnet Tempo ARE a problem it now seems. So it could be hardware.

Gregory

MacMikester
04-20-2001, 07:08 PM
As Gregory covers, try reinstalling just the core system files as a clean install. Then replace the System, Finder and System Resources files in the old system folder with the new ones. Trash the new System folder, rename the "Old System Folder" to "System Folder" , make sure the active system icon badge reappears and reboot. Empty Trash. In my experience, the 9.0.4 install sometimes corrupts the System File.

Regards

Louie
04-20-2001, 09:22 PM
It would help to know what you used to format the Cheetahs with. Do they have data on them? Are they striped or single disks? You are aware that you can't boot from a RAID on that machine, aren't you? Is the Disk Startup CP set properly?

magician
04-21-2001, 12:13 AM
I would revert back to stock config, just to get the machine back up and running.

then I would install the ATTO, alone, with no drives attached, and flash it with the latest firmware. This is a useful diagnostic measure. If it passes ok, then we need to talk about your cables and termination.

what else is attached to that machine? Have you reseated your SDRAM?

you may want to reseat your ZIF, too.....right Louie?

http://macgurus.com/infopop/emoticons/icon_wink.gif

Louie
04-21-2001, 12:03 PM
I have only found that reseating the ZIF was required if it had been changed or removed, but it wouldn't hurt to try it.

unclemac
05-16-2001, 08:34 PM
Thanks for the input, and sorry for the long delay. . .

Just to clarify, I performed multiple formats / clean installs (OS and Drive Setup from 9.0.4 CD) with the same results. I could not wait to troubleshoot any more, so I "borrowed" a G4 400 from an unsuspecting coworker and installed the SCSI setup. The G4 booted fine and has been great ever since.

I put the orginal ATA drive back int the B/W G3, still thinking that the problem was between the G3 and the SCSI setup. Everthing looked great - for 2 days. . . .

The G3 began to crash frequently, then would not boot reporting an extesnion conflict; on reboot with extensions off it reported a type -18 error with details that included "major problem" amd "cannot find the Finder". I ran DW 2.1 and it could not replace the directory, I ran it several more times but never completed.

As the data was backed up and the user had another machine available, I ran the hail mary TT 3.0.1(per Mac Gurus warning/advice); it froze up tight while trying to correct directory problems. After that the drive would no longer mount, and does not show up in Drive Setup. Tried in another mac and a PC, with no luck. I guess it is toast.

I was just reading another Gurus thread about directory problems on a Medea drive, and the description is too similar for comfort for what happened next.

Have to run I - will post the grand finally ASAP.

Thanks again for the help!

unclemac
05-17-2001, 07:17 PM
back to the saga-

I decided not to give the machine to a user and use it myself for a long while because of the strange symptoms. I installed a maxtor ATA drive that came out of a two week old G4 (replaced with another Mac Gurus SCSI Seagate/Granite setup!), initalized and installed from a brand new OS 9.1 CD. I copied data onto the drive and all was well.

After about a week of stable use, the G3 repeated its meltdown (type -18, "can't find the finder", etc.).

Just to recap - very similar symptoms with 2 different ATA drives (and different cables), a brand new ATTO/Cheetah/Granite setup, and yes I tried everything suggested including reseating and even changing the ram. The only thing I did not do were reseat the ZIF because it has not been messed with (and I have no experience doing it). Also, I did not flash the ATTO card, but as it has performed flawlessly in the G4 400, I have ruled that out.

Not being a real guru myself, I decided it was time for professional help. I took the G3 to my local Apple service center with the long, ugly story. I have always been happy with their service and knowledge. They had the machine for several days and could not find any hardware problems. They reformatted the drive (the same ATA maxtor) and reinstalled 9.1. I was disapointed that they did not find anything like a PCI bus problem or something. . .

The first thing I did was run disc first aid. It reported an error that it could not repair! The second thing I did was run DD 6 from a brand new disc. It reported major errors too numerous to count. Each time I ran DD, it would run through the first dozen or so major errors reporting they were fixed, and then it would report an internal error and ask me to run it again.

About the sixth time I ran it with the same result, I rebooted and drive would not mount. As I mentioned before, this sounds very similar to the problem jb reported in the Disc directory problems/SCSI thead even though I have no unusual hardware installed or connected.

Sorry to be so long winded, but this has been a really long and painfull experience that has me second and third guessing everything I thought I knew. Is there any way to save this machine? Have I missed somthing obvious?

Anyone want to buy a slightly used B/W G3 350 cheap???

Thanks in advance,
newbie

Louie
05-18-2001, 01:42 PM
The early B&Ws had lousy, slow, ATA controllers. Slapping a modern UlraDMA 66/100 drive in one with out properly seting the single page, multipage and DMA modes with a disk driver utility is leaving yourself open to HD corruption from timing issues. Intech's HD SpeedTools 3.2 can set those modes automatically (or manually) properly to avoid corruption.

unclemac
05-18-2001, 07:40 PM
Louie:

Thanks for the reply. As you can tell I am in over my head on this, but the ATA controller issue fits most of the symptoms. When you mention HD corruption, does that mean it is dead? The first ATA drive that died and now does not mount was the original to the best of my knowledge. . . Could installing the PCI SCSI setup (assuming I did somthing wrong) have caused some damage to any hardware that then caused the ATA drive to become corrupted, or do you think these things are not related?

If I use Speedtools, will a new ATA drive still be at risk because of the controller issue you mentioned? If so, then I am assuming I need to find the right drive for this machine. Any drawbacks to Speedtools (Is there any machine/system/hardware that you would recommend that I NOT use it on ? I never seen or heard of it before.

Should my loacal Apple service center known about this problem?

Thanks again! (how do you guys know all this stuff!?) :-D

newbie

Louie
05-19-2001, 01:44 PM
As Magician stated earlier, take the machine back to the original configuration ( remove the ATTO and SCSI drives) and software.

Now the goal is to get the ATA drive working properly. Unless the ATA drive is phyically damaged, you should be able to reformat it.

Dowmload Intech's HD SpeedTools and let it reformat the drive. (If it can't see the drive, try Apple's Drive Setup. If Drive Setup can see it, do a low level initialization. Now, Intech should see it). Read carefully Intech's instructions, especially the discussion about B&W ATA controllers).

http://www.macgurus.com/shoppingcart/showrampage.cgi?intechsoftware.html

Reinstall your OS and run Intech's "Integrity" tests as prescribed.

Once the ATA drive is cool, it will be time to reinstall the ATTO, etc.

The whole idea is to keep it simple. Divide and conquer.

[This message has been edited by Louie (edited 19 May 2001).]

Louie
05-19-2001, 01:56 PM
If the current ATA drive is bad, check this compatibility survey from users http://forums.xlr8yourmac.com/drivedb/search.drivedb.lasso . The Intech driver should take care of the timing mismatch problems between your controller and modern drives.

unclemac
05-20-2001, 01:58 AM
Sorry for the confusion. Let me clarify:

мя The G3 ran fine with original ATA drive on OS 8.6.

мя I removed the orignal ATA drive and replaced it with new Macgurus SCSI setup, intilized with Drive Setup and installed OS 9.0.4. I did not use SoftRAID (I think Gregory assumed that I did ). :-(

мя The SCSI setup was not booting correctly, so I removed it and installed it in a G4 400. The SCSI setup is running fine in the G4.

My last three posts refer to AFTER I had removed the SCSI set up. No Cheetahs, no ATTO; just one ATA drive. I hope this clears up the order of events. I should have replied earlier to some of the advice/questions that were not relevant. You guys are diagnosing problems I have not even had yet! That's what I call service.

I will check out the links It seems like it is time for me to experience Speed tools. Thanks again for your continued support. I am sure I speak for many users when I say that your services are invaluable.

magician
05-20-2001, 03:24 AM
absolutely read the Intech manual carefully. If you do so, you will be able to configure your drive correctly.

unclemac
05-21-2001, 10:16 AM
I will be ordering Speedtools today, and will let you all know how it goes.

Thanks again!

unclemac
06-07-2001, 01:16 PM
Just a follow up -

I played with the DMA settings with Speedtools and everthing has been great. I have run DW 2.1 and DD6.0 repetedly, and neither have reported anything out of the ordinary!

I have been using the machine myself for weeks now without a single freeze or crash!

One last question for my continuing education: Although all is well, I looked (per guru advice) for a detailed explaination of the DMA setting choices, but did not find any with the included downloaded info from Intech.

Some good stuff to be sure, but I did not find any info that explained or suggested what settings should work with what drives. . . did I just miss it? Any ideas where I might learn more about this DMA stuff? I submitted a tech support request to Intech, but no relpy yet.

Thanks Gurus!

[This message has been edited by newbie (edited 07 June 2001).]

magician
06-09-2001, 02:41 AM
hi....did you use Intech's tech support form? If not, you will want to do so to get a reply from them.

i thought that info was in the manual included with the sw?

ok. Just checked. It took me a few minutes, but I found the section in the manual that discusses those settings in Chapter 4.

http://macgurus.com/infopop/emoticons/icon_wink.gif

Louie
06-11-2001, 02:12 PM
I'd like to hear answers to the same questions. I've only gotten involved once with this this "crappy Apple ATA controller/UltraDMA drive" issue; my wife's beige G3. Apparently, the early B&W's are a worse case, followed by the biege G3. It seems that Intech's SpeedTools can deal with the mismatch quite well automatically. It also allows you to manually set Single Page, MultiPage and DMA modes, however, I've not seen any guidelines. Maybe it's a trial and error thing. The automatic setting worked well for me, but I'd like to hear Chris from InTech expound.

My gut feel is that there are lots of older G3's out there with UltraDMA/66/100 drives that are experiencing HD corruption and don't know it or don't know why.

Glad yours is doing well.

magician
06-11-2001, 05:44 PM
L, would you like me to invite Chris to drop by, or were you able to learn what you needed from chapter 4 of the HDST manual?

let me know, either way.

thanks.

unclemac
06-11-2001, 05:53 PM
I have to agree with Louie. I am not a guru (yet!), but I picked the brain of a half dozen people that have at least as much experience as I do, as well as the local Apple service center, and nobody had a clue about the ATA controller issue. So how would joe average user ever find out? As everyone can see, I spent alot of time and effort tryiing to fix a SCSI problem that did not exist.

If not for the Gurus knowledge and products (and xclr8yourmac.com), this G3 might now be the coolest doorstop in all central california!

I have not had time to follow up on magician's last post yet, but I did not see enough info the first time through the InTech documentation, and I thought I looked closely. . .if the info is there it sure doesn't jump out and grab you.

So far it has been trial and error for me. Everthing is great, but why?

Oh yeah, I did use the InTech tech support form, but still no response. I guess I will try again incase it was user error.

[This message has been edited by newbie (edited 11 June 2001).]

Louie
06-11-2001, 06:26 PM
I'd like Chris to give us at least a summary. His software did a commendable job automatically, and gives you the abilty to set the modes manually and go to the "Safe Mode" (dead slow). However, I feel we need a feel as how to set the modes for troublesome combos: ie. Beige w/ UltraDMA 66 or 100, B&W w/UltraDMA 66 or 100. etc.

The User's Guide gives no details about what numbers to try manually. For me, it was was a grope (trial and error).

[This message has been edited by Louie (edited 11 June 2001).]

magician
06-15-2001, 03:38 AM
ok.

I will invite him.

cpkarr
06-15-2001, 12:26 PM
Hi Guys.

As a primer I've read all the posts in this thread and re-read the relevant sections in Ch.4 and Ch. 7. While I'm still satisfied with our doc, I know this stuff can be difficult to grasp. It was for me, too.

Anyway, I don't know of any hard and fast rules on Biege & Blue & Whites etc. because the Mac's built-in ATA controller is only half of the equation: the other half is the drive. Unfortunately, as bad as some of the Mac ATA chips have been, many drives are far worse. Worse still, a manufacturer will often fix the bug and keep the same part number.

This is what makes hard and fast rules impossible. We have no knowledge of potential problems with the DRIVE. You just have to keep reducing until the drive starts working reliably, even if this means all DMA has been turned off.

Chris Karr
Intech Software Corp

Louie
06-15-2001, 12:43 PM
Thanks Chris:

So it's trial and error for the experts also. That's the first time that I've seen the drives faulted.

I wonder how many people out there with Beige and B&W's have slapped whatever bargain ATA drive from Best Buy into their machines are getting HD corruption and haven't discovered it yet?

Can any other driver besides yours deal with it?

cpkarr
06-15-2001, 01:16 PM
Yep, it's trial and error for us, too. Regarding the drives being faulted, that's not something we like to publish in our manuals since our software is actually being distributed by two manufacturers right now.

As for your "Best Buy" scenario, it sends chills down my spine. I don't know how the average guy deals with stuff like this. It's all very complex and all he cares about is trying to get his work done, not troubleshoot hardware/firmware/software combos. Computers still have a long way to go before they become "appliances."

As for your last question, we're the only game in town for 100% compatibility. The only other software that tries to address this problem is FWB (I think), but their options are far more limited than ours.

Chris

Louie
06-15-2001, 09:37 PM
Well, I'm glad to hear you confirm that last thought because that's what I've been implying to all since I got into ATA drives and your HD SpeedTools with my wife's machine a while back. Up till then I was all SCSI.

I read about all these folks with Macs, slow controllers, ATA 100 drives, and corruption. Nobody talks about SpeedTools but me that I've seen.