PDA

View Full Version : SCSI & OS X



Rem
04-02-2001, 05:45 PM
Ok so I've been through all the fun up upgrading to os x. I think I have a do not show hardrive button check somewhere and cant find it. I have a miles u2w card and a cheetah 9 gig hd. All cables, drives, and cards were brought to me via the Gurus http://macgurus.com/infopop/emoticons/icon_smile.gif All was good with my B&W g3 till osx. I have the hd plugged into the last space on the chain (futhest from the card) as the instructions indicate. I have the built in terminator on the internal cable, and since i have no external devices I have the card termination set to on for both high and low. I have tried it with auto as well, but to no avail. What am I missing? They said osx was picky about termination, but geez. Or is there afirmware update that i missed?

Dogstarman
04-02-2001, 06:22 PM
Well, OSX is more than picky about SCSI. It is downright not supported generally. Initio is hard at work on drivers (so they say). Here is what their site says:

"Initio does not support beta software and this includes the Public Beta of OS X. We are working on drivers for the final release of OS X and will have them available at about the time of the Apple release of OS X next year.¬?

You can safely install the Public Beta of OS X on your IDE drives and use it now, however you will not be able to access your devices on our SCSI adapters until we have support available.

Initio will continue to be responsive and oriented to our Macintosh customers' needs on this issue and all others. We will have complete support for all three of our Macintosh products under OS X when OS X is released early in 2001."

Louie
04-02-2001, 07:30 PM
It has been written for months that the initial release of OS X will only support SCSI cards sold by the Apple. Same for CD/DVD, video, etc.

Rem
04-02-2001, 08:04 PM
As far as I know I have the public release, not the beta version. (dosesnt have a "b" in the version number.) I hadn't read on apple's page that scsi wasnt going to be supported...too bad. I'm not sure why my scsi is so much faster than my ata but they know more about it than I do. Thanks for the chat. And I'll keep bugging initio.

TZ
04-13-2001, 04:56 PM
i bought one of the Apple OEM 2940U2B's just to get OS X up ($89 is great deal and worth every penny). OS X doesn't recognize the mirrored boot volume or stripped, but I had space on my three drives for some plain HFS+ for 9.1, Classic, and OS X partitions.

Trouble is only Disk Utility 1.0 (DFA 10.0) works. The version of DFA from 9.1 freezes and I hve to force quit. Same for Disk Warrior (2.1). Ouch!

However, SoftRAID makes the best driver, even in on non-RAID volumes.

I LIKE that OS X won't touch (damage, mess up, ) my files on RAID. it modifies everything it touches.

Apple has a real habit (history) of making changes up until last minute - no different this time - which can mean some/most of your hard work on writiing drivers may or may not work or be supported. And could change the rules of the game. So don't feel bad - Apple is in a catch-22 that no one will promise or have their product ready, and Apple really needs to insure that there will be products available on launch date. aka "§eta II" or "early adopters" which basically happens in any business: never implement a new OS until it has had months of testing, a service pack or two, and field testing in the organization on their LAN etc.

Trouble with the Installer app, Disk First Aid and Drive Setup as well. You can do everything right and run into deep dodo.

Gregory

bobw
04-15-2001, 07:25 PM
The 2940 is an Adaptec card. one of the ones they say they won't be updating the drivers for OS X. I have an Adaptec 2930 that works with OS X and Adaptec is updating the drivers for that card and several others.

TZ
04-15-2001, 07:49 PM
Yes the Apple card is Adaptec OEM - and as long as it either has the 1.2 firmware or OS X will update the firmware on the card when you go to install, the card works fine. Apple supports their OEM cards, not Adaptec. Which is why I bought one - two months ago when there was some inventory available.

Right now I am getting 75MB/s peak & sustained read; 41MB/s write peak & sustained.

As for OS X - installs 103,640 files. Then Dev Tools. Then update. Then my files (50,000) so in the end it now takes Disk Warrior (2.1) nearly a full hour to make one pass at the OS X volume (8GB out of 16GB ).

Gregory

Rem
04-16-2001, 06:51 PM
Thanks fellas,
I dont think im gonna drop more cash to down grade for a flashy interface...i think im gonna keep running os 9.1 when i need to acess my scsi drive...kind of a pain....but I dont feel like blowing 90 bucks for something that initio should be coming out with in the near futer

Rem
05-02-2001, 08:16 PM
Oh hey,
those nifty folks over at initio have some beta drivers up for their scsi cards. Seem to be working just fine! have at em.