PDA

View Full Version : Raid0 Partitioning



SteveL
03-02-2001, 11:19 PM
What is the general thinking on the ideal partition size when setting up a Raid0 array consisting of two drives? Do the partition sizes affect performance? If a third X15 were to be added to the array, would this affect the approach to partitioning? Primary use is FCP and Photoshop.

G4 Sawtooth
Miles 2 card
Two X15's
SoftRaid 2.2
OS 9.1

Thanks!

kaye
03-03-2001, 12:15 PM
S,

You have hit on an area where there are a lot of different thoughts on this subject. magician does not partition. I do, particularly a small partition for a system folder on the striped RAID (vintage Mac), but I don't use FCP, so someone who does can better answer your question there, and I don't do Photoshop for a living. Not much help.

I am curious about your Sawtooth and Miles2 with two striped X15s. Have you ever benchmarked that setup? Miles2 may be saturated with two X15s, just wondering what you are getting now, before adding a third X15. k

SteveL
03-03-2001, 12:57 PM
K,

Thanks for the reply. I haven't done any benchmarking as of yet - I'm still putting the parts together. However, I should point out that may BIG plan is to migrate the Miles2 board to a G3 and put an ATTO in the Sawtooth, which, I gather, should be a better match to the X15's. I'll already have the Granite cabling, termination and SoftRaid. So much hardware, so little cash!

SteveL
03-03-2001, 01:16 PM
On a somewhat different note, having installed the Bluenote card into the same box (G4) and using the external pin adapter, I can't get the external Zip drive to mount. And, the Iomega driver (v6.0.7) will not load. I have done the recommended firmware update to the Bluenote. The Zip is the only drive on the chain and is terminated, the SCSI id is 5 (the BN id is the default 7).

I remain,
Blue about the Bluenote

MacMikester
03-03-2001, 01:20 PM
I am not a Guru, but I follow Kaye's thinking in partitioning. One small factor to consider for ultimate speed is that partitions are assigned to the disk platters in the order in which they are created. The first partions are physically located on the outer tracks of the platter which benefit from faster transfer rates compared to the inner tracks. In a RAID 0, the striped partion is on the outer tracks of both (or all) disks. You can bench mark volumes on the first and last partitions and see real differences. So, your fastest partition will be your first partition. For heavy PhotoShop use, for example, you may want the first partition to be your scratch partion.

Regards

On the BlueNote,

As always, double check termination and cabling. The Zip may not be a Fast-20 device and unable to sync with the BlueNote at 20 MHz. Try setting the BlueNote to sync at 10 MHz.

[This message has been edited by MacMikester (edited 03 March 2001).]

SteveL
03-03-2001, 01:47 PM
Thanks for the partition primer, Mikester. On the Bluenote, I have it set to 10MHz.

Louie
03-03-2001, 02:07 PM
I use several BlueNotes but have never used the external connector. Initio recommends turning the synch rate down to 10. I would consider turning it down to 5 for the Zip. THe BlueNote has a much better reputation than Zip's and I would be much more suspicious of the Zip.

You want the Zip set to draw termination power from the SCSI bus.

It shouldn't matter, but try the BlueNote in a different slot. It's not a bus master card.

Are you using the included external adapter from Initio? I have several of them and they all look a little different but cheap. That could be a problem, but should be OK at low synch rates

I'm using Iomega 6.06 for an internal Zip 100 and OS 9.04. It works well. I seem to remember reading a comment on MacFixIt that the Iomega driver that comes with OS 9.1 does not work as well as some other version. I'll try to find the comment. Is the Zip a 100 or 250?

[This message has been edited by Louie (edited 03 March 2001).]

Louie
03-03-2001, 02:31 PM
There is a report on MacFixIt that the Iomega drive that installs with OS 9.1 is a problem child. The recommendation is to download and use Iomega 2.8. Get it here http://www.iomega.com/datahandler/servlet/dataprocess/driverlist?database=steerdown .

kaye
03-03-2001, 02:39 PM
S,

After you get this other stuff straightened out, I sure would like to know how the Miles2 and X15s perform on Sawtooth. k

jorge
03-03-2001, 03:23 PM
guys,

the Miles2 in new world machines maxes out at 40 Mb write. I ran dual x15s on a Miles2 in a Sawtooth with 76MB sustained reads and 40 MB sustaned writes. Adding an Atto SCSI 3 card, 80 Mb sustained reads and 80 MB sustained writes.

j

SteveL
03-03-2001, 05:51 PM
Thanks all for responding on a weekend: MacGurus - They never close! I'll try the older Zip driver but in the meantime, I'm gonna just ethernet to my Powerbook's internal Zip. The real issue for me is not so much the Zip drive but the SCSI scanner and CD Burner which I will be testing next on the Bluenote. I'll probably be back for more advice if you can stand it.
K, I will post my performance results as soon as I have them; we'll see if they back-up Jorge's figures.

magician
03-04-2001, 02:54 AM
you may want to consider taking that adapter out of the mix and using a 50-pin MicroD cable. It's better, from the standpoint of noise. You can find 50-pin MIcroD cables on the external cables page.

http://macgurus.com/infopop/emoticons/icon_biggrin.gif

SteveL
03-04-2001, 03:20 PM
I'll try the 50 pin micro-D cable. I've had to give up on the Bluenote board for now - I could only get the CD burner to run on it and now the CPU will not boot with ANYTHING connected to the Bluenote. The monitor screen shows grey and the cursor is locked. I can only shut down by disconnecting power. With nothing connected, the CPU starts up fine. I have the sinking feeling that I may have fried the board?? I was gonna try a different PCI slot but I had to stop before I slit my wrists (just kidding). The fact that the CD burner ran on the board makes me believe this is not a problem with the board itself (until I cooked it) but a user problem; possibly to do with termination issues. I manually set the Bluenote termination to "single 50 pin" as recommended by Initio using Smart SCSI and terminated the last device in the chain. Then I added the Zip drive with it's termination on giving me two devices on the chain both terminated and then the failure to boot occured. Did I screw the pooch?

magician
03-05-2001, 12:13 AM
the best thing to do with the Bluenote would be to reflash its firmware with the latest revision, and then ensure that you click the "defaults" button. Leave all settings at defaults, for now.

SteveL
03-05-2001, 10:15 AM
O.K., thanks. I'll try to approach this again with a fresh brain, i.e., reflash my own firmware.

[This message has been edited by SteveL (edited 05 March 2001).]

SteveL
03-05-2001, 02:18 PM
Kaye,

You asked about benchmark performance for the Sawtooth with Miles2 and 2 X15's stripped: Peak read 65.49 MB/s, sustained read 38.10 MB/s, peak write 60.67 MB/s, sustained write 55.94 MB/s. With system cache enabled, sustained read 42.55 MB/s, sustained write 57.62 MB/s.

In other news, Bluenote lives! I did a clean system reinstall, flashed the Bluenote firmware and everything seems fine or at least I'm back to where I originally started - which is OK by me. Now if I can just lick this scanner problem...

SteveL
03-05-2001, 02:31 PM
Just read the note in another forum about testing at a file size of 8MB and a cache segment of 2, disk cache off: Under these settings: sustained read 68.21 MB/s, sustained write 71.92 mb/s. These results are somewhat different than Jorge's, particularly in the sustained read.

kaye
03-05-2001, 03:45 PM
S,

Those are great numbers. Kinda blows out of the water what I thought a Miles2 could do in a Sawtooth and I'm sure Jorge is going to be curious. Actually your sustained read is just a tad lower than his but your sustained write is almost double. And it is the sustained write you are achieving on a single Miles2 that is very impressive. I don't know what to make of it. But don't change anything, ever.

You know, more I think about it, a Miles2 in a Sawtooth should do much better. After all, it is an U2W card. Only in a vintage Mac would it be limited to 40MB/s sustained write. Jorge, I need your comments on this. k

[This message has been edited by kaye (edited 05 March 2001).]

SteveL
03-05-2001, 05:40 PM
Just for the record, I have spoken with Linocolor (Heidleberg) concerning the Saphir Ultra scanner and the Bluenote. According to their tech people, the Saphir Ultra will not run on the Bluenote; the rep claimed that they have had other users with this problem. They recommended the Adaptech 2906 or 2930 SCSI board. I was curious if Macgurus has had any experience with this combination - either the Saphir and Bluenote or the Saphir and Adaptech?

kaye
03-05-2001, 05:54 PM
I didn't remember Saphir being mentioned before. Actually scanner came up about half way thru this, so I'm going over to their web site to find out why they say that. BlueNote is the most compatible SCSI card I have ever run into. k

jorge
03-05-2001, 08:01 PM
I ran dual x15s on a Miles2 in a Yose and 450 Mhz G4 machines never to surpass the 40 MB sustained write speeds with 1.06 firmware! Left everything at default settings.

Didn't mess with cache and disk cache on (had 512 Mb ram at the time must have been a large disk cache).

Great numbers!

j