PDA

View Full Version : sleep command/SCSI conflict



Cooker
01-21-2001, 01:16 PM
This is a good one.
When my G4 begins to sleep, my RAID volume locks up and dismounts. ( 2 36g Cheetahs with UL3D and softRAID ) and the computer never does sleep, it just locks up. I have to reboot and remount the scsi volume. Everything else is running just fine. I even re-initialized the the drive and it currently has no data on it. It still freezes on the sleep command ??? Any Ideas

Cook

Cooker
01-21-2001, 01:20 PM
Oh by the way, when I boot up from a different ata drive, all is well, so I imagine the problem is not in the RAID setup, plus my benchmark test are very good. In fact the benchmarks are just as good on the problem startup drive.
Thanks
Cook

kaye
01-21-2001, 02:23 PM
Cook,

Here is what I found at SoftRAID:

Drives power down when a Server is in active use.
SoftRAID was originally designed purely for Servers, where it is a poor idea to put drives to "sleep". With the new Mac OS hardware designs, sleep becomes an integral part of all machines. SoftRAID 2.2 and later support both sleep and "deep sleep" if the rest of the hardware does also, especially the SCSI card.

Sometimes the Energy Saver Control Panel does not handle sleep properly, and puts the drives to sleep. There are two answers.

1. Use Sleeper, from Jon Gotow. It works around most all of the sleep related issues. A great shareware product, 100% compatible with SoftRAID.

2. Reset the Saver prefs. Please do ALL of the following steps in order:

1. Delete the Energy Control Panel preference file in the System Folder

2. Restart the machine immediately and reset the PRAM. (Hold down the command-option-PR keys as the machine restarts, until the machine chimes. Hold it down until there are 3 cycles of resetting the PRAM)

3. Let the machine restart, and open the Energy Saver Control panel. Set the system to never sleep.

4. Under more options, set the drives SEPARATELY to "never sleep".

The first order of business would be to check that the ATTO UL3D supports sleep and deep sleep. k

Cooker
01-21-2001, 07:03 PM
Thanks Kaye,

For starters I just went to the sleep preferences and chose never sleep on the hard drives. So far, so good.

Thanks a lot.
Cooker

magician
01-21-2001, 10:30 PM
all our machines are set here to keep drives up and running at all times. We dim displays. That's it.

works very well, and is not real expensive, in terms of power usage. Sleeping Macs draw very little juice.

crazyeights
01-21-2001, 11:46 PM
I wondered about what happens in Hardware Heaven with Energy Saver. Thanks for the info, as always. I too have had strangeness happen when allowing drives to sleep. Don't know if it was related to Energy Saver, but decided the only thing I cared about was "phosphor burn", So canned the drive sleep and all's been well since.

Did I ever tell you guys how much I appreciate having a reliable mac again? Thanks to you guys..........

c8