PDA

View Full Version : ATTO SE IV card won't do transfers



DJ TEMPO
12-24-2000, 01:06 PM
OK, I'm going nuts. I've been trying, for the past year now, to get a ATTO Silcon Express IV SCSI-3 card running on my 8100/80. I do digital audio with an AudioMedia 2 card and the transfer rate would be useful.

I install the card, hook up a freshly formatted drive (currently trying Conner CFP4207W drives) which I format on the main internal SCSI-buss using Apples HD utility on my 8.1 CD, hook up one or both drives to the 68-pin cable (with active termination), boot (goes fine), write small files (goes fine), but...

when I try recording audio the machine locks up after several write processes. It goes about 15 seconds and freezes. Also, if I try to transfer files from my startup to either of the 2 Connor drives, it locks up.

I've tried Seagate ST15230W's, a couple spare Barracuda's I have lying around from my 8500/200 with an FWB card (works perfectly). I'm stumped. I've tried bot active and passive termination, messed with the control panel that was included with the card (ATTO Express A/V, v2.2), nothing seems to work.

I got this thing about a year ago. Tried to get it running for probalby a couple months and gave up. I took to it again tonight thinking that the SCSI-fairy might have blessed me... but no.

Any ideas? Need more info? Help???

Chip

crazyeights
12-24-2000, 02:29 PM
DJ, too bad you didn't send it back.

Sounds like a software conflict. Anyway, I presume there is firmware which you are supposed to flash to that card. Check to make sure that the firmware version you are using is compatible with the Mac OS version you are running, then, without the drive connected, flash the card with firmware, reconnect the drive and see what happens. Make SURE you are using the correct firmware for that card before doing the flash.

You didn't mention it, but was this card purchased from the Guru's? If one of them is up to it, you may get a response as they are a congenial bunch, but, as busy as these guys are, it's pro-bono when they support someone who bought their gear elsewhere.

In the more information category, you talked hardware, but no software..which is where the problem likely is. What OS? What is the SCSI setup utility you are using for the ATTO card? What are the drivers you are using on the HD's? Did you even flash the card before trying it? For forum support, nothing is presumed...the devil is in the details.

Best,

c8

DJ TEMPO
12-24-2000, 02:53 PM
There was a band out of Georgia in the early 80's called the Crazy Eights. "Make a Circuit with Me" was the song, if I'm remembering correctly.

I got the thing off eBay. With my wide-eyed view of the world right now, that might be the problem. ;-)

Firmware? How might I find that out? When I call up the ATTO SEIV control panel, it lists the card as ID7, Vendor: Atto, Product: SiliconExpressIV, and Rev: 0A00

Why should I take off my clothes in front of the card (flashing? JOKE!!!)

Where would I get the proper update?

I'm running System 7.5.3 as it's copatible with the recording software I'm using.

I used System 8.1's Drive Set-Up v.1.4 to format the drives.

There isn't an Apple formatter prior to v.1.4 that will recognize the drives, what should I use to get the 4GB drives formatted as a single partition and still be recognizable to the card. This on the assumption that it's the formatting utility. (now my suspicion)

I'd eventually like to upgrade to 8.1 to take advantage of newer recording software, but for now it's 7.5.3. Any changes I'd need then?

Sorry for so many questions. There are just too few answers in the manual.

Chip

kaye
12-24-2000, 07:01 PM
DJT,

I have four or five of the ATTO SiliconExpress IV cards laying around here somewhere. I stopped using them in NuBus machines when G3 cards became available because the ATTO card would not work with a G3 then.

I do remember that Anubis by CharisMac was the only driver that would work. I tried all of the various utilities available at the time. What was curious was that ATTO tech support didn't even know that until I told them. Never figured that out. They were selling the card and when NuBus PowerMacs came out, they didn't know what driver would work. What's with that?

Anyway, Anubis has gone thru a lot of upgrades since then, so the latest may not work, but certainly earlier did, and it worked very well. Two issues with the ATTO card, even with the hard drives using Anubis that may be a problem for your AudioMedia 2 card (never had one of those):

1.The ATTO card is not SCSI Manager 4.3 compliant.
2.If I recall correctly, the card sets locked NuBus transactions. You might want to experiment with locking/unlocking that setting if you can.

Anyway, try Anubis. If it does not work, I will look around here and see if I have an old copy that would work. k

DJ TEMPO
12-24-2000, 08:47 PM
Kaye-

Whelp... the Anubis name is familiar to me. Yet with all the old software I have floating around here, I don't have a copy.

And what do I do about having partitions larger than 2GB? Seems any older program like that isn't going to take larger partitions into account.

Chip

DJ TEMPO
12-24-2000, 08:48 PM
Kaye-

Further-

If the SEIV isn't exactly the best choice, what is? Jackhammer is the only other name I've heard of for Nubus.

Chip

magician
12-24-2000, 10:43 PM
I would check the ATTO website for firmware updates. That is definitely step one.

DJ TEMPO
12-25-2000, 12:56 AM
I went to ATTO's site and got the 1.6.5 updater installed. No diference.

Could someone give me some guidelines regarding termination? The manual says to use an active terminator with the internal connector. Might this be wrong? I don't have an internal passive terminator, so I haven't tried it. Any ideas?

Chip

kaye
12-25-2000, 01:46 AM
Chip,

You don't need to go that far back with Anubis, even the latest may work. The 2GB limit for NuBus Macs/PowerMacs is in ROM and only applies to a boot partition. Any other non-boot partition is only limited by the OS. OS7.5.3 limit is 2 Terabytes.

I think the SEIV is a good choice, but when I got a G3, it was not compatible. So I have several JackHammers which work with the Newer G3 only. I have just heard some rumors that the SEIV is now compatible with the Newer G3. I used Conner and Seagate drives with the SEIV and they worked fine.

Forget a passive terminator. No good. The last drive on your SCSI cable, put a jumper across the TE (termination enable) pins. That will work. Also make sure that none of your drives are set for "termination power" from the drive. Termination power should be set for from the bus, and that is because the SEIV provides termination power. Two or more sources of term power is not good. k

kaye
12-25-2000, 02:09 AM
Chip,

Remember, termination (TE) and termination power (TP) are two different things. k

crazyeights
12-25-2000, 02:32 AM
Hi Chip. Yes, that band WAS me. At the time I had Multiple Personality Disorder which manifested as the various band members.

First, read this page: http://www.macgurus.com/graphics/mgwhichscsiadapters6.html

If you wrap your mind around that, it will help you a lot. It'll give you a reference to make sense of it.

First, when you ran updater 1.6.5, in the window, did you get a message telling you it had found the card and done an update? (Something like blah blah card was updated...or found and updated.....?

So far as SCSI busses, connected to the motherboard, there is an internal SCSI bus, and an external SCSI bus (back of the machine). Your ATTO card is considered a THIRD and separate physical bus. Okay?

Any and all devices connected on the motherboard (hereafter MOBO) internal OR external SCSI busses MUST have separate ID #'s. Example; You can NOT have a drive on the external SCSI connector with the same address as a drive connected to the internal SCSI connector, because those 2 SCSI busses are handled by one SCSI controller.

Termination......Lets pretend.. you have one external HD connected to the external SCSI bus set at ID 2, and then one internal HD(ID 4) and one CD drive(ID 3) on that internal SCSI bus, and the CD drive is the last PHYSICAL device on that SCSI ribbon. To work properly, the external drive needs to be terminated (only device, but the LAST device)....your internal ID 4 HD needs to NOT be terminated...and the internal CD drive (last device)on the chain after the internal HD MUST be terminated.

That is the SCSI basics Mantra around here. "The last PHYSICAL device on any SCSI chain MUST be terminated". Say it slowly 3 times. And "any devices BEFORE the last one on a chain must NOT be terminated". The SCSI ID #'s don't have to be in order on any given SCSI bus, just different "addresses". Keep in mind that, on the motherboard there is only ONE buss, but 2 potential chains, internal and external, and "The last PHYSICAL device.........etc".

Your ATTO card is it's OWN SCSI controller (obviously separate from the mobo (motherboard) controller) and for termination purposes, each SCSI connector is a potential SCSI chain. (See mantra above). SInce duties for SCSI management on the ATTO are on the card itself, you could have device IDs that are the same as a device(s) connected to the mobo buss.

Magician or the other Gurus can say all of the above more accurately and in about a tenth of the verbosity I do. This is all fairly new to me too.

Maybe Kaye can find software that will work, but.........IMO, the easiest thing to do of course, would be to buy a card from gurus, and get the best guidance and support in the business, as well as access to the software that works for them. Something to consider. These guys ROCK!!!

And gurus, please jump in and correct any of the above if I'm out to lunch on the facts....

Good luck chip

c8

[This message has been edited by crazyeights (edited 25 December 2000).]

[This message has been edited by crazyeights (edited 25 December 2000).]

[This message has been edited by crazyeights (edited 25 December 2000).]

crazyeights
12-25-2000, 02:54 AM
Oh yeah guys......Happy holidays!!!!

DJ TEMPO
12-25-2000, 05:43 PM
Crazy Eights- Are you serious about the band? e-mail me at:

djtempo@airmail.net

I'd love to talk about it. Big WLIR hit with "make a circuit with me". Loved that song.

Chip

DJ TEMPO
12-25-2000, 07:52 PM
OK gang... here's the latest...

I've gotten the termination set up per the posts you've both left. There are 3 drives on the ATTO card, ID's 2, 4, and 6. The first two are hooked up but not terminated. The last is terminated across the TE jumper and set to "power from bus" per one of the last postings. (Check out hdsareus@aol.com on eBay, I'm not new to this stuff)

So... I started formatting with Remus Lite 1.4 figuring that Apples formatter doesn't do it, Anubis doesn't work either, and the drives are going to be RAIDed in the end anyway. All was going as it should be when the program interrupted saying "an error occurred while formatting the drive at ATTO Silicon Express IV, slot 3, SCSI ID 4." Interesting thing is, the drive light is still flashing as though it's still formatting (it's flashing as I speak)

It took about as much time as it did when I was trying to record audio to a formatted drive. Could it be some sort of buffer problem, or something to the sort. While I understand most of the technology that's involved here, I don't claim to "know" it all.

Just tried another of the 3 and it's did/said the same thing.

Yes, unique IDs, terminated as I'm led to believe it should be. I'm a little stumped. I know the formatting routines are part of the drives' ROMs, but should it continue even after the program that initiated the format reports an error?

And why the error?

Should I just dump this 8100 and ATTO card in the trash? My 8500 with it's Jackhammer card perform flawlessly. But I don't have an AudioMedia card for it. :-(

Hope you've had a good holiday.

Chip

crazyeights
12-25-2000, 09:05 PM
Hi Chip, no, I was just kidding about the band, although, whether the handle is an actual descriptor depends on who you ask.

Try taking all the other drives off the ATTO SCSI chain except the last one, and see what's the result. It will still be the last one on the chain, so if it's set as you say, it's address/termination should be fine. Start from the most simple set-up, and go from there. If the one drive DOES work, then add one....etc...a process of elimination. If it doesn't work, that narrows down the problem.

Kaye, are you around? Is it a rule of thumb when flashing firmware to a card that it is preferred the drive be disconnected from the card? Or is this only with Miles2?

I'm stickin to my 2 on just buying a card from guru's, and going from there, but I understand the draw of "tinkering" on the old macs. There is truth to the adage of "buyer beware" when buying used and unsupported stuff.

c8

[This message has been edited by crazyeights (edited 25 December 2000).]

magician
12-25-2000, 10:36 PM
flashing a card with nothing attached, and with extensions off, simply keeps things clean and reduces opportunities for problems. It is just good practice.

I think your advice is good, dave. Testing drives one at a time is a good way to proceed. Make sure that termination is enabled on the card, as well, and as you test drives one at a time, make sure you doublecheck that termination is enabled on each one. Label them, so you don't get confused!

this should yield additional helpful information.

kaye
12-26-2000, 12:59 AM
The manual does not mention any ROM updating. His version 1.6.5 is the software control panel etc.

DJT, do you have a manual for the card? Are the 68-pin drives the only thing connected to the SEIV? Or do you also have a 50-pin internal device connected to the SEIV? Do you have anything connected to the SEIV external connector? The reason I ask is that there are three resistor packs labeled R1, R2, and R3 which have to be installed/removed in various configurations depending on what is connected to the SEIV. In addition, whatever resistor packs are installed, the little white dot on the resistor pack is pin 1 and should match a little white square around pin 1 on the socket. They can be installed backwards.

If you don't have a manual, I can describe the configurations of these resistor packs for your setup and all others. k

DJ TEMPO
12-26-2000, 03:26 AM
Magician-

Just flashed the card again with extensions off. Didn't change anything.

I've tried one drive by itself, termination enabled/disabled.

The resistor packs are with the dot to the left when viewing the card from the nubus connector. The drive(s) are presently only connected to the internal 68-pin plug with nothing else attached.

For arguements' sake, if I did by a similar card from the Gurus, how would this tech support process differ? This is the 2nd SEIV card I've tried with the same results. I even went so far as to replace the 8100's motherboard after the first card was giving me fits thinking it might that.

Chip

BTW.. THANK YOU ALL for the help. This is much more than I might ever have hoped for. :-)

crazyeights
12-26-2000, 02:15 PM
DJ, you have a LOT of hours messing with this......at least you're not squeamish about tinkering inside your mac. Spend some time reading the information on this site, including the following link: http://www.macgurus.com/shoppingcart/showrampage.cgi?mgscsiinitioboards.html

Also, try another SCSI ribbon....ensure there is no crud in the PCI slot, connectors are clean, etc...do you have another PCI video card or something that you can use to insure there is not a problem with the buss itself? If you are certain there is not a problem with the buss...............

one of the things you will notice is the Gurus are fairly picky about what products they sell, and they endorse and support everything they sell. I am new to this Hi-po Mac stuff, but from what I've experienced and read, the current generations of Initio stuff are pretty upgrade friendly, as contrasted by the variables mentioned by you, and the advice of Kaye and Magician, with the cards you are trying. Per Kaye's comments, it sounds like those are decent cards, but they don't sound as "matured" as the cards Guru's now sell. These guru's have an amazing retention of knowledge with older hardware and devices, but there is a reason they cover PCI SCSI cards with the selection they now sell.

I bought a Miles2 kit, and a cheetah U160/LVD from them, and with their guidance, it literally was Plug and Play. (...and FAST!) I am not versed in SCSI protocol parlance, regarding the drives you mentioned. Miles2 is for drives that can run in LVD (see above linked page for info), then there's the Miles (Single-Ended Ultra SCSI-3, wide) and the Miles Bluenote (SCSI-2, narrow). Pricing is on the same above page. One of the great things about PCI SCSI is the ability to migrate it to another machine when it's time to retire/retask an older one. The ATTO Ultra 3 (on ATTO page) is not really optimal in vintage macs.

These guys have the best support there is. That's what you'll hear over and over again. You are enjoying an unusually gracious level of attention for the Guru's right now. Don't get me wrong, these guy's are damn nice folks, but when they get really busy, their customers will get preference over non-customers. They are frequently quite busy.

I hope this windy post helps. Also, it's not neccessary to post a question to more than one Forum topic. Ideally, an intial post is pegged to topic, but "if you post it, they will see it".

Best to you,

c8


[This message has been edited by crazyeights (edited 26 December 2000).]

[This message has been edited by crazyeights (edited 26 December 2000).]

DJ TEMPO
12-26-2000, 02:39 PM
Well, Mr Eights...

I'm on an 8100... NUBUS slots. I've got an 8500 with a PCI Jackhammer card in it that runs perfectly.

I figured I'm being privvied to this teck support. It's at least nice to know that there are people out there willing to lend a hand when they have time.

On the NUBUS premise, any suggestions there? I think I'm going to break out my old Quadra 800 (in storage) and give it a whirl with this ATTO card just to see what happens. If I have the same problems, it's configuration of the card/drives. If I don't... it's the 8100.

Seems this is getting to be the only possibility left. Or... maybe... I really AM going crazy.

peace

magician
12-26-2000, 03:09 PM
DJ,

I think that is a very sound plan, but you should test each drive independently on the other machine. If your symptoms vary, then you know you have issues with drives. If the symptoms do not vary, then you know the problem remains with the card. Obviously, if things work better on the other machine, then you have a logic board problem.

we do not, at this time, sell NuBus cards of any kind. We supported them for a long time, but when it came time to discontinue the NuBus JackHammer, that's pretty much when we stopped supporting NuBus cards. The JackHammer was always acknowledged as the best card of its type. The ATTO was considered usable, but not as compatible. Frankly, your only hope of getting better support than you are receiving from us here is directly from ATTO, and you obviously will have to gut it out and get past their first tier tech support weenies. This can truly test your patience, and may end up being a waste of time.

the way I see it, moving the card and drives to a new system is a fast way to narrow things down quickly. I would test each drive separately, however.

feel free to post your results here. We understand that you are not yet a customer, but we also have no doubt that you will become one at some point in the future. No one else on the market does what we do here, and that's why we believe that all roads lead to us. It's arrogant, but in those areas where we specialize, we do deliver the best value. One way we make it possible, as dave mentioned, is we focus on specific areas. We don't do it all. No one could.

http://macgurus.com/infopop/emoticons/icon_smile.gif

good luck, and happy holidays!

crazyeights
12-26-2000, 03:21 PM
http://www.macgurus.com/ubb/dance.gif (actual low rez film of me preparing to swing BOTH feet up and stick them in my mouth) 8100 = nubus.....duh.

http://macgurus.com/infopop/emoticons/icon_redface.gif

DJ TEMPO
12-27-2000, 01:45 AM
Eightman...

No biggie. I know how details get lost in the shuffle. ;-)

Chip

DJ TEMPO
12-27-2000, 01:48 AM
Magician-

I don't think I could get even equal support from ATTO.

FYI, I had the same problems with a Nubus Jackhammer card, come to think of it. I'm sensing a motherboard problem...

Chip

crazyeights
12-27-2000, 02:45 AM
Yeah, but in BOTH motherboards you've tried, same problem?

Did you check that nubus slot for gunk, and eyeball the card connectors?

c8

DJ TEMPO
12-27-2000, 03:14 AM
FYI, I'm testing using a Seagate ST34573W which was pulled from my 8500 where it was working fine.

The Quadra 800 had the same problem(s).

Card pins are fine.

One "predictability that I noticed: it seems to take 60 seconds (maybe 61 maybe 59) to give me the error message in every test. The drive light keeps flashing like it's still formatting, but assumedly it won't ever get there. I'm not willing to wait a couple hours to find out if it actually formats out.

I've tried termination on/off, term power to buss, from drive, to drive, and none at all. I've tried all the above combos with the drive 2nd to last on my (new) ribbon cable and an active terminator at the end.

Am I becoming hopeless? It's the 2nd card and the 3rd Mac with the same problem.

(from The Fly...) "help me... help me..."

despaxas
12-27-2000, 06:08 AM
wow...what a thread.

When formatting a drive unexpectedly stops there will be bad blocks. Maybe a more basic approach to formatting is needed. Try zeroing all data or a low level format of each of the drives and see if that can be completed.

FWIW, I had a very similer problem with a/v a while back where my comp would either freeze up, or I would get some strange error code using many different apps (OS9.0.4) while recording. Sometimes soon after recording started, other times after a while. I was positive everything was physically correct, and I went absolutely crazy. Only after doing a low level format, then formatting the drives to HFS+, did it start working correctly. The only problem here, is that only 8.1 or higher supports HFS+.

magician
12-27-2000, 12:48 PM
well....if you are noticing the same symptoms using two different cards on two different machines, the only other possibilities are that your drive developed a problem which you did not notice when it is was in your other machine, or you have cable or termination problems.

doing a low level format is one of the most stringent things you can do to a drive, and a failure to complete a format is, IMO, confirmation of a defective or failed drive. Fortunately, Seagate drives are warranted for five years. You may need to swap it out.

DJ TEMPO
12-27-2000, 01:43 PM
Whelp folks...

I took the drive off the ATTO card and connected it to the internal buss... formatted out fine. Now that it's formatted, we'll see what I can do with it...

Chip

DJ TEMPO
12-27-2000, 02:23 PM
Please... don't anyone hate me.

As I start out this posting, I'd like to thank those who have been helping me with this remarkable problem I've BEEN having. Please note the past tense.

When I first bought the first card, I went through much of the same rigamarole that I've been posting here. I did, at one point, suspect the ribbon cable and bought a new one from a reputable computer parts place here in Dallas (Altex Electronics). Problems continued.

I gave up for about a year. I've since gotten an 8500 with a PCI Jackhammer card which was "plug and play". My frustrations with the ATTO card then multiplied. I bought a 2nd card maybe 4 months ago. Same deal.

I picked up the torch again about a week ago, and shortly thereafter found your web-site with this chain of posts being initiated.

This morning, I tried simply hooking up one drive to the ATTO card, all termination jumpers OPEN on the card, an active internal terminator, and (here's the clincher) another -NEW- SCSI-3 cable I received today from a re-seller on eBay.

Everything works perfectly. Sound Designer has been recording a file now for about 15 minutes without a glitch.

I broke out my meter and tested the previous 2 ribbon cables that I'd been using. Several of the pins are dead on the first cable, 1 pin is dead on the second.

I guess the point is, never assume anything. Even "new" stuff can be bad. I think this is a lesson that can apply to all facets of this computer hobby/living/pursuit we all are involved in.

Again, thank you to those who have been patient enough to deal with this otherwise easy-to-solve problem.

Sincerely-

Chip Tredo
6313 Whittier Drive #2
Plano, TX 75093
972-504-6684

JayPee
12-27-2000, 04:30 PM
DJ Tempo,

Out of curiosity, what kind of music are you into?

DJ TEMPO
12-27-2000, 06:09 PM
JayPee

"Dance", to use the term loosely. House, trance, garage, techno, etc.

Check: www.clubneo.net (http://www.clubneo.net)

Hasn't been updated in a while, but that's the jist of it.

Chip

crazyeights
12-27-2000, 06:48 PM
No biggy, and far be it from me to say I told you so....(see earlier post http://macgurus.com/infopop/emoticons/icon_biggrin.gif ).

Dumb luck on my part........if there is one thing I've learned from the gurus...assume NOTHING, go back to basics.....check basic elements first......

Glad you got it working

c8



[This message has been edited by crazyeights (edited 27 December 2000).]

JayPee
12-28-2000, 05:18 PM
DJ Tempo,

Nice to see a fellow DJ on here. I spin mostly harder techno and electro. Check out http://www.rotation1.homestead.com/main.html for an event I help out with. Eventually, http://www.drunkenmasters.org will have some info about the people I regularly work with..

Glad to see things worked out..

DJ TEMPO
12-29-2000, 01:32 PM
Just wanted to let you folks know, and also anyone with similar problems who might be reading this in the future, ATTO has sent me 3 e-mails addressing my problem. I consider this remarkable considering the dated nature of the card. I think ATTO is worthy of "the good guys of the year" award.. BTW... the card is functioning wonderfully now. Durn cable...

I'm doing a ProTools 442 interface recording with DECK II 2.5. I've done 4 tracks in and 16 tracks out without missing a beat.

Chip

magician
12-29-2000, 11:21 PM
wow....THAT's interesting.

thanks for letting us know.

http://macgurus.com/infopop/emoticons/icon_biggrin.gif