PDA

View Full Version : Norton, Norton, what have you done?



John Haines
12-08-2000, 07:11 PM
The following was posted to the Norton troubleshooting forum on 12/07/00. I have yet to receive a reply.

Product: Norton Utilities for Macintosh
Version: 5.0.3
Supported operating system: Mac OS 9
Formatting: HFS+
Macintosh model: --Other--

Problems with Norton Disk Doctor (NUM 5.x):

Configuration:
Power Tower Pro w/XLR8 500MHz G3 upgrade card with 3 volumes, running
MacOS 9.04
- Primary BootRAID volume is 2-36GB Cheetah HD's driven by Miles
SoftRAID
- Backup volumes are 2 50GB Barracuda drives
Backups are made using Retrospect (Duplicate) so essentially I have 3
duplicate volumes.

History:
Problems started after installation on 12/06/00 of trial version of
Norton AntiVirus 7.0. Subsequent to installing it I discovered that
Outlook Express 5.01 no longer showed attachments to inbox messages
in-line (it worked ok with sent messages and there was no problem at
all when running from one of the backup volumes). Another problem was
a dramatic slowdown of a game, Ultimate Pool PPC 1.1.

[The only other installation I made that day was an update to Toast.
I would think this shouldn't have anything to do with an email
application because of the difference in function (Toast is for
burning CD's) but to be certain I replaced the new files with the old
ones from my backups, with no effect. Of course there is the
possibility that the Toast update could also have installed some
unidentifiable or invisible file in the System Folder but the
difference in function leads me to think that the probability of this
being the problem is not very high.]

I first uninstalled NAV using the installer, but the problem with
MSOE remained. Next I found and trashed 2 invisible NAV files that
the installer did not get rid of. Then, from one of my backups, I
replaced one by one every extension and every preference file I could
think of that might be related to the problem. Then, thinking that
somehow Outlook Express might have become corrupted I replaced the
application itself, and then my email database. Then I replaced the
entire Preferences Folder and then the Extensions Folder. Finally, I
replaced the entire System Folder in my boot volume with one from one
of my 2 backups and that did the trick.

However, when I tried to run NDD 5.0.2 from my primary (boot) volume,
it started up but immediately froze. So I restarted using one of my
backup volumes and ran NDD on the boot volume and it reported only
minor problems. I now restarted using the boot volume and again
attempted to run NDD located on that volume and again it froze. After
trying several times I discovered by chance that when I attempted to
make a screenshot of the state of NDD, it started working. I did this
several times until NDD finally completed it's diagnostic run. There
were several major problems that it fixed:

Check Disk Information
A major error was found in the Volume Header Block.
The total file count is incorrect.
(6,1,5)
The problem was fixed.

A major error was found in the Volume Header Block.
The free block count is incorrect.
(6,1,9)
The problem was fixed.

A major error was found in the Allocation File.
The contents of the file do not agree with the locations of all files
as shown in the Catalog.
(8,1)
The problem was fixed.

Wonderful, I thought. So I again ran NDD just to make sure and again
it froze. However I discovered that if I placed it in the background
by clicking on the Finder, it started working again. And that is
where the situation remains now: NDD works, but only when in the
background. It just freezes when brought to the front.

I have since used Norton LiveUpdate to download and install NUM 5.0.3
but there is no change in this bizarre behavior from NUM 5.0.2.
Incidentally, the only utilities I have installed and use in this
software package are NDD, Volume Recover, UnErase and Wipe Info. I
have been advised by my Mac consultants (MacGurus) not to use Speed
Disk on my RAID array, which they installed.


Addendum, posted 12/08/00:

I have just discovered that every attempt to print now causes a type
11 error and the application (MS Word 98 or SimpleText) to crash. I
might add that printing has never been a problem. I have run Norton Disk Doctor numerous times, rebuilt the desktop and run Disk Warrior. I have no clue what the problem might be. Any help will be appreciated.

John Haines

Louie
12-08-2000, 08:27 PM
John:

I wouldn't expect a timely or comprehensive reply to your post on that board.

Here's the email address of the Symantec Project Manager for NUM. It MAY help.

Dave Lewis<dlewis@symantec.com>

[This message has been edited by Louie (edited 08 December 2000).]

magician
12-09-2000, 05:59 AM
john, as it appears that at least one of your backups is current, I would just blow that primary volume away. Just reinitialize, then restore your data from one of your backups.

I am not a big fan of using Retrospect for stuff like this. Just work in the Finder, and drag and drop.

it sounds possible that your system file itself got patched at some point? I do think discovering that NUM5.03 only wants to run in the background is a stellar clue. It will mean something to Symantec, no doubt.

if you care, really care, then you can wait for them.

I myself would prefer to get back up and running immediately.

your call.

http://macgurus.com/infopop/emoticons/icon_biggrin.gif

John Haines
12-09-2000, 11:11 AM
Magician, your suggestion to reinitialize is probably the best idea. Since my post there are some new problems: I have now discovered that not only Print, but Page Setup also causes a type 11 error and crashes the application. Also, I tried to run a Conflict Catcher Conflict Test but it never gets beyond the initial test, saying that the files I listed as suspect are not the cause - even when I haven't listed any such files.

Questions:

1 - I presume this reinitializing is done with Hard Disk Speed Tools (I have v.2.7)?

2 - Since this problem ocurred 3 days ago, I have generated quite a few documents (Photoshop images, Word docs, email, etc)that have not been duplicated on the one pristine volume remaining (called Backup 2). I suppose that copying most of these files to Backup 2 would not be a problem, but can I also copy my email which exists in a file called Microsoft User Data/Identies without causing problems for Outlook Express?

3 - Since my post I have installed 2 applications: Merriam Webster Unabridged Dictionary. It installs a number of files, including an application called M-W Link that links the dictionary to any text-editing software, including the basic OS (you can check any word, anywhere, including file and folder names!). It also installs a font suitcase in the Fonts Folder, and MW Extension in the Extensions Folder. Have you heard of any problems with this software? I have also installed TurboTax Deluxe (it used to be called MacInTax). Same question.

Thanks.

John Haines

Louie
12-09-2000, 01:38 PM
HDST is now up to v 3.1.1. There's a free d/l.

MacMikester
12-09-2000, 09:00 PM
Hey John,

It's risky to install new software onto a system disk that is already experiencing problems. I don't know about the dictionary software but, in the past, TurboTax and other Intuit software installers have been absolutely dumb as rocks. They would install older versions of sysytem components over newer existing ones without warning. I don't have my copy of TurboTax for this year yet so I don't know how misbehaved it is. In any event, I try to do all sysyem component installs by hand when the installer leaves that option open. That way I know exactly what is where.

Just for grins, check your Extensions Folder and make sure no intellectually challenged installer has stuck in the old bugaboo "ObjectSupport Library" which will wreak havoc in any of the recent MacOS versions.

Regards

John Haines
12-10-2000, 01:29 AM
MacMikester

Thanks for the advice. No, there is no Objects Support Lib in the Extensions Folder and when I get the courage to initialize my BootRAID disk, I'll pay special attention to reinstalling TurboTax. I know what you mean. Every year it goes through a very buggy introduction. The very fact that it is now called TurboTax instead of MacInTax is an omen.

John Haines

magician
12-10-2000, 11:51 AM
you can indeed backup those other files, including your email database, though I would be certain that you are placing email resources exactly where they belong.

if memory serves, your drives were initialized with SoftRAID. I would update to SoftRAID 2.2.2, then reinitialize the affected drive with that application. Once that is done, and all is well, update drivers on your other drives.

one of the system resources that Intuit installers commonly install is an old revision of AppleScript. It is not uncommon to end up with duplicate and conflicting versions after installing Intuit products.

John Haines
12-10-2000, 02:26 PM
Magician

Your memory is perfect. I've downloaded SoftRAID 2.2.2 but I apologize - I'm not sure what you mean by, "...then reinitialize the affected drive with that application. Once that is done, and all is well, update drivers on your other drives." I presume I will be reinitializing BootRAID with SoftRAID from Backup 2, which of course is not a RAID array. I've downloaded HDST 3.1.1. Is this a driver and am I supposed to do something with it?

As for AppleScript, The TurboTax installation log makes no mention of it. The one currently in the extensions folder is v.1.4.3., same as on Backup 2.

BTW, I like the way you've organized this forum. It's very easy to follow threads, post new topics and reply.

John Haines

magician
12-11-2000, 12:29 AM
HDST is a utility used, in your case, to handle removables like Jaz and Zip. If nothing has changed on your machine since it was last here, you need to run the SoftRAID 2.2.2 updater, run the updated version of SoftRAID 2.2.2, and point it at each drive in succession and update drivers.

the drive that is giving you problems, that drive needs to be reinitialized, again using SoftRAID. If it is a striped array that is giving you problems, then reinitialize each drive in the array, then recreate the array.

John Haines
12-11-2000, 08:17 AM
Magician

Yes, my machine is exactly the same as you set it up (minus 7.6.1): I don't know if the primary volume (BootRAID) is striped or spotted but it consists of 2-36GB Cheetas (it is fast). The other 2 volumes are 50GB Cudas that I use only for backup. I've never touched SoftRAID so I have no idea how to use it and I want to get this straight before I destroy everything:

- I first update the drivers for the 2 backup drives from the BootRAID drive using SoftRAID (hopefully it will lead me by the hand). I presume I can't do this for the BootRAID drive, while in BootRAID, and that since it will be initialized it doesn't matter anyway.

- Then I restart from Backup 2 (the only drive untouched by NAV)

- Then I reinitialize BootRAID and recreate the array, again using SoftRAID (again I hope it will tell me exactly what to do).

- Finally, I drag everything from Backup 2 to the new BootRAID volume and then restart from it.

Yes?

Thanks again.

John

Louie
12-11-2000, 01:14 PM
What is BootRAID?

John Haines
12-11-2000, 02:27 PM
Louie

I apologize, I thought that I had made that clear in my first post. BootRAID is the name that MacGurus gave to my primary volume, a software-based RAID array that consists of the 2 Cheetah hard drives, when they set up my machine. The other two drives (50GB Barracudas) are not RAID arrays, and are only used for backup.

Thank you

John

magician
12-11-2000, 02:44 PM
John, you must boot off one of your backup drives, update SoftRAID to 2.2.2, then point it at your two Cheetahs. SoftRAID will prompt you to update drivers. Simply say "yes," then reinitialize each Cheetah. This will destroy the contents of the array.

it IS the array which is giving you problems, right?

then highlight each reinitalized Cheetah, and drag and drop them to the left-hand side of the SoftRAID window. Name your restriped array "bootarray" or whatever it is named (identical case lettering, so your aliases hopefully won't all break), and hit return. The new array will mount on the desktop.

then, point SoftRAID at each backup drive. Update drivers manually, one by one, on each Cuda.

restart.

you should still be booting off one of your backups. Transfer your data from your backup back to your boot array, and then open and close the system folder on it to "bless" it. Select it in the Startup Drive Control Panel as the boot device, and close the control panel. Open the control panel, and confirm that it is still selected. If it is, close it again, and execute a restart, this time, from the array. If it is not, download SystemPicker from the Apple directory on our FTP site at ftp.macgurus.com and use it to designate the boot array as your boot volume. Execute a restart.

you should now be booting off your array, as before. Check your aliases. Use SystemPicker to boot off your backup again, and run DiskWarrior and DiskDoctor 5.03 and NAV6.03 to confirm that all is well. If so, revert back to your boot array, and get on with life.

that should do it.

John Haines
12-11-2000, 05:34 PM
Magician

Yes, BootRAID is the sick one. I started the process and up came a rather complex dialog box from SoftRAID. Are the settings as they appear correct (especially Photoshop acceleration?)?

John

magician
12-11-2000, 08:05 PM
leave all those settings at defaults. No need to get fancy.

John Haines
12-11-2000, 11:35 PM
Magician

I initialized both Cheetas (took several hours) and am ready to drag disks to volume column.
Question: Choose Weighted stripe, Striped-RAID 0, or Mirrored RAID? I presume I have to shift click the disks in the Create New Volume dialog to select both Cheetas?

I've had some problems running on Backup 2 (volume): (it took me a while to figure out how to get Outlook Express to find the correct User Data/Identities but it's ok now. Also I encountered Print and Page Setup problems as in the old BootRAID volume (incl. type 11 application crashes) but somehow I got it to work ok again (have absolutely no idea how I did it).

Please be patient with me, I feel like I'm swimming in the dark.

John

[This message has been edited by John Haines (edited 12 December 2000).]

[This message has been edited by John Haines (edited 12 December 2000).]

magician
12-12-2000, 01:53 AM
john

sounds like you did a low-level format. If your drives completed this procedure, you can assume your subsystem is viable. A low-level format is quite stringent. A quick initialize would have been fine--and it takes literally about ten seconds, max.

select RAID 0.

a restart may not fix all aliases. You may be able to rebuild your desktop after you have renamed your missing bootarray correctly, and dragged your data across to the new RAID 0 volume, but you may end up having to recreate them. Naming your boot array identically to what it was before will help.

your Outlook stuff typically gets installed into a folder in the Documents folder, though yours may be going elsewhere.

John Haines
12-12-2000, 01:12 PM
Magician

I am typing this from the new BootRAID!!! Had a slew of miscellaneout problems but at least those I had before the reinitialization (printing, page setup, Norton DD running in background, etc) are gone.

There is one problem however that is odd in that it never happened before you mentioned it: the Startup Disk CP doesn't work properly!: When I open it, none of the disks are highlighted. If I highlight one (say BootRAID), then close and open it again, ALL the disks are highlighted. And no matter what I do with it, the machine restarts on one of the backup disks. The utility I downloaded from your site, System Picker, does the trick but I'd like to get Startup Disk working properly again.

One curious thing is that in System Picker there are numerical designations after each disk. I just now opened it and (whoa - for the first time!) the BootRAID disk says 9.04, the others have 1.0 (previously, Backup 2 had 9.04 and the Backup 1 and BootRAID had 1.0). Since 9.04 is the version of my Mac OS, I presume this is what it means but I don't know what 1.0 is, or if that might be related to the Startup Disk CP problem.

Incidentally, I am very grateful for your help in walking me through all this. I don't know where else I could have turned for the answers. MacGurus are lifesavers.

magician
12-12-2000, 03:54 PM
john, you are encountering a bug in SoftRAID which requires System Picker as a temporary work-around until the next update to MacOS9.xx is released.

when you run Disk Doctor, it will correctly alert you that the system folders on the other volumes are not "blessed." Don't panic--this is the mechanism that System Picker uses to ensure that you boot off the volume of your choice. You can repair or not in Disk Doctor. It is your choice, and not an indicator of any other problem.

just leave a copy of System Picker on your desktop and use it to restart your Mac. That will take care of this issue until MacOS 9.1, aka "Fortissimo," I believe, is released. It should probably be released at MW-SF in early Jan.

crazyeights
12-12-2000, 04:41 PM
I installed NAV trial...........once........

Immediately I started having the same problems john has described, and then some.

Kinda funny......it was like I had used an anti-virus package to install a virus. I too gave up and reformatted.

M, do you guys use anti-virus software there in Heaven, and if so, what do you use?

c8

John Haines
12-12-2000, 04:58 PM
Magician - Thanks. I will look for it. Now, a new development: I reinstalled the Merriam-Webster unabridged dictionary, along with it's M-W Link software. It worked fine but shortly thereafter I ran NDD and again it would only run in the background. I trashed the M-W Link extension in the extension folder and MW preferences in the preferences folder, restarted, and NDD ran fine (in the foreground), and the Dictionary also worked ok, albeit without that nice link to all text applications. Interestingly, there is a file in the M-W folder called pref.mw so I guess the one in the prefs folder was just for the Link.

Thanks again.

crazyeights - I've used Virex for a couple of years now and have never had a problem... or a virus.

John

crazyeights
12-13-2000, 12:58 AM
John, I didn't mean to cast aspersions on NAV complete....

there was something about the trial version that, at that time, threw my machine fits. It was the NAV trial on NDD 4.0

Sounds like you got your problem licked.

Best,

Dave

magician
12-13-2000, 03:14 PM
we use NAV6.03 at this time. Works very well. I think Darin is the only guy using System Works so far.

John Haines
12-14-2000, 12:29 AM
magician - I don't know if it is because of a bug in SoftRAID but in addition to the system folders not being blessed, NDD found 4 other major errors in my 2 backup volumes which I had never before seen: The signature is incorrect. (16,1,1); The system name is bad (16,1,2); The event queue size is bad (16,1,11); The shell name is bad (16,1,3). I also don't know what the numbers mean but I include them FYI. All errors were fixed by NDD. They appeared after I had performed backups (using CopyAgent). Should I expect them to recur after subsequent backups or are they generally one-time errors?

magician & crazyeights - I too don't want to cast aspersions on NAV. In fact, because of it's ability to scan incoming email, which Virex can't, I very much would like to be able to use it. But I can't afford to have the problems I encountered (see my first post below). Do you think the trial and licensed versions of NAV are so different that these problems would not occur with the licensed one?

John

crazyeights
12-14-2000, 01:40 AM
John, Mag says they use NAV 6.03, and he should know.

Magician, do you use NAV 6.03 on your RAID machines? (I can see you smiling now saying, "all my machines are RAIDed".)

Although I was a little flabbergasted at the time, I figured it was a bug in the expiration routine of the code on the trial version. How often do you expose your system to possible viri? Really though, the way some of those nastties and worms are written, a "hatch" date is written into the routine to insure the unwitting recipient is thoroughly infected. Which means backups would be hosed too.

Let's see what Magician say's. Hell, knowing about this stuff is his full time job. I'm just a student.

http://macgurus.com/infopop/emoticons/icon_biggrin.gif

c8

John Haines
12-14-2000, 02:06 AM
crazyeights - Since Virex has never even hinted that something might be a virus, I can't really answer your question with any certainty. I download quite a bit of software, esp updaters, but from what I think to be reputable sites. I don't share software or any kind of disks with anyone The only floppies I might use are old software. I do get email (far too much spam) and just recentlly my ISP told me he had added virus protection to his mail servers. I told him I thought Macs weren't susceptable to email viruses. He didn't know about that but he suggested NAV. And that brings us full circle.

John

[This message has been edited by John Haines (edited 14 December 2000).]

crazyeights
12-14-2000, 02:33 AM
Hi John,

Yeah, they are still somewhat rare, but they DO happen. Strangely, that has been one of the benefits of the macs lower market share. But, now the U.S. Navy is starting to use macs, for more security, of all things, which is like issuing an invitation for mayhem.

If Magician DOES use NAV on his RAIDed machines, that's a pretty good endorsement.

Best,

c8

John Haines
12-14-2000, 12:26 PM
magician or crazyeights (or anyone who has any ideas about it) - a new problem (can it be related?). Yesterday I sent out a bunch of emails (OE 5.01). Today they are nowhere to be found. In fact all my mail (in and out) since 12/12/00 is missing. I checked the Identities folders and the latest Date Modified is 12/12/00. I would think since I sent and received mail on the 13th it should say it was modified on the 13th, no? I checked the NDD reports and for 12/12 it lists the following fixes:

Norton Disk Doctor 5.0.2 Disk Examination Report
Disk: BootRAID
Tue, Dec 12, 2000, 10:00 PM
Check Files
Minor errors were found in the files listed below.
The bundle bit is on, but should be off.
(15,2,10)
The problem was fixed.
BootRAID:System Folder:Extensions:Microsoft Internet Library
BootRAID:System Folder:Launcher Items:€Internet:3 IE 5.0
BootRAID:System Folder:Launcher Items:€Internet:5Com4.7.2

A minor error was found in the file listed below.
The custom icon bit is off, but should be on.
(15,2,11)
The problem was fixed.
BootRAID:System Folder:Extensions:Microsoft Internet Library


Do you think this might have something to do with it? And, if so, can NDD Undo repair the damage (I've used NDD on this volume twice since the 12th)?

Also, about this bug in SoftRAID: Since it never happened before can I presume it is something in v.2.2.2, and will reverting back to v.2.2.1 fix it?

John

crazyeights
12-14-2000, 01:19 PM
Hi John,

Did you double check in OE prefs that it is set to file a copy of sent e-mail to you Sent Mail folder?

I have NEVER heard Mag or any of the forum Moderators recomended reverting to SoftRAID 2.2.1

One of the Moderators can give you better feedback than I, FOR SURE, but the errors you described that NDD found are pretty common ones.

Check your sent mail prefs, and DON'T revert to SoftRAID 2.2.1, unless Mag or one of the other guys tells you to do so.

As you tweak your machine, get guidance from the Guru's, and keep it simple. If you have to keep using NDD to repair things, than something is flaky, and until you deal with that, your problems will continue.

Just curious, how many 3rd party extensions do you have loaded onto that machine? If you can remember when things started getting flaky, what software have you installed around that time?

If that is as Mag says, a mission critical machine, you'd be well served to keep extraneous software OFF of it. I would expect that's one of the reasons so many of the Gurus have multiple machines. From what I've read on this forum, Magician doesn't put new software on his mission crit machines until he's pounded on it on some of his others for awhile.

Although it is flattering to be addressed in a question in your same breath with Magician, HE'S (one of) the Guru(s). My level of expertise is more akin to the guy who would be sweeping the floor where he works. I'm slow, but learning, and haven't destroyed any hardware YET......(he say's, knocking on wood)

Ah, to have the mind and spirit of a youngster like spud, as it was prior to the period of abuse of my neuro-chemistry.

http://macgurus.com/infopop/emoticons/icon_biggrin.gif

magician
12-14-2000, 01:36 PM
ok....where to start.

1. I do use NAV6.03, and have, for quite some time. As long as it is used in accord with the guidance on our utility rant (http://www.macgurus.com/graphics/mgscsisoftware.html) page, we find it the best solution of its kind.

2. K may have a strong opinion on using SoftRAID 2.2.2 vs 2.2.1. I do not. I am interested to hear his opinion. If memory serves, your machine was originally built using 2.2.1 and worked well for months. I suppose it's a decision that should be based on what bugs are fixed between 2.2.1 and 2.2.2. Reviewing the upgrade notes included with each version, or posted on the SoftRAID website, may equip you to make a decision. I'm using 2.2.2 on all machines here, and living wih the boot bug with the assistance of System Picker.

3. the NUM errors you mentioned below did not affect the contents of your email database. My suspicion is that your mail was sent using the database on one of your backups, rather than off your boot array, or vice versa. Bundle bits refer to the way icons appear on the desktop--not the actual contents of files. These are resource fork problems. Not file fork problems. (Remember, all Mac files are binaries, still).

4. please ensure that you have used Live Update to update all parts of Norton Utilities and NAV. It is important that you are running current revisions. I see no need, at this point, to update to the next point-revisions of these applications included in System Works, but it will probably become necessary at some point in the midterm future.

FWIW, I would not use CopyAgent at this time. I do not trust it. We've been waiting for a revision for awhile now.

what did I miss?

[This message has been edited by magician (edited 14 December 2000).]

Louie
12-14-2000, 01:37 PM
I don't use IE, but if this happened with Netscape, it would be caused by the "Copies and Folders" preferences not being set to copy sent mail to the "Sent Mail" Folder. This happens on a fresh install or copying the browser over from another disk such as you recently did. Merely set the preferences properly and send yourself a test message (it won't recover the lost ones).

kaye
12-14-2000, 01:51 PM
magician,

I like SoftRAID 2.2.2 just fine and have no desire/need that I know of to go back to 2.2.1.

I also wonder whether he may have installed two copies of OE. The loss of sent mail can be explained, as C8 and Louie say, by not having the OE prefs set for copying sent mail, but the loss of incoming mail sounds like he is running dual OE's, and that incoming mail he "lost" is with another copy of OE. k

John Haines
12-14-2000, 02:04 PM
You guys are faster than a speeding bullet...

crazyeights (and now louie) (and magician) - Thanks for the replies. Yes, the prefs in OE are so set. In fact, they are the same as they've always been. The missing messages were there yesterday (both inbox and sent) but this morning they weren't. What's more, some messages that I had deleted yesterday had reappeared. A test message to myself today worked properly. I did try running NDD Undo and it didn't restore them. I doubt that UnErase would do so either since the messages are just one days worth of a huge database file that is constantly being changed.

I certainly will wait to hear from magician about SoftRAID before reverting. They set up this beast and they remain my gurus.

And now that magician had weighed in on this, yes, SoftRAID 2.2.1 was the original you used and it worked like a charm for a year. Never had problems switching startup disks with OS 9.04's Startup Disk.

Speaking of LiveUpdate: I just a few minutes ago finished using it to update NUM from 5.0.2 to 5.0.3. All 5.0.2 files are now in the trash but I think perhaps I should save them. But LiveUpdate reported an error and said to re-install the full product and try again. It said a patch was applied.

Installer Log File
Thursday, December 14, 2000 1:15 PM Beginning installation.
PNsl
Type of Install: Easy Install
Installed BootRAID:System Folder:Extensions:Norton Shared Lib
Thursday, December 14, 2000 1:15 PM
The installation is complete.


kaye - No, I have only one copy of OE 5.01 installed. I tried to see if it might be in one of the other volumes but when I booted from either of my backup disks it said :
"Outlook Express cannot load the Microsoft Internet shared libraries. There may not be..." and then gave 3 possibilities, memory, needed files, and "reboot from unlocked startup disk and relaunch OE"

I better post this before someone else weighs in.

John

John Haines
12-14-2000, 02:39 PM
magician - Don't use CopyAgent!? Isn't this the replacement for Speed Doubler? If I don't use it (I've done so since the first week it came out) then backing up with the Finder's copy function will take forever since it replaces everything (over 6GB). Should I revert to Retrospect (I'm speaking of the Duplicate function, not Backup)? That is what I have been using for backups for a year now with no problems. Even booting from one of the backup disks worked perfectly: I could use all apps, including OE. The only "problem" I ever found was that the desktop printer icon was X'ed out and a new one added.

John

magician
12-14-2000, 03:28 PM
this will be a judgement call on your part, John. We encountered problems with CopyAgent here, and discussed them in an old, old thread somewhere on these forums....I believe under System Software Tips. You will certainly need to set the forums to display old messages for you to find it, not just msgs posted within the past 30 or 45 days. Searching may turn up the thread.

there was an update to CopyAgent released today, and I just put it on our FTP site. If memory serves, the problems we encountered were network-related, so you may not have suffered from them or noticed them yourself. If you are not moving data among several Macs, I suspect it may work fine for you. I administrate several servers here over TCP/IP, and move lots of data around between various machines, so it proved itself unusable to me within 24hrs. It worked fine on our bench machine, bam_bam, in the basement. As long as I didn't work off our servers too much. On beast, my primary 9600, I had to deinstall it almost immediately. It also caused problems on boo_boo, one of our heavily upgraded S900's.

my suspicion is that some of the directory problems you were repairing successfully with DiskDoctor may have been caused by CopyAgent, or at least moved from one drive to your others. I am encouraged by the fact that DD repaired them, but I still would keep a close eye on that stuff. You do not want to let it slide.

my gut-feel is that you should hang in there with SoftRAID 2.2.2, even though it does have this Startup Drive control panel bug. Using System Picker is a viable work-around for the near-term. Mark James at SoftRAID LLC has confirmed for me that OS9.1, Fortissimo, anticipated to ship at MW-SF, fixes the problem.

as for your OE issue....remember that your mail database is in the Identities folder in the Outlook Express 5.02 folder. If you are not running OE5.02, you should be. My suspicion remains that your copy of OE is using a database off one of your backups rather than the one off your new boot array.

John Haines
12-14-2000, 05:59 PM
magician - The way my machine worked for an entire year prior to these problems was flawless. Now, I cannot switch between disks without problems and I need to do so ocasionally - to run Disk Warrior, for example. If you believe CopyAgent is buggy then It would seem to make sense to revert back to what worked so well for my backups, Retrospect (Duplicate function).

Also, unless you know of some compelling reason not to use SoftRAID 2.2.1, which is what you used to set up my machine originally, it seems to make sense to go back to that also. However, If I do, does it work the same way as 2.2.2 and will it install the correct drivers... or am I opening a can of worms?

As for OE, I think you might be right that it is using a database from one of the other disks but how do I check that... or repair it?

Thanks, John


[This message has been edited by John Haines (edited 14 December 2000).]

magician
12-14-2000, 11:07 PM
deciding whether to use SoftRAID 2.2.2 or 2.2.1 is your call, John, as is determining whether to use CopyAgent or Retrospect.

to determine which database you are using, compare the dates on the databases on each of your backups. The one with the latest date will be the one you used last, which may or may not be the one you want to continue using.

John Haines
12-14-2000, 11:47 PM
magician - You got it! The Database with the latest date is in the Backup 1 disk. Therefore, OE is storing the data there. But since it isn't appearing in the application, OE is not retrieving it from there. How can I fix this?

Would dragging the database to the BootRAID disk work? And which part of the database? The only folders there that have today's date are the Database, Database Cache, Messages, Preferences and Signatures folders, all of which are within the Microsoft User Data / Identities /John folder. There are other folders and files within the Microsoft User Data folder but their dates are all old, therefore unchanged. I recall reading something about this and will try to find it if I can. But if you know the answer it would save me some time.

Thanks very much.

John

[This message has been edited by John Haines (edited 15 December 2000).]

John Haines
12-15-2000, 12:44 AM
magician - I found it. In a readme in the OE 5 folder. FYI here it is:

2.4 Maintaining Mail and User Data When Reinstalling Microsoft
Outlook Express 5 on Macintosh OS 9.0
------------------------------------------------------------------
Microsoft Outlook Express stores your mail and user data in the
Microsoft Users Data folder in the Documents folder on your hard
disk.

>>>To maintain mail and user data when reinstalling:
* Copy the Outlook Express 5 folder to your hard disk and replace
the existing Outlook Express 5 folder.

NOTE: You can store your Microsoft User Data folder in any
location, including a server. However, you should place an alias
to that folder in either your system Documents folder or the
Outlook Express 5 folder.

If you set up your Macintosh computer for Multiple Users, the
Microsoft Users Data folder is located in: Users:<user name>:
Documents, where <user name> is the name of the user.


So I dragged/copied the Microsoft Users Data folder from Backup 1 to BootRAID and placed it within the OE 5 folder (I prefer it there rather than in the Documents folder - seems to make more sense). I restarted and all of today's (actually yesterday's now) mail is there, Inbox and Sent. There are some other messages from the 12th that are missing but presumably they were overwritten when I backed up. Let's just hope everything is still there when I wake up tomorrow.

It's amazing how simple things are once you know what to do. Thanks again.

John

John Haines
12-15-2000, 03:05 AM
magician - In the words of Yogi Berra, "It ain't over till it's over." Well, it ain't over.

After all these changes I decided it would be good to rebuilt the desktop. I did so and, just to make sure everything was working, I opened OE. Damn! - My normal choice of Users was gone again and in it's place there was only "Main User" (the generic) listed. I checked and sure enough, there was a new Microsoft User Data folder in the Documents folder of the Backup 1 disk. I trashed it and copied my real Microsoft User Data folder from BootRAID back to this location. OE opened to the correct database.

Why is OE so determined to use this as the location for the database? Could it have something to do with the fact that Backup 1 (formerly Backup 2) was the disk from which I reinitialized BootRAID. But I can't have my database in a Backup disk or it will be destroyed every time I backup. How can I fix it?

John

[This message has been edited by John Haines (edited 15 December 2000).]

magician
12-15-2000, 02:48 PM
you need to make your Mac default to the Documents folder on your boot array, and not the Documents folder on your backup. When you backed up, the Mac remembered that that was the Documents folder it was using. You simply need to check your General Controls control panel, enable the Documents folder, then make sure that your Mac points to the one on your boot array, and not the one on your backup.

John Haines
12-15-2000, 04:04 PM
magician - It doesn't work. This is what I did:

General Controls has 3 buttons like this:

When opening or saving a document, take me to
- Folder that is set by the application
- Last folder used in the application (my normal choice)
€ Documents folder (selected)

I chose the last. I then saved a document from SimpleText to the Documents folder on BootRAID (it had been pointing to the one on Backup 1.
I then restarted and opened OE. It still chose the Microsoft User Data folder on Backup 1. I saved an email message to the Documents folder on BootRAID, quit and restarted OE. It still goes to Backup 1.
Simpletext now goes to the one on BootRAID, as it should.

So I repeated the process, then rebuilt the desktop and restarted. No good. OE still goes to the Microsoft User Data on Backup 1.

I then copied the Microsoft User Data folder to the Documents folder on BootRAID, placed an alias in the OE folder, trashed the one on Backup 1 then Opened and closed the General Controls CP. Restarted and opened OE. It generated a new Microsoft User Data folder in the Documents folder in the Backup 1 disk. Now the opening dialog shows only the generic, Main User.

It must be controlled by something else.

An idea: Do you think that if I moved the Microsoft User Data folder to the Documents folder on BootRAID (so I don't lose it), then used SoftRAID to initialize Backup 1 and then backed up Boot RAID to Backup 1, this might break OE's memory? Or... use this occasion to install OE 5.02 in Boot RAID and when it asks to import the database (if it does!), point it at the proper one in BootRAID???

John

magician
12-15-2000, 05:03 PM
John

i might be inclined to move the prefs file for OE (save it, in case you elect to replace it later) so it makes a new one. Maybe that's what controls where OE looks for its DB. Not sure.

the only thing I can say is, make CERTAIN that you don't get confused over which versions are where, and do NOT delete anything important. Keep your backups straight!

you should definitely update OE. I have no idea whether it will fix this problem for you or not.

my feeling is that reinitializing is a good thing to do for purposes of general maintenance biannually or so, but probably overkill for this specific purpose.

I'm curious if anyone else has encountered this problem? This seems to have slimmed down to a one-on-one conversation, and I'm interested to see what advice the others here might have to offer.

John Haines
12-15-2000, 06:27 PM
magician - Yes, you are the last one with any interest, I guess. Here's the latest:

First I copied the Microsoft User Data folder in the Documents folder in Backup 1 to the Documents folder in BootRAID, then moved the original from the Documents folder to another folder [reinitialization of BootRAID] in another location in Backup 1. Then I installed OE 5.02 in BootRAID. I started it and got the following dialog box:

To use data from your previous version
of Outlook Exppress, move or copy the Identities
folder located in Backup 1:-reinitialization of
BootRAID:Microsoft User Identities: to the
Outlook Express 5.02 folder on your hard disk. To
do so, click Quit, move or copy the folder in the
Finder, and start Outlook Express again.

I did so. Same #$@#%#$@* thing!

So then I trashed the Microsoft User Data folder in Backup 1, trashed OE 5.02 in BootRAID, emptied the trash and then reinstalled OE 5.02. I started it up and it immediately created a new Microsoft User Data folder in the Documents folder of Backup 1 and listed only the generic, Main User in the startup dialog box.

This is beginning to get to me.

John

kaye
12-15-2000, 06:39 PM
I'll chime in with no problems with OE 4.5. This is how OE 4.5 sets up its folders and I have never changed any of it.

Outlook Express 4.5 Folder contains Outlook Express 4.5 and a folder called OE User(s) (there are other unimportant items to this discussion). Inside OE User(s) is a folder called Main User (there would be others if someone else used this computer). Inside Main User is a folder called Internet Mail. This is where all the mail is stored in folders the application sets up such as Inbox, Sent Mail, etc. and all of the folders I have added such as MacGurus, Schwab, United Airlines, HOT, etc.

If this folder setup were to be changed, I'm sure OE would not see everything or perhaps anything. k

John Haines
12-15-2000, 07:10 PM
kaye - Tell me about it! I loved OE 4.5. I loved the interface, the simplicity, and especially the "contacts" (now called "Address Book". I could have a bunch of mail lists that were perfectly editable. And then I changed to OS 9.

Thanks for reminding me. Now I have to find a solution to OE 5.

John
http://www.macgurus.com/ubb/mad.gif

Louie
12-15-2000, 07:15 PM
I can't directly help because I use Netscape, however, I've had the same problem with Netscape more than once. I have a copy of Netscape on each of several volumes. I need all of these to point to only one set of preferences (where the Netscape Registrys and Users' bookmarks, various mailboxs, newsgroups, etc. are kept). If they all didn't point to the same place place, mail would be scattered everywhere.

The way I have been able to fix it after it gets screwed up (copying volumes, etc.) is to pick the volume which I use the most and make sure the Netscape preferences (mailboxes,etc.) are as complete as possible. Then, I startup from each of the other volumes and trash the Netscape Preferences on each of these volumes. After each has been trashed, I start Netscape on that "secondary" volume and it will say, "hey, where do I look for all the goodies that I need?". Now, I tell it to look to the "main" volume Netscape preferences. The result is that all copies of the browser are using the same preferences.

For backup, you only copy that one main set of preferences (data).

Hope this helps. I think it's the same problem you have.

John Haines
12-15-2000, 07:58 PM
Hi Louie - Thanks for the thoughts. Yes, it is probably something like that, but different. My latest experiment was trashing the prefs in both BootRAID and Backup 1 disks which changed nothing. I am beginning to come to the conclusion that the origin of the problem was the fact that my reinitialization of BootRAID at the beginning of this oddessy was made from the backup disk that OE keeps looking to for data. I think that initializing this disk might get rid of whatever code is creating the problem, in the meanwhile saving all the important Identities/database etc that reside in the Microsoft User Data folder, in the BootRAID disk. And then, using CopyAgent to copy everything from BootRAID to Backup 1.

What do you think?

John

Louie
12-15-2000, 08:10 PM
It seems that you should be able to make it point to the correct Data Folder. I know that till I figured out how Netscape behaved, that it nearly drove me nuts every time that I copied to a new volume.

John Haines
12-15-2000, 09:26 PM
Louie - Ok. I used syst picker to change to Backup 1. Hit restart. Finder quits.

[The startup disk no longer has a valid System folder. System and "Finder" must be in the same folder. If you continue you may not be able to restart the computer. Do you want to continue?]
[A file/disk error has ocurred]

Note: both backup disk icons have disappeared from the desktop.

I hit cancel. Same dialogue box. I hit Yes.

Computer goes through restart routine, twice (2 gongs). Backup 1 is now the active disk. I try to start OE.

[Outlook Express cannot load the Microsoft shared libraries (several possible reasons)]

I try System Picker again. Only choice is BootRAID. I hit Restart.

Back again to BootRAID.

Scary.

What to do???


John

John Haines
12-15-2000, 10:54 PM
anyone - An observation: When I start Sherlock the disk checked is not BootRAID but Backup 1. Every time, even if I uncheck Backup 1, check BootRAID, quit and then open it again. Rebuilding the desktop makes no difference. This must be related to the OE problem.

John

Louie
12-15-2000, 11:17 PM
When you copied your backup volume, your aliases got all screwed up. The originals aren't all where the aliases think they should be. That's what wrong with IE.

When you use System Picker, pick the volume you want to be the startup disk and wait until the searching ends before you hit restart.

Give System Picker some more memory and it will search faster.

The way System Picker works is to de-bless all or most of the systems on all the volumes except the one you pick. Sometimes it does a sort of a stutter-start to accomplish this.

John Haines
12-15-2000, 11:53 PM
Louie - Thank you, I didn't realize that graphic folder stuff in the middle of System Picker meant to wait.
Ok, I increased the memory in Syst Picker, then, after waiting till the folders stopped spinning:

Syst Picker set to Backup 1/Restart
2 gongs, booted Backup 1
Sherlock opened with disk checked - BootRAID

Syst Picker set to Backup 2/Restart
Partial boot/froze/force restart, successfully booted Backup 2
Sherlock opened with disk checked - BootRAID

Syst Picker set to BootRAID/Restart
2 gongs, booted BootRAID
Sherlock opened with disk checked - Backup 1

How about suggesting a scheme for starting the whole reinitialization proceedure over? I think we're beating a dead horse. Don't you see a basic disk identification problem here?

John

Louie
12-16-2000, 01:23 AM
It's really just a matter of fixing your aliases. One way to fix it is to do manually.

While in the Finder, highlite an alias that is known to point to the wrong file. Under the File Menu, pull down to "Show Original". The file that the alias is pointing to will open to verify that it is wrong. Trash that alias that was highlighted, go to the file or folder that should have opened and make a new alias. Drag the new, proper alias where it belongs.

I don't know how many you have, but if it's not a huge amount, I'd rather do that than start from scratch with a blank disk.

You always need to check your aliases when you copy a disk like you did. The aliases are going thru the hierarchy as it was, not as it is.

John Haines
12-16-2000, 04:11 AM
Louie - OK. I went through all the aliases in the BootRAID disk I thought might be of significance. There are a ton of 'em in a couple of games that point at CD's so I didn't check them all. Most of the broken links were for apps, utils, stuff, etc., that I use very infrequently and which could well have become broken long before I did this radical reconstruction. There was only one of plausably direct significance, the alias for iCab, my default browser. This pointed at the iCab in the Backup 1 disk. It probably happened shortly after the reinitialization. At that time I did as magician suggested and checked my aliases. Most of those I use frequently were ok and since he didn't put an exclamation mark after his suggestion, I only checked those I use frequently. I do remember that OE was incorrect and perhaps iCab was also. In which case I may have pointed it at the incorrect disk. But I don't know for sure. Anyway I have now repaired every broken alias in the Launcher, the Apple Menu, and the Control Panels.

Then I rebuilt the Desktop and restarted.
Then, using System Picker (in the proper manner), I switched disks to Backup 1. From which:
I ran NDD and then Disk Warrior on BootRAID.
Then I switched back to BootRAID disk.

Results: Same problems - OE in Boot RAID uses the Microsoft User Data in Backup 1. If that folder is not there, it generates a generic one. And Sherlock always opens with it's new default disk, Backup 1.

It's a puzzlement. Any other suggestions will be received gratefully.

Yours, wistfully (you have no icon that fits)

John

MacMikester
12-16-2000, 11:51 AM
Hey John,

It's just not that complicated, relax. Anytime you copy around so much disk info between three disks with system folders and Microsoft apps, you are going to have to do some repairing to get things in sync. I use a shareware Alias checking/repair app called Alias Director (there are others). It will list all broken aliases on a disk you select and give you the option to trash the alias or create the proper link. You can do this manually as well. here's how:

Startup from your intended Disk (BootRaid) then UNMOUNT (drag to trash) all other disks with potentially inappropriate links. Now you have only the disk mounted where you want all your aliases to point. Manually double click each alias and broken links will bring up the Finder's dialog box to repair them. (Or use an Alias checking app to get ALL aliases fixed.) Easy.

MangleStomp apps are a little more problematic 'cause they like to create their own registries hidden in various places (sometimes in Preferences, sometimes not). No matter, you can also beat them into submission. Do what you did before to get OE to create a generic useless MicroSoft User Data folder in the Documents Folder. The drag/copy the entire MUD folder from the good backup into the Documents Folder. Let the Finder REPLACE the useless MUD folder. You are done.

Cheers

John Haines
12-16-2000, 12:25 PM
MacMikester - Thanks for the input. I'm not sure if you understand what my problem is... or if I understand what you are suggesting. It may have taken me longer than with Alias Director but I think I fixed all broken aliases. I just highlighted each, did a command-R (Show Original), then on the highlighted original I did a command-I (Get Info). If it was not the correct one, I corrected it.

My big problem is that OE in my primary volume (BootRAID) insists on using one of my backup disks (Backup 1) as the location for the Microsoft User Data. Naturally, if I backup BootRAID to Backup 1 it overwrites all my new User data.

My secondary problem (not critical, just a bit annoying) is that Sherlock also defaults to Backup 1 when opening.

If I drag/copy any MUD folder (the one OE is using, in the Documents folder of Backup 1) into the Documents Folder (of, I presume you are referring to BootRAID), How do I "Let the Finder REPLACE the useless MUD folder", and if it does that, will OE then see the correct MUD as being in BootRAID?

Still perplexed, but grateful
John

ps - I assume a MangleStomp app is one that generates a bunch of hidden files???

MacMikester
12-16-2000, 12:48 PM
Hey John,

MangleStomp = MicroSoft.

The key here is that OE is not using RELATIVE addressing to find its files. It is not saying "let me go to the root directory of the boot disk and find the MUD folder to get my database". It is saying "my MUD folder is on Backup 1 at block so-and so". When you UNMOUNT Backup 1 or reinstall OE to force it to recreate a MUD folder, it will always go right back to the exact location it created that new folder. Let it do so----just do a standard drag/copy of your old files into the new file location and OE will look in the new location but find the old files.

After you create your new MUD folder in the Documents Folder in the root of BootRaid, drag your old MUD folder off Backup 1 and drop it onto the Documents Folder on BootRaid. You will get the Finder dialog yadayadayada already exists, replace? You say YES. You're done.

PS: if this doesn't work, do EXACTLY the same thing in the beginning but drag/copy only the Database files into the the new MUD folder and let these replace the generic ones. (It may be only the database files that are located by absolute addressing)

Once you have the correct database working on BootRaid, you don't have to worry about rewriting the files on Backup 1 during the next backup.

As far as I know, Sherlock will Checkmark any mounted disks it has had a chance to index. Give it a chance to index BootRaid and then BR will show up with a checkmark. Use the sheduling function of Sherlock to start indexing any disk you want.

Regards

[This message has been edited by MacMikester (edited 16 December 2000).]

John Haines
12-16-2000, 01:12 PM
MacMikester - That makes a lot of sense. From what you say I presume that merely opening OE while these disks are in the trash will force it to place the generic MUD in BootRAID (since there is no other place for it).

While I am trying this, can you please address the related situation with Sherlock? In other words, would opening Sherlock while these disks are in the trash it to realign itself with BootRAID?

BTW, You say dragging these backup disks to the trash unmounts them. Is this a similar function to the Unmount command in utilities like SoftRAID?

Thanks again
John

MacMikester
12-16-2000, 01:28 PM
Hey John,

1) I believe so, but you will have to try it. Most Mangle Stomp apps are like evil ghouls, they self-repair by recreating missing files. These apps are intellectually challenged and suffer from birth defects from having been hatched in an operating system that does not have the beautiful built-in navigation and file systems of the MacOS. They do not understand that the OS can tell them where their files are so they create inflexible rigid roadmaps to absolute disk addresses to find their way around. Kinda like Hansel and Gretel with their breadcrumbs in a world of GPS technology http://macgurus.com/infopop/emoticons/icon_smile.gif

2) read the edited post below re: Sherlock

3) Yes, unmounting is the same.

[This message has been edited by MacMikester (edited 16 December 2000).]

John Haines
12-16-2000, 01:38 PM
MacMikester - I dragged both Backup 1 and 2 to the trash, as you said. Dialogue box asked if I wanted to do that and if I did the disks would reappear on the desktop when the computer was restarted. I said Yes. I also dragged a copy of Microsoft User Data that had been in BootRAID to the trash. I then opened OE and immediately both backup disks reappeared on the desktop and OE found the MUD in Backup 1. It's a stubborn bugger.

As for Sherlock, Boot RAID is indexed. It is the only disk that is.

John

[This message has been edited by John Haines (edited 16 December 2000).]

MacMikester
12-16-2000, 01:53 PM
OK John,

'More than one way to tame a tiger.
Trash the OE preferences files from the Preferences Folders on all disks and unmount the disks as before. Then open OE on BootRaid and see what kind of a prompt you get.

I opened the OE prefs file with a text editor program and it does indeed list an ABSOLUTE address for the MUD folder in the preferences text. However, MangleSoft is sneaky and this may not be the only location where the addresses are stored. Let's see.

All I can tell you about Sherlock is that if the app is not showing BootRaid as checked, but shows Backup 1 as checked, then this particular copy of Sherlock has not indexed BootRAid yet. Tell it to do so and it will.

[This message has been edited by MacMikester (edited 16 December 2000).]

MacMikester
12-16-2000, 02:13 PM
[This message has been edited by MacMikester (edited 16 December 2000).]

John Haines
12-16-2000, 02:27 PM
MacMikester - Home run!!! Thank you!!!
http://macgurus.com/infopop/emoticons/icon_biggrin.gif

All we need now is a single to win the game: Ole Sherlock still defaults to Backup 1. But, hold it a minute, this is a Mac. If I trash the prefs of Sherlock it should look for the active disk or at least at the one that is indexed.... Well, almost. It now has all three disks checked, Backup 1, Backup 2, BootRAID - in that order. How do I change that?

John


[This message has been edited by John Haines (edited 16 December 2000).]

MacMikester
12-16-2000, 02:49 PM
As Babe points to the center field upper deck seats he says:

The checks in Sherlock (I'm using Sherlock 2) only tell it which disks to actively index. Uncheck the ones you don't want further indexing on (both of your backups). The text to the right of the drive tells you the date of the last indexing on that drive. The schedule you set up tells it when to index. This is in the application menus for Sherlock under Find:Index Volumes: Schedule. You can also delete and create indexes here.

http://macgurus.com/infopop/emoticons/icon_biggrin.gif

John Haines
12-16-2000, 03:05 PM
The ball explodes off the bat, soars out to right field, is going, going... the wind's got it...just misses the foul pole... strike one. Sherlock still wants to search all disks, BootRAID last.
http://www.macgurus.com/ubb/tongue.gif

[This message has been edited by John Haines (edited 16 December 2000).]

[This message has been edited by John Haines (edited 16 December 2000).]

MacMikester
12-16-2000, 03:47 PM
John, Johnster, Jonnheiser-------DELETE THOSE OTHER INDEXES!!!!!!!!! That is going to be your high fastball over the middle of the plate. Come on, do it, I dare ya http://macgurus.com/infopop/emoticons/icon_biggrin.gif

John Haines
12-16-2000, 03:48 PM
Just a minute, ladies and gentlemen, the umpire out in right field is signalling a HOME RUN! Let's go to the videotape... ah yes, there it is, a fan is reaching out and... in his attempt to catch the the ball, he knocks it foul. The game is over. We WIN!!!
http://www.macgurus.com/ubb/dance.gif http://www.macgurus.com/ubb/dance.gif http://www.macgurus.com/ubb/dance.gif http://www.macgurus.com/ubb/dance.gif http://www.macgurus.com/ubb/dance.gif

John Haines
12-16-2000, 03:50 PM
http://macgurus.com/infopop/emoticons/icon_biggrin.gif

John Haines
12-16-2000, 04:03 PM
There were no other indexes. I just updated the index on BootRAID. Tipped the ball, so to speak...

Thanks very much.
John
http://macgurus.com/infopop/emoticons/icon_smile.gif

Louie
12-16-2000, 10:58 PM
A special award for service above and beyond the call of duty is being struck at this moment in the basement for MM.

And for John, a service medal with star for learning something that he will never forget.

John Haines
12-16-2000, 11:53 PM
Louie, magician, MacMikester, kaye, and crazyeights - Many, many thanks for all the thought you gave to my little problem... and for just being there. You guys are great.

magician
12-17-2000, 04:13 AM
dang, I took Saturday off (didn't really intend to, it just happened) and look what I missed!

http://macgurus.com/infopop/emoticons/icon_biggrin.gif