PDA

View Full Version : Cross Flashing GeForce2MX (PC->mac)



MadDog
06-02-2002, 03:46 PM
Well, I finally decided to give it a try and cross flash a PC version of the Creative Labs Creative Labs 3D Blaster Annihilator 2 MX PCI
which I found about on this page:
http://www.cybercoment.com/macgeforce.htm

I have a rev2 B&W G3/450, running 9.1. I put the NVidia 2.1.1 extensions in my system folder before proceding. I have the latest firmware update.

I used the floppy image from the above page to make a boot floppy (it looks like you have to use WinImage).

At first, it gave me a command line error. I recalled that the newer NVflash programs (4.13, I think was on the floppy) dont have a -m switch, and when I looked through the batch files, I saw that it was trying to use the -m switch.

So, I replaced the nvflash.exe with an earlier version (3.15 IIRC), and ran the flash.

This time, I got no errors at all, and it seemed peachy.

I took the card to my mac, and put it in the 66 MHz PCI slot.

Nothing. I tried zapping the PRAM, but for some reason, with the GF2MX card in any slot, I _cannot_ zap the PRAM with the key command (apple-option-P-R). It just doesnt work at all. Weird.

So, I removed the card, zapped the PRAM with no cards at all in the mac (I dont have any other than the video card), and then put the card in a 33 MHz slot.

This time it worked ! I booted fine, and ran Combat Mission Demo, which didnt work with my Voodoo3 card.

So, I decided to put the card one last time in the 66 MHz slot.

No go.

Thinking it was no big deal, I put the card back into a 33 MH slot (the middle 33 MHz slot if it matters).

Nothing.

Fast forward, several PRAM zaps (without the card present in a slot), and switching the card from the 66 to the 33 MHz slots. Sometimes I would get garbled video, soetimes not too garbled video. One thing to note -sometimes when the garbled video wasnt too bad, I saw that the computer would continue to boot, while the video was no longer being updated. It _looked_ like a lockup, but I could hear the boot being finished up (I could hit the power key, and I hear the audible shutdown dialog warning).

Anyway, finally, I got a good signal when in the 33 MHz slot, and here I type.

I have a bad feeling that the card will futz up the next time I reboot.

Just for giggles, here is what the apple system profiler says about the card:

display
NVDA,NVMac
1027F
161
10DE
32 MB

Any good ideas about why this is happening ? I cant figure out why the PRAM zap key combo doesnt work. Maybe I should try a zap using TechTool or something similar.

OpenFirmware issue ?

Mad Dog


http://www.macgurus.com/ubb/jollyroger.gif

mactheripper
06-03-2002, 01:49 AM
Go, MadDog, go!!!!!!

lasvegas
06-03-2002, 07:54 PM
MadDog, did you try the CUDA switch?

MadDog
06-03-2002, 08:24 PM
The B&W has a CUDA ?

Color me surprised ! WHere is it ?

Mad Dog


http://www.macgurus.com/ubb/jollyroger.gif