View Full Version : 3dfx and ATI in a G# Beige...

01-13-2002, 02:32 AM
HEllo all...

Yet another issue that has me stumped. First the hrdwre: A Rev A Beige G3 @ 500 mhz (read Sonnett 466 oc'ed to 500) w 384 mbs ram and a 3dfx Voodoo 5/5500... OS 9.1 (don't laugh...I like it and am reluctant to give up my Voodoo). I am trying to get a 3dfx 5500 card to work while a monitor is connected to the built in Rage 11+ card in my G3. I would like to connect two monitors. One hrdwre accelerated by the 3dfx card the other connected to the Rage11+. My motive is that I have just rediscovered an old external XClaim TV (Ati) device in my pile of debris that conects via S video which will let me watch TV on my computer(duh...). IT works with the Rage and the AV card when the 3dfx card and extensions are removed. So...
The problem is that when the 3dfx card is installed and a monitor is connected to the built in ATi card the darn thing will not boot. The 3dfx extensions also don't get along with the ATi stuff... So... Can it work? Two extensions sets maybe...but still the hardware issue...

01-13-2002, 03:06 AM
I am running an ATI RADEON & a 3Dfx V5 in a B&W (yosemite) G3/500 system and it works fine. I have not tried the AV stuff - the RADEON does have a S-Video out, but no other 'Xclaim' or 'VR' features. I am running 9.1 and have no conflicts - except I can no longer put the system to sleep. The V5 does suck a lot of power - so if you have the G3 DT (gossamer) model - that might be an issue.


To boldly go where no english professor has gone before! -)

01-13-2002, 03:18 AM
Hey spaz2,
At what point does the crash happen? If this is during extension load you might be able to rearrange the startup order and resolve it.


01-13-2002, 04:08 AM
Ricks...It locks up almost immediatly. The monitor gets power (chung!) and the cursor shows up but will not move...and thats it. No Happy Mac (or sad or death chime). No "march of extension icons". Nothin but off grey screen. No hdd spin. So...I can't get to the part of flashing the PRAM or anything. I've tried it with all of the 3dfx extensions removed. I've tried it with different rev.s of 3dfx extensions. I think I'll stick in a v3/3000 and see if that does it. Anyone????

How do I change the strtup order/sequence?

dragonX...The ATi Rage11+ is built in to the MOB and the v5/5500 is on the PCI bus. Is the B&W's ATi card built into the MOB? I can't remeber. MAybe we have a ROM mineis a rev a) issue or a video controller difference between these two gen's? A Radeon and a 5500!!! Nice!!!

The ATi XClaimTV (the purple external box that plugs into the G3's personality A/V card's S video port and Audio Mini-jack) works with the MOB's Rage11+ and the G's A/V card. It does not work with the 5500. With the card out and the extensions (3dfx) still part of the set the ATi software cannot find the ATi XclaimTV. Remove the extensions and it works well...This is OK but the Rage 11+ is not a very robust video card (2mbs built in with a 4 mb card is no where near the 5500's dual graphics chips and 64mbs!!!). So I want both to work but cannot seem to get it. I've searched the TIL but to no effect. Anyone out there have a fix???

[This message has been edited by spaz2 (edited 13 January 2002).]

01-13-2002, 05:16 PM
Still thinking on this one. You have a hardware incompatability that's for sure. You have tried resetting the CUDA when you installed the PCI card. If you ever had another card in that PCI slot the computer will still expect to see that particular card there untill you do a reset.

To change the startup order you only have to change the name of an extension, sometimes just by adding a space at the beginning of the name (it then will load first). Extensions load in alphabetical, adding another character will change where it sits in the list. Obviously not your problem, but good to know.


01-14-2002, 02:57 AM

Well I have had some success but still I am runnin' into issues. Esentially I removed the Apple IX3d extensions from the active sartup folder. I boot up but all of the Menu and COntrol Strip and Desktop loads to the 3dfx driven monitor and the desktop photo of my son loads to the Rage11+ driven monitor. The Appple IxMicro drivers are for the PCI card that Apple used to include in their build to order config.. They appear to have been partially responsible for the lockup as now the system boots. I think they install as part of the general OS install off of OS 9 or from the download update of 9.1 or 9.2.1. I'm not certain that they were part of the general installtion back in the days of 8 and I believe they needed to be installed by the user if the card was installed as a later add on.

Ricks...you may be onto something regardeing the extension loading sequence. I say this as the 3dfx driven monitor has all of the Menu and desktop. This suggests that the 3dfx icons are loading first (and Extension Manager puts them prior to the ATi drivers...#s 1st followed by alpha sequence). Apple reccomends keeping all of the menu functions on the monitor runnin' off of the the built in graphics chip. So...maybe I'll mess with the loading sequence and see what happens...tomorrow...

The newest problem has emerged. I attempted to open the Monitor and Sounds control panel so as to allocate APPS and stuff but every time I do so the whole thing locks up and a fragmented (only bits and pieces are visible) error window pops open and a Type 1 error message occurs. The restart buttons are jinked so I am reduced to the three finger salute. Type one error=? Seems that the M&S Control Panel does not know how to deal with the card...


01-15-2002, 03:01 PM
Just so you dont feel lonely, I ran an Xclaim alongside a Voodoo 5 5500 in my XLR8 G3 500 boosted 8500. I also ran a monitor off each card (3 monitors including one attached to the onboard video port). I had a start up monitor battle raging all the time. I never knew for sure what the placement for start up monitor was going to be. The ati card would often fail to perform some of the functions in TV mode, such as toggling screen viewing size. My control strip was mysteriously turned off quite often as well. Cant remember how many ATI extension changes I tried but none of them seemed to help alot. Either of the cards worked well separately but just didnt want to be in the same room with each other....Hehehe....still plucking out the gray hairs from that episode

Is error type 1 a bus error?

[This message has been edited by Macdaddi2u (edited 15 January 2002).]

01-16-2002, 03:39 AM
I'm not much help on your problem, but I will say that I haven't had any problems between a V5 and a Xclaim 128VR. They have together been in two 8500s, a 7500, and now for the last year in a PTP with another IMS Twin Turbo. The OS remembers which monitor the menu bar was last on. The only problem I had was the classic ATI green x over the desktop video extension, which a bit of musical extensions finally fixed. The freezing up after tv size change was another ATI glitch. The control strip disappearance still bugs me. I'm not sure, but it seems to default to hide/off after a crash.

Just for grins, try it with the original processor and speed. If not, then perhaps an incompatability with the older ATI chipset. Someone has to have a V5 in a beige G3 who can comment.

01-17-2002, 05:27 PM
Howdy folks. I don't have a V5 but a V4 running in a rev. 2 beige G3, and at first I had problems, but not anymore. I'm gonna do this from a hazy memory, but I don't think I'll leave anything out.
The system:
Beige G3 rev.2; NewerTech G3 400mhz
ATTO UW single channel PCI
Rage Pro on MOB
448 megs RAM
Various hdds connected internally and externally of both the SCSI and IDE flavors.
Mac OS 9.1

I have two monitors, one connected to the Rage Pro and the other to the V4. No problems. I did run into some problems until: I turned off the IXMicro extensions; ran the "latest" V4 version driver, something like 1.13b, I think; and have the latest extensions that came out for the Rage Pro card. I don't have the latest ATI extensions for ATI cards, though. I don't run the ATI video control panel. I let the 3DfX control panel have priority. I also have turned off the Apple video extension, I don't have anything that will work with it. One thing that I noticed which seemed to help was having a mounting utility, like Charismac's Anubis mounting utility. It seemed to bring order to an otherwise hectic startup. You shouldn't have power problems, since the V5 has its own power supply. Otherwise, I have a simple set up and an uncomplicated set of extensions. The only other thing that I can think of that you might try is try different slots for the V5. I have mine running in the middle slot, with the USB on the right and the SCSI closest to the communication card. I can't think of anything else that stands out about my setup. If any of y'all can think of something to ask, I'll do my best to answer.

Best of luck.

01-18-2002, 12:21 AM
Thanx discodan

I'll try it on later but it'll hafta wait 'til the wkend...

02-15-2002, 02:25 AM
It works! I thought I'd take another shot at it and I dunno why or how but it does... I've done a clean install w a low level reformat and I have not reinstalled the 3dfx drivers so no extra boost off of the 5500. Maybe the lack of the 3dfx drivers? Hmmm... I've also increased the vram to 6 from 2mbs for the built in vid..

[This message has been edited by spaz2 (edited 15 February 2002).]

s.d. finley
02-15-2002, 02:41 PM
Hey guys, i just purchased a 3dfx voodoo 5500 over e-bay anf the guy did not include the installer cd!!! Can anybody send me a link, i have been searching and cannot find one that WORKS.
Or, make me a copy of your installer cd and i will send you money!
Please guys/gals, as i am desparate!!

thanx all


02-15-2002, 08:06 PM
Why do you want the install cd? I have it but I think it is not very useful. I also have the printed material that came w the box...

I just sent off 1.1.2 to you via email...I hope that is OK. Toss it in the garbage if you don't want it. I think 1.1.3 is around on the MacG's FTP site.

Anyway, the card goes in the AGP or PCI slot. Connect a monitor. Flash the PRAM. Install the drivers. Resart and play...1.1.3 is the last driver set that 3dfx had somthing to do with. It was in beta ithink just as 3dfx was being consumed by nVidia. Our cards are very nice but "X" support is neglible and improbable. Open GL in 9.2.2 is not supported (I think it was Open GL or was it Glide...duh). But I still think it was a very cool card...

[This message has been edited by spaz2 (edited 15 February 2002).]

02-15-2002, 08:13 PM
oh i forgot...the 5000s needed a power supply. get a splitter and plug the card in...same sort of plug-socket as you would find on a standard hdd or cd-rom...plugs in along the upper edge of the card...

s.d. finley
02-16-2002, 01:03 AM
Thanx spaz2, you were all over both my threads! Thanx for the help1


02-16-2002, 01:45 AM
I thought this one was mine... http://macgurus.com/infopop/emoticons/icon_smile.gif

02-16-2002, 10:32 AM
I keep the 112 and the 113 posted on my site

Damien's Stuff (http://www.macmeisters.com/Damien/)


02-16-2002, 03:37 PM
Very nice D. W thnx.