PDA

View Full Version : PTP/Radeon/PioneeerDVD305s/Any ideas?



EGPoulin
06-03-2001, 12:48 PM
Hi all,

I'm sure that this has been beaten to death, but I have:

Power Tower Pro 225
XLR8 Carrier/400MHz G3
384MB RAM
ATI Radeon PCI
OS 9.1 with full Software Updates
OEM Pioneer 305s DVD-Rom (SCSI)
Intech CD/DVD Speed Tools 5.7
Radeon Drivers 1.1.1

By itself, the dvd drive mounts everything, including movies and works great. REALLY FAST using Intech

drivers.

I hit the "ThinkDVD" web site and downloaded Apple DVD Player 2.4, the patch, and also the Apple CD/DVD

Driver hack.

I used Tome Viewer and extracted the app and the extensions as directed. Applied the patch, re-started

and tried to play a DVD-Movie. Here's what happened:

1) Using Intech drivers, the Apple DVD app loads, and starts playing the "FBI Warning" stills on DVD that

have them first (Toy Story for instance) but once it starts loading the movie menu the App quits out with

a "Apple DVD Player cannot continue because of an error." message.

2) Using the Apple CD/DVD Driver 1.3.1 hack the drive again works great, mounts DVDs, but when I launch

the DVD Player, it comes up with the message "Apple DVD Player cannot find Apple CD/DVD Driver or

DVD-Module is not installed, please check is CD/DVD driver is installed and restart"

I've tried all that I can think of to get this to work, including a clean install of 9.1 on another

volume, re installing the DVD over and over, and making sure that the radeon drivers are all set.

Any other ideas? Should I try the DVD 2.5? (and could someone send it to me) Any other hacks or

patches?

Any help would be great, thanks everyone!

~~~Eric~~~
InnovativeDS@att.net

[This message has been edited by EGPoulin (edited 04 June 2001).]

EGPoulin
06-04-2001, 09:21 AM
Edit: I have tried all the usual crash fixes, I.E. 128K disk cache, no VM, large RAM allocation to DVD APP.

magician
06-04-2001, 05:52 PM
EG, not my area of expertise, unfortunately. Maybe you should email that Lukifer guy (http://www169.pair.com/lukifer/contact.html) who hosts all those DVD utilities? Or invite him to join us here?

http://www169.pair.com/lukifer/contact.html

EGPoulin
06-04-2001, 09:50 PM
Got DVD 2.5.... we'll what happens.

I have to call it a night, but I will check over at Lukifer's site and see what trouble I can stir up! :-) Go gurus!.

Talk to you all soon and thanks as always.

~~~Eric~~~

EGPoulin
06-08-2001, 08:11 AM
Alright, here is the current run down. I know that most here don't have any suggestions and that's cool, I just wanted to keep all of you who are interested informed. :-)

Through testing I determined that the jumper for 512/2048 default block size needs to be set for 512 (duh but worth a shot). DVD does not mount with it on 2048.

Only CD/DVD device on the bus is the Pioneer DVD-Rom.

Using "DVD ToolKit - JUNE 2001"'s apps:

-xvi's DVDInfo 2.02 Reports:

> DVDInfo, version 2.0.2, by xvi.
> Scanning for devices, please wait......
>
> Location: SCSI 0,1,0
> Vendor: PIONEER
> Model: DVD-ROM DVD-305
> Firmware: 1.00
> Serial Number:
> RPC Status: RPC-1 (region-free)
>
> Done.

However Region 1.0.8 reports:

>"No Region Free (RPC-1) DVD drive found."

Looks like a conflict here....

Next, Using any of the Apple DVD players the same errors still persist. These are again:

With hacked Apple CD/DVD Driver, DVD player launches but displays the message "Apple CD/DVD Driver or DVD-Module not found..." ect.

With Intech CD Speedtools, the DVD app launches, will play any FBI stills off a DVD Movie, then once is starts to launch the menu, it quits with an "Sorry, Apple DVD Player cannot continue because of an error. Error Number -9882"

These are the only two drivers that I have tried since they are the only ones that I have. I cannot seem to find the "software architects" or "Radialogic" DVD Drivers.

I've tried the hacked DVD player Version 2.2, 2.3, 2.4, 2.5 and even 2.2 SuperMod. with the same results. (and yes, I have been using the appropriate extensions for each player version)

In addition, to attempt to deal with the region control issues, I have tried the region autoswitch that was included with the xvi dvd tool kit, but since region does not recognize the drive as RPC-1, I don't know if it helps.

At this point, I believe that my problem lies in one of two places, possibly drivers, but I'm leaning towards region control.

I've searched the internet, and it seems that the drive was supposed to ship RPC-2, and there does not seem to be any flashers for it. How it got to be RPC-1 I'm still at a loss since the seller says that he did not flash it and the he bought it new (OEM). Any suggestions there would be much helpful. I really don't care if the drive is region free so if a flasher to reset it to factory could be found, I would be fine with that.

So where to go from here guys?

Thanks alot.

~~~Eric~~~
Innovativeds@att.net


[This message has been edited by EGPoulin (edited 08 June 2001).]

kaye
06-08-2001, 10:54 AM
Eric,

That jumper for "512/2048 default block size needs to be set for 512" you describe, I also have such jumper pins on my Kenwood 52X TrueX CD-ROM drive and out of the box it was set for 2048 Bytes (no jumper installed). I called Kenwood Tech and asked what the... and they said leave it at 2048 Bytes. They did say what the 512 Bytes was for but I don't remember (Linux machines?) and didn't write it down. k

EGPoulin
06-08-2001, 10:57 AM
So kenwood told you to leave it at 2048 and not 512? I'll have to try it again and maybe that will be the fix..

Thanks.

~~~Eric~~~

EGPoulin
06-08-2001, 01:45 PM
Nothing too exciting going on with my post over at the Rip Different Forums, but here is the link anyway..
http://www.macdvd.org/ubb/Forum4/HTML/000076.html

magician
06-08-2001, 06:55 PM
eric, i think i have the sw architects stuff in the basement.....email me directly and i'll go check it out.

Louie
06-11-2001, 06:52 PM
A block size of 512 is for UNIX; 2048 is for Mac and Windoze according to my Yamaha and Toshiba books.

magician
06-12-2001, 03:23 AM
hey, sorry eric.....almost forgot about you--and I DID get your email. My memory sucks!

i'll dig around tomorrow, and see if i can find that sw. i was in the basement today, and didn't stumble across it, so it might have gotten "organized."

hang in there!

EGPoulin
06-13-2001, 08:55 AM
Newest update:

I was getting pretty frustrated with this whole setup and then two things happened, 1) A guy from the "RipDifferent" forums came through and sent me the Radialogic drivers and 2) from the blue XVI e-mailed me. (XVI is the guy that wrote many of the MAC DVD utilities out there such as DVDInfo, Region, and Region Switch, his page is here. http://xvi91.multimania.com/ ) (http://xvi91.multimania.com/) Apparently he reads the RipDifferent forums, saw my thread, and wanted to help me and also help his development of the utilities (and of course the Mac community as a whole) This is what we have been able to determine:

Problem 1: Getting whichever CD/DVD Driver you’re using to register with the Region Manager Extension on boot

So what we have found so far is that the Intech drivers DO NOT register my drive with the Apple Region Manager (and XVI seems to think that they in general do not). The Radialogic and the Apple (hacked) CD/DVD Drivers do. This was determined by using the DVDInfo 1.1.0 utility with each different driver. (1.1.0 is that last know good utility for SCSI DVD, 2.0.2 is mostly for ATA/IDE and some of my results will go into DVDInfo 2.0.3) Solution is to not use the Intech for the DVD-Rom. Using the other two, the drive gets registered (and the output from the problem below is the result of a properly registered drive).

Problem 2: Getting Region Manager to set the region of the RPC-1 drive.

The first part is what my Pioneer Drive registered as, and the second part is XVI’s comments:

<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>
>With the hacked Apple CD/DVD Driver 1.3.1 results in:
>
>"DVDInfo 1.1.0, by xvi.
>
>WARNING:
>DVDInfo will display information as reported by Apple's Region Manager.
>Please read DVDInfo's documentation about Apple's Region Manager
>(in)accuracies!
> Vendor: PIONEER
> Model: DVD-ROM DVD-305
> Firmware: 1.00
> RPC-2: Region locked (Phase II)
> Flags: 5 changes left, 4 vendor resets left.
> State: NONE (no region set)
> Region: not yet set
>
>Done."

This sounds right (the Apple driver also register CD drives with the
region manager, as usual). Note the "Region: not yet set", it means
that your drive will fail to read most movies. A region MUST be set
in order to play movies. That's your trouble, really.
<HR></BLOCKQUOTE>

Problem 2 is where I am right now (and that I need to install a clean system because all of the sudden I can’t mount DVD’s with any of the drivers… but that’s an easy 10 minute process since I have the 9.1 CD.)

He also sent me the newest patched version of the Apple CD/DVD Driver to work with the DVD-Player, and some other utilities that will output some debugging info for him to improve his work as well. (don’t worry, I’m taking very strict precautions handling these files and their output!). I will be working on this tonight and tomorrow night and will let you all know how it goes.

On a side note, do the Gurus have a contact at Intech that we could invite here or I could mail to ask about ¬ěregion manager registration¬î functionality in the next revision of CD/DVD Speed tools? As I own that great piece of software I would love to be able to use it exclusively.

~~~Eric~~~


[This message has been edited by EGPoulin (edited 13 June 2001).]

Louie
06-13-2001, 03:28 PM
Maybe Mag can get Chris to comment on this.

EGPoulin
06-13-2001, 04:37 PM
I've seen many reports on the Internet that the Intech Drivers are working fine with other DVD-Rom Movies but they are mostly IDE drives. Maybe it is strictly CD/DVD Speed tools and SCSI DVD-Roms or even just the newer DVD-Roms.

Who knows.. I definately won't until I get home to try some of ths stuff out.

magician
06-14-2001, 07:24 PM
sure, Eric. I'll shoot Chris at Intech an email, and see if he can join us here.

I tried to send you the other drivers....that Architects stuff, but it comes out to like 10MB in size, and it bounced from your mailbox. If you like, I guess I could upload it to a mac.com public directory, and you could download from there? Let me know if you still need those drivers. It sounds like you and your pal might be able to get some really good work done here.

http://macgurus.com/infopop/emoticons/icon_smile.gif

cpkarr
06-14-2001, 09:07 PM
Hey Guys.

I've been reading your thread, and while I don't have a clear explanation as to what's going on, I have a few comments and suggestions.

First, it is not true that we don't register with the region manager, (unless Apple has changed the spec on us, which I doubt). We do this for MacOS 8.1 and higher.

As for suggestions, I have several. First: try turning off the streaming cache. While the streaming cache will improve overall performance, with DVD movies it is critical that each individual i/o be as short as possible in duration. This is particularly true with SCSI drives. If no success, try the proceedure we outline at <http://www.IntechUSA.com/DVDNews.html>. If the files copy then there is no region conflict. If the problem is just throughput from your SCSI DVD drive, you can play the movie from your hard drive since it will be much faster.

We have gotten that drive and several other SCSI DVD's to play movies on our G4, but you're really pushing things trying to play movies on your older system. You have very little room for any bottlenecks. However, it still might be possible. I'm very interested to see if you can get it going. If I have any more ideas, I'll post 'em.

Good Luck.

Chris Karr
Intech Software Corp

cpkarr
06-14-2001, 09:09 PM
Hi again. For some reason my web link did not post. Here it is again: http://www.IntechUSA.com/DVDNews.html?

Chris

EGPoulin
06-14-2001, 09:52 PM
WHOOOOOOO HOOOOOOOOO!!!

It's a strange thing, but a whoo hoo just the same. Full text will be coming soon but to put everything in a nut shell, I CAN WATCH DVD's ON MY PTP!!

It all came down to Regoin Management. Essentially the drive did not have a region set for what ever reason and the only way that I was able to get it to set was to restart the machine with a DVD in the drive and the DVD extensions in the the system folder (and at that time I still had the Radialogic Drivers in the system too).

The system booted and right before the full desktop came up a dialog came up telling me that to play dvd's I needed to set a region and if I wanted to now. I set it for region one, put the Intech drivers back in (radialogic drivers wouldn't mount), restarted and started watching matrix with the DVD 2.2 player hack. :-)

More in a few.

YEAH!!!

:-)

~~~Eric~~~

EGPoulin
06-14-2001, 11:07 PM
Thanks for being there Chris, Sorry to cast doubt on the CD/DVD Speedtools, but it really seemed like a plausible explanation given the utilities that I was using. I will let the author know and maybe he can fix the programs. I REALLY like what Intech has to offer and very happy that I bought it.

In terms of performance, I have not touched anything that usually causes crashes. The Speedtools caches are set to 4mb for directory and auto for streaming, VM is off but I have that off anyway, disk cache is default, and I didn't touch the RAM allocation of the 2.2 app. I am downloading the newest 2.7 and am expecting to see even better results.

It seems that the newer Pioneer Drives are some of the few to have these kind of "unexplainable" problems. I don't know why the only way to get the system to set the Region was to restart with a DVD in the drive... I wasn't even using a fresh system. It was the same system that I have been using for quite a while. Either way, it triggered something and I'm now golden.

So who needs help? I have a nice library of DVD stuff and will be writing a detailed How-To since everyone (including me) have been asking the same questions.

Also, S-Video out from the Radeon looks beautiful..... Finally a decent feature on that damn card... Nuff said.

Wow, I need to go to bed so I can get up for work. I'll also be firing off an e-mail to the major Mac news sites (especially Breeden's site) this weekend.

Little more than a week of fighting and all is good... So what should I tackle next? :-)

Thanks for everyone's help!

~~~Eric~~~

cpkarr
06-15-2001, 12:18 AM
Eric

Well done. It takes a lot of patience to hang in there this long. I didn't take your post as a slam against us. Given the fact that it ended up being a region issue, your original theory was not too far off the mark. I know you now appreciate how complex all this stuff can be (even for us), especially on a Mac that was never designed for DVD playback!

Anyway, we'll add your experiences to our support knowledge base so maybe we can save someone else the pain you went through. Please send an e-mail to feedback@intechusa.com and ask to be forwarded to Chris Karr. I'm interested in the region code software you were using so maybe we can figure out what went wrong with it.

Chris

magician
06-15-2001, 03:02 AM
gents, this is a phenomenal thread--and Eric, please do let us know when you have your page posted. If you would like us to host your page for you, it would be our distinct honor.

great work!

thanks Chris! Don't be a stranger!

http://macgurus.com/infopop/emoticons/icon_smile.gif

EGPoulin
06-17-2001, 06:31 PM
Ahhhh, just got back from holiday in Maine with my girlfriend... she's actually put up with me for 2 years, Imagine that! Didn't even have a phone in the room all weekend. It was NICE.

About the DVD,

Thanks guys for your support! :-) I think that it was a learning experience for all.

Mag, about hosting the page, considering that I really have no real place to put it, I would also be honored to be part of the Mac Gurus' site... maybe the "DVD page of diversions"... er... something to that effect. :-) We could even tie DVD drives to the page.

Anyway, need to unpack. I will start writing this week. Enjoy!

~~~Eric~~~

Louie
06-17-2001, 07:34 PM
What did you tell your wife?

EGPoulin
06-17-2001, 10:46 PM
My wife???? Wow, I didn't even know I was married! :-) No No, I'm 23 and never been married.

magician
06-18-2001, 02:01 PM
deal, Eric.

make sure you take a pic of your girlfriend to "illustrate" the page. We've always been in favor of gratuitous girlfriend shots, just like we favor gratuitous sex, violence, exotic car chase-scenes, and a Discordian historical viewpoint.

http://macgurus.com/infopop/emoticons/icon_wink.gif